Subject: [lmap] Information Model: Question on ma-report-result-obj

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Thu, 24 Mar 2016 19:26:24 +0000

Juergen,

I see you added the schedule name and action name to the result object (as well as renamed it).

So what makes a result unique within the report the combination of these 3 elements?

BR,
Tim

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 29 Mar 2016 16:44:30 +0200

> So what makes a result unique within the report the combination of these 3 elements?

The unique key would be the schedule name and the action name (because
this identifies an action) combined with the start-time. The task name
is not strictly necessary and more a matter of convenience.

One possible issue is the conflict list, which is simply a list of
task names. So the collector does not get to know which actions in
which schedules actually caused a conflict. The alternative would be
to make this a list of (schedule name, action name) pairs.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Tue, 29 Mar 2016 15:13:30 +0000

Thanks Juergen,

I'll use that as a key - we should document that in the information model to remove any confusion.

Yes I agree the conflict list in the report ought be the action instance that caused the conflict. Good catch!

BR,
Tim

-----Original Message-----
From: EXT Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Tuesday, March 29, 2016 9:45 AM
To: Carey, Timothy (Nokia - US)
Cc: [email-masked]
Subject: Re: [lmap] Information Model: Question on ma-report-result-obj

> So what makes a result unique within the report the combination of these 3 elements?

The unique key would be the schedule name and the action name (because this identifies an action) combined with the start-time. The task name is not strictly necessary and more a matter of convenience.

One possible issue is the conflict list, which is simply a list of task names. So the collector does not get to know which actions in which schedules actually caused a conflict. The alternative would be to make this a list of (schedule name, action name) pairs.

/js