Subject: [lmap] Need your help to understand how YANG data model is carried over wire (was Large Scale Measurement of Access network Performance <lmap.ietf.org>

From: Linda Dunbar <[email-masked]>
Date: Fri, 6 May 2016 22:55:55 +0000

Juergen,

This email post is supposed to show how a YANG data model is carried over wire:  https://www.ietf.org/mail-archive/web/lmap/current/msg02038.html

Hope you can help me to resolve those mysteries:

-         The Controller use a "POST /restconf/data/ietf-lmap:lmap/schedules HTTP/1.1" to send a "schedule". But where is the actual "icmp-latency-measurement" is actually defined? Where is "report-daily" is defined? They are all in the form of "strings". So supposedly, any string can be encoded there, then what content is carried from "Controller" to the "Measurement Agent"?

-        What purpose do the following two lines achieve?

  C: Host: example.com

  C: Content-Type: application/yang.data+json

What would happen if those two lines are not there?

-        What does the following line achieve?

  C:       "timing": "hourly"

Thank you very much.

Linda Dunbar

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 7 May 2016 08:55:45 +0200

Linda,

please take a look at draft-ietf-lmap-yang-04.txt and
draft-ietf-lmap-restconf-02.txt.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 9 May 2016 23:11:05 +0000

Juergen, 

My question was "where the actual "icmp-latency-measurement" is actually defined. Your answer is "look at the Draft-ietf-lmap-yang-04", which doesn't really help me very much. 

Draft-ietf-lmap-yang-04  has the following. Does it mean that the actual "icmp-latency-measurement" is defined by the URI? who provides the actual URI? What if the URI doesn't have any "measurement"?  

<task>
   <name>icmp-latency-measurement</name>
   <metric>
   <uri>urn:....</uri>
   </metric>
</task>

"draft-ietf-lmap-restconf-02" only has the following, as if treating "icmp-latency-measurement" as a known action (But there could be different ways to measure ICMP latency". 

<action>
  <name>icmp-latency-hourly</name>
  <task>icmp-latency-measurement</task>
  <destination>daily</destination>
</action>

Thanks, Linda

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Saturday, May 07, 2016 1:56 AM
To: Linda Dunbar
Cc: [email-masked]
Subject: Re: Need your help to understand how YANG data model is carried over wire (was Large Scale Measurement of Access network Performance <lmap.ietf.org>

Linda,

please take a look at draft-ietf-lmap-yang-04.txt and draft-ietf-lmap-restconf-02.txt.

/js

On Fri, May 06, 2016 at 10:55:55PM +0000, Linda Dunbar wrote:
> Juergen,
> 
> This email post is supposed to show how a YANG data model is carried 
> over wire:  
> https://www.ietf.org/mail-archive/web/lmap/current/msg02038.html
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 10 May 2016 01:28:21 +0200

>    <name>icmp-latency-measurement</name>

Well, this defines the LMAP task with the name 'icmp-latency-measurement'.
Now your question is what does 'icmp-latency-measurement' actually do?
One answer is that the URN identifies a well-defined metric in a metrics 
registry. The IPPM working group is defining a metrics registry, see
draft-ietf-ippm-metric-registry-06 and draft-ietf-ippm-initial-registry-00.

/js