Subject: [lmap] MAs that require a common proxy

From: Ron Stana <[email-masked]>
Date: Tue, 19 Jul 2016 04:17:33 +0000

LMAP Team,

We have an MA that cannot be communicated with directly and so requires communication through a proxy server.  One proxy server can be used for many MAs, thus there is a 1-to-many relationship.

The LMAP APIs seem to assume direct communication from the Controller to the MA.

Our initial thought is to add the MA-ID as a URL parameter to requests from the Controller to the proxy.  This would allow the proxy to know which MA the request is for.  While this would not necessarily make the requests LMAP compliant it would allow the content to remain LMAP compliant.

Thoughts from the LMAP Team on how to handle this situation would be appreciated,

Ron

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 19 Jul 2016 08:21:57 +0200

Ron,

I think this is a rather general problem that deserves to be solved
generically, that is without assuming anything specific about the data
models being proxied. The NETMOD/NETCONF WGs are doing work related to
mount-points, which may be something to look into. But perhaps even
generic HTTP proxies could help if your MAs have addresses that are
resolvable by the proxy.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Bugenhagen, Michael K" <[email-masked]>
Date: Tue, 19 Jul 2016 13:10:32 +0000

I would recommend using an approach like we used with VoIP where agents that go through proxy's and firewalls have a different behavior and make sure a channel is open in both directions by being a bit more chatty (at least from a IOT perspective)...

   The MA pokes the Controller, and the control can then directly get back to the agent...

Regards,
Mike

om: lmap [mailto:[email-masked]] On Behalf Of Ron Stana
Sent: Monday, July 18, 2016 11:18 PM
To: [email-masked]
Subject: [lmap] MAs that require a common proxy

LMAP Team,

Ron
This communication is the property of CenturyLink and may contain confidential or privileged information. Unauthorized use of this communication is strictly prohibited and may be unlawful. If you have received this communication in error, please immediately notify the sender by reply e-mail and destroy all copies of the communication and any attachments.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 19 Jul 2016 15:43:14 +0200

Michael,

you seem to be talking about what is known as 'call home' in the
NETCONF WG (<https://tools.ietf.org/html/draft-ietf-netconf-call-home-17>)
while the original question was an N:1 proxy situation. If the reason for
this N:1 proxy situation is indeed a NAT function, then yes 'call
home' is the recommended  way to go. See the 3rd paragraph in section 2
of <https://tools.ietf.org/html/draft-ietf-lmap-restconf-03>.

/js

> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

---

From: "Bugenhagen, Michael K" <[email-masked]>
Date: Tue, 19 Jul 2016 14:02:34 +0000

Correct, it wasn't named when I was doing that type of work ... early VoIP days..

Thanks!
Mike

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]]
Sent: Tuesday, July 19, 2016 8:43 AM
To: Bugenhagen, Michael K
Cc: 'Ron Stana'; [email-masked]
Subject: Re: [lmap] MAs that require a common proxy

Michael,

you seem to be talking about what is known as 'call home' in the NETCONF WG (<https://tools.ietf.org/html/draft-ietf-netconf-call-home-17>)
while the original question was an N:1 proxy situation. If the reason for this N:1 proxy situation is indeed a NAT function, then yes 'call home' is the recommended  way to go. See the 3rd paragraph in section 2 of <https://tools.ietf.org/html/draft-ietf-lmap-restconf-03>.

/js