Subject: Re: [lmap] WGLC comments for https://datatracker.ietf.org/doc/draft-ietf-lmap-information-model/

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 12 Aug 2016 11:40:37 +0200

On Thu, Jul 28, 2016 at 04:29:32PM +0000, Romascanu, Dan (Dan) wrote:
> A few (mostly) editorial and clarification comments for https://datatracker.ietf.org/doc/draft-ietf-lmap-information-model/:

Thanks Dan. See my response inline.
 
> 1.       Section 3, pag. 8: 'It should be clear that the top-level behavior of an MA is simply to execute Schedules.' - what does 'top-level behavior' exactly mean?

I have changes this to:

  The primary function of an MA is to execute Schedules.
 
> 2.       Section 3.3.2, pag. 16, definition of ma-suppression-match - s/An optional and possibly empty unordered set of match pattern/ An optional and possibly empty unordered set of match patterns/

Added the plural s.

> 3.       Section 3.8.1, pag 34, definition of ma-channel-interface-name - 'If not present, the system will select a suitable interface.' - who is 'the system' here?'

It is usually the IP stack - if you connect() a socket, the IP stack
usually decides which interface it uses by looking at the routing
table. This extra parameter only makes sense in very specific corner
cases (e.g., you use link-local addresses or for whatever reason you
want to try to overwrite the routing decision). I find 'system' a
reasonable term here. Do you want to change it to 'operating system'
or 'IP protocol stack implementation'?

> 4.       Section 3.9, pag. 36: 'A reporting task might also have a flag parameter'- capitalize Reporting Task for consistency

Capitalized as suggested.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 14 Aug 2016 07:28:36 +0000

All suggestions are fine. For #3 -  'IP protocol stack implementation' seems most clear to me. 

Thanks for addressing my comments. 

Regards,

Dan

> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:j.schoenwaelder@jacobs-
> university.de]
> Sent: Friday, August 12, 2016 12:41 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: Re: [lmap] WGLC comments for
> https://datatracker.ietf.org/doc/draft-ietf-lmap-information-model/
>

... 
 
> > 1.       Section 3, pag. 8: 'It should be clear that the top-level behavior of an
> MA is simply to execute Schedules.' - what does 'top-level behavior' exactly
> mean?
> 
> I have changes this to:
> 
> > 2.       Section 3.3.2, pag. 16, definition of ma-suppression-match - s/An
> optional and possibly empty unordered set of match pattern/ An optional
> and possibly empty unordered set of match patterns/
> 
> Added the plural s.
> 
> > 3.       Section 3.8.1, pag 34, definition of ma-channel-interface-name - 'If not
> present, the system will select a suitable interface.' - who is 'the system'
> here?'
> 
> It is usually the IP stack - if you connect() a socket, the IP stack usually
> decides which interface it uses by looking at the routing table. This extra
> parameter only makes sense in very specific corner cases (e.g., you use link-
> local addresses or for whatever reason you want to try to overwrite the
> routing decision). I find 'system' a reasonable term here. Do you want to
> change it to 'operating system'
> > 4.       Section 3.9, pag. 36: 'A reporting task might also have a flag
> parameter'- capitalize Reporting Task for consistency
>