Subject: Re: [lmap] WGLC for draft-ietf-lmap-information-model-13

From: Dan Romascanu <[email-masked]>
Date: Mon, 12 Dec 2016 14:10:30 +0200

The WGLC concluded. There were no comments. Taking silence as consensus we
shall go ahead and prepare the submission for to the IESG.

At this point we would request the WG participants:

1. to let us know if there are any known Intellectual Property relevant to
this document
2. to let us know if there are any implementations or plans to implement
the IM defined in this document

Thanks and Regards,

Dan

On Mon, Nov 21, 2016 at 6:23 PM, Dan Romascanu <[email-masked]> wrote:

> This message starts an LMAP WGLC for draft-ietf-lmap-information-model-13
> - https://datatracker.ietf.org/doc/draft-ietf-lmap-information-model/.
>
> Please let us know if you believe that this document is ready to be sent
> to the IESG for consideration as Proposed Standards. It's OK to state that
> the document is just fine, it's even better to let us know if you have
> concerns and comments to improve and detail them. Messages about
> implementations or plans to implement are also welcome. Please send these
> before Monday December 5, 2016.
>
> Thanks and Regards,
>
> Jason and Dan
>
>
>

---

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Mon, 12 Dec 2016 20:33:04 +0000

Dan,

I provided comments to Juergen which I believe is expected to go into a new revision of the IM.

I do not know of IP relevant to this document.
BBF plans to define a TR-069 data model based on the IM defined in this document.

BR,
Tim

From: Dan Romascanu [mailto:[email-masked]]
Sent: Monday, December 12, 2016 6:11 AM
To: [email-masked]
Subject: Re: [lmap] WGLC for draft-ietf-lmap-information-model-13

The WGLC concluded. There were no comments. Taking silence as consensus we shall go ahead and prepare the submission for to the IESG.
At this point we would request the WG participants:
1. to let us know if there are any known Intellectual Property relevant to this document
2. to let us know if there are any implementations or plans to implement the IM defined in this document
Thanks and Regards,
Dan

On Mon, Nov 21, 2016 at 6:23 PM, Dan Romascanu <[email-masked]<mailto:[email-masked]>> wrote:
This message starts an LMAP WGLC for draft-ietf-lmap-information-model-13 - https://datatracker.ietf.org/doc/draft-ietf-lmap-information-model/.
Please let us know if you believe that this document is ready to be sent to the IESG for consideration as Proposed Standards. It's OK to state that the document is just fine, it's even better to let us know if you have concerns and comments to improve and detail them. Messages about implementations or plans to implement are also welcome. Please send these before Monday December 5, 2016.
Thanks and Regards,
Jason and Dan

---

From: Dan Romascanu <[email-masked]>
Date: Mon, 12 Dec 2016 22:37:36 +0200

Hi Tim,

Can you share the comments on the mail list? If I missed them - can you
point to the message? We were not planning a new revision of the IM - so we
need to get consensus on the changes.

Thanks and Regards,

Dan

On Mon, Dec 12, 2016 at 10:33 PM, Carey, Timothy (Nokia - US) <
[email-masked]> wrote:

> *From:* Dan Romascanu [mailto:[email-masked]]
> *Sent:* Monday, December 12, 2016 6:11 AM
> *To:* [email-masked]
> *Subject:* Re: [lmap] WGLC for draft-ietf-lmap-information-model-13
>
>
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 12 Dec 2016 21:50:29 +0100

Hi Dan,

the proposed diff is here:

http://www.beadg.de/draft-ietf-lmap-information-model-14-from-3.diff.html

It is all editorial as far as I can tell.

/js

> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Mon, 12 Dec 2016 20:54:00 +0000

Dan,
They were comments embedded in the PDF version of the document.
Here was the resulting messages from Juergen and myself – you can see in the diff; the changes were editorial
------------------------------------------------------------------------------------------------------------------------------------------------------

Thanks Tim. I have made a couple of edits. See here for a diff:

- I did not remove the logging examples; they may not be tremendously

  useful but then I like to minimize the edits.

- Order of options and RFC 2119 language: There are many things in

  this document that I think are normative but where we do not use RFC

  2119 language. It would be a major effort to go through the document

  and put RFC 2119 language everywhere where we say something

  normative. Not sure I am keen on doing this until I am forced to do

  so. (There are actually only two MUST - both related to timestamp

  formats.)

- The text about order of options may look duplicate but then the text

  is once for the report and once for the schedule, i.e. action

  invocation. I do not think this duplication is harmful.

- Yes, the information does not define the parameters aka options of

  tasks. Hence you can't find this flag in the information model.

/js

On Sun, Dec 04, 2016 at 07:57:56PM +0000, Carey, Timothy (Nokia - US) wrote:

> Juergen,

> FYI - I did a review of the LMAP IM - My comments are attached. I didn't see any problems in the information model - just some editorial comments.

> Merry Christmas

> Tim

I was happy with the changes except for  a definition of options – which Juergen provided

-----------------------------------------------------------------------------------------------------------------------------------------------

<TAC> Ok - I didn't catch the linkage to the term parameter; that when we use it in the draft, the term as a link to an option...

-----Original Message-----

From: Juergen Schoenwaelder [mailto:[email-masked]]

Sent: Thursday, December 08, 2016 2:23 AM

To: Carey, Timothy (Nokia - US) <[email-masked]<mailto:[email-masked]>>

Cc: Weil, Jason <[email-masked]<mailto:[email-masked]>>

Subject: Re: Review of the LMAP Information Model

On Wed, Dec 07, 2016 at 09:56:47PM +0000, Carey, Timothy (Nokia - US) wrote:

> - Yes, the information does not define the parameters aka options of

>   tasks. Hence you can't find this flag in the information model.

> <TAC> My point is that people might be looking for this in the information model. Maybe just let them know its an option like:

> Reporting Task might also have a flag parameter, defined as an Option,

> to indicate whether to send a report without measurement results if

> there is no measurement result data pending to be transferred to the Collector.

I just searched for 'parameter' in the text it seems there are several places where we do not specifically indicate that parameters are represented as options in the information model. But then we do have text that clarifies this in some places, e.g. the definition of ma-task-obj says:

   [...] Options allow the configuration of task

   parameters (in the form of name-value pairs).

If we want to clarify this more generally earlier in the text, then it might seem more useful to change the second item 3. in section 3:

OLD

   3.  Task Configurations.  A set of Task Configurations is used to

       configure the Tasks that are run by the MA.  This includes the

       registry entries for the Task and any configuration parameters.

       Task Configurations are referenced from a Schedule in order to

       specify what Tasks the MA should execute.

NEW

   3.  Task Configurations.  A set of Task Configurations is used to

       configure the Tasks that are run by the MA.  This includes the

       registry entries for the Task and any configuration parameters,

       represented as Task Options. Task Configurations are referenced

       from a Schedule in order to specify what Tasks the MA should

       execute.

What do you think?

/js
-----------------------------------------------------------------------------------------------------------------------------------------------------

From: Dan Romascanu [mailto:[email-masked]]
Sent: Monday, December 12, 2016 2:38 PM
To: Carey, Timothy (Nokia - US) <[email-masked]>
Cc: [email-masked]
Subject: Re: [lmap] WGLC for draft-ietf-lmap-information-model-13

Hi Tim,
Can you share the comments on the mail list? If I missed them - can you point to the message? We were not planning a new revision of the IM - so we need to get consensus on the changes.
Thanks and Regards,
Dan

On Mon, Dec 12, 2016 at 10:33 PM, Carey, Timothy (Nokia - US) <[email-masked]<mailto:[email-masked]>> wrote:
Dan,

BR,
Tim

From: Dan Romascanu [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, December 12, 2016 6:11 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [lmap] WGLC for draft-ietf-lmap-information-model-13

---

From: Dan Romascanu <[email-masked]>
Date: Mon, 12 Dec 2016 23:00:50 +0200

Thanks, Tim!

Does anybody have any reservation about these changes?

If yes, please let us know immediately on the lmap mail list.
If not, Juergen will issue a revised version of the IM in a couple of days.

Regards,

Dan

On Mon, Dec 12, 2016 at 10:54 PM, Carey, Timothy (Nokia - US) <
[email-masked]> wrote:

> ------------------------------------------------------------
> ------------------------------------------------------------
> ------------------------------
>
>
>
> > FYI - I did a review of the LMAP IM - My comments are attached. I didn't
> see any problems in the information model - just some editorial comments.
>
> >
>
> > Merry Christmas
>
> >
>
> > Tim
>
>
>
>
>
> ------------------------------------------------------------
> ------------------------------------------------------------
> -----------------------
>
> <TAC> Ok - I didn't catch the linkage to the term parameter; that when we
> use it in the draft, the term as a link to an option...
>
>
>
> From: Juergen Schoenwaelder [mailto:[email-masked]
> <[email-masked]>]
>
> Cc: Weil, Jason <[email-masked]>
>
> > <TAC> My point is that people might be looking for this in the
> information model. Maybe just let them know its an option like:
>
> >
>
> I just searched for 'parameter' in the text it seems there are several
> places where we do not specifically indicate that parameters are
> represented as options in the information model. But then we do have text
> that clarifies this in some places, e.g. the definition of ma-task-obj says:
>
>
>
> If we want to clarify this more generally earlier in the text, then it
> might seem more useful to change the second item 3. in section 3:
>
>
>
> OLD
>
>
>
> ------------------------------------------------------------
> ------------------------------------------------------------
> -----------------------------
>
>
>
>
>
>
>
> *Sent:* Monday, December 12, 2016 2:38 PM
> *To:* Carey, Timothy (Nokia - US) <[email-masked]>
> *Cc:* [email-masked]
>