Subject: Re: MDHCP review

From: Mikhail Smirnov <[email-masked]>
Date: Sat, 21 Nov 1998 00:48:54 +0100

Steve,

I'm not an implementor, but IMHO your words

> maintain a similarity between MDHCP and DHCP?" Eliminating this design 
> constraint would allow us to make MDHCP simpler and more efficient.

provide a good answer to your questions.
(and finally, code sharing is not a good design goal).

regards

Michael

---

From: Dave Thaler <[email-masked]>
Date: Fri, 20 Nov 1998 21:47:33 -0500 (EST)

> (and finally, code sharing is not a good design goal).

I disagree.  For example, it is the primary reason that PIM-SM and PIM-DM
continue to share packet formats and such, even though they are
independent protocols.  Cisco and gated have both proven the benefits of 
that decision.

-Dave

---

From: Vern Paxson <[email-masked]>
Date: Sat, 21 Nov 1998 00:55:57 PST

> independent protocols.  Cisco and gated have both proven the benefits of 

I suspect Mikhail meant this more along the lines of "code sharing is not a
*compelling* design goal" when designing things with considerably different
functionality.

		Vern

---

From: Mikhail Smirnov <[email-masked]>
Date: Sat, 21 Nov 1998 16:59:13 +0100

> independent protocols.  Cisco and gated have both proven the benefits of 

I agree, but this is not a code sharing but interworking and 
compatibility feature (1st of all re-use of functionality and,
maybe but not necessary a re-use of some code).

-Michael

---

From: Mikhail Smirnov <[email-masked]>
Date: Sat, 21 Nov 1998 17:03:28 +0100

> *compelling* design goal" when designing things with considerably different

absolutely!
(Thanks Vern, I should read my mails bottom up then your reply would 
save me a message)

- Michael