Subject: Re: New name for MDHCP

From: Dave Thaler <[email-masked]>
Date: Mon, 21 Dec 1998 16:58:47 -0500 (EST)

> At the malloc working group meeting in Orlando, we agreed to change the name 
> of 
> the MDHCP protocol to something else. This was suggested because MDHCP is no 
> longer very similar to DHCP. Here are a few ideas that I have heard batted 
> around. Please send other suggestions to this list.
> 
> Multicast Multicast Address Request Protocol (MARP)
> Multicast Address Assignment Protocol (MAAP)
> 
> Of these, I prefer the latter because the former was already used for my 
> proposal last spring.
> 
> -Steve

To add my two cents:

I personally prefer a name which identifies it as the host-server protocol
(as opposed to intra-domain or inter-domain).  For example, it would be
nice to see the word "host" or the word "client" somewhere in the name.

-Dave

---

From: Steve Hanna <[email-masked]>
Date: Mon, 21 Dec 1998 16:54:28 -0500 (EST)

At the malloc working group meeting in Orlando, we agreed to change the name of 
the MDHCP protocol to something else. This was suggested because MDHCP is no 
longer very similar to DHCP. Here are a few ideas that I have heard batted 
around. Please send other suggestions to this list.

-Steve

---

From: Mark Handley <[email-masked]>
Date: Mon, 21 Dec 1998 17:17:51 -0500

>Multicast Address Request Protocol (MARP)

I prefer the former.  The latter is sure to get confused with the
existing multicast AAP.  Besides, I think the work "Request" conveys
something of the client-server nature of the protocol.

In response to Dave's point, we could go for something like:

Client Request Of Multicast Address (CROMA)
Multicast Address Request by Client (MARC) (!)
Multicast Address Request from Server (MARS)
Client/server Address Request Protocol (CARP)
Host Address Request Protocol (HARP)
Multicast Address Client/Server Protocol (MACS)

I'm sure the potential list is near infinite :-)

Cheers,
	Mark

---

From: Bob Quinn <[email-masked]>
Date: Mon, 21 Dec 1998 23:50:01 -0500

At 05:17 PM 12/21/98 -0500, Mark Handley wrote:
>existing multicast AAP.  

I also prefer the former for the same reason.

>Besides, I think the work "Request" conveys

Another possibility that describes the nature of the request is "Lease."  
Hence a variation would be: "MALP: Multicast Address Lease Protocol."

Regards,
--
Bob Quinn
[email-masked]