
Received: from m.wordtothewise.com (goliath.word-to-the-wise.com [208.187.80.130]) by sb7.songbird.com (8.12.11/8.12.11) with ESMTP id k28JLQ5F003379 for <abuse-feedback-report@mipassoc.org>; Wed, 8 Mar 2006 11:21:26 -0800
Received: from [10.3.2.16] (184.word-to-the-wise.com [208.187.80.184]) (using TLSv1 with cipher RC4-SHA (128/128 bits)) (No client certificate requested) by m.wordtothewise.com (Postfix) with ESMTP id E126F1066D; Wed,  8 Mar 2006 11:20:48 -0800 (PST)
In-Reply-To: <440F2D0C.1090607@solidmatrix.com>
References: <E25343C1-15B9-467B-905C-799B990CAE58@word-to-the-wise.com> <440F2D0C.1090607@solidmatrix.com>
Mime-Version: 1.0 (Apple Message framework v746.2)
Content-Type: text/plain; charset=US-ASCII; delsp=yes; format=flowed
Message-Id: <792182BC-C3C1-4BDA-AA8C-1927ED9302EE@word-to-the-wise.com>
Content-Transfer-Encoding: 7bit
From: Steve Atkins <steve@word-to-the-wise.com>
Subject: Re: [feedback-report] ARF spec question
Date: Wed, 8 Mar 2006 11:20:47 -0800
To: Yakov Shafranovich <YakovS@solidmatrix.com>
X-Mailer: Apple Mail (2.746.2)
X-SongbirdInformation: support@songbird.com for more information
X-Songbird: Found to be clean
X-Songbird-From: steve@word-to-the-wise.com
Cc: abuse-feedback-report@mipassoc.org
X-BeenThere: abuse-feedback-report@mipassoc.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: Public forum for discussion on the feedback-report draft <abuse-feedback-report.mipassoc.org>
List-Unsubscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=unsubscribe>
List-Archive: <http://mipassoc.org/pipermail/abuse-feedback-report>
List-Post: <mailto:abuse-feedback-report@mipassoc.org>
List-Help: <mailto:abuse-feedback-report-request@mipassoc.org?subject=help>
List-Subscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=subscribe>
X-List-Received-Date: Wed, 08 Mar 2006 19:21:30 -0000

On Mar 8, 2006, at 11:14 AM, Yakov Shafranovich wrote:

> Steve Atkins wrote:
> ...
>> The spec says that the body of this content type consists of
>> multiple fields formatted according to the ABNF of RFC822
>> header fields. While you could take that to mean that each
>> individual field is formatted that way (which they are here) it
>> seems to me that the whole body should be formatted that
>> way, meaning that it terminates at the first blank line.
>> That leads to a couple of questions.
>> First, am I right to say that the snippet above isn't valid,
>> and the blank lines should go away?
>
> It is an interesting question. When I wrote the spec originally, I  
> looked at the other three "multipart/report" standards: DSNs, MDNs  
> and message tracking.
>
> For example, RFC 3464 which is a "child" of the "multipart/report"  
> MIME type has specific conventions in regards to blank lines.  
> Section 2.1 states that:
>
>    "per-message fields appear first, followed by a
>    blank line.  Following the per-message fields are one or more  
> groups
>    of per-recipient fields.  Each group of per-recipient fields is
>    preceded by a blank line."
>
> RFC 3886 is a bit more explicit in section 3.1:
>
>    "The per-message fields appear first, followed by a blank line.
>    Following the per-message fields are one or more groups of per-
>    recipient fields.  Each group of per-recipient fields is  
> preceded by
>    a blank line.  Note that there will be a blank line between the  
> final
>    per-recipient field and the MIME boundary, since one CRLF is
>    necessary to terminate the field, and a second is necessary to
>    introduce the MIME boundary."
>
> RFC 3798 (another "multipart/report" child) does not mention  
> anything about blank lines but it is clear from examples that blank  
> lines should not be allowed.
>
> All of this seems to imply that in absence of specific  
> instructions, your interpretation is correct.
>
>> Second, if so, do we need to clarify the wording in the
>> spec?
>
> It is a good idea to clarify the spec in any case. The question is  
> whether to allow blank lines?

Definitely not, IMO.

They add no value in this case and they mean that people won't be
able to reuse time-tested header parsing code.

RFC822 headers are an ugly format to parse and the only real
advantages of using them as a format are code reuse, documentation
reuse and familiarity of email people with the format. If we tweak
the format just a little by allowing embedded blank lines then
we inherit all the problems and avoid any chance to reuse
production tested code.

It also breaks all the existing parsers I'm aware of. :)

Cheers,
   Steve



Received: from manet.hmdnsgroup.com (manet.hmdnsgroup.com [63.247.133.3]) by sb7.songbird.com (8.12.11/8.12.11) with ESMTP id k28JFAao002543 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=NO) for <abuse-feedback-report@mipassoc.org>; Wed, 8 Mar 2006 11:15:11 -0800
Received: from pool-70-17-225-240.balt.east.verizon.net ([70.17.225.240]:4283 helo=[192.168.1.2]) by manet.hmdnsgroup.com with esmtpsa (TLSv1:AES256-SHA:256) (Exim 4.52) id 1FH47A-0001gh-49; Wed, 08 Mar 2006 14:14:28 -0500
Message-ID: <440F2D0C.1090607@solidmatrix.com>
Date: Wed, 08 Mar 2006 14:14:20 -0500
From: Yakov Shafranovich <YakovS@solidmatrix.com>
Organization: SolidMatrix Technologies, Inc.
User-Agent: Thunderbird 1.5 (Windows/20051201)
MIME-Version: 1.0
To: Steve Atkins <steve@word-to-the-wise.com>
Subject: Re: [feedback-report] ARF spec question
References: <E25343C1-15B9-467B-905C-799B990CAE58@word-to-the-wise.com>
In-Reply-To: <E25343C1-15B9-467B-905C-799B990CAE58@word-to-the-wise.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-HMDNSGroup-MailScanner-Information: Please contact the ISP for more information
X-HMDNSGroup-MailScanner: Found to be clean
X-HMDNSGroup-MailScanner-SpamCheck: 
X-HMDNSGroup-MailScanner-From: yakovs@solidmatrix.com
X-AntiAbuse: This header was added to track abuse, please include it with any abuse report
X-AntiAbuse: Primary Hostname - manet.hmdnsgroup.com
X-AntiAbuse: Original Domain - mipassoc.org
X-AntiAbuse: Originator/Caller UID/GID - [47 12] / [47 12]
X-AntiAbuse: Sender Address Domain - solidmatrix.com
X-Source: 
X-Source-Args: 
X-Source-Dir: 
X-SongbirdInformation: support@songbird.com for more information
X-Songbird: Found to be clean
X-Songbird-From: yakovs@solidmatrix.com
Cc: abuse-feedback-report@mipassoc.org
X-BeenThere: abuse-feedback-report@mipassoc.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: Public forum for discussion on the feedback-report draft <abuse-feedback-report.mipassoc.org>
List-Unsubscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=unsubscribe>
List-Archive: <http://mipassoc.org/pipermail/abuse-feedback-report>
List-Post: <mailto:abuse-feedback-report@mipassoc.org>
List-Help: <mailto:abuse-feedback-report-request@mipassoc.org?subject=help>
List-Subscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=subscribe>
X-List-Received-Date: Wed, 08 Mar 2006 19:15:25 -0000

Steve Atkins wrote:
...
> The spec says that the body of this content type consists of
> multiple fields formatted according to the ABNF of RFC822
> header fields. While you could take that to mean that each
> individual field is formatted that way (which they are here) it
> seems to me that the whole body should be formatted that
> way, meaning that it terminates at the first blank line.
> 
> That leads to a couple of questions.
> 
> First, am I right to say that the snippet above isn't valid,
> and the blank lines should go away?
> 

It is an interesting question. When I wrote the spec originally, I 
looked at the other three "multipart/report" standards: DSNs, MDNs and 
message tracking.

For example, RFC 3464 which is a "child" of the "multipart/report" MIME 
type has specific conventions in regards to blank lines. Section 2.1 
states that:

    "per-message fields appear first, followed by a
    blank line.  Following the per-message fields are one or more groups
    of per-recipient fields.  Each group of per-recipient fields is
    preceded by a blank line."

RFC 3886 is a bit more explicit in section 3.1:

    "The per-message fields appear first, followed by a blank line.
    Following the per-message fields are one or more groups of per-
    recipient fields.  Each group of per-recipient fields is preceded by
    a blank line.  Note that there will be a blank line between the final
    per-recipient field and the MIME boundary, since one CRLF is
    necessary to terminate the field, and a second is necessary to
    introduce the MIME boundary."

RFC 3798 (another "multipart/report" child) does not mention anything 
about blank lines but it is clear from examples that blank lines should 
not be allowed.

All of this seems to imply that in absence of specific instructions, 
your interpretation is correct.

> Second, if so, do we need to clarify the wording in the
> spec?
> 

It is a good idea to clarify the spec in any case. The question is 
whether to allow blank lines?

Yakov


Received: from mta1.habeas.com (mta1.habeas.com [208.184.22.25]) by sb7.songbird.com (8.12.11/8.12.11) with ESMTP id k28IZo7E028863 for <abuse-feedback-report@mipassoc.org>; Wed, 8 Mar 2006 10:35:50 -0800
Received: from ofw1.habeas.com (63-207-218-130.ded.pacbell.net [63.207.218.130]) by mta1.habeas.com (Postfix) with ESMTP id C2FB33477; Wed,  8 Mar 2006 10:35:12 -0800 (PST)
Received: from [10.9.8.20] (heceta.habeas.com [10.9.8.20]) by ofw1.habeas.com (Postfix) with ESMTP id B88CA13D5; Wed,  8 Mar 2006 10:35:12 -0800 (PST)
Message-ID: <440F23D8.9050902@habeas.com>
Date: Wed, 08 Mar 2006 10:35:04 -0800
From: "Carl S. Gutekunst" <csg@habeas.com>
Organization: Habeas, Inc.
User-Agent: Mozilla Thunderbird 1.0.7 (X11/20050923)
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: Steve Atkins <steve@word-to-the-wise.com>
Subject: Re: [feedback-report] ARF spec question
References: <E25343C1-15B9-467B-905C-799B990CAE58@word-to-the-wise.com>
In-Reply-To: <E25343C1-15B9-467B-905C-799B990CAE58@word-to-the-wise.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-SongbirdInformation: support@songbird.com for more information
X-Songbird: Found to be clean
X-Songbird-From: csg@habeas.com
Cc: abuse-feedback-report@mipassoc.org
X-BeenThere: abuse-feedback-report@mipassoc.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: Public forum for discussion on the feedback-report draft <abuse-feedback-report.mipassoc.org>
List-Unsubscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=unsubscribe>
List-Archive: <http://mipassoc.org/pipermail/abuse-feedback-report>
List-Post: <mailto:abuse-feedback-report@mipassoc.org>
List-Help: <mailto:abuse-feedback-report-request@mipassoc.org?subject=help>
List-Subscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=subscribe>
X-List-Received-Date: Wed, 08 Mar 2006 18:36:05 -0000

Steve Atkins wrote:

> First, am I right to say that the snippet above isn't valid,
> and the blank lines should go away? 

Well, it certainly breaks my parser, which stops on the first blank line.

I'm wondering about the cause, though: Are you sure the CR/LF/Newline 
mapping is proper all along the path?

<csg>


Received: from [192.168.0.2] (adsl-71-131-40-72.dsl.sntc01.pacbell.net [71.131.40.72]) (authenticated bits=0) by sb7.songbird.com (8.12.11/8.12.11) with ESMTP id k28IQNCL027352 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=NO); Wed, 8 Mar 2006 10:26:24 -0800
Message-ID: <440F21A9.9080101@dcrocker.net>
Date: Wed, 08 Mar 2006 10:25:45 -0800
From: Dave Crocker <dhc@dcrocker.net>
Organization: Brandenburg InternetWorking
User-Agent: Thunderbird 1.5 (Windows/20051025)
MIME-Version: 1.0
To: Steve Atkins <steve@word-to-the-wise.com>
Subject: Re: [feedback-report] ARF spec question
References: <E25343C1-15B9-467B-905C-799B990CAE58@word-to-the-wise.com>
In-Reply-To: <E25343C1-15B9-467B-905C-799B990CAE58@word-to-the-wise.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-SongbirdInformation: support@songbird.com for more information
X-Songbird: Found to be clean
X-Songbird-From: dhc@dcrocker.net
Cc: abuse-feedback-report@mipassoc.org
X-BeenThere: abuse-feedback-report@mipassoc.org
X-Mailman-Version: 2.1.5
Precedence: list
Reply-To: dcrocker@bbiw.net
List-Id: Public forum for discussion on the feedback-report draft <abuse-feedback-report.mipassoc.org>
List-Unsubscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=unsubscribe>
List-Archive: <http://mipassoc.org/pipermail/abuse-feedback-report>
List-Post: <mailto:abuse-feedback-report@mipassoc.org>
List-Help: <mailto:abuse-feedback-report-request@mipassoc.org?subject=help>
List-Subscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=subscribe>
X-List-Received-Date: Wed, 08 Mar 2006 18:26:40 -0000

> The spec says that the body of this content type consists of
> multiple fields formatted according to the ABNF of RFC822
> header fields. While you could take that to mean that each
> individual field is formatted that way (which they are here) it
> seems to me that the whole body should be formatted that
> way, meaning that it terminates at the first blank line.


On the theory that the benefit of blindly citing conformance to rfc822 header 
syntax is that it permits re-using well-established code for processing such a 
header, then the extra blank lines must be an absolute no-no.

 From any other perspective, I suspect the blank lines are merely a nuisance, 
since the MIME dividers take care of finding the ending boundary.

d/
-- 

Dave Crocker
Brandenburg InternetWorking
<http://bbiw.net>


Received: from m.wordtothewise.com (goliath.word-to-the-wise.com [208.187.80.130]) by sb7.songbird.com (8.12.11/8.12.11) with ESMTP id k28I4BED023997 for <abuse-feedback-report@mipassoc.org>; Wed, 8 Mar 2006 10:04:11 -0800
Received: from [10.3.2.16] (184.word-to-the-wise.com [208.187.80.184]) (using TLSv1 with cipher RC4-SHA (128/128 bits)) (No client certificate requested) by m.wordtothewise.com (Postfix) with ESMTP id 51C44106B2 for <abuse-feedback-report@mipassoc.org>; Wed,  8 Mar 2006 10:03:33 -0800 (PST)
Mime-Version: 1.0 (Apple Message framework v746.2)
Content-Transfer-Encoding: 7bit
Message-Id: <E25343C1-15B9-467B-905C-799B990CAE58@word-to-the-wise.com>
Content-Type: text/plain; charset=US-ASCII; delsp=yes; format=flowed
To: abuse-feedback-report@mipassoc.org
From: Steve Atkins <steve@word-to-the-wise.com>
Date: Wed, 8 Mar 2006 10:03:32 -0800
X-Mailer: Apple Mail (2.746.2)
X-SongbirdInformation: support@songbird.com for more information
X-Songbird: Found to be clean
X-Songbird-From: steve@word-to-the-wise.com
Subject: [feedback-report] ARF spec question
X-BeenThere: abuse-feedback-report@mipassoc.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: Public forum for discussion on the feedback-report draft <abuse-feedback-report.mipassoc.org>
List-Unsubscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=unsubscribe>
List-Archive: <http://mipassoc.org/pipermail/abuse-feedback-report>
List-Post: <mailto:abuse-feedback-report@mipassoc.org>
List-Help: <mailto:abuse-feedback-report-request@mipassoc.org?subject=help>
List-Subscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=subscribe>
X-List-Received-Date: Wed, 08 Mar 2006 18:04:19 -0000

I have a snippet of ARF report here (with some of the data masked a  
little
to protect the guilty).

--_----------=_114183695220154735
Content-Disposition: inline
Content-Transfer-Encoding: 7bit
Content-Type: message/feedback-report

Feedback-Type: abuse

Version: 1

Source-IP: 208.187.80.130

Feedback-Agent: HatStand/1.0

Received-Date: Wed, 8 Mar 2006 05:10:12 -0500


--_----------=_114183695220154735

There's one obvious problem - we're at version 0.1 right now,
not version 1 - but the spacing of the lines also seems wrong.

The spec says that the body of this content type consists of
multiple fields formatted according to the ABNF of RFC822
header fields. While you could take that to mean that each
individual field is formatted that way (which they are here) it
seems to me that the whole body should be formatted that
way, meaning that it terminates at the first blank line.

That leads to a couple of questions.

First, am I right to say that the snippet above isn't valid,
and the blank lines should go away?

Second, if so, do we need to clarify the wording in the
spec?

Cheers,
   Steve



Received: from [192.168.0.2] (adsl-71-131-42-153.dsl.sntc01.pacbell.net [71.131.42.153]) (authenticated bits=0) by sb7.songbird.com (8.12.11/8.12.11) with ESMTP id k25GoNY1011290 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=NO) for <abuse-feedback-report@mipassoc.org>; Sun, 5 Mar 2006 08:50:24 -0800
Message-ID: <440B16A9.4050102@dcrocker.net>
Date: Sun, 05 Mar 2006 08:49:45 -0800
From: Dave Crocker <dhc@dcrocker.net>
Organization: Brandenburg InternetWorking
User-Agent: Thunderbird 1.5 (Windows/20051025)
MIME-Version: 1.0
To: abuse-feedback-report@mipassoc.org
References: <mailman.7234.1141517632.1568.abuse-feedback-report@mipassoc.org> <1E700D11-45B0-437B-8F61-612E2E24AC77@word-to-the-wise.com>
In-Reply-To: <1E700D11-45B0-437B-8F61-612E2E24AC77@word-to-the-wise.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-SongbirdInformation: support@songbird.com for more information
X-Songbird: Found to be clean
X-Songbird-From: dhc@dcrocker.net
Subject: [feedback-report] ARF deployment status page
X-BeenThere: abuse-feedback-report@mipassoc.org
X-Mailman-Version: 2.1.5
Precedence: list
Reply-To: dcrocker@bbiw.net
List-Id: Public forum for discussion on the feedback-report draft <abuse-feedback-report.mipassoc.org>
List-Unsubscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=unsubscribe>
List-Archive: <http://mipassoc.org/pipermail/abuse-feedback-report>
List-Post: <mailto:abuse-feedback-report@mipassoc.org>
List-Help: <mailto:abuse-feedback-report-request@mipassoc.org?subject=help>
List-Subscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=subscribe>
X-List-Received-Date: Sun, 05 Mar 2006 16:50:33 -0000

Folks,

The ARF page <http://mipassoc.org/arf> now includes a pointer to the development 
and use page maintained by Steve Atkins.

d/
-- 

Dave Crocker
Brandenburg InternetWorking
<http://bbiw.net>


Received: from m.wordtothewise.com (goliath.word-to-the-wise.com [208.187.80.130]) by sb7.songbird.com (8.12.11/8.12.11) with ESMTP id k251OHnW015912 for <abuse-feedback-report@mipassoc.org>; Sat, 4 Mar 2006 17:24:17 -0800
Received: from [10.3.2.16] (184.word-to-the-wise.com [208.187.80.184]) (using TLSv1 with cipher RC4-SHA (128/128 bits)) (No client certificate requested) by m.wordtothewise.com (Postfix) with ESMTP id 542431066D for <abuse-feedback-report@mipassoc.org>; Sat,  4 Mar 2006 17:23:39 -0800 (PST)
Mime-Version: 1.0 (Apple Message framework v746.2)
In-Reply-To: <B21F34DD56F6BC43BBD9768659FB89E4B8CF7EDD@EXCH-C1.corp.cloudmark.com>
References: <B21F34DD56F6BC43BBD9768659FB89E4B8CF7EDD@EXCH-C1.corp.cloudmark.com>
Content-Type: text/plain; charset=US-ASCII; delsp=yes; format=flowed
Message-Id: <AF1CB421-B4FE-4700-A0F4-1332EB21B0F0@word-to-the-wise.com>
Content-Transfer-Encoding: 7bit
From: Steve Atkins <steve@word-to-the-wise.com>
Subject: Re: [feedback-report] MIME::ARF
Date: Sat, 4 Mar 2006 17:23:38 -0800
To: abuse-feedback-report@mipassoc.org
X-Mailer: Apple Mail (2.746.2)
X-SongbirdInformation: support@songbird.com for more information
X-Songbird: Found to be clean
X-Songbird-From: steve@word-to-the-wise.com
X-BeenThere: abuse-feedback-report@mipassoc.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: Public forum for discussion on the feedback-report draft <abuse-feedback-report.mipassoc.org>
List-Unsubscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=unsubscribe>
List-Archive: <http://mipassoc.org/pipermail/abuse-feedback-report>
List-Post: <mailto:abuse-feedback-report@mipassoc.org>
List-Help: <mailto:abuse-feedback-report-request@mipassoc.org?subject=help>
List-Subscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=subscribe>
X-List-Received-Date: Sun, 05 Mar 2006 01:24:40 -0000

On Mar 4, 2006, at 4:23 PM, Vipul Ved Prakash wrote:

> Thanks.  Would be great to have these on CPAN as well.
>

Yes. They need docs and testcases and licenses[1] and other such
things before that, though.

Once I have Mail::ARF released I'll be looking at those,
and probably a better namespace than the current one too.

(Any perlish people who want to give me namespace advice
offlist would be very welcome).

Cheers,
   Steve

[1] New BSD, if anyone cares.

> Cheers,
> vipul
>
> -----Original Message-----
> From: abuse-feedback-report-bounces@mipassoc.org
> [mailto:abuse-feedback-report-bounces@mipassoc.org] On Behalf Of Steve
> Atkins
> Sent: Saturday, March 04, 2006 4:18 PM
> To: abuse-feedback-report@mipassoc.org
> Subject: Fwd: [feedback-report] MIME::ARF
>
>
>
> Begin forwarded message:
>
>>
>> From: Steve Atkins <steve@blighty.com>
>> Date: March 4, 2006 4:12:53 PM PST
>> To: abuse-feedback-report@mipassoc.org
>> Subject: Re: [feedback-report] MIME::ARF
>>
>>
>>
>> On Mar 4, 2006, at 3:46 PM, Vipul Ved Prakash wrote:
>>
>>> Hi,
>>>
>>> Is the MIME::ARF module publically available?
>>
>> Assuming you mean mine, it's publicly available, yes, linked  
>> somewhere
>
>> on arf.word-to-the-wise.com.
>>
>>> Is it intended to be open
>>> source?
>>
>> Certainly. Share and enjoy.
>>
>> I have another module for validating ARF I'll be dropping onto the
>> website in the next couple of days.
>>
>> Cheers,
>>   Steve
>>
>>
>>
>
> _______________________________________________
> abuse-feedback-report mailing list
> abuse-feedback-report@mipassoc.org
> http://mipassoc.org/mailman/listinfo/abuse-feedback-report



Received: from mx2.cloudmark.com (mx2.cloudmark.com [63.80.128.197]) by sb7.songbird.com (8.12.11/8.12.11) with ESMTP id k250NixE011127 for <abuse-feedback-report@mipassoc.org>; Sat, 4 Mar 2006 16:23:45 -0800
X-MimeOLE: Produced By Microsoft Exchange V6.5
Content-class: urn:content-classes:message
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Subject: RE: [feedback-report] MIME::ARF
Date: Sat, 4 Mar 2006 16:23:05 -0800
Message-ID: <B21F34DD56F6BC43BBD9768659FB89E4B8CF7EDD@EXCH-C1.corp.cloudmark.com>
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
Thread-Topic: [feedback-report] MIME::ARF
Thread-Index: AcY/6qh1vwQX6mo3RzKiItlwbHQvSQAAEUBQ
From: "Vipul Ved Prakash" <vipul@cloudmark.com>
To: "Steve Atkins" <steve@word-to-the-wise.com>, <abuse-feedback-report@mipassoc.org>
X-SongbirdInformation: support@songbird.com for more information
X-Songbird: Found to be clean
X-Songbird-From: vipul@cloudmark.com
Content-Transfer-Encoding: 8bit
X-MIME-Autoconverted: from quoted-printable to 8bit by sb7.songbird.com id k250NixE011127
Cc: 
X-BeenThere: abuse-feedback-report@mipassoc.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: Public forum for discussion on the feedback-report draft <abuse-feedback-report.mipassoc.org>
List-Unsubscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=unsubscribe>
List-Archive: <http://mipassoc.org/pipermail/abuse-feedback-report>
List-Post: <mailto:abuse-feedback-report@mipassoc.org>
List-Help: <mailto:abuse-feedback-report-request@mipassoc.org?subject=help>
List-Subscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=subscribe>
X-List-Received-Date: Sun, 05 Mar 2006 00:23:56 -0000

Thanks.  Would be great to have these on CPAN as well. 

Cheers,
vipul 

-----Original Message-----
From: abuse-feedback-report-bounces@mipassoc.org
[mailto:abuse-feedback-report-bounces@mipassoc.org] On Behalf Of Steve
Atkins
Sent: Saturday, March 04, 2006 4:18 PM
To: abuse-feedback-report@mipassoc.org
Subject: Fwd: [feedback-report] MIME::ARF



Begin forwarded message:

>
> From: Steve Atkins <steve@blighty.com>
> Date: March 4, 2006 4:12:53 PM PST
> To: abuse-feedback-report@mipassoc.org
> Subject: Re: [feedback-report] MIME::ARF
>
>
>
> On Mar 4, 2006, at 3:46 PM, Vipul Ved Prakash wrote:
>
>> Hi,
>>
>> Is the MIME::ARF module publically available?
>
> Assuming you mean mine, it's publicly available, yes, linked somewhere

> on arf.word-to-the-wise.com.
>
>> Is it intended to be open
>> source?
>
> Certainly. Share and enjoy.
>
> I have another module for validating ARF I'll be dropping onto the 
> website in the next couple of days.
>
> Cheers,
>   Steve
>
>
>

_______________________________________________
abuse-feedback-report mailing list
abuse-feedback-report@mipassoc.org
http://mipassoc.org/mailman/listinfo/abuse-feedback-report



Received: from m.wordtothewise.com (goliath.word-to-the-wise.com [208.187.80.130]) by sb7.songbird.com (8.12.11/8.12.11) with ESMTP id k250IQUA010727 for <abuse-feedback-report@mipassoc.org>; Sat, 4 Mar 2006 16:18:26 -0800
Received: from [10.3.2.16] (184.word-to-the-wise.com [208.187.80.184]) (using TLSv1 with cipher RC4-SHA (128/128 bits)) (No client certificate requested) by m.wordtothewise.com (Postfix) with ESMTP id 4B3B71066D for <abuse-feedback-report@mipassoc.org>; Sat,  4 Mar 2006 16:17:48 -0800 (PST)
Mime-Version: 1.0 (Apple Message framework v746.2)
References: <mailman.7234.1141517632.1568.abuse-feedback-report@mipassoc.org>
Content-Type: text/plain; charset=US-ASCII; format=flowed
Message-Id: <1E700D11-45B0-437B-8F61-612E2E24AC77@word-to-the-wise.com>
Content-Transfer-Encoding: 7bit
From: Steve Atkins <steve@word-to-the-wise.com>
Subject: Fwd: [feedback-report] MIME::ARF
Date: Sat, 4 Mar 2006 16:17:47 -0800
To: abuse-feedback-report@mipassoc.org
X-Mailer: Apple Mail (2.746.2)
X-SongbirdInformation: support@songbird.com for more information
X-Songbird: Found to be clean
X-Songbird-From: steve@word-to-the-wise.com
X-BeenThere: abuse-feedback-report@mipassoc.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: Public forum for discussion on the feedback-report draft <abuse-feedback-report.mipassoc.org>
List-Unsubscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=unsubscribe>
List-Archive: <http://mipassoc.org/pipermail/abuse-feedback-report>
List-Post: <mailto:abuse-feedback-report@mipassoc.org>
List-Help: <mailto:abuse-feedback-report-request@mipassoc.org?subject=help>
List-Subscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=subscribe>
X-List-Received-Date: Sun, 05 Mar 2006 00:18:34 -0000

Begin forwarded message:

>
> From: Steve Atkins <steve@blighty.com>
> Date: March 4, 2006 4:12:53 PM PST
> To: abuse-feedback-report@mipassoc.org
> Subject: Re: [feedback-report] MIME::ARF
>
>
>
> On Mar 4, 2006, at 3:46 PM, Vipul Ved Prakash wrote:
>
>> Hi,
>>
>> Is the MIME::ARF module publically available?
>
> Assuming you mean mine, it's publicly available, yes,
> linked somewhere on arf.word-to-the-wise.com.
>
>> Is it intended to be open
>> source?
>
> Certainly. Share and enjoy.
>
> I have another module for validating ARF I'll be dropping
> onto the website in the next couple of days.
>
> Cheers,
>   Steve
>
>
>



Received: from mx2.cloudmark.com (mx2.cloudmark.com [63.80.128.197]) by sb7.songbird.com (8.12.11/8.12.11) with ESMTP id k24NlGaG007559 for <abuse-feedback-report@mipassoc.org>; Sat, 4 Mar 2006 15:47:16 -0800
X-MimeOLE: Produced By Microsoft Exchange V6.5
Content-class: urn:content-classes:message
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Date: Sat, 4 Mar 2006 15:46:38 -0800
Message-ID: <B21F34DD56F6BC43BBD9768659FB89E4B8CF7EDC@EXCH-C1.corp.cloudmark.com>
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
Thread-Topic: MIME::ARF
Thread-Index: AcY/5eEb7jhoPDf4RSCkaG2wMOLdrw==
From: "Vipul Ved Prakash" <vipul@cloudmark.com>
To: <abuse-feedback-report@mipassoc.org>
X-SongbirdInformation: support@songbird.com for more information
X-Songbird: Found to be clean
X-Songbird-From: vipul@cloudmark.com
Content-Transfer-Encoding: 8bit
X-MIME-Autoconverted: from quoted-printable to 8bit by sb7.songbird.com id k24NlGaG007559
Subject: [feedback-report] MIME::ARF
X-BeenThere: abuse-feedback-report@mipassoc.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: Public forum for discussion on the feedback-report draft <abuse-feedback-report.mipassoc.org>
List-Unsubscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=unsubscribe>
List-Archive: <http://mipassoc.org/pipermail/abuse-feedback-report>
List-Post: <mailto:abuse-feedback-report@mipassoc.org>
List-Help: <mailto:abuse-feedback-report-request@mipassoc.org?subject=help>
List-Subscribe: <http://mipassoc.org/mailman/listinfo/abuse-feedback-report>,  <mailto:abuse-feedback-report-request@mipassoc.org?subject=subscribe>
X-List-Received-Date: Sat, 04 Mar 2006 23:47:18 -0000

Hi, 

Is the MIME::ARF module publically available?  Is it intended to be open
source?

Cheers,
vipul


