Subject: [marf] I-D Action: draft-ietf-marf-redaction-07.txt

From: [email-masked]
Date: Tue, 24 Jan 2012 09:44:07 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Messaging Abuse Reporting Format Working Group of the IETF.

	Title           : Redaction of Potentially Sensitive Data from Mail Abuse Reports
	Author(s)       : J.D. Falk
                          M. Kucherawy
	Filename        : draft-ietf-marf-redaction-07.txt
	Pages           : 8
	Date            : 2012-01-24

   Email messages often contain information that might be considered
   private or sensitive, per either regulation or social norms.  When
   such a message becomes the subject of a report intended to be shared
   with other entities, the report generator may wish to redact or elide
   the sensitive portions of the message.  This memo suggests one method
   for doing so effectively.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-marf-redaction-07.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-marf-redaction-07.txt

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 24 Jan 2012 09:50:59 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Tuesday, January 24, 2012 9:44 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-marf-redaction-07.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Messaging Abuse Reporting
> Format Working Group of the IETF.
> 

The DISCUSS was cleared this morning.  This version includes the changes based on Alessandro's suggestions, per recent consensus support.  We hope this is the final version.  We'll ping Pete to approve this one on Friday if there hasn't been any squawking.

-MSK

---

From: Barry Leiba <[email-masked]>
Date: Fri, 27 Jan 2012 00:37:05 -0500

> The DISCUSS was cleared this morning.  This version includes the changes
> based on Alessandro's suggestions, per recent consensus support.  We hope
> this is the final version.  We'll ping Pete to approve this one on Friday
if there
> hasn't been any squawking.

In case Murray's note wasn't clear on this:
We do want some folks to give -07 a final review and make sure that the
changes since WG approval are still acceptable.  We think the document is
now a better one than what we sent to the IESG before.  Let's get some
confirmation on that, please.

Pete is considering, based on IESG feedback, whether or not to issue a
second IETF Last Call on the document, similarly to re-confirm consensus
after the changes.  It's an interesting discussion as to how much may
change *after* a document is approved by the community, and before it goes
to the RFC Editor.  We don't know yet what Pete will do, but even a new
Last Call will likely only delay the document by two weeks.

Barry

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 26 Jan 2012 22:37:53 -0800

Just a point of clarification, this will actually be a third IETF Last Call, after its state change from Informational to Proposed Standard.  Whew.  :)

From: [email-masked] [mailto:[email-masked]] On Behalf Of Barry Leiba
Sent: Thursday, January 26, 2012 9:37 PM
To: Murray S. Kucherawy
Cc: [email-masked]
Subject: Re: [marf] I-D Action: draft-ietf-marf-redaction-07.txt

> this is the final version.  We'll ping Pete to approve this one on Friday if there

In case Murray's note wasn't clear on this:
We do want some folks to give -07 a final review and make sure that the changes since WG approval are still acceptable.  We think the document is now a better one than what we sent to the IESG before.  Let's get some confirmation on that, please.

Pete is considering, based on IESG feedback, whether or not to issue a second IETF Last Call on the document, similarly to re-confirm consensus after the changes.  It's an interesting discussion as to how much may change *after* a document is approved by the community, and before it goes to the RFC Editor.  We don't know yet what Pete will do, but even a new Last Call will likely only delay the document by two weeks.

Barry

---

From: Shmuel (Seymour J.) Metz <[email-masked]>
Date: Fri, 27 Jan 2012 09:01:13 -0500

In
<[email-masked]>,
on 01/27/2012
   at 12:37 AM, Barry Leiba <[email-masked]> said:

>We do want some folks to give -07 a final review and make sure that
>the changes since WG approval are still acceptable.

It looks good as long as it keeps the IESG happy.

-- 
     Shmuel (Seymour J.) Metz, SysProg and JOAT
     Atid/2        <http://patriot.net/~shmuel>
We don't care. We don't have to care, we're Congress.
(S877: The Shut up and Eat Your spam act of 2003)

---

From: Barry Leiba <[email-masked]>
Date: Fri, 27 Jan 2012 11:53:22 -0500

> It looks good as long as it keeps the IESG happy.

I'm glad to see the first half of that sentence.  Note that "keeping
the IESG happy" is not what we're asking here.  The main point is
whether the WG thinks this document is (1) good, and (2) better than
previous versions.

If anyone thinks this version has made the document *worse*, we want
to know that, regardless of whether the IESG is happy.

Barry, in a very chairy mood today

---

From: SM <[email-masked]>
Date: Fri, 27 Jan 2012 08:58:14 -0800

Hi Barry,
>to know that, regardless of whether the IESG is happy.

The RFC 2119 boilerplate and reference is missing.

Regards,
-sm

---

From: Barry Leiba <[email-masked]>
Date: Fri, 27 Jan 2012 12:16:19 -0500

> The RFC 2119 boilerplate and reference is missing.

True: there's one SHOULD and one MAY in the document now.

Barry

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 27 Jan 2012 09:42:34 -0800

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Barry Leiba
> Sent: Friday, January 27, 2012 9:16 AM
> To: Message Abuse Report Format working group

&#%$!

Fixed for -08.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 27 Jan 2012 09:53:41 -0800

> From: [email-masked] [mailto:[email-masked]] On Behalf Of SM
> Sent: Friday, January 27, 2012 8:58 AM
> To: Barry Leiba
> Cc: Message Abuse Report Format working group
> >If anyone thinks this version has made the document *worse*, we want to
> >know that, regardless of whether the IESG is happy.
> 

For the record: Apart from that, you're happy with the changes since the DISCUSS?

---

From: Scott Kitterman <[email-masked]>
Date: Fri, 27 Jan 2012 13:10:03 -0500

On Tuesday, January 24, 2012 09:50:59 AM Murray S. Kucherawy wrote:
...
> if there hasn't been any squawking.
...
Modulo the RFC 2119 boilerplate issue, I think it's good.

Scott K

---

From: Dave CROCKER <[email-masked]>
Date: Fri, 27 Jan 2012 10:27:04 -0800

> For the record: Apart from that, you're happy with the changes since the DISCUSS?

+1

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Steve Atkins <[email-masked]>
Date: Fri, 27 Jan 2012 10:48:22 -0800

> 	Filename        : draft-ietf-marf-redaction-07.txt

Looks OK to me, modulo the trivial issues others have already mentioned.

Cheers,
  Steve

---

From: SM <[email-masked]>
Date: Fri, 27 Jan 2012 11:24:42 -0800

Hi Murray,
>For the record: Apart from that, you're happy with the changes since 

Yes, send it off.

Regards,
-sm

---

From: Barry Leiba <[email-masked]>
Date: Fri, 27 Jan 2012 16:13:36 -0500

OK... Murray, please post -08 and we'll tell Pete it's ready for his move.

Barry

---

From: Shmuel (Seymour J.) Metz <[email-masked]>
Date: Fri, 27 Jan 2012 12:20:42 -0500

In
<CAC4RtVA45t+BN=[email-masked]>,
on 01/27/2012
   at 11:53 AM, Barry Leiba <[email-masked]> said:

>The main point is whether the WG thinks this document is (1) good,

Yes.
 
>and (2) better than previous versions.

No, but just as good.

---

From: "John Levine" <[email-masked]>
Date: 1 Feb 2012 00:36:57 -0000

>> For the record: Apart from that, you're happy with the changes since the DISCUSS?

Yes, getting rid of the extra advice was the right fix.  Ship it.

R's,
John