Subject: [marf] I-D Action: draft-ietf-marf-authfailure-report-08.txt

From: [email-masked]
Date: Tue, 03 Jan 2012 16:58:04 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Messaging Abuse Reporting Format Working Group of the IETF.

	Title           : Authentication Failure Reporting using the Abuse Report Format
	Author(s)       : Hilda L. Fontana
	Filename        : draft-ietf-marf-authfailure-report-08.txt
	Pages           : 20
	Date            : 2012-01-03

   This memo registers an extension report type to the Abuse Reporting
   Format (ARF), affecting multiple registries, for use in generating
   receipt-time reports about messages that fail one or more email
   message authentication checks.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-marf-authfailure-report-08.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-marf-authfailure-report-08.txt

---

From: Scott Kitterman <[email-masked]>
Date: Tue, 03 Jan 2012 21:50:14 -0500

On Tuesday, January 03, 2012 04:58:04 PM [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Messaging Abuse Reporting
> Format Working Group of the IETF.
> 
> 	Title           : Authentication Failure Reporting using the Abuse Report
> Format Author(s)       : Hilda L. Fontana

I've lost track of the bidding.  Is this the draft supposed to discuss the SPF 
downref or is that done separately as part of the last call?

Scott K

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 3 Jan 2012 19:07:39 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Scott Kitterman
> Sent: Tuesday, January 03, 2012 6:50 PM
> To: [email-masked]
> Subject: Re: [marf] I-D Action: draft-ietf-marf-authfailure-report-08.txt
> 
> I've lost track of the bidding.  Is this the draft supposed to discuss
> the SPF downref or is that done separately as part of the last call?

The IETF-wide Last Call announcement has to point out the downref.  That's what was missed, necessitating a repeat of that part of the process.

This version doesn't change anything about the downref, but rather just incorporates all the IESG feedback we'd received thus far.

---

From: Alessandro Vesely <[email-masked]>
Date: Wed, 04 Jan 2012 10:32:59 +0100

On 04.01.2012 04:07, Murray S. Kucherawy wrote:
> This version doesn't change anything about the downref, but rather just
> incorporates all the IESG feedback we'd received thus far.

I'd be curious to learn the rationale for allowing comments everywhere in
SPF-DNS fields.  Doesn't that gratuitously complicate parsing?

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 4 Jan 2012 09:00:52 -0800

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Alessandro Vesely
> Sent: Wednesday, January 04, 2012 1:33 AM
> To: [email-masked]
> > This version doesn't change anything about the downref, but rather
> > just incorporates all the IESG feedback we'd received thus far.
> 
> I'd be curious to learn the rationale for allowing comments everywhere
> in SPF-DNS fields.  Doesn't that gratuitously complicate parsing?

Quite simply, the Gen-ART reviewer pointed out that all of the other ABNF definitions we have used CFWS instead of FWS, except SPF-DNS, so it's been updated to match.