Subject: [marf] Where we go from here

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sun, 22 Jan 2012 21:51:18 -0800

With the imminent approval of the redaction draft, we are left with four current documents.  As we appear to be low on remaining steam, we need to decide what to do with them.  Barry and I are thinking that the working group will meet in Paris at the end of March to tie up loose ends, and come in for a landing shortly thereafter.

What's below is my own current opinion on our documents, having observed the working group's current interest levels, consulting with Barry and Pete, and knowing about other related IETF activity.

1) draft-ietf-marf-as ("Creation and Use of Email Feedback Reports: An Applicability Statement for the Abuse Reporting Format (ARF)")

I believe this document is useful and possibly even important to get out there.  It's also the one closest to earning the labels "well-developed" and "has consensus".  We have some feedback on the current version that the working group needs to process, and I hope we can do that in the coming few weeks.  I will also solicit a few more reviewers from outside MARF but within the realm of abuse reporting and applicability statements.  After that, I think a Working Group Last Call would be in order, and then we can send it to the IESG.

2) draft-ietf-marf-dkim-reporting ("Extensions to DKIM for Failure Reporting")

Although the protocol specified here has been implemented in open source for several years, there has been significant feedback within MARF on some possible better ways to do it.  I don't think the working group has the energy to invest in re-hashing it from the ground up and producing something worthy of the standards track that would then expect some widespread deployment.  Instead, I propose that this one be "parked", and eventually returned to "Individual" status and progressed outside of the working group, or perhaps through APPSAWG if there's interest there, perhaps seeking Experimental status.

3) draft-ietf-marf-spf-reporting ("SPF Authentication Failure Reporting using the Abuse Report Format")

The feedback on the DKIM reporting draft makes me wonder if this one needs to be revisited with a similar bent.  Regardless, there will likely be more energy for processing this one in the proposed "spfbis" working group rather than in MARF, so I suggest it be "parked", and if and when spfbis charters (or re-charters) to take this on, it can pick up the work item.

4) draft-ietf-marf-reporting-discovery ("A DNS TXT Record for Advertising and Discovering Willingness to Provide or Receive ARF Reports")

This draft doesn't have a current champion.  It also describes a protocol that is not in any known open use, nor have we heard from anyone who plans to implement it.  It's based on a proprietary protocol whose owner was seeking to move it into open use, but currently doesn't have personnel to dedicate to its advancement.  I know there is a small amount of interest in MARF to see this progress, but it also needs some significant interest from industry, and we've seen no evidence of that at all.  Accordingly, it is now a "parked" working group document.  It will expire later this month.  I don't believe we should continue to work on it.

Feedback welcome.

-MSK

---

From: Scott Kitterman <[email-masked]>
Date: Mon, 23 Jan 2012 08:22:45 -0500

On Sunday, January 22, 2012 09:51:18 PM Murray S. Kucherawy wrote:
> The feedback on the DKIM reporting draft makes me wonder if this one needs
> to be revisited with a similar bent.  Regardless, there will likely be more
> energy for processing this one in the proposed "spfbis" working group
> rather than in MARF, so I suggest it be "parked", and if and when spfbis
> charters (or re-charters) to take this on, it can pick up the work item.

I would prefer to finish this.  It's very close to done, there are no 
alternative approaches on the table, and it's currently out of scope for 
spfbis.

The only significant issue to deal with is text for the downref.  The rest is 
just minor stuff I've been waiting for us to be ready to pick up on this to do.

Scott K

---

From: Shmuel (Seymour J.) Metz <[email-masked]>
Date: Mon, 23 Jan 2012 08:19:40 -0500

In
<[email-masked]>,
on 01/22/2012
   at 09:51 PM, "Murray S. Kucherawy" <[email-masked]> said:

>4) draft-ietf-marf-reporting-discovery ("A DNS TXT Record for
>Advertising and Discovering Willingness to Provide or Receive ARF
>Reports")

I was planning to write code that used those data, but had some issues
that I will bring up if a champion surfaces. I certainly see a need
for at least the consumer side, although not necessarily in the same
form.

-- 
     Shmuel (Seymour J.) Metz, SysProg and JOAT
     Atid/2        <http://patriot.net/~shmuel>
We don't care. We don't have to care, we're Congress.
(S877: The Shut up and Eat Your spam act of 2003)

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 23 Jan 2012 08:44:40 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Shmuel Metz
> Sent: Monday, January 23, 2012 5:20 AM
> To: [email-masked]
> Subject: Re: [marf] Where we go from here
> 
> that I will bring up if a champion surfaces. I certainly see a need for
> at least the consumer side, although not necessarily in the same form.

That gets us half way there.  We need to see interest from the producer side too, and to date there has been none.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 25 Jan 2012 22:24:36 -0800

Well, if we'd known that threatening to shut the working group down soon would've sparked all this interest and activity, we could've done it sooner!

This is good stuff.  All three remaining documents have recently taken big steps toward being ready for advancement.

We have requested a one-hour meeting for the IETF meeting in Paris at the end of March.  Ideally, we would meet there to discuss the progress of these three documents through the formal parts of evaluation and processing, and then spin down shortly thereafter, a job well done.  That means IETF Last Call will need to start by early March at the latest, so Working Group Last Calls need to start by mid-February at the latest.  With the recent momentum, I think we can hit those marks.

Everyone, please take a run through all three drafts (draft-ietf-marf-as, draft-ietf-marf-dkim-reporting, draft-ietf-marf-spf-reporting) top-to-bottom and report any feedback, including "I looked at this, I agree with it, let's move forward" or suchlike.  Once all three of them look to be on solid ground, we can start the various Last Call processes.

Thanks,
-MSK, as co-chair

From: [email-masked] [mailto:[email-masked]] On Behalf Of Murray S. Kucherawy
Sent: Sunday, January 22, 2012 9:51 PM
To: Message Abuse Report Format working group
Subject: [marf] Where we go from here

Feedback welcome.

-MSK