Subject: [marf] I-D Action: draft-ietf-marf-as-06.txt

From: [email-masked]
Date: Sun, 05 Feb 2012 21:16:56 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Messaging Abuse Reporting Format Working Group of the IETF.

	Title           : Creation and Use of Email Feedback Reports: An Applicability Statement for the Abuse Reporting Format (ARF)
	Author(s)       : J.D. Falk
                          M. Kucherawy
	Filename        : draft-ietf-marf-as-06.txt
	Pages           : 13
	Date            : 2012-02-05

   RFC 5965 defines an extensible, machine-readable format intended for
   mail operators to report feedback about received email to other
   parties.  This document describes common methods for utilizing this
   format for abuse reporting.  Mailbox Providers of any size, mail
   sending entities, and end users can use these methods as a basis to
   create procedures that best suit them.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-marf-as-06.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-marf-as-06.txt

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sun, 5 Feb 2012 21:24:13 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Sunday, February 05, 2012 9:17 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-marf-as-06.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Messaging Abuse Reporting
> Format Working Group of the IETF.
> 
> 	Title           : Creation and Use of Email Feedback Reports: An
> Applicability Statement for the Abuse Reporting Format (ARF)
> 	Author(s)       : J.D. Falk
>                           M. Kucherawy

This version includes the following based on WGLC feedback so far, which I believe is either minor editorial stuff or has rough consensus, just so we all have an updated but common place from which to work:

- relocate text about auto-generation based on spam filters from Section 5 into Section 8, suggested by Steve

- add a note that the numbered bullets will become symbol bullets (i.e., an unordered list) prior to publication, suggested by John and Barry

- some clarifying text requested by Scott

- reposition the report destination address heuristics discussion, suggested by Steve

- add opt-out text, suggested by Steve

- some rewording and reorganization in Section 8, suggested by Alessandro

- discussion of costs of unsolicited reports, suggested by Steve

- move discussion of automated report generation from the DKIM reporting draft to a new Section 9 here

- move Security Considerations specific to any kind of automated report generation to Security Considerations here

- some editorial stuff suggested by Shmuel

- add/update references accordingly

We're still in WGLC, so let the bashing continue...

-MSK

---

From: Shmuel (Seymour J.) Metz <[email-masked]>
Date: Mon, 06 Feb 2012 09:39:59 -0500

In <[email-masked]>, on 02/05/2012
   at 09:16 PM, [email-masked] said:

>draft-ietf-marf-as-06.txt

In 8.  Generating and Handling Unsolicited Reports, if a MUST is
appropriate in item 6 then surely it is also appropriate in item 12. I
suggest

6.   A report generator MUST provide a way for a report recipient
     to request no further reports be sent to that address,
     unless the provider only accepts abuse complaints in ARF
     format, and MAY provide a way for recipients to change the
     address(es) to which reports about them are sent.

12.  Published abuse mailbox addresses SHOULD NOT reject messages
     not in the ARF format, as generation of ARF messages can
     occasionally be unavailable or not applicable.

-- 
     Shmuel (Seymour J.) Metz, SysProg and JOAT
     Atid/2        <http://patriot.net/~shmuel>
We don't care. We don't have to care, we're Congress.
(S877: The Shut up and Eat Your spam act of 2003)

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 6 Feb 2012 10:09:01 -0800

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Shmuel Metz
> Sent: Monday, February 06, 2012 6:40 AM
> To: [email-masked]
> Subject: Re: [marf] I-D Action: draft-ietf-marf-as-06.txt
> 

Why are ARF-only receivers exempt from this MUST?

---

From: Shmuel (Seymour J.) Metz <[email-masked]>
Date: Mon, 06 Feb 2012 18:36:04 -0500

In
<[email-masked]>,
on 02/06/2012

>Why are ARF-only receivers exempt from this MUST?

Because they don't support the normal channel for reporting abuse.

---

From: Alessandro Vesely <[email-masked]>
Date: Tue, 07 Feb 2012 11:55:23 +0100

> Because they don't support the normal channel for reporting abuse.

What is the "normal" channel?  Section 8 is limited to sending
unsolicited reports, which is deemed "typically heuristic".

---

From: Shmuel (Seymour J.) Metz <[email-masked]>
Date: Tue, 07 Feb 2012 08:14:22 -0500

In <[email-masked]>, on 02/07/2012
   at 11:55 AM, Alessandro Vesely <[email-masked]> said:

>What is the "normal" channel?

Plain text messages to the abuse and postmaster mailboxes.

>Section 8 is limited to sending unsolicited reports,

Understood. The question is whether somebody complaining about UBE
from a network has to shut up and eat his spam.

---

From: Alessandro Vesely <[email-masked]>
Date: Tue, 07 Feb 2012 19:46:21 +0100

> from a network has to shut up and eat his spam. 

Got it.  Nevertheless, we don't want to encourage retaliation, do we?

IMHO, it is useful to just know that a domain doesn't want to get
complaints about any spam it sends.  It is up to recipients to decide
what to do with messages having such senders.

---

From: Shmuel (Seymour J.) Metz <[email-masked]>
Date: Tue, 07 Feb 2012 16:19:16 -0500

In <[email-masked]>, on 02/07/2012
   at 07:46 PM, Alessandro Vesely <[email-masked]> said:

>Nevertheless, we don't want to encourage retaliation, do we?

First, I wouldn't call one complaint per spam received retaliation.
Second. I would support non-abusive[1[ retaliation where feasible,
e.g.,

   * Blocking of ASN
   * Boycotts
   * Criminal complaints
   * Lawsuits

[1] And out of scope fot MARF