Subject: Re: [marf] Stephen Farrell's No Objection on draft-ietf-marf-as-14: (with COMMENT)

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 25 Apr 2012 00:06:59 +0000

> -----Original Message-----
> From: Stephen Farrell [mailto:[email-masked]]
> Sent: Monday, April 23, 2012 4:34 AM
> To: The IESG
> Cc: [email-masked]; [email-masked]
> Subject: Stephen Farrell's No Objection on draft-ietf-marf-as-14: (with
> COMMENT)
> 
> Stephen Farrell has entered the following ballot position for
> draft-ietf-marf-as-14: No Objection
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> 
> Please refer to http://www.ietf.org/iesg/statement/discuss-
> criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> Just a bunch of nitty comments. Feel free to take 'em or leave 'em.

Leaving 'em, except:

> 5.1 (2) - I think you mean that "they think will" pass SPF/DKIM checks,
> since they can't be sure

OK.

> 5.2 (1) - "the receiver" is a bit ambiguous in the 1st sentence, maybe
> s/the receiver/the report receiver/? (Or if handling is expensive for
> both, then maybe say that.)

OK (the former).

> 5.5 (1) - is "bulk senders" at the end here ambiguous? I read it as
> referring to the sender of the message(s) that triggered the report.

Right, but I'm fumbling on wording to clarify.  Is "bulk email senders" enough (as different to "bulk report senders")?

> 6 - what is a "smaller" AS or use-case? Do you mean fewer people will
> do this or that its simpler?

As in this section (the statement) has less to say than the sections above that talk about the "abuse" feedback report type.

> 6 - point (3), is the "MUST be constructed" there right? If everything
> needed to satisfy this MUST is later in point 3, then you could say
> "MUST be done as stated below" - as is, this looks like there's
> something else needed to satisfy the MUST but you don't say what.

The first MUST sets the overall goal.  Since it is not itself normative, it could change to "needs to", since the normative stuff later is what really lays it out.

> 8.3 - this is a little terse, maybe point back at those recommendations
> or say a bit more?

Sure (the reference).

> 8.4 - might be better to say "larger volumes or higher frequency"

OK.

> 8.5 - I guess this means that report receivers ought not react to
> missing reports as if something was wrong. Not sure if that's worth
> noting explicitly or not.

How would you react to a missing report?

-MSK

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 25 Apr 2012 01:48:18 +0100

Hiya,

As these are all comments you can continue to leave 'em
however you like:-)

> Right, but I'm fumbling on wording to clarify.  Is "bulk email senders" enough (as different to "bulk report senders")?

Well, sometimes just using more words works, e.g. maybe "the sender(s)
of the messages that triggered the reports" (but I didn't look back
for context so that might be useless;-)

> How would you react to a missing report?

Complain to the waiter? :-)

Or throw away the next rx'd because its not last-seq+1 or
whatever). Sell the information as to who'd doing what based on
the nodes that think they're running this protocol?

S