
From ashimura@sfc.keio.ac.jp  Sun Mar 24 15:19:45 2013
Return-Path: <ashimura@sfc.keio.ac.jp>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id A16F621F8E0D for <media-types@ietfa.amsl.com>; Sun, 24 Mar 2013 15:19:45 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -3.19
X-Spam-Level: 
X-Spam-Status: No, score=-3.19 tagged_above=-999 required=5 tests=[AWL=-0.300,  BAYES_00=-2.599, HELO_EQ_JP=1.244, HOST_EQ_JP=1.265, J_CHICKENPOX_32=0.6, J_CHICKENPOX_93=0.6, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 4bbl+tlEJMOR for <media-types@ietfa.amsl.com>; Sun, 24 Mar 2013 15:19:44 -0700 (PDT)
Received: from imap05.sfc.keio.ac.jp (imap05.sfc.keio.ac.jp [133.27.5.205]) by ietfa.amsl.com (Postfix) with ESMTP id 14FFE21F8E0C for <media-types@ietf.org>; Sun, 24 Mar 2013 15:19:41 -0700 (PDT)
Received: from mail-gw2.sfc.keio.ac.jp ([133.27.4.128]) by imap05.sfc.keio.ac.jp with esmtp (Exim 4.69 #1 (Debian-mda)) id 1UJtGN-0003LA-7b for <media-types@ietf.org>; Mon, 25 Mar 2013 07:19:39 +0900
X-IronPort-Anti-Spam-Filtered: true
X-IronPort-Anti-Spam-Result: AuIAAHp6T1GFGwXAl2dsb2JhbABDhRvAVYFyFg4BAQEBAQgWBzyCJAEBBAEyAQU7BQEQCxgJFg8JAwIBAgE3AQ0GAQwBBQIBAYgKBQ20IYQjiQ+NTQuBQAeDQAOId6INgWQ
Received: from smtp1202.sfc.keio.ac.jp ([133.27.5.192]) by mail-gw2.sfc.keio.ac.jp with ESMTP; 25 Mar 2013 07:19:38 +0900
Received: from s78.22.229.222.fls.vectant.ne.jp ([222.229.22.78] helo=[192.168.0.11]) by smtp1202.sfc.keio.ac.jp with esmtpsa (Exim 4.76 #1 (Debian-submission)) id 1UJtGM-00088b-KB; Mon, 25 Mar 2013 07:19:38 +0900
Message-ID: <514F7BFA.6000201@sfc.keio.ac.jp>
Date: Mon, 25 Mar 2013 07:19:38 +0900
From: Kazuyuki Ashimura <ashimura@sfc.keio.ac.jp>
Organization: Keio University
User-Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20130308 Thunderbird/17.0.4
MIME-Version: 1.0
To: Paul Libbrecht <paul@hoplahup.net>, media-types@ietf.org
References: <4FABF6EE.80103@w3.org> <119C90DA-0C41-4BA0-9FAA-477E6CA610AD@hoplahup.net>
In-Reply-To: <119C90DA-0C41-4BA0-9FAA-477E6CA610AD@hoplahup.net>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
Cc: ietf-xml-mime@imc.org, www-multimodal@w3.org
Subject: Re: [media-types] Request for review of EmotionML media type: application/emotionml+xml
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
Reply-To: ashimura@sfc.keio.ac.jp
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sun, 24 Mar 2013 22:24:43 -0000

On 05/11/2012 04:30 AM, Paul Libbrecht wrote:
>
> Dear Kazuyuki,
>
> would you think as conceivable to put EmotionML into a clipboard?
> If yes it would be nice to include in this specification:
> - a Windows clipboard name (more or less, just a string) which applications would register at start
> - a Macintosh Uniform Type Identifier (which application descriptors could register)

Dear Paul,

Thank you very much for your thoughtful comment.

We the W3C Multimodal Interaction Working Group discussed
the above point and the conclusion was we don't put EmotionML
into a clipboard because we didn't get any use cases.

P.S.
I thought I had responded to your comment earlier but it
seems there was some problem with email distribution from my
W3C address to the IETF list.  So I'm resending this message
using my Keio address.  We are planning to publish a Proposed
Recommendation for EmotionML and would like to get your OK.

Thanks,

Kazuyuki


>
> thanks in advance
>
> Paul
>
>
> Le 10 mai 2012 à 19:12, Kazuyuki Ashimura a écrit :
>
>>
>> Dear list,
>> # sorry but resending because I used wrong address for my previous post.
>>
>> W3C has just published a Candidate Recommendation for "Emotion Markup
>> Language (EmotionML)" at:
>>
>> http://www.w3.org/TR/2012/CR-emotionml-20120510/
>>
>> I am sending this request to ask the Ietf-types list for comments on
>> the Media Type section of the EmotionML specification following the
>> procedure defined at:
>>
>> http://www.w3.org/2002/06/registering-mediatype
>>
>> ---
>> The Media Type section of the EmotionML specification is available
>> at:
>>
>> http://www.w3.org/TR/2012/CR-emotionml-20120510/#MIME-type
>>
>> and a plain text copy is also available below.
>>
>> MIME media type name:
>> ---------------------
>>     application
>>
>> MIME subtype name:
>> ------------------
>>     emotionml+xml
>>
>> Required parameters:
>> --------------------
>>     None.
>>
>> Optional parameters:
>> --------------------
>>     charset
>>
>>         This parameter has identical semantics to the charset parameter of the application/xml media type as specified in [RFC3023] or its successor.
>>
>> Encoding considerations:
>> ------------------------
>>     By virtue of EmotionML content being XML, it has the same considerations when sent as "application/emotionml+xml" as does XML. See RFC 3023 (or its successor), section 3.2.
>>
>> Security considerations:
>> ------------------------
>>     EmotionML elements may include arbitrary URIs. Therefore the security issues of [RFC3986], section 7, should be considered.
>>
>>     In addition, because of the extensibility features for EmotionML, it is possible that "application/emotionml+xml" will describe content that has security implications beyond those described here. However, if the processor follows only the normative semantics of this specification, this content will be ignored. Only in the case where the processor recognizes and processes the additional content, or where further processing of that content is dispatched to other processors, would security issues potentially arise. And in that case, they would fall outside the domain of this registration document.
>>
>> Interoperability considerations:
>> --------------------------------
>>     This specification describes processing semantics that dictate the required behavior for dealing with, among other things, unrecognized elements.
>>
>>     Because EmotionML is extensible, conformant "application/emotionml+xml" processors MAY expect that content received is well-formed XML, but processors SHOULD NOT assume that the content is valid EmotionML or expect to recognize all of the elements and attributes in the document.
>>
>> Published specification:
>> ------------------------
>>     This media type registration is extracted from Appendix B of the "Emotion Markup Language (EmotionML) 1.0" specification.
>>
>> Additional information:
>> -----------------------
>>     Magic number(s):
>>
>>         There is no single initial octet sequence that is always present in EmotionML documents.
>>
>>     File extension(s):
>>
>>         EmotionML documents are most often identified with the extensions ".emotionml".
>>
>>     Macintosh File Type Code(s):
>>
>>         TEXT
>>
>> Person & email address to contact for further information:
>> ----------------------------------------------------------
>>     Kazuyuki Ashimura, <ashimura@w3.org>.
>>
>> Intended usage:
>> ---------------
>>     COMMON
>>
>> Author/Change controller:
>> -------------------------
>>     The EmotionML specification is a work product of the World Wide Web Consortium's Multimodal Interaction Working Group. The W3C has change control over these specifications.
>>
>>
>> ----------------------
>> Normative References:
>> ----------------------
>>
>> RFC 3023
>> XML Media Types, M. Murata et al., Editors. IETF RFC 3023, January 2001.
>>
>> Sincerely,
>>
>> Kazuyuki
>>
>> --
>> Kaz Ashimura, W3C Staff Contact for Web&TV, MMI and Voice
>> Tel: +81 466 49 1170
>>
>>
>
>
>


-- 
Kaz Ashimura, W3C Staff Contact for Web&TV, MMI and Voice
Tel: +81 466 49 1170

From ashimura@sfc.keio.ac.jp  Sun Mar 24 15:46:55 2013
Return-Path: <ashimura@sfc.keio.ac.jp>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 2BCF121F8E32 for <media-types@ietfa.amsl.com>; Sun, 24 Mar 2013 15:46:55 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.38
X-Spam-Level: 
X-Spam-Status: No, score=-2.38 tagged_above=-999 required=5 tests=[AWL=0.510,  BAYES_00=-2.599, HELO_EQ_JP=1.244, HOST_EQ_JP=1.265, J_CHICKENPOX_32=0.6, J_CHICKENPOX_93=0.6, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id U4KS2B5kFnR1 for <media-types@ietfa.amsl.com>; Sun, 24 Mar 2013 15:46:54 -0700 (PDT)
Received: from imap07.sfc.keio.ac.jp (imap07.sfc.keio.ac.jp [133.27.5.207]) by ietfa.amsl.com (Postfix) with ESMTP id 0545021F8E0A for <media-types@ietf.org>; Sun, 24 Mar 2013 15:46:54 -0700 (PDT)
Received: from mail-gw2.sfc.keio.ac.jp ([133.27.4.128]) by imap07.sfc.keio.ac.jp with esmtp (Exim 4.69 #1 (Debian-mda)) id 1UJtgi-0004zV-BM for <media-types@ietf.org>; Mon, 25 Mar 2013 07:46:52 +0900
X-IronPort-Anti-Spam-Filtered: true
X-IronPort-Anti-Spam-Result: AuIAACSCT1GFGwXBl2dsb2JhbABDhRjAVYFwFg4BAQEBAQgWBzyCJAEBAQMBAQI1QAEQCw4KCRYPCQMCAQIBFi8GAQwBBQIBAYgKBQ20HoQliQ+NTQuBQAeDQAOId4syg12SfoFk
Received: from smtp1203.sfc.keio.ac.jp ([133.27.5.193]) by mail-gw2.sfc.keio.ac.jp with ESMTP; 25 Mar 2013 07:46:51 +0900
Received: from s78.22.229.222.fls.vectant.ne.jp ([222.229.22.78] helo=[192.168.0.11]) by smtp1203.sfc.keio.ac.jp with esmtpsa (Exim 4.76 #1 (Debian-submission)) id 1UJtgh-00073x-Rb; Mon, 25 Mar 2013 07:46:51 +0900
Message-ID: <514F825B.9070709@sfc.keio.ac.jp>
Date: Mon, 25 Mar 2013 07:46:51 +0900
From: Kazuyuki Ashimura <ashimura@sfc.keio.ac.jp>
Organization: Keio University
User-Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20130308 Thunderbird/17.0.4
MIME-Version: 1.0
To: Bjoern Hoehrmann <derhoermi@gmx.net>, media-types@ietf.org
References: <4FABECC0.4050805@w3.org> <gepoq7t4uidcgmaa9fhh44tma06vi3k0bt@hive.bjoern.hoehrmann.de>
In-Reply-To: <gepoq7t4uidcgmaa9fhh44tma06vi3k0bt@hive.bjoern.hoehrmann.de>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Cc: ietf-xml-mime@imc.org, www-multimodal@w3.org
Subject: Re: [media-types] Request for review of EmotionML media type: application/emotionml+xml
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
Reply-To: ashimura@sfc.keio.ac.jp
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sun, 24 Mar 2013 22:46:55 -0000

Hi Bjoern and media-types list,
# sorry resending with the correct address for the media-types list

Thank you for your thoughtful comments every time, Bjoern.

The W3C Multimodal Interaction Working Group is planning to
publish a Proposed Recommendation for EmotionML and would
like to wrap up the MIME type registration procedure.

Could you please see inline below for my response to your
comment?

BTW, I thought I had sent the following response to your
comment and it is archived at the W3C archive at:
  http://lists.w3.org/Archives/Public/www-multimodal/2012May/0016.html

However, it seems there was some email trouble and my message
was not archived at the IETF archive...

So this time I'd like to use my Keio address instead.

On 05/11/2012 10:22 AM, Bjoern Hoehrmann wrote:
>
> * Kazuyuki Ashimura wrote:
>> W3C has just published a Candidate Recommendation for "Emotion Markup
>> Language (EmotionML)" at:
>>
>>   http://www.w3.org/TR/2012/CR-emotionml-20120510/
>>
>> I am sending this request to ask the Ietf-types list for comments on
>> the Media Type section of the EmotionML specification following the
>> procedure defined at:
>>
>>   http://www.w3.org/2002/06/registering-mediatype
>
> The procedure requires Working Groups to ask for ietf-types review when
> making a Last Call announcement. I have not been able to find any such
> request in the archive. If the Working Group failed to follow the pro-
> cedure, it would be helpful if you could put that on the record.

Sorry but as you pointed out we failed to send out a review request
when we published the Last Call Working Draft.

>> MIME media type name:
>> ---------------------
>>      application
>
> This is using an outdated template. The current one is in RFC 4288. In
> it, some field names are different and some fields are organized in a
> different manner.

Thank you for pointing out that, Bjoern.

I've checked RFC4288 at:
  http://tools.ietf.org/html/rfc4288

and think we should say:
[[
Type name:
     application

Subtype name:
     emotionml+xml
]]
instead here.

>> Optional parameters:
>> --------------------
>>      charset
>>
>>          This parameter has identical semantics to the charset parameter
>> of the application/xml media type as specified in [RFC3023] or its
>> successor.
>>
>> Encoding considerations:
>> ------------------------
>>      By virtue of EmotionML content being XML, it has the same
>> considerations when sent as "application/emotionml+xml" as does XML. See
>> RFC 3023 (or its successor), section 3.2.
>
> RFC 3023 has boilerplate for this, but the above seems close enough.

Thanks!

So the revised version of the EmotionML media type definition should
be the following.  Please note I've added "Applications that use this
media type" field and "Restrictions on usage" field based on the
RFC4288 template.  Also I've split "Author/Change controller" field
into "Author" field and "Change controller" field.

[[
Type name:
     application

Subtype name:
     emotionml+xml

Required parameters:
     None.

Optional parameters:
     charset

     This parameter has identical semantics to the charset parameter of
     the application/xml media type as specified in [RFC 3023] or its
     successor.

Encoding considerations:
     By virtue of EmotionML content being XML, it has the same
     considerations when sent as "application/emotionml+xml" as does
     XML. See RFC 3023 (or its successor), section 3.2.

Security considerations:
     EmotionML elements may include arbitrary URIs. Therefore the
     security issues of [RFC 3986], section 7, should be considered.

     In addition, because of the extensibility features for EmotionML,
     it is possible that "application/emotionml+xml" will describe
     content that has security implications beyond those described
     here. However, if the processor follows only the normative
     semantics of this specification, this content will be
     ignored. Only in the case where the processor recognizes and
     processes the additional content, or where further processing of
     that content is dispatched to other processors, would security
     issues potentially arise. And in that case, they would fall
     outside the domain of this registration document.

Interoperability considerations:
     This specification describes processing semantics that dictate the
     required behavior for dealing with, among other things,
     unrecognized elements.

     Because EmotionML is extensible, conformant
     "application/emotionml+xml" processors MAY expect that content
     received is well-formed XML, but processors SHOULD NOT assume that
     the content is valid EmotionML or expect to recognize all of the
     elements and attributes in the document.

Published specification:
     This media type registration is extracted from Appendix B of the
     "Emotion Markup Language (EmotionML) 1.0" specification.

Additional information:

     Magic number(s):
     There is no single initial octet sequence that is always present
     in EmotionML documents.

     File extension(s):
     EmotionML documents are most often identified with the extensions
     ".emotionml".

     Macintosh File Type Code(s):
     TEXT

Person & email address to contact for further information:
     Kazuyuki Ashimura, <ashimura@w3.org>.

Intended usage:
     COMMON

Restrictions on usage:
     None.

Author:
     The EmotionML specification is a work product of the World Wide
     Web Consortium's Multimodal Interaction Working Group.

Change controller:
     The W3C has change control over these specifications.
]]

Thanks,

Kazuyuki

-- 
Kaz Ashimura, W3C Staff Contact for Web&TV, MMI and Voice
Tel: +81 466 49 1170


From ashimura@sfc.keio.ac.jp  Sun Mar 24 16:15:09 2013
Return-Path: <ashimura@sfc.keio.ac.jp>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id B262721F8BF4 for <media-types@ietfa.amsl.com>; Sun, 24 Mar 2013 16:15:09 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.508
X-Spam-Level: 
X-Spam-Status: No, score=-2.508 tagged_above=-999 required=5 tests=[AWL=0.382,  BAYES_00=-2.599, HELO_EQ_JP=1.244, HOST_EQ_JP=1.265, J_CHICKENPOX_32=0.6, J_CHICKENPOX_93=0.6, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id F3TQDmkdvGHH for <media-types@ietfa.amsl.com>; Sun, 24 Mar 2013 16:15:08 -0700 (PDT)
Received: from pechora8.dc.icann.org (unknown [IPv6:2620:0:2830:201::1:74]) by ietfa.amsl.com (Postfix) with ESMTP id 5D69621F8C5D for <media-types@ietf.org>; Sun, 24 Mar 2013 16:15:08 -0700 (PDT)
Received: from imap07.sfc.keio.ac.jp (imap07.sfc.keio.ac.jp [133.27.5.207]) by pechora8.dc.icann.org (8.13.8/8.13.8) with ESMTP id r2ONEgD8024034 for <media-types@iana.org>; Sun, 24 Mar 2013 23:15:03 GMT
Received: from mail-gw2.sfc.keio.ac.jp ([133.27.4.128]) by imap07.sfc.keio.ac.jp with esmtp (Exim 4.69 #1 (Debian-mda)) id 1UJtR5-0004XO-SN for <media-types@iana.org>; Mon, 25 Mar 2013 07:30:43 +0900
X-IronPort-Anti-Spam-Filtered: true
X-IronPort-Anti-Spam-Result: AuIAABN+T1GFGwXCl2dsb2JhbABDhRvAVYFyFg4BAQEBAQgWBzyCJAEBAQMBAQI1QAEQCw4KCRYPCQMCAQIBFi8GAQwBBQIBAYgKBQ20IYQjiQ+NTQuBQAeDQAOId4syg12SfoFk
Received: from smtp1204.sfc.keio.ac.jp ([133.27.5.194]) by mail-gw2.sfc.keio.ac.jp with ESMTP; 25 Mar 2013 07:30:43 +0900
Received: from s78.22.229.222.fls.vectant.ne.jp ([222.229.22.78] helo=[192.168.0.11]) by smtp1204.sfc.keio.ac.jp with esmtpsa (Exim 4.76 #1 (Debian-submission)) id 1UJtR5-0006Zu-D7; Mon, 25 Mar 2013 07:30:43 +0900
Message-ID: <514F7E92.6080304@sfc.keio.ac.jp>
Date: Mon, 25 Mar 2013 07:30:42 +0900
From: Kazuyuki Ashimura <ashimura@sfc.keio.ac.jp>
Organization: Keio University
User-Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20130308 Thunderbird/17.0.4
MIME-Version: 1.0
To: Bjoern Hoehrmann <derhoermi@gmx.net>, media-types@iana.org
References: <4FABECC0.4050805@w3.org> <gepoq7t4uidcgmaa9fhh44tma06vi3k0bt@hive.bjoern.hoehrmann.de>
In-Reply-To: <gepoq7t4uidcgmaa9fhh44tma06vi3k0bt@hive.bjoern.hoehrmann.de>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Greylist: Delayed for 00:40:03 by milter-greylist-4.2.3 (pechora8.dc.icann.org [192.0.46.74]); Sun, 24 Mar 2013 23:15:03 +0000 (UTC)
Cc: ietf-xml-mime@imc.org, www-multimodal@w3.org
Subject: Re: [media-types] Request for review of EmotionML media type: application/emotionml+xml
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
Reply-To: ashimura@sfc.keio.ac.jp
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sun, 24 Mar 2013 23:15:09 -0000

Hi Bjoern and media-types list,

Thank you for your thoughtful comments every time, Bjoern.

The W3C Multimodal Interaction Working Group is planning to
publish a Proposed Recommendation for EmotionML and would
like to wrap up the MIME type registration procedure.

BTW, I thought I had sent the following response to your
comment and it is archived at the W3C archive at:
  http://lists.w3.org/Archives/Public/www-multimodal/2012May/0016.html

However, it seems there was some email trouble and my message
was not archived at the IETF archive...

So this time I'd like to use my Keio address instead.

Could you please see inline below for my response to your
comment?

On 05/11/2012 10:22 AM, Bjoern Hoehrmann wrote:
>
> * Kazuyuki Ashimura wrote:
>> W3C has just published a Candidate Recommendation for "Emotion Markup
>> Language (EmotionML)" at:
>>
>>   http://www.w3.org/TR/2012/CR-emotionml-20120510/
>>
>> I am sending this request to ask the Ietf-types list for comments on
>> the Media Type section of the EmotionML specification following the
>> procedure defined at:
>>
>>   http://www.w3.org/2002/06/registering-mediatype
>
> The procedure requires Working Groups to ask for ietf-types review when
> making a Last Call announcement. I have not been able to find any such
> request in the archive. If the Working Group failed to follow the pro-
> cedure, it would be helpful if you could put that on the record.

Sorry but as you pointed out we failed to send out a review request
when we published the Last Call Working Draft.

>> MIME media type name:
>> ---------------------
>>      application
>
> This is using an outdated template. The current one is in RFC 4288. In
> it, some field names are different and some fields are organized in a
> different manner.

Thank you for pointing out that, Bjoern.

I've checked RFC4288 at:
  http://tools.ietf.org/html/rfc4288

and think we should say:
[[
Type name:
     application

Subtype name:
     emotionml+xml
]]
instead here.

>> Optional parameters:
>> --------------------
>>      charset
>>
>>          This parameter has identical semantics to the charset parameter
>> of the application/xml media type as specified in [RFC3023] or its
>> successor.
>>
>> Encoding considerations:
>> ------------------------
>>      By virtue of EmotionML content being XML, it has the same
>> considerations when sent as "application/emotionml+xml" as does XML. See
>> RFC 3023 (or its successor), section 3.2.
>
> RFC 3023 has boilerplate for this, but the above seems close enough.

Thanks!

So the revised version of the EmotionML media type definition should
be the following.  Please note I've added "Applications that use this
media type" field and "Restrictions on usage" field based on the
RFC4288 template.  Also I've split "Author/Change controller" field
into "Author" field and "Change controller" field.

[[
Type name:
     application

Subtype name:
     emotionml+xml

Required parameters:
     None.

Optional parameters:
     charset

     This parameter has identical semantics to the charset parameter of
     the application/xml media type as specified in [RFC 3023] or its
     successor.

Encoding considerations:
     By virtue of EmotionML content being XML, it has the same
     considerations when sent as "application/emotionml+xml" as does
     XML. See RFC 3023 (or its successor), section 3.2.

Security considerations:
     EmotionML elements may include arbitrary URIs. Therefore the
     security issues of [RFC 3986], section 7, should be considered.

     In addition, because of the extensibility features for EmotionML,
     it is possible that "application/emotionml+xml" will describe
     content that has security implications beyond those described
     here. However, if the processor follows only the normative
     semantics of this specification, this content will be
     ignored. Only in the case where the processor recognizes and
     processes the additional content, or where further processing of
     that content is dispatched to other processors, would security
     issues potentially arise. And in that case, they would fall
     outside the domain of this registration document.

Interoperability considerations:
     This specification describes processing semantics that dictate the
     required behavior for dealing with, among other things,
     unrecognized elements.

     Because EmotionML is extensible, conformant
     "application/emotionml+xml" processors MAY expect that content
     received is well-formed XML, but processors SHOULD NOT assume that
     the content is valid EmotionML or expect to recognize all of the
     elements and attributes in the document.

Published specification:
     This media type registration is extracted from Appendix B of the
     "Emotion Markup Language (EmotionML) 1.0" specification.

Additional information:

     Magic number(s):
     There is no single initial octet sequence that is always present
     in EmotionML documents.

     File extension(s):
     EmotionML documents are most often identified with the extensions
     ".emotionml".

     Macintosh File Type Code(s):
     TEXT

Person & email address to contact for further information:
     Kazuyuki Ashimura, <ashimura@w3.org>.

Intended usage:
     COMMON

Restrictions on usage:
     None.

Author:
     The EmotionML specification is a work product of the World Wide
     Web Consortium's Multimodal Interaction Working Group.

Change controller:
     The W3C has change control over these specifications.
]]

Thanks,

Kazuyuki

-- 
Kaz Ashimura, W3C Staff Contact for Web&TV, MMI and Voice
Tel: +81 466 49 1170


From paul@hoplahup.net  Mon Mar 25 05:15:58 2013
Return-Path: <paul@hoplahup.net>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 949F521F8C74 for <media-types@ietfa.amsl.com>; Mon, 25 Mar 2013 05:15:58 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.248
X-Spam-Level: 
X-Spam-Status: No, score=-2.248 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, HELO_EQ_DE=0.35, HTML_MESSAGE=0.001]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id S99JxrCvdOy8 for <media-types@ietfa.amsl.com>; Mon, 25 Mar 2013 05:15:58 -0700 (PDT)
Received: from moutng.kundenserver.de (moutng.kundenserver.de [212.227.126.186]) by ietfa.amsl.com (Postfix) with ESMTP id DDF8A21F8C67 for <media-types@ietf.org>; Mon, 25 Mar 2013 05:15:57 -0700 (PDT)
Received: from [192.168.178.40] (p5DDEC2D8.dip0.t-ipconnect.de [93.222.194.216]) by mrelayeu.kundenserver.de (node=mreu0) with ESMTP (Nemesis) id 0M7Fkw-1UZ8DV0EuE-00x3iV; Mon, 25 Mar 2013 13:15:23 +0100
Mime-Version: 1.0 (Apple Message framework v1085)
Content-Type: multipart/alternative; boundary=Apple-Mail-4--640533400
From: Paul Libbrecht <paul@hoplahup.net>
In-Reply-To: <514F7BFA.6000201@sfc.keio.ac.jp>
Date: Mon, 25 Mar 2013 13:15:23 +0100
Message-Id: <BB8D5F79-7AF5-45F6-9FB0-F2033DE8947A@hoplahup.net>
References: <4FABF6EE.80103@w3.org> <119C90DA-0C41-4BA0-9FAA-477E6CA610AD@hoplahup.net> <514F7BFA.6000201@sfc.keio.ac.jp>
To: ashimura@sfc.keio.ac.jp
X-Mailer: Apple Mail (2.1085)
X-Provags-ID: V02:K0:FzvWSlz6zrSuhGGgX5X6m3+7PkFFykof5c0AEAqbe2m 7QeuImSjAZ7/d2BSzJPMfcFKTelJ1AuTXFdSyZ47km37jIyO3p 0FNPdG0UkwsOclqH2GCVXj9z49jjCSqGFCZWJ2wWacrpdXS1eM SzFqUd49zJy43RdpEFi/iuyY/otzUNuLQgPQlXruhEiakYLVan 0S1q691/FMTgv5SbHYKpp3DhcysfDsn/UTfMcRvrQ5pYltc+Lv wC5p2lK0YZAnTMLBaHCyXIakG+NIHuacibhAAg96+9O6C/uXaW zQ0MiST6dKtt7kiHcqkWmmpQDTN7OpCOELqZRATlr2426N3eUs F3NIXeyVC9Llw5Q+REkR9vKlmA+d9R8zmfHsubSVBfeZDMhsE2 G7xCHRAJZwOIw==
Cc: media-types@ietf.org, ietf-xml-mime@imc.org, www-multimodal@w3.org
Subject: Re: [media-types] Request for review of EmotionML media type: application/emotionml+xml
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 25 Mar 2013 12:15:58 -0000

--Apple-Mail-4--640533400
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=us-ascii

Dar Kazuyuki,

If no use case is findable, please ignore my request.

Paul


On 24 mars 2013, at 23:19, Kazuyuki Ashimura wrote:

>> would you think as conceivable to put EmotionML into a clipboard?
>> If yes it would be nice to include in this specification:
>> - a Windows clipboard name (more or less, just a string) which =
applications would register at start
>> - a Macintosh Uniform Type Identifier (which application descriptors =
could register)
>=20
> Dear Paul,
>=20
> Thank you very much for your thoughtful comment.
>=20
> We the W3C Multimodal Interaction Working Group discussed
> the above point and the conclusion was we don't put EmotionML
> into a clipboard because we didn't get any use cases.


--Apple-Mail-4--640533400
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
	charset=us-ascii

<html><head></head><body style=3D"word-wrap: break-word; =
-webkit-nbsp-mode: space; -webkit-line-break: after-white-space; =
"><div>Dar Kazuyuki,</div><div><br></div><div>If no use case is =
findable, please ignore my =
request.</div><div><br></div><div>Paul</div><div><br></div><br><div><div>O=
n 24 mars 2013, at 23:19, Kazuyuki Ashimura wrote:</div><br =
class=3D"Apple-interchange-newline"><blockquote type=3D"cite"><span =
class=3D"Apple-style-span" style=3D"border-collapse: separate; =
font-family: Helvetica; font-style: normal; font-variant: normal; =
font-weight: normal; letter-spacing: normal; line-height: normal; =
orphans: 2; text-align: -webkit-auto; text-indent: 0px; text-transform: =
none; white-space: normal; widows: 2; word-spacing: 0px; =
-webkit-border-horizontal-spacing: 0px; -webkit-border-vertical-spacing: =
0px; -webkit-text-decorations-in-effect: none; -webkit-text-size-adjust: =
auto; -webkit-text-stroke-width: 0px; font-size: medium; =
"><div><blockquote type=3D"cite">would you think as conceivable to put =
EmotionML into a clipboard?<br></blockquote><blockquote type=3D"cite">If =
yes it would be nice to include in this =
specification:<br></blockquote><blockquote type=3D"cite">- a Windows =
clipboard name (more or less, just a string) which applications would =
register at start<br></blockquote><blockquote type=3D"cite">- a =
Macintosh Uniform Type Identifier (which application descriptors could =
register)<br></blockquote><br>Dear Paul,<br><br>Thank you very much for =
your thoughtful comment.<br><br>We the W3C Multimodal Interaction =
Working Group discussed<br>the above point and the conclusion was we =
don't put EmotionML<br>into a clipboard because we didn't get any use =
cases.</div></span></blockquote></div><br></body></html>=

--Apple-Mail-4--640533400--

From ashimura@sfc.keio.ac.jp  Mon Mar 25 06:18:14 2013
Return-Path: <ashimura@sfc.keio.ac.jp>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id A6DED21F856D for <media-types@ietfa.amsl.com>; Mon, 25 Mar 2013 06:18:14 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 0.51
X-Spam-Level: 
X-Spam-Status: No, score=0.51 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, HELO_EQ_JP=1.244, HOST_EQ_JP=1.265, J_CHICKENPOX_32=0.6]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id mryVltwQfEW0 for <media-types@ietfa.amsl.com>; Mon, 25 Mar 2013 06:18:14 -0700 (PDT)
Received: from imap02.sfc.keio.ac.jp (imap02.sfc.keio.ac.jp [133.27.5.202]) by ietfa.amsl.com (Postfix) with ESMTP id AB35821F84AD for <media-types@ietf.org>; Mon, 25 Mar 2013 06:18:13 -0700 (PDT)
Received: from mail-gw2.sfc.keio.ac.jp ([133.27.4.128]) by imap02.sfc.keio.ac.jp with esmtp (Exim 4.69 #1 (Debian-mda)) id 1UK7Ht-0002aN-FN for <media-types@ietf.org>; Mon, 25 Mar 2013 22:18:09 +0900
X-IronPort-Anti-Spam-Filtered: true
X-IronPort-Anti-Spam-Result: AuAAAApOUFGFGwXBl2dsb2JhbABEwwGCXYF/Fg4BAQEBAQgWBzyCJAEBBAE4QRALGAklDwI4AQ0GDQEHAQGICgW5T4kPjxgHY4JdA4h3oXEc
Received: from smtp1203.sfc.keio.ac.jp ([133.27.5.193]) by mail-gw2.sfc.keio.ac.jp with ESMTP; 25 Mar 2013 22:18:09 +0900
Received: from p15179-obmd01.tokyo.ocn.ne.jp ([180.7.144.179] helo=[192.168.13.2]) by smtp1203.sfc.keio.ac.jp with esmtpsa (Exim 4.76 #1 (Debian-submission)) id 1UK7Ht-0006XD-3I; Mon, 25 Mar 2013 22:18:09 +0900
Message-ID: <51504E3B.50009@sfc.keio.ac.jp>
Date: Mon, 25 Mar 2013 22:16:43 +0900
From: Kazuyuki Ashimura <ashimura@sfc.keio.ac.jp>
Organization: Keio University
User-Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20130308 Thunderbird/17.0.4
MIME-Version: 1.0
To: Paul Libbrecht <paul@hoplahup.net>
References: <4FABF6EE.80103@w3.org> <119C90DA-0C41-4BA0-9FAA-477E6CA610AD@hoplahup.net> <514F7BFA.6000201@sfc.keio.ac.jp> <BB8D5F79-7AF5-45F6-9FB0-F2033DE8947A@hoplahup.net>
In-Reply-To: <BB8D5F79-7AF5-45F6-9FB0-F2033DE8947A@hoplahup.net>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Cc: media-types@ietf.org, ashimura@sfc.keio.ac.jp, ietf-xml-mime@imc.org, www-multimodal@w3.org
Subject: Re: [media-types] Request for review of EmotionML media type: application/emotionml+xml
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
Reply-To: ashimura@sfc.keio.ac.jp
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 25 Mar 2013 13:18:14 -0000

On 03/25/2013 09:15 PM, Paul Libbrecht wrote:
> Dar Kazuyuki,
>
> If no use case is findable, please ignore my request.

Thank you for your understanding, Paul!

Kazuyuki


>
> Paul
>
>
> On 24 mars 2013, at 23:19, Kazuyuki Ashimura wrote:
>
>>> would you think as conceivable to put EmotionML into a clipboard?
>>> If yes it would be nice to include in this specification:
>>> - a Windows clipboard name (more or less, just a string) which
>>> applications would register at start
>>> - a Macintosh Uniform Type Identifier (which application descriptors
>>> could register)
>>
>> Dear Paul,
>>
>> Thank you very much for your thoughtful comment.
>>
>> We the W3C Multimodal Interaction Working Group discussed
>> the above point and the conclusion was we don't put EmotionML
>> into a clipboard because we didn't get any use cases.
>


-- 
Kaz Ashimura, W3C Staff Contact for Web&TV, MMI and Voice
Tel: +81 466 49 1170

From dret@berkeley.edu  Thu Mar 28 18:41:36 2013
Return-Path: <dret@berkeley.edu>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 76A2821F84DC for <media-types@ietfa.amsl.com>; Thu, 28 Mar 2013 18:41:36 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.599
X-Spam-Level: 
X-Spam-Status: No, score=-6.599 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id CBywT7UysdNl for <media-types@ietfa.amsl.com>; Thu, 28 Mar 2013 18:41:36 -0700 (PDT)
Received: from pechora4.lax.icann.org (pechora4.icann.org [IPv6:2620:0:2d0:201::1:74]) by ietfa.amsl.com (Postfix) with ESMTP id D7F9421F8484 for <media-types@ietf.org>; Thu, 28 Mar 2013 18:41:35 -0700 (PDT)
Received: from cm04fe.IST.Berkeley.EDU (cm04fe.IST.Berkeley.EDU [169.229.218.145]) by pechora4.lax.icann.org (8.13.8/8.13.8) with ESMTP id r2T1fF3H015951 for <media-types@iana.org>; Fri, 29 Mar 2013 01:41:35 GMT
Received: from mobile-166-137-186-003.mycingular.net ([166.137.186.3] helo=dretpro.local) by cm04fe.ist.berkeley.edu with esmtpsa (TLSv1:AES256-SHA:256) (Exim 4.76) (auth plain:dret@berkeley.edu) (envelope-from <dret@berkeley.edu>) id 1ULO0V-0005JJ-Ea for media-types@iana.org; Thu, 28 Mar 2013 18:21:29 -0700
Message-ID: <5154EC97.20102@berkeley.edu>
Date: Thu, 28 Mar 2013 18:21:27 -0700
From: Erik Wilde <dret@berkeley.edu>
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/20130216 Thunderbird/17.0.3
MIME-Version: 1.0
To: media-types@iana.org
References: <20130327023118.32662.16489.idtracker@ietfa.amsl.com>
In-Reply-To: <20130327023118.32662.16489.idtracker@ietfa.amsl.com>
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 7bit
X-Greylist: Delayed for 00:19:44 by milter-greylist-4.0 (pechora4.lax.icann.org [192.0.33.74]); Fri, 29 Mar 2013 01:41:35 +0000 (UTC)
X-Mailman-Approved-At: Sat, 30 Mar 2013 15:52:42 -0700
Subject: [media-types] [apps-discuss] Fwd: New Version Notification for draft-sinnema-xacml-media-type-02.txt
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 29 Mar 2013 01:41:36 -0000

A new version of I-D, draft-sinnema-xacml-media-type-02.txt
has been successfully submitted by Erik Wilde and posted to the
IETF repository.

Filename:	 draft-sinnema-xacml-media-type
Revision:	 02
Title:		 eXtensible Access Control Markup Language (XACML) Media Type
Creation date:	 2013-03-26
Group:		 Individual Submission
Number of pages: 9
URL: 
http://www.ietf.org/internet-drafts/draft-sinnema-xacml-media-type-02.txt
Status: http://datatracker.ietf.org/doc/draft-sinnema-xacml-media-type
Htmlized: http://tools.ietf.org/html/draft-sinnema-xacml-media-type-02
Diff: http://www.ietf.org/rfcdiff?url2=draft-sinnema-xacml-media-type-02

Abstract:
    This specification registers an XML-based media type for the
    eXtensible Access Control Markup Language (XACML).

Note to Readers

    This draft should be discussed on the apps-discuss mailing list.
