
From andy@arin.net  Wed May  1 10:54:23 2013
Return-Path: <andy@arin.net>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 4215E21F9A65 for <media-types@ietfa.amsl.com>; Wed,  1 May 2013 10:54:23 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -5.999
X-Spam-Level: 
X-Spam-Status: No, score=-5.999 tagged_above=-999 required=5 tests=[AWL=-4.000, BAYES_00=-2.599, J_CHICKENPOX_44=0.6]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id RhjtBjkCqd03 for <media-types@ietfa.amsl.com>; Wed,  1 May 2013 10:54:23 -0700 (PDT)
Received: from pechora7.dc.icann.org (pechora7.icann.org [IPv6:2620:0:2830:201::1:73]) by ietfa.amsl.com (Postfix) with ESMTP id F332B21F99CC for <media-types@ietf.org>; Wed,  1 May 2013 10:54:22 -0700 (PDT)
Received: from smtp2.arin.net (smtp2.arin.net [IPv6:2001:500:4:13::32]) by pechora7.dc.icann.org (8.13.8/8.13.8) with ESMTP id r41Hs221004105 for <media-types@iana.org>; Wed, 1 May 2013 17:54:22 GMT
Received: by smtp2.arin.net (Postfix, from userid 323) id 6BC232136B6; Wed,  1 May 2013 13:54:02 -0400 (EDT)
Received: from CHAXCH06.corp.arin.net (chaxch06.corp.arin.net [192.149.252.95]) by smtp2.arin.net (Postfix) with ESMTP id EB76C2136AF; Wed,  1 May 2013 13:53:59 -0400 (EDT)
Received: from CHAXCH04.corp.arin.net (10.1.30.19) by CHAXCH06.corp.arin.net (192.149.252.95) with Microsoft SMTP Server (TLS) id 14.2.328.9; Wed, 1 May 2013 13:53:38 -0400
Received: from CHAXCH01.corp.arin.net ([169.254.1.209]) by CHAXCH04.corp.arin.net ([10.1.30.19]) with mapi id 14.02.0328.009; Wed, 1 May 2013 13:53:52 -0400
From: Andy Newton <andy@arin.net>
To: "media-types@iana.org" <media-types@iana.org>
Thread-Topic: registration of application/rdap+json
Thread-Index: AQHORpTVrYPOwkBnGEmIpSQ1CMmXUA==
Date: Wed, 1 May 2013 17:53:52 +0000
Message-ID: <62D9228640AC7F49B2DD9ED0C9CE60E58BC0160B@CHAXCH01.corp.arin.net>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
user-agent: Microsoft-MacOutlook/14.3.2.130206
x-originating-ip: [10.1.35.138]
Content-Type: text/plain; charset="us-ascii"
Content-ID: <9B9343CCEC9E7A428253CB20D2623140@corp.arin.net>
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
X-Greylist: Sender DNS name whitelisted, not delayed by milter-greylist-4.2.3 (pechora7.dc.icann.org [IPv6:2620:0:2830:201::1:73]); Wed, 01 May 2013 17:54:22 +0000 (UTC)
X-Mailman-Approved-At: Wed, 01 May 2013 11:14:37 -0700
Cc: "weirds@ietf.org Group" <weirds@ietf.org>
Subject: [media-types] registration of application/rdap+json
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 01 May 2013 17:54:23 -0000

All,

The WEIRDS working has recently completed WGLC on a draft that registers
the media type application/rdap+json.
(Section 8.2 of http://tools.ietf.org/html/draft-ietf-weirds-using-http-04)

It has been suggested that we need to add more information to our
registration, specifically in the security considerations section. We are
looking for guidance on this matter.

The registration in the draft is as follows:

This specification registers the "application/rdap+json" media type.

   Type name: application

   Subtype name: rdap+json

   Required parameters: n/a

   Encoding considerations: n/a

   Security considerations: n/a

   Interoperability considerations: n/a

   Published specification: [[ this document ]]

   Applications that use this media type: RDAP

   Additional information: n/a

   Person & email address to contact for further information: Andy Newton
<andy@hxr.us>

   Intended usage: COMMON

   Restrictions on usage: none

   Author: Andy Newton

   Change controller: IETF

   Provisional Registration: Yes


I have proposed the following changes to better meet the criteria needed
for registration:

   Encoding considerations: The media described by this media-type is
JSON. JSON supports Unicode. At a minimum, all servers offering this media
must support be capable of serving it using UTF-8 encoding.

    Security considerations: See the Security Considerations specified in
Section 6 of RFC 4627.

    Interoperability considerations: See draft-ietf-weirds-json-response.

    Additional information: This media type is a product of the IETF
WEIRDS working group. The WEIRDS charter, information on the WEIRDS
mailing list, and other documents produced by the WEIRDS working group can
be found at https://datatracker.ietf.org/wg/weirds/


Guidance and help are appreciated. Does this registration meet the needs
for an IANA media type registration?
-andy


From derhoermi@gmx.net  Wed May  1 13:26:16 2013
Return-Path: <derhoermi@gmx.net>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id E6E4221F99D2 for <media-types@ietfa.amsl.com>; Wed,  1 May 2013 13:26:15 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.599
X-Spam-Level: 
X-Spam-Status: No, score=-6.599 tagged_above=-999 required=5 tests=[AWL=-4.000, BAYES_00=-2.599]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id i0OYo7VLR99u for <media-types@ietfa.amsl.com>; Wed,  1 May 2013 13:26:15 -0700 (PDT)
Received: from pechora1.lax.icann.org (unknown [IPv6:2620:0:2d0:201::1:71]) by ietfa.amsl.com (Postfix) with ESMTP id 8DAD721F9B48 for <media-types@ietf.org>; Wed,  1 May 2013 13:26:01 -0700 (PDT)
Received: from mout.gmx.net (mout.gmx.net [212.227.17.20]) by pechora1.lax.icann.org (8.13.8/8.13.8) with ESMTP id r41KPR1J005167 for <media-types@iana.org>; Wed, 1 May 2013 20:25:48 GMT
Received: from mailout-de.gmx.net ([10.1.76.1]) by mrigmx.server.lan (mrigmx001) with ESMTP (Nemesis) id 0Leg4G-1UFZJQ2nni-00qSYp for <media-types@iana.org>; Wed, 01 May 2013 22:25:26 +0200
Received: (qmail invoked by alias); 01 May 2013 20:25:26 -0000
Received: from p5B231A2B.dip0.t-ipconnect.de (EHLO netb.Speedport_W_700V) [91.35.26.43] by mail.gmx.net (mp001) with SMTP; 01 May 2013 22:25:26 +0200
X-Authenticated: #723575
X-Provags-ID: V01U2FsdGVkX1+tnR4yDTitCYOkSqOG4YjJ+xJ6rRcGuLYxFXuL5T A4/+OyI1M4usKr
From: Bjoern Hoehrmann <derhoermi@gmx.net>
To: Andy Newton <andy@arin.net>
Date: Wed, 01 May 2013 22:25:27 +0200
Message-ID: <k1u2o81gj69cevk5qo3l0cb0cq47cupsrh@hive.bjoern.hoehrmann.de>
References: <62D9228640AC7F49B2DD9ED0C9CE60E58BC0160B@CHAXCH01.corp.arin.net>
In-Reply-To: <62D9228640AC7F49B2DD9ED0C9CE60E58BC0160B@CHAXCH01.corp.arin.net>
X-Mailer: Forte Agent 3.3/32.846
MIME-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 8bit
X-Y-GMX-Trusted: 0
X-Greylist: IP, sender and recipient auto-whitelisted, not delayed by milter-greylist-4.0 (pechora1.lax.icann.org [192.0.33.71]); Wed, 01 May 2013 20:25:48 +0000 (UTC)
Cc: "media-types@iana.org" <media-types@iana.org>, "weirds@ietf.org Group" <weirds@ietf.org>
Subject: Re: [media-types] registration of application/rdap+json
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 01 May 2013 20:26:16 -0000

* Andy Newton wrote:
>The WEIRDS working has recently completed WGLC on a draft that registers
>the media type application/rdap+json.
>(Section 8.2 of http://tools.ietf.org/html/draft-ietf-weirds-using-http-04)

>   Applications that use this media type: RDAP

This should give you some idea of the kind of application that would use
the format (2D drawing application, music playback). At least say some-
thing like "Implementations of the Registration Data Access Protocol
[RDAP]" if that is accurate.

>   Provisional Registration: Yes

If the draft is approved for publication as an RFC, I don't think it'd
be quite right for the registration to be provisional, but I'd have to
check RFC 6838.

>I have proposed the following changes to better meet the criteria needed
>for registration:
>
>   Encoding considerations: The media described by this media-type is
>JSON. JSON supports Unicode. At a minimum, all servers offering this media
>must support be capable of serving it using UTF-8 encoding.

This should simply reference RFC 6839, section 3.1.

>    Security considerations: See the Security Considerations specified in
>Section 6 of RFC 4627.

It's a good idea to point out that since the format is based on JSON
that the Security Considerations for JSON also apply to this format,
but this would at least need some assertion that the specific format
does not have security considerations beyond that, or something else
along those lines.

>    Interoperability considerations: See draft-ietf-weirds-json-response.

Does that draft list known interoperability problems? If there are no
known interoperability problems, it would be fine to say that.

(I also note the lack of discussion of fragment identifiers.)
-- 
Björn Höhrmann · mailto:bjoern@hoehrmann.de · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/ 

From superuser@gmail.com  Wed May  1 14:31:15 2013
Return-Path: <superuser@gmail.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 7D1F321F9B46 for <media-types@ietfa.amsl.com>; Wed,  1 May 2013 14:31:15 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.936
X-Spam-Level: 
X-Spam-Status: No, score=-1.936 tagged_above=-999 required=5 tests=[AWL=0.063,  BAYES_00=-2.599, HTML_MESSAGE=0.001, J_CHICKENPOX_44=0.6, NO_RELAYS=-0.001]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 65rMUEiztRaa for <media-types@ietfa.amsl.com>; Wed,  1 May 2013 14:31:14 -0700 (PDT)
Received: from pechora4.lax.icann.org (pechora4.icann.org [IPv6:2620:0:2d0:201::1:74]) by ietfa.amsl.com (Postfix) with ESMTP id E3CA621F9B45 for <media-types@ietf.org>; Wed,  1 May 2013 14:31:14 -0700 (PDT)
Received: from mail-wi0-x232.google.com (mail-wi0-x232.google.com [IPv6:2a00:1450:400c:c05::232]) by pechora4.lax.icann.org (8.13.8/8.13.8) with ESMTP id r41LUrU9024599 for <media-types@iana.org>; Wed, 1 May 2013 21:31:14 GMT
Received: by mail-wi0-f178.google.com with SMTP id hm14so1901712wib.17 for <media-types@iana.org>; Wed, 01 May 2013 14:30:53 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:x-received:in-reply-to:references:date:message-id :subject:from:to:cc:content-type; bh=k42AAt26O+Fqklardact07AO9/UfH2Act1J0nbUcxvg=; b=mE3Z5kmQQI3xDSzlxFqHqC8Z9MqQvfLCj2RfYuDFsk2ZVk4qoWGMBjGmDrRgGSX+f8 jgqtp+yb3+aTBCkdqzP5L2i6l1qcaxUQHaWNoGT5Gwixr64qTzBiFwBdpKStWM7LOiBe X3bbt/Fps6Eq42rhtFeMR7NjF+t0VKCmOBZEvuzfW0kPRGJ4XY6HBvAE28fZgEJEkKEb QPW/rPnl52J73679LnyMJd3wFvVLZPEML2y65eZZ90Z6jLc+6q+itQr65AipcFiVfm9I tZ3X7DkOglsFr4ujFfo/n09xXsfbm63r9BqD6+A7p4c8F/Lpm1+YVZzS1NawdKJc77r8 UG3g==
MIME-Version: 1.0
X-Received: by 10.180.14.5 with SMTP id l5mr6062270wic.32.1367443853396; Wed, 01 May 2013 14:30:53 -0700 (PDT)
Received: by 10.180.14.34 with HTTP; Wed, 1 May 2013 14:30:53 -0700 (PDT)
In-Reply-To: <62D9228640AC7F49B2DD9ED0C9CE60E58BC0160B@CHAXCH01.corp.arin.net>
References: <62D9228640AC7F49B2DD9ED0C9CE60E58BC0160B@CHAXCH01.corp.arin.net>
Date: Wed, 1 May 2013 14:30:53 -0700
Message-ID: <CAL0qLwZa=d1q_278gXjB+xv7Z-634RTx0=KZ0ep_4n8DpJZzJw@mail.gmail.com>
From: "Murray S. Kucherawy" <superuser@gmail.com>
To: Andy Newton <andy@arin.net>
Content-Type: multipart/alternative; boundary=f46d040fa04c21d11d04dbaed534
X-Greylist: IP, sender and recipient auto-whitelisted, not delayed by milter-greylist-4.0 (pechora4.lax.icann.org [IPv6:2620:0:2d0:201::1:74]); Wed, 01 May 2013 21:31:14 +0000 (UTC)
X-Mailman-Approved-At: Wed, 01 May 2013 15:01:57 -0700
Cc: "media-types@iana.org" <media-types@iana.org>, "weirds@ietf.org Group" <weirds@ietf.org>
Subject: Re: [media-types] [weirds] registration of application/rdap+json
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 01 May 2013 21:31:15 -0000

--f46d040fa04c21d11d04dbaed534
Content-Type: text/plain; charset=ISO-8859-1

Looks good to me.  You might also reference the Encoding Considerations in
RFC4627 if they're applicable.


On Wed, May 1, 2013 at 10:53 AM, Andy Newton <andy@arin.net> wrote:

> All,
>
> The WEIRDS working has recently completed WGLC on a draft that registers
> the media type application/rdap+json.
> (Section 8.2 of http://tools.ietf.org/html/draft-ietf-weirds-using-http-04
> )
>
> It has been suggested that we need to add more information to our
> registration, specifically in the security considerations section. We are
> looking for guidance on this matter.
>
> The registration in the draft is as follows:
>
> This specification registers the "application/rdap+json" media type.
>
>    Type name: application
>
>    Subtype name: rdap+json
>
>    Required parameters: n/a
>
>    Encoding considerations: n/a
>
>    Security considerations: n/a
>
>    Interoperability considerations: n/a
>
>    Published specification: [[ this document ]]
>
>    Applications that use this media type: RDAP
>
>    Additional information: n/a
>
>    Person & email address to contact for further information: Andy Newton
> <andy@hxr.us>
>
>    Intended usage: COMMON
>
>    Restrictions on usage: none
>
>    Author: Andy Newton
>
>    Change controller: IETF
>
>    Provisional Registration: Yes
>
>
> I have proposed the following changes to better meet the criteria needed
> for registration:
>
>    Encoding considerations: The media described by this media-type is
> JSON. JSON supports Unicode. At a minimum, all servers offering this media
> must support be capable of serving it using UTF-8 encoding.
>
>     Security considerations: See the Security Considerations specified in
> Section 6 of RFC 4627.
>
>     Interoperability considerations: See draft-ietf-weirds-json-response.
>
>     Additional information: This media type is a product of the IETF
> WEIRDS working group. The WEIRDS charter, information on the WEIRDS
> mailing list, and other documents produced by the WEIRDS working group can
> be found at https://datatracker.ietf.org/wg/weirds/
>
>
> Guidance and help are appreciated. Does this registration meet the needs
> for an IANA media type registration?
> -andy
>
> _______________________________________________
> weirds mailing list
> weirds@ietf.org
> https://www.ietf.org/mailman/listinfo/weirds
>

--f46d040fa04c21d11d04dbaed534
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr"><div><br></div><div>Looks good to me.=A0 You might also re=
ference the Encoding Considerations in RFC4627 if they&#39;re applicable.<b=
r></div></div><div class=3D"gmail_extra"><br><br><div class=3D"gmail_quote"=
>On Wed, May 1, 2013 at 10:53 AM, Andy Newton <span dir=3D"ltr">&lt;<a href=
=3D"mailto:andy@arin.net" target=3D"_blank">andy@arin.net</a>&gt;</span> wr=
ote:<br>
<blockquote class=3D"gmail_quote" style=3D"margin:0 0 0 .8ex;border-left:1p=
x #ccc solid;padding-left:1ex">All,<br>
<br>
The WEIRDS working has recently completed WGLC on a draft that registers<br=
>
the media type application/rdap+json.<br>
(Section 8.2 of <a href=3D"http://tools.ietf.org/html/draft-ietf-weirds-usi=
ng-http-04" target=3D"_blank">http://tools.ietf.org/html/draft-ietf-weirds-=
using-http-04</a>)<br>
<br>
It has been suggested that we need to add more information to our<br>
registration, specifically in the security considerations section. We are<b=
r>
looking for guidance on this matter.<br>
<br>
The registration in the draft is as follows:<br>
<br>
This specification registers the &quot;application/rdap+json&quot; media ty=
pe.<br>
<br>
=A0 =A0Type name: application<br>
<br>
=A0 =A0Subtype name: rdap+json<br>
<br>
=A0 =A0Required parameters: n/a<br>
<br>
=A0 =A0Encoding considerations: n/a<br>
<br>
=A0 =A0Security considerations: n/a<br>
<br>
=A0 =A0Interoperability considerations: n/a<br>
<br>
=A0 =A0Published specification: [[ this document ]]<br>
<br>
=A0 =A0Applications that use this media type: RDAP<br>
<br>
=A0 =A0Additional information: n/a<br>
<br>
=A0 =A0Person &amp; email address to contact for further information: Andy =
Newton<br>
&lt;<a href=3D"mailto:andy@hxr.us">andy@hxr.us</a>&gt;<br>
<br>
=A0 =A0Intended usage: COMMON<br>
<br>
=A0 =A0Restrictions on usage: none<br>
<br>
=A0 =A0Author: Andy Newton<br>
<br>
=A0 =A0Change controller: IETF<br>
<br>
=A0 =A0Provisional Registration: Yes<br>
<br>
<br>
I have proposed the following changes to better meet the criteria needed<br=
>
for registration:<br>
<br>
=A0 =A0Encoding considerations: The media described by this media-type is<b=
r>
JSON. JSON supports Unicode. At a minimum, all servers offering this media<=
br>
must support be capable of serving it using UTF-8 encoding.<br>
<br>
=A0 =A0 Security considerations: See the Security Considerations specified =
in<br>
Section 6 of RFC 4627.<br>
<br>
=A0 =A0 Interoperability considerations: See draft-ietf-weirds-json-respons=
e.<br>
<br>
=A0 =A0 Additional information: This media type is a product of the IETF<br=
>
WEIRDS working group. The WEIRDS charter, information on the WEIRDS<br>
mailing list, and other documents produced by the WEIRDS working group can<=
br>
be found at <a href=3D"https://datatracker.ietf.org/wg/weirds/" target=3D"_=
blank">https://datatracker.ietf.org/wg/weirds/</a><br>
<br>
<br>
Guidance and help are appreciated. Does this registration meet the needs<br=
>
for an IANA media type registration?<br>
-andy<br>
<br>
_______________________________________________<br>
weirds mailing list<br>
<a href=3D"mailto:weirds@ietf.org">weirds@ietf.org</a><br>
<a href=3D"https://www.ietf.org/mailman/listinfo/weirds" target=3D"_blank">=
https://www.ietf.org/mailman/listinfo/weirds</a><br>
</blockquote></div><br></div>

--f46d040fa04c21d11d04dbaed534--
