
From nobody Thu Mar  6 19:46:41 2014
Return-Path: <ron.even.tlv@gmail.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id F017F1A0234 for <media-types@ietfa.amsl.com>; Tue,  4 Mar 2014 06:19:09 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 2.73
X-Spam-Level: **
X-Spam-Status: No, score=2.73 tagged_above=-999 required=5 tests=[BAYES_40=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, FRT_BELOW2=2.154, HTML_MESSAGE=0.001, SPF_SOFTFAIL=0.665, T_FRT_BELOW2=0.01] autolearn=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id HHgooxM-v0zi for <media-types@ietfa.amsl.com>; Tue,  4 Mar 2014 06:19:08 -0800 (PST)
Received: from pechora1.lax.icann.org (pechora1.icann.org [IPv6:2620:0:2d0:201::1:71]) by ietfa.amsl.com (Postfix) with ESMTP id 5B2651A0244 for <media-types@ietf.org>; Tue,  4 Mar 2014 06:19:05 -0800 (PST)
Received: from mail-we0-x230.google.com (mail-we0-x230.google.com [IPv6:2a00:1450:400c:c03::230]) by pechora1.lax.icann.org (8.13.8/8.13.8) with ESMTP id s24EIfh3032451 for <ietf-types@iana.org>; Tue, 4 Mar 2014 14:19:01 GMT
Received: by mail-we0-f176.google.com with SMTP id x48so5016444wes.35 for <ietf-types@iana.org>; Tue, 04 Mar 2014 06:18:41 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113;  h=from:to:cc:subject:date:message-id:mime-version:content-type :thread-index:content-language; bh=KWQjMXv6t5kQKIN9eWhtqRCLGK4Y2guA8wZgwRP6uU0=; b=jOzoYqGUVsj/eiTqRyEZpbH6B+rLRWYyl7wWs0OKJepqQkTX/Bjxl2LGMq2ggOP39Z 96MdJc/GufSeD2vuM3OUjE8hBjIz/RyOE0gjLrbiKY2074txci/JZX0NdKHhv4avQX21 MzabtpTIDA9UCBjaxz4xUq6PBoKdOHkWVEVxDE0ttI1MF+6vh2xMoRcfNl+qUJ+/6/mC WzIn6bHmkPphcpwCfsPU0k5JxsCsXYlEz1ls46u7sEpvkICX0w/07wqpjjLrcik7iUN9 k27kB1VImAE3Un3/Ct+sVWpNOAIHQymPL3Tyv6P76FJf/GAZ+kDefagU+IJhvsAMtBAB iFoQ==
X-Received: by 10.194.87.195 with SMTP id ba3mr18284788wjb.53.1393942720878; Tue, 04 Mar 2014 06:18:40 -0800 (PST)
Received: from RoniE ([2001:67c:370:160:50f8:ad6:f20a:2521]) by mx.google.com with ESMTPSA id ju6sm52657759wjc.1.2014.03.04.06.18.37 for <multiple recipients> (version=TLSv1 cipher=ECDHE-RSA-AES128-SHA bits=128/128); Tue, 04 Mar 2014 06:18:40 -0800 (PST)
From: "Roni Even" <ron.even.tlv@gmail.com>
To: "'IANA Media types'" <ietf-types@iana.org>
Date: Tue, 4 Mar 2014 16:18:32 +0200
Message-ID: <030d01cf37b4$a33dc8d0$e9b95a70$@gmail.com>
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_030E_01CF37C5.66CF4B60"
X-Mailer: Microsoft Outlook 14.0
Thread-Index: Ac83tAwAj7yTRVxBQ9yQcl9tpkgGwg==
Content-Language: en-us
X-Greylist: IP, sender and recipient auto-whitelisted, not delayed by milter-greylist-4.0 (pechora1.lax.icann.org [IPv6:2620:0:2d0:201::1:71]); Tue, 04 Mar 2014 14:19:02 +0000 (UTC)
Archived-At: http://mailarchive.ietf.org/arch/msg/media-types/KVFcILZ-ebAXahtkypjJq4E9cq8
X-Mailman-Approved-At: Thu, 06 Mar 2014 19:46:40 -0800
Cc: "'Ali C. Begen \(abegen\)'" <abegen@cisco.com>, draft-ietf-payload-g7110@tools.ietf.org, payload@ietf.org
Subject: [media-types] registeration of G7110 media subtype for G.711.0 payload
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 04 Mar 2014 14:19:10 -0000

This is a multipart message in MIME format.

------=_NextPart_000_030E_01CF37C5.66CF4B60
Content-Type: text/plain;
	charset="us-ascii"
Content-Transfer-Encoding: 7bit

Hi,

 

draft-ietf-payload-g7110-02
<http://tools.ietf.org/html/draft-ietf-payload-g7110-02>  has passed Working
Group Last Call in the Payload Working Group. 
The document registers media subtype G7110.  
 
The new registrations are in Section 5.1 of the document and is also given
bellow.
  

Comments on the registration are welcome.

 

Thanks

Roni Even

Payload WG co-chair

 

 

 

 

Media Type Registration

 

   Type name: audio

 

   Subtype name: G7110

 

   Required parameters:

 

      rate: The RTP timestamp clock rate, which is equal to the sampling

      rate.  The typical rate used with G.711 encoding is 8000, but

      other rates may be specified.  The default rate is 8000.

 

      complaw: Indicates the companding law (A-law or mu-law) employed.

      The case-insensitive values are "al" or "mu" for A-law and mu-law,

      respectively.

 

   Optional parameters:

 

      channels: See RFC 4566 [RFC4566] for definition.  Specifies how

      many audio streams are represented in the G.711.0 payload and MUST

      be present if the number of channels is greater than one.  This

      parameter defaults to 1 if not present (as per RFC 4566) and is

      typically a non-zero small-valued positive integer.  It is

      expected that implementations that specify multiple channels will

      also define a mechanism to map the channels appropriately within

      their system design, otherwise the channel order specified in RFC

      3551 [RFC3551] Section 4.1 will be assumed (e.g., left, right,

      center, ... ).

 

      maxptime: See RFC 4566 [RFC4566] for definition.

 

      ptime: See RFC 4566 [RFC4566] for definition.  The inclusion of

      "ptime" is RECOMMENDED and SHOULD be in the SDP unless there is an

      application specific reason not to include it (e.g., an

      application that has a variable ptime on a packet-by-packet

      basis).  For constant ptime applications, it is considered good

      form to include "ptime" in the SDP for session diagnostic

      purposes.  For the constant ptime multiple channel case described

      in Section 4.2.2, the inclusion of "ptime" can provide a desirable

      payload check.

 

   Encoding considerations:

 

      This media type is framed binary data (see Section 4.8 in RFC 6838

      [RFC6838]) compressed as per ITU-T Rec. G.711.0.

 

   Security considerations:

 

      See Section 10.

 

   Interoperability considerations: none

 

   Published specification:

 

      ITU-T Rec. G.711.0 and RFC XXXX.

 

      [ RFC Editor: please replace XXXXX with a reference to this RFC ]

 

   Applications that use this media type:

 

      Although initially conceived for VoIP, the use of G.711.0, like

      G.711 before it, may find use within audio and video streaming and

      /or conferencing applications for the audio portion of those

      applications.

 

   Additional information:

 

   The following applies to stored-file transfer methods:

 

         Magic numbers: #!G7110A\n or #!G7110M\n (for A-law or MU-law

         encodings respectively, see Section 6).

 

        File Extensions: None

 

         Macintosh file type code: None

 

         Object identifier or OIL: None

 

   Person & email address to contact for further information:

 

      Michael A. Ramalho <mramalho@cisco.com> or <mar42@cornell.edu>

 

   Intended usage: COMMON

 

   Restrictions on usage:

 

      This media type depends on RTP framing, and hence is only defined

      for transfer via RTP [RFC3550].  Transport within other framing

      protocols is not defined at this time.

 

   Author: Michael A. Ramalho

 

   Change controller:

 

 

      IETF Payload working group delegated from the IESG.

 

 


------=_NextPart_000_030E_01CF37C5.66CF4B60
Content-Type: text/html;
	charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

<html xmlns:v=3D"urn:schemas-microsoft-com:vml" =
xmlns:o=3D"urn:schemas-microsoft-com:office:office" =
xmlns:w=3D"urn:schemas-microsoft-com:office:word" =
xmlns:m=3D"http://schemas.microsoft.com/office/2004/12/omml" =
xmlns=3D"http://www.w3.org/TR/REC-html40"><head><meta =
http-equiv=3DContent-Type content=3D"text/html; =
charset=3Dus-ascii"><meta name=3DGenerator content=3D"Microsoft Word 14 =
(filtered medium)"><style><!--
/* Font Definitions */
@font-face
	{font-family:Calibri;
	panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
	{margin:0in;
	margin-bottom:.0001pt;
	font-size:11.0pt;
	font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
	{mso-style-priority:99;
	color:blue;
	text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
	{mso-style-priority:99;
	color:purple;
	text-decoration:underline;}
pre
	{mso-style-priority:99;
	mso-style-link:"HTML Preformatted Char";
	margin:0in;
	margin-bottom:.0001pt;
	font-size:10.0pt;
	font-family:"Courier New";}
span.EmailStyle17
	{mso-style-type:personal-compose;
	font-family:"Calibri","sans-serif";
	color:windowtext;}
span.HTMLPreformattedChar
	{mso-style-name:"HTML Preformatted Char";
	mso-style-priority:99;
	mso-style-link:"HTML Preformatted";
	font-family:"Courier New";}
.MsoChpDefault
	{mso-style-type:export-only;
	font-family:"Calibri","sans-serif";}
@page WordSection1
	{size:8.5in 11.0in;
	margin:1.0in 1.25in 1.0in 1.25in;}
div.WordSection1
	{page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext=3D"edit" spidmax=3D"1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext=3D"edit">
<o:idmap v:ext=3D"edit" data=3D"1" />
</o:shapelayout></xml><![endif]--></head><body lang=3DEN-US link=3Dblue =
vlink=3Dpurple><div class=3DWordSection1><p =
class=3DMsoNormal>Hi,<o:p></o:p></p><p =
class=3DMsoNormal><o:p>&nbsp;</o:p></p><pre><span =
style=3D'font-size:11.0pt;font-family:"Calibri","sans-serif";color:black'=
><a =
href=3D"http://tools.ietf.org/html/draft-ietf-payload-g7110-02">draft-iet=
f-payload-g7110-02</a> </span><span =
style=3D'font-size:11.0pt;font-family:"Calibri","sans-serif"'>has passed =
Working Group Last Call in the Payload Working Group. =
<o:p></o:p></span></pre><pre><span =
style=3D'font-size:11.0pt;font-family:"Calibri","sans-serif"'>The =
document registers media subtype G7110.&nbsp; =
<o:p></o:p></span></pre><pre><span =
style=3D'font-size:11.0pt;font-family:"Calibri","sans-serif"'><o:p>&nbsp;=
</o:p></span></pre><pre><span =
style=3D'font-size:11.0pt;font-family:"Calibri","sans-serif"'>The new =
registrations are in Section 5.1 of the document and&nbsp;is also given =
bellow.<o:p></o:p></span></pre><pre>&nbsp; <o:p></o:p></pre><p =
class=3DMsoNormal>Comments on the registration are =
welcome.<o:p></o:p></p><p class=3DMsoNormal><o:p>&nbsp;</o:p></p><p =
class=3DMsoNormal>Thanks<o:p></o:p></p><p class=3DMsoNormal>Roni =
Even<o:p></o:p></p><p class=3DMsoNormal>Payload WG =
co-chair<o:p></o:p></p><p class=3DMsoNormal><span =
style=3D'font-size:10.0pt;font-family:"Courier =
New";color:black'><o:p>&nbsp;</o:p></span></p><p class=3DMsoNormal><span =
style=3D'font-size:10.0pt;font-family:"Courier =
New";color:black'><o:p>&nbsp;</o:p></span></p><p class=3DMsoNormal><span =
style=3D'font-size:10.0pt;font-family:"Courier =
New";color:black'><o:p>&nbsp;</o:p></span></p><p class=3DMsoNormal><span =
style=3D'font-size:10.0pt;font-family:"Courier =
New";color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><b><span style=3D'color:black'>Media Type =
Registration<o:p></o:p></span></b></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Type name: =
audio<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Subtype name: =
G7110<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Required =
parameters:<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; rate: The RTP =
timestamp clock rate, which is equal to the =
sampling<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; rate.&nbsp; The =
typical rate used with G.711 encoding is 8000, =
but<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; other rates may be =
specified.&nbsp; The default rate is 8000.<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; complaw: Indicates =
the companding law (A-law or mu-law) employed.<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; The =
case-insensitive values are &quot;al&quot; or &quot;mu&quot; for A-law =
and mu-law,<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
respectively.<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Optional =
parameters:<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; channels: See RFC =
4566 [RFC4566] for definition.&nbsp; Specifies =
how<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; many audio streams =
are represented in the G.711.0 payload and MUST<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; be present if the =
number of channels is greater than one.&nbsp; =
This<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; parameter defaults =
to 1 if not present (as per RFC 4566) and is<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; typically a =
non-zero small-valued positive integer.&nbsp; It =
is<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; expected that =
implementations that specify multiple channels =
will<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; also define a =
mechanism to map the channels appropriately =
within<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; their system =
design, otherwise the channel order specified in =
RFC<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 3551 [RFC3551] =
Section 4.1 will be assumed (e.g., left, right,<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; center, ... =
).<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; maxptime: See RFC =
4566 [RFC4566] for definition.<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ptime: See RFC 4566 =
[RFC4566] for definition.&nbsp; The inclusion of<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &quot;ptime&quot; =
is RECOMMENDED and SHOULD be in the SDP unless there is =
an<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; application =
specific reason not to include it (e.g., an<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; application that =
has a variable ptime on a packet-by-packet<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; basis).&nbsp; For =
constant ptime applications, it is considered =
good<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; form to include =
&quot;ptime&quot; in the SDP for session =
diagnostic<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; purposes.&nbsp; For =
the constant ptime multiple channel case =
described<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; in Section 4.2.2, =
the inclusion of &quot;ptime&quot; can provide a =
desirable<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; payload =
check.<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Encoding =
considerations:<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; This media type is =
framed binary data (see Section 4.8 in RFC 6838<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; [RFC6838]) =
compressed as per ITU-T Rec. G.711.0.<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Security =
considerations:<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; See Section =
10.<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; =
Interoperability considerations: none<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Published =
specification:<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ITU-T Rec. G.711.0 =
and RFC XXXX.<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; [ RFC Editor: =
please replace XXXXX with a reference to this RFC =
]<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Applications =
that use this media type:<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Although initially =
conceived for VoIP, the use of G.711.0, like<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; G.711 before it, =
may find use within audio and video streaming =
and<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; /or conferencing =
applications for the audio portion of those<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
applications.<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Additional =
information:<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; The following =
applies to stored-file transfer methods:<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
Magic numbers: #!G7110A\n or #!G7110M\n (for A-law or =
MU-law<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
encodings respectively, see Section 6).<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'> =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;File Extensions: =
None<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
Macintosh file type code: None<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
Object identifier or OIL: None<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Person &amp; =
email address to contact for further =
information:<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Michael A. Ramalho =
&lt;mramalho@cisco.com&gt; or =
&lt;mar42@cornell.edu&gt;<o:p></o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Intended =
usage: COMMON<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Restrictions =
on usage:<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; This media type =
depends on RTP framing, and hence is only =
defined<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; for transfer via =
RTP [RFC3550].&nbsp; Transport within other =
framing<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; protocols is not =
defined at this time.<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Author: =
Michael A. Ramalho<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span style=3D'color:black'>&nbsp;&nbsp; Change =
controller:<o:p></o:p></span></p><p class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span =
style=3D'color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; IETF Payload =
working group delegated from the IESG.<o:p></o:p></span></p><p =
class=3DMsoNormal><o:p>&nbsp;</o:p></p><p =
class=3DMsoNormal><o:p>&nbsp;</o:p></p></div></body></html>
------=_NextPart_000_030E_01CF37C5.66CF4B60--


From szilva@changenet.sk  Sat Mar  8 07:25:46 2014
Return-Path: <szilva@changenet.sk>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 6AB881A028B for <media-types@ietfa.amsl.com>; Sat,  8 Mar 2014 07:25:46 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 3.438
X-Spam-Level: ***
X-Spam-Status: No, score=3.438 tagged_above=-999 required=5 tests=[BAYES_50=0.8, DEAR_SOMETHING=1.973, SPF_SOFTFAIL=0.665] autolearn=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id LMVfHqq7GsCn for <media-types@ietfa.amsl.com>; Sat,  8 Mar 2014 07:25:44 -0800 (PST)
Received: from pechora4.lax.icann.org (pechora4.icann.org [IPv6:2620:0:2d0:201::1:74]) by ietfa.amsl.com (Postfix) with ESMTP id 052591A02B3 for <media-types@ietf.org>; Sat,  8 Mar 2014 07:25:43 -0800 (PST)
Received: from cn03.changenet.sk (cn03.changenet.sk [86.110.225.135]) by pechora4.lax.icann.org (8.13.8/8.13.8) with ESMTP id s28FPH4A030010 for <media-types@iana.org>; Sat, 8 Mar 2014 15:25:38 GMT
Received: from localhost (localhost.localdomain [127.0.0.1]) (using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)) (No client certificate requested) (Authenticated sender: szilva) by cn03.changenet.sk (Postfix) with ESMTPSA id CA943A17A7 for <media-types@iana.org>; Sat,  8 Mar 2014 16:08:50 +0100 (CET)
Received: from chello089173219155.chello.sk (chello089173219155.chello.sk [89.173.219.155]) by mail.changenet.sk (Horde Framework) with HTTP; Sat, 08 Mar 2014 16:08:50 +0100
Message-ID: <20140308160850.57913ia6w1v9df0g@mail.changenet.sk>
Date: Sat, 08 Mar 2014 16:08:50 +0100
From: szilva@changenet.sk
To: media-types@iana.org
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8; DelSp="Yes"; format="flowed"
Content-Disposition: inline
Content-Transfer-Encoding: 7bit
User-Agent: Internet Messaging Program (IMP) H3 (4.3.7)
X-Virus-Scanned: clamav-milter 0.97.8 at cn03
X-Virus-Status: Clean
X-Greylist: Delayed for 00:16:25 by milter-greylist-4.0 (pechora4.lax.icann.org [192.0.33.74]); Sat, 08 Mar 2014 15:25:38 +0000 (UTC)
Archived-At: http://mailarchive.ietf.org/arch/msg/media-types/uJOGWqyNAIjF2Xf-vxqsZSXkxVc
X-Mailman-Approved-At: Sat, 08 Mar 2014 11:12:07 -0800
Subject: [media-types] media type registration of the Slovak national standard for e-forms container e-form+xml, e-form+zip
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sat, 08 Mar 2014 15:29:17 -0000

Dear sirs,

I am an idependent member of working groups of the Committee for  
standardization of information systems of public administration in  
Slovak republic, which defined a national e-forms container and is  
working also on another standards. The Committee works under the  
Ministry of finance of the Slovak republic and its public website is  
here: http://informatizacia.sk/standards-for-is-pa/4632s

The e-forms container will contain all definitions, schemas and  
transformations needed for a visual and other presentations of an  
e-government e-form, for filling an e-form, validation of filled data,  
etc.

We would like to register a mimetype for this national e-forms  
container, but firstly we would like to consult the correct naming.


My questions:

1. Is there any experience with registration of media types for  
national IT or e-government standards? Are there any examples of  
national standards' subtypes?

2. I would like to ask you, what registration tree would you suggest  
for our national e-forms container. "Vendor tree" or "Personal or  
Vanity tree"?

3. What should be the "IANA-approved designation of the producer's  
name" in the case of national e-government standard? Are there any  
written rules for the names?


More explanation:

The e-forms container will be primarily used by Slovak national  
e-government portal for publication of all e-forms specifications, but  
it will be also used by vendors/software producers, who will create  
and distribute commercial or freeware software for general public and  
business customers (e.g. economical or accounting software for  
business, software for filling e-forms, software for e-signing of  
e-forms, etc). It could be possibly used by other countries or vendors.

The container has two equal forms: XML structure or ZIP container.
The technical specification of the e-forms container is published as a  
legislative document - "Edict About Standards for Information Systems  
of Public Administration" and use of this specification is imposed by  
the Slovak national legislation. (It is currently available only in  
Slovak language and the requirements for the e-forms container are  
defined in this supplement:  
https://lt.justice.gov.sk/Attachment/Priloha_3_e-formulare.pdf?instEID=-1&attEID=63268&docEID=353297&matEID=6842&langEID=1&tStamp=20140304134546663  
)

The e-forms container is based on existing standards: JAR file format,  
DublinCore, Open Packaging Format, OpenDocument format, EPUB Open  
Container Format. The e-forms container also extends these standards  
for specific e-forms usage.


Currently the following nonstandard media types for e-forms containers  
are used in Slovakia:
application/e-form+zip
application/x-eform-xml

Firstly we thought, we can register something like this:
application/vnd.e-form+zip
application/vnd.e-form+xml
(maybe "e-form" will be only "eform")

But if we understand the RFC 6838 correctly, we should create an  
abbreviation for the organization which is responsible for the Slovak  
e-government IT standards and this abbreviation must be incorporated  
in the subtype name.

Maybe something like this ? :
(note, these are only examples that were not approved or consulted by  
our Committee)

application/vnd.gov.sk.e-form+zip
application/vnd.gov.sk.e-form+xml

or something like this :

application/vnd.finance.gov.sk.e-form+zip
application/vnd.finance.gov.sk.e-form+xml

Explanation for the "gov.sk": It is the second-level domain name used  
by the Slovak government organizations, such as www.government.gov.sk,  
www.finance.gov.sk, www.nases.gov.sk, etc.



As an example I filled the registration template for the XML variant  
of the container, but this is not an official registration request:



    Type name: application

    Subtype name: Vendor Tree - vnd.gov.sk.e-form+xml

    Required parameters:   None.

    Optional parameters:  "charset"

          UTF-8 is required for Slovak national e-forms containers.  
This parameter has identical semantics to the charset parameter of the  
"application/xml" media type as specified in RFC3023.

    Encoding considerations:  Identical to those of "application/xml"  
as described in RFC3023, Section 3.2.

    Security considerations:  Files may contain script and other  
active content.

    Interoperability considerations:

    Published specification:  (only in Slovak language)  
https://lt.justice.gov.sk/Attachment/Priloha_3_e-formulare.pdf?instEID=-1&attEID=63268&docEID=353297&matEID=6842&langEID=1&tStamp=20140304134546663

    Applications that use this media type:  Slovak e-government  
portals and (in the future) software from some other vendors.

    Fragment identifier considerations:

    Additional information:

      Deprecated alias names for this type:

      Magic number(s):  As specified for "application/xml" in RFC3023,  
Section 3.2.

      File extension(s):  .xml, .eform

      Macintosh file type code(s):  TEXT

    Person & email address to contact for further information:   
National agency for network and electronic services  -  or  -   
Ministry of Finance of the Slovak republic

    Intended usage: COMMON

    (One of COMMON, LIMITED USE, or OBSOLETE.)

    Restrictions on usage:

    (Any restrictions on where the media type can be used go here.)

    Author:


----


An incomplete e-forms container structure:
- mimetype - e-form mimetype
- META-INF/manifest.xml - references and paths of all of the content  
in the container
- meta.xml - e-form identification, version, name, short description  
and other metadata
- schema.xsd - XML Schema for the data.xml
- data.xml - optional - user data filled in the e-form
- Content/ - presentation schema and transformation schema of the data  
(primarily XSLT file)
- Presentation/ - optional - a presentation containing the data filled  
by an user (a result of the XSLT transformation of data.xml)
- Thumbnails/ - e-form thumbnail
- attachments.xml - optional - list of attachments
- Attachments/ - optional - attachments listed in attachments.xml
- settings.xml - optional - application settings


---


Thank you for any help

Stefan Szilva
Viglasska 7
Bratislava
Slovak republic
szilva@changenet.sk




From nobody Fri Mar 14 01:40:35 2014
Return-Path: <duerst@it.aoyama.ac.jp>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 7A7891A00A6 for <media-types@ietfa.amsl.com>; Fri, 14 Mar 2014 01:40:32 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 1.773
X-Spam-Level: *
X-Spam-Status: No, score=1.773 tagged_above=-999 required=5 tests=[BAYES_05=-0.5, DEAR_SOMETHING=1.973, MIME_8BIT_HEADER=0.3] autolearn=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ct6DrWqyA-bQ for <media-types@ietfa.amsl.com>; Fri, 14 Mar 2014 01:40:30 -0700 (PDT)
Received: from pechora1.lax.icann.org (pechora1.icann.org [IPv6:2620:0:2d0:201::1:71]) by ietfa.amsl.com (Postfix) with ESMTP id 8C84B1A00B2 for <media-types@ietf.org>; Fri, 14 Mar 2014 01:40:29 -0700 (PDT)
Received: from acspool01.acbb.aoyama.ac.jp (acspool01.acbb.aoyama.ac.jp [133.2.20.162]) by pechora1.lax.icann.org (8.13.8/8.13.8) with ESMTP id s2E8e1br016281 for <media-types@iana.org>; Fri, 14 Mar 2014 08:40:22 GMT
Received: from scintmta02.scbb.aoyama.ac.jp (scintmta02.scbb.aoyama.ac.jp [133.2.253.34]) by acspool01.acbb.aoyama.ac.jp (secret/secret) with ESMTP id s2E8RQHB024444 for <media-types@iana.org>; Fri, 14 Mar 2014 17:27:27 +0900
Received: from scmse02.scbb.aoyama.ac.jp ([133.2.253.231]) by scintmta02.scbb.aoyama.ac.jp (secret/secret) with SMTP id s2E8OsJX001682; Fri, 14 Mar 2014 17:24:55 +0900
Received: from (unknown [133.2.206.134]) by scmse02.scbb.aoyama.ac.jp with smtp id 712a_784f_1ed52234_ab52_11e3_991c_001e6722eec2; Fri, 14 Mar 2014 17:24:54 +0900
Received: from [IPv6:::1] (unknown [133.2.210.1]) by itmail2.it.aoyama.ac.jp (Postfix) with ESMTP id B75ECC03A3; Fri, 14 Mar 2014 17:24:53 +0900 (JST)
Message-ID: <5322BCCD.8080000@it.aoyama.ac.jp>
Date: Fri, 14 Mar 2014 17:24:45 +0900
From: =?UTF-8?B?Ik1hcnRpbiBKLiBEw7xyc3Qi?= <duerst@it.aoyama.ac.jp>
Organization: Aoyama Gakuin University
User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.3.0
MIME-Version: 1.0
To: szilva@changenet.sk, media-types@iana.org
References: <20140308160850.57913ia6w1v9df0g@mail.changenet.sk>
In-Reply-To: <20140308160850.57913ia6w1v9df0g@mail.changenet.sk>
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 7bit
X-Greylist: Delayed for 00:12:32 by milter-greylist-4.0 (pechora1.lax.icann.org [192.0.33.71]); Fri, 14 Mar 2014 08:40:22 +0000 (UTC)
Archived-At: http://mailarchive.ietf.org/arch/msg/media-types/hgYhYn13so_mv9jh7NzQ3_6iySw
Subject: Re: [media-types] media type registration of the Slovak national standard for e-forms container e-form+xml, e-form+zip
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 14 Mar 2014 08:40:32 -0000

Hello Stefan,

On 2014/03/09 00:08, szilva@changenet.sk wrote:
> Dear sirs,
>
> I am an idependent member of working groups of the Committee for
> standardization of information systems of public administration in
> Slovak republic, which defined a national e-forms container and is
> working also on another standards. The Committee works under the
> Ministry of finance of the Slovak republic and its public website is
> here: http://informatizacia.sk/standards-for-is-pa/4632s
>
> The e-forms container will contain all definitions, schemas and
> transformations needed for a visual and other presentations of an
> e-government e-form, for filling an e-form, validation of filled data, etc.
>
> We would like to register a mimetype for this national e-forms
> container, but firstly we would like to consult the correct naming.
>
>
> My questions:
>
> 1. Is there any experience with registration of media types for national
> IT or e-government standards? Are there any examples of national
> standards' subtypes?

I don't remember any such case.

> 2. I would like to ask you, what registration tree would you suggest for
> our national e-forms container. "Vendor tree" or "Personal or Vanity tree"?

If it's (or it's going to be) a national standard, then why not 
Standards Tree? For more details, please see 
http://tools.ietf.org/html/rfc6838#section-3.1.

Regards,   Martin.

> 3. What should be the "IANA-approved designation of the producer's name"
> in the case of national e-government standard? Are there any written
> rules for the names?
>
>
> More explanation:
>
> The e-forms container will be primarily used by Slovak national
> e-government portal for publication of all e-forms specifications, but
> it will be also used by vendors/software producers, who will create and
> distribute commercial or freeware software for general public and
> business customers (e.g. economical or accounting software for business,
> software for filling e-forms, software for e-signing of e-forms, etc).
> It could be possibly used by other countries or vendors.
>
> The container has two equal forms: XML structure or ZIP container.
> The technical specification of the e-forms container is published as a
> legislative document - "Edict About Standards for Information Systems of
> Public Administration" and use of this specification is imposed by the
> Slovak national legislation. (It is currently available only in Slovak
> language and the requirements for the e-forms container are defined in
> this supplement:
> https://lt.justice.gov.sk/Attachment/Priloha_3_e-formulare.pdf?instEID=-1&attEID=63268&docEID=353297&matEID=6842&langEID=1&tStamp=20140304134546663
> )
>
> The e-forms container is based on existing standards: JAR file format,
> DublinCore, Open Packaging Format, OpenDocument format, EPUB Open
> Container Format. The e-forms container also extends these standards for
> specific e-forms usage.
>
>
> Currently the following nonstandard media types for e-forms containers
> are used in Slovakia:
> application/e-form+zip
> application/x-eform-xml
>
> Firstly we thought, we can register something like this:
> application/vnd.e-form+zip
> application/vnd.e-form+xml
> (maybe "e-form" will be only "eform")
>
> But if we understand the RFC 6838 correctly, we should create an
> abbreviation for the organization which is responsible for the Slovak
> e-government IT standards and this abbreviation must be incorporated in
> the subtype name.
>
> Maybe something like this ? :
> (note, these are only examples that were not approved or consulted by
> our Committee)
>
> application/vnd.gov.sk.e-form+zip
> application/vnd.gov.sk.e-form+xml
>
> or something like this :
>
> application/vnd.finance.gov.sk.e-form+zip
> application/vnd.finance.gov.sk.e-form+xml
>
> Explanation for the "gov.sk": It is the second-level domain name used by
> the Slovak government organizations, such as www.government.gov.sk,
> www.finance.gov.sk, www.nases.gov.sk, etc.
>
>
>
> As an example I filled the registration template for the XML variant of
> the container, but this is not an official registration request:
>
>
>
>     Type name: application
>
>     Subtype name: Vendor Tree - vnd.gov.sk.e-form+xml
>
>     Required parameters:   None.
>
>     Optional parameters:  "charset"
>
>           UTF-8 is required for Slovak national e-forms containers. This
> parameter has identical semantics to the charset parameter of the
> "application/xml" media type as specified in RFC3023.
>
>     Encoding considerations:  Identical to those of "application/xml" as
> described in RFC3023, Section 3.2.
>
>     Security considerations:  Files may contain script and other active
> content.
>
>     Interoperability considerations:
>
>     Published specification:  (only in Slovak language)
> https://lt.justice.gov.sk/Attachment/Priloha_3_e-formulare.pdf?instEID=-1&attEID=63268&docEID=353297&matEID=6842&langEID=1&tStamp=20140304134546663
>
>
>     Applications that use this media type:  Slovak e-government portals
> and (in the future) software from some other vendors.
>
>     Fragment identifier considerations:
>
>     Additional information:
>
>       Deprecated alias names for this type:
>
>       Magic number(s):  As specified for "application/xml" in RFC3023,
> Section 3.2.
>
>       File extension(s):  .xml, .eform
>
>       Macintosh file type code(s):  TEXT
>
>     Person & email address to contact for further information:  National
> agency for network and electronic services  -  or  -  Ministry of
> Finance of the Slovak republic
>
>     Intended usage: COMMON
>
>     (One of COMMON, LIMITED USE, or OBSOLETE.)
>
>     Restrictions on usage:
>
>     (Any restrictions on where the media type can be used go here.)
>
>     Author:
>
>
> ----
>
>
> An incomplete e-forms container structure:
> - mimetype - e-form mimetype
> - META-INF/manifest.xml - references and paths of all of the content in
> the container
> - meta.xml - e-form identification, version, name, short description and
> other metadata
> - schema.xsd - XML Schema for the data.xml
> - data.xml - optional - user data filled in the e-form
> - Content/ - presentation schema and transformation schema of the data
> (primarily XSLT file)
> - Presentation/ - optional - a presentation containing the data filled
> by an user (a result of the XSLT transformation of data.xml)
> - Thumbnails/ - e-form thumbnail
> - attachments.xml - optional - list of attachments
> - Attachments/ - optional - attachments listed in attachments.xml
> - settings.xml - optional - application settings
>
>
> ---
>
>
> Thank you for any help
>
> Stefan Szilva
> Viglasska 7
> Bratislava
> Slovak republic
> szilva@changenet.sk
>
>
>
> _______________________________________________
> media-types mailing list
> media-types@ietf.org
> https://www.ietf.org/mailman/listinfo/media-types
>


From nobody Mon Mar 17 04:23:22 2014
Return-Path: <szilva@changenet.sk>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 81BA71A03D4 for <media-types@ietfa.amsl.com>; Mon, 17 Mar 2014 03:26:12 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 4.338
X-Spam-Level: ****
X-Spam-Status: No, score=4.338 tagged_above=-999 required=5 tests=[BAYES_50=0.8, DEAR_SOMETHING=1.973, J_CHICKENPOX_42=0.6, MIME_8BIT_HEADER=0.3, SPF_SOFTFAIL=0.665] autolearn=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 3DFtytt6vwXa for <media-types@ietfa.amsl.com>; Mon, 17 Mar 2014 03:26:09 -0700 (PDT)
Received: from pechora4.lax.icann.org (pechora4.icann.org [IPv6:2620:0:2d0:201::1:74]) by ietfa.amsl.com (Postfix) with ESMTP id A26021A00A6 for <media-types@ietf.org>; Mon, 17 Mar 2014 03:26:07 -0700 (PDT)
Received: from cn03.changenet.sk (cn03.changenet.sk [86.110.225.135]) by pechora4.lax.icann.org (8.13.8/8.13.8) with ESMTP id s2HAPd2D027615 for <media-types@iana.org>; Mon, 17 Mar 2014 10:25:59 GMT
Received: from localhost (localhost.localdomain [127.0.0.1]) (using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)) (No client certificate requested) (Authenticated sender: szilva) by cn03.changenet.sk (Postfix) with ESMTPSA id 9D4FFA177D; Mon, 17 Mar 2014 11:01:19 +0100 (CET)
Received: from chello089173219155.chello.sk (chello089173219155.chello.sk [89.173.219.155]) by mail.changenet.sk (Horde Framework) with HTTP; Mon, 17 Mar 2014 11:01:18 +0100
Message-ID: <20140317110118.10645ltjtjjp6c0s@mail.changenet.sk>
Date: Mon, 17 Mar 2014 11:01:18 +0100
From: szilva@changenet.sk
To: "Martin J. =?utf-8?b?RMO8cnN0?=" <duerst@it.aoyama.ac.jp>
References: <20140308160850.57913ia6w1v9df0g@mail.changenet.sk> <5322BCCD.8080000@it.aoyama.ac.jp>
In-Reply-To: <5322BCCD.8080000@it.aoyama.ac.jp>
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8; DelSp="Yes"; format="flowed"
Content-Disposition: inline
Content-Transfer-Encoding: 8bit
User-Agent: Internet Messaging Program (IMP) H3 (4.3.7)
X-Virus-Scanned: clamav-milter 0.97.8 at cn03
X-Virus-Status: Clean
X-Greylist: Delayed for 00:24:17 by milter-greylist-4.0 (pechora4.lax.icann.org [192.0.33.74]); Mon, 17 Mar 2014 10:25:59 +0000 (UTC)
Archived-At: http://mailarchive.ietf.org/arch/msg/media-types/igkJB8NtW8PdoBjwzi9exb-X5xc
X-Mailman-Approved-At: Mon, 17 Mar 2014 04:23:21 -0700
Cc: media-types@iana.org
Subject: Re: [media-types] media type registration of the Slovak national standard for e-forms container e-form+xml, e-form+zip
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 17 Mar 2014 10:26:12 -0000

Hello,

thank you for your reply.


1. We need to know an IANA-acceptable subtype name for our e-forms  
container in a very short time. It must be written in the Slovak  
legislation and the deadline for the legislation process is in 1 or 2  
weeks from now.

We need to know, what can be the "IANA-approved designation of the  
producer's name".
After a consultation in one of our working groups we propose the  
acronym "gov.sk" for Slovak national standards for information systems  
of public administration defined by the Ministry of finance of the  
Slovak republic (in a standardization process in the Committee for  
standardization of information systems of public administration and  
its working groups).

Is the acronym "gov.sk" acceptable for IANA?
(As an example, it will be used in the following form:  
application/vnd.gov.sk.some-media-type,  
application/vnd.gov.sk.e-form+xml, etc.)

"gov.sk" is the second-level domain name used by the Slovak government  
organizations, such as www.government.gov.sk, www.finance.gov.sk,  
www.nases.gov.sk, etc.

(The contact person for the Ministry of finance of the Slovak republic  
will be Peter Biro - standard ( at ) mfsr.sk )


2. Is the following media type designation acceptable for IANA? :
"e-form+xml" - application/vnd.gov.sk.e-form+xml
"e-form+zip" - application/vnd.gov.sk.e-form+zip


>> 2. I would like to ask you, what registration tree would you suggest for
>> our national e-forms container. "Vendor tree" or "Personal or Vanity tree"?
>
> If it's (or it's going to be) a national standard, then why not  
> Standards Tree? For more details, please see  
> http://tools.ietf.org/html/rfc6838#section-3.1.


Do you think IESG can accept the Ministry of finance of the Slovak  
republic as a recognized standards-related organization? If you think  
so, how long can such a decision take and what is needed for such an  
approval?

Or you think we should submit our specification to the IESG  
standardization process - i.e. for publication as an RFC?

We do not have any experience with the IETF/IESG standardization  
process and I have doubt if it is realistic to try to register our  
national standard in the Standards Tree. Our specifications are  
currently only in the Slovak language and I don't know if or when we  
will create an adequate English version. Our working groups do not  
have enough time and human resources (most of the work is done  
voluntarily). I'm afraid our standardization effort in the Standards  
Tree can get stuck because of these reasons. We need the media type  
registration in a short time.


Thank you for any help.

Stefan Szilva
Viglasska 7
Bratislava
Slovak republic



Citát "Martin J. Dürst" <duerst@it.aoyama.ac.jp>:

> Hello Stefan,
>
> On 2014/03/09 00:08, szilva@changenet.sk wrote:
>> Dear sirs,
>>
>> I am an idependent member of working groups of the Committee for
>> standardization of information systems of public administration in
>> Slovak republic, which defined a national e-forms container and is
>> working also on another standards. The Committee works under the
>> Ministry of finance of the Slovak republic and its public website is
>> here: http://informatizacia.sk/standards-for-is-pa/4632s
>>
>> The e-forms container will contain all definitions, schemas and
>> transformations needed for a visual and other presentations of an
>> e-government e-form, for filling an e-form, validation of filled data, etc.
>>
>> We would like to register a mimetype for this national e-forms
>> container, but firstly we would like to consult the correct naming.
>>
>>
>> My questions:
>>
>> 1. Is there any experience with registration of media types for national
>> IT or e-government standards? Are there any examples of national
>> standards' subtypes?
>
> I don't remember any such case.
>
>> 2. I would like to ask you, what registration tree would you suggest for
>> our national e-forms container. "Vendor tree" or "Personal or Vanity tree"?
>
> If it's (or it's going to be) a national standard, then why not  
> Standards Tree? For more details, please see  
> http://tools.ietf.org/html/rfc6838#section-3.1.
>
> Regards,   Martin.
>
>> 3. What should be the "IANA-approved designation of the producer's name"
>> in the case of national e-government standard? Are there any written
>> rules for the names?
>>
>>
>> More explanation:
>>
>> The e-forms container will be primarily used by Slovak national
>> e-government portal for publication of all e-forms specifications, but
>> it will be also used by vendors/software producers, who will create and
>> distribute commercial or freeware software for general public and
>> business customers (e.g. economical or accounting software for business,
>> software for filling e-forms, software for e-signing of e-forms, etc).
>> It could be possibly used by other countries or vendors.
>>
>> The container has two equal forms: XML structure or ZIP container.
>> The technical specification of the e-forms container is published as a
>> legislative document - "Edict About Standards for Information Systems of
>> Public Administration" and use of this specification is imposed by the
>> Slovak national legislation. (It is currently available only in Slovak
>> language and the requirements for the e-forms container are defined in
>> this supplement:
>> https://lt.justice.gov.sk/Attachment/Priloha_3_e-formulare.pdf?instEID=-1&attEID=63268&docEID=353297&matEID=6842&langEID=1&tStamp=20140304134546663
>> )
>>
>> The e-forms container is based on existing standards: JAR file format,
>> DublinCore, Open Packaging Format, OpenDocument format, EPUB Open
>> Container Format. The e-forms container also extends these standards for
>> specific e-forms usage.
>>
>>
>> Currently the following nonstandard media types for e-forms containers
>> are used in Slovakia:
>> application/e-form+zip
>> application/x-eform-xml
>>
>> Firstly we thought, we can register something like this:
>> application/vnd.e-form+zip
>> application/vnd.e-form+xml
>> (maybe "e-form" will be only "eform")
>>
>> But if we understand the RFC 6838 correctly, we should create an
>> abbreviation for the organization which is responsible for the Slovak
>> e-government IT standards and this abbreviation must be incorporated in
>> the subtype name.
>>
>> Maybe something like this ? :
>> (note, these are only examples that were not approved or consulted by
>> our Committee)
>>
>> application/vnd.gov.sk.e-form+zip
>> application/vnd.gov.sk.e-form+xml
>>
>> or something like this :
>>
>> application/vnd.finance.gov.sk.e-form+zip
>> application/vnd.finance.gov.sk.e-form+xml
>>
>> Explanation for the "gov.sk": It is the second-level domain name used by
>> the Slovak government organizations, such as www.government.gov.sk,
>> www.finance.gov.sk, www.nases.gov.sk, etc.
>>
>>
>>
>> As an example I filled the registration template for the XML variant of
>> the container, but this is not an official registration request:
>>
>>
>>
>>    Type name: application
>>
>>    Subtype name: Vendor Tree - vnd.gov.sk.e-form+xml
>>
>>    Required parameters:   None.
>>
>>    Optional parameters:  "charset"
>>
>>          UTF-8 is required for Slovak national e-forms containers. This
>> parameter has identical semantics to the charset parameter of the
>> "application/xml" media type as specified in RFC3023.
>>
>>    Encoding considerations:  Identical to those of "application/xml" as
>> described in RFC3023, Section 3.2.
>>
>>    Security considerations:  Files may contain script and other active
>> content.
>>
>>    Interoperability considerations:
>>
>>    Published specification:  (only in Slovak language)
>> https://lt.justice.gov.sk/Attachment/Priloha_3_e-formulare.pdf?instEID=-1&attEID=63268&docEID=353297&matEID=6842&langEID=1&tStamp=20140304134546663
>>
>>
>>    Applications that use this media type:  Slovak e-government portals
>> and (in the future) software from some other vendors.
>>
>>    Fragment identifier considerations:
>>
>>    Additional information:
>>
>>      Deprecated alias names for this type:
>>
>>      Magic number(s):  As specified for "application/xml" in RFC3023,
>> Section 3.2.
>>
>>      File extension(s):  .xml, .eform
>>
>>      Macintosh file type code(s):  TEXT
>>
>>    Person & email address to contact for further information:  National
>> agency for network and electronic services  -  or  -  Ministry of
>> Finance of the Slovak republic
>>
>>    Intended usage: COMMON
>>
>>    (One of COMMON, LIMITED USE, or OBSOLETE.)
>>
>>    Restrictions on usage:
>>
>>    (Any restrictions on where the media type can be used go here.)
>>
>>    Author:
>>
>>
>> ----
>>
>>
>> An incomplete e-forms container structure:
>> - mimetype - e-form mimetype
>> - META-INF/manifest.xml - references and paths of all of the content in
>> the container
>> - meta.xml - e-form identification, version, name, short description and
>> other metadata
>> - schema.xsd - XML Schema for the data.xml
>> - data.xml - optional - user data filled in the e-form
>> - Content/ - presentation schema and transformation schema of the data
>> (primarily XSLT file)
>> - Presentation/ - optional - a presentation containing the data filled
>> by an user (a result of the XSLT transformation of data.xml)
>> - Thumbnails/ - e-form thumbnail
>> - attachments.xml - optional - list of attachments
>> - Attachments/ - optional - attachments listed in attachments.xml
>> - settings.xml - optional - application settings
>>
>>
>> ---
>>
>>
>> Thank you for any help
>>
>> Stefan Szilva
>> Viglasska 7
>> Bratislava
>> Slovak republic
>> szilva@changenet.sk
>>
>>
>>
>> _______________________________________________
>> media-types mailing list
>> media-types@ietf.org
>> https://www.ietf.org/mailman/listinfo/media-types
>>
>




From nobody Tue Mar 18 00:01:38 2014
Return-Path: <duerst@it.aoyama.ac.jp>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 835981A032F for <media-types@ietfa.amsl.com>; Tue, 18 Mar 2014 00:01:36 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 0.973
X-Spam-Level: 
X-Spam-Status: No, score=0.973 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DEAR_SOMETHING=1.973, J_CHICKENPOX_42=0.6, MIME_8BIT_HEADER=0.3] autolearn=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id opRIho4EXtkR for <media-types@ietfa.amsl.com>; Tue, 18 Mar 2014 00:01:34 -0700 (PDT)
Received: from pechora8.dc.icann.org (pechora8.icann.org [IPv6:2620:0:2830:201::1:74]) by ietfa.amsl.com (Postfix) with ESMTP id 630001A0664 for <media-types@ietf.org>; Tue, 18 Mar 2014 00:01:31 -0700 (PDT)
Received: from scspool01-14.scbb.aoyama.ac.jp (scspool.scbb.aoyama.ac.jp [133.2.253.9]) by pechora8.dc.icann.org (8.13.8/8.13.8) with ESMTP id s2I711gI025351 for <media-types@iana.org>; Tue, 18 Mar 2014 07:01:22 GMT
Received: from scintmta01-14.scbb.aoyama.ac.jp (scintmta01-14.scbb.aoyama.ac.jp [133.2.253.64]) by scspool01-14.scbb.aoyama.ac.jp (Postfix) with ESMTP id B44F132E5FE for <media-types@iana.org>; Tue, 18 Mar 2014 13:23:04 +0900 (JST)
Received: from scmse02.scbb.aoyama.ac.jp (scmse02.scbb.aoyama.ac.jp [133.2.253.159]) by scintmta01-14.scbb.aoyama.ac.jp (Postfix) with SMTP id E84B832E02B; Tue, 18 Mar 2014 13:22:40 +0900 (JST)
Received: from (unknown [133.2.206.134]) by scmse02.scbb.aoyama.ac.jp with smtp id 455b_08b0_f1d68aba_ae54_11e3_b299_001e6722eec2; Tue, 18 Mar 2014 13:22:40 +0900
Received: from [IPv6:::1] (unknown [133.2.210.1]) by itmail2.it.aoyama.ac.jp (Postfix) with ESMTP id 63807C042B; Tue, 18 Mar 2014 13:22:40 +0900 (JST)
Message-ID: <5327CA08.5010909@it.aoyama.ac.jp>
Date: Tue, 18 Mar 2014 13:22:32 +0900
From: =?UTF-8?B?Ik1hcnRpbiBKLiBEw7xyc3Qi?= <duerst@it.aoyama.ac.jp>
Organization: Aoyama Gakuin University
User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.3.0
MIME-Version: 1.0
To: szilva@changenet.sk
References: <20140308160850.57913ia6w1v9df0g@mail.changenet.sk> <5322BCCD.8080000@it.aoyama.ac.jp> <20140317110118.10645ltjtjjp6c0s@mail.changenet.sk>
In-Reply-To: <20140317110118.10645ltjtjjp6c0s@mail.changenet.sk>
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: quoted-printable
X-Greylist: Delayed for 01:19:57 by milter-greylist-4.2.3 (pechora8.dc.icann.org [192.0.46.74]); Tue, 18 Mar 2014 07:01:23 +0000 (UTC)
Archived-At: http://mailarchive.ietf.org/arch/msg/media-types/Ny4kmAlDq9_H_0vn7f-AeGSWgao
Cc: media-types@iana.org
Subject: Re: [media-types] media type registration of the Slovak national standard for e-forms container e-form+xml, e-form+zip
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 18 Mar 2014 07:01:36 -0000

Hello Stefan,

This is just my personal opinion, but I would go ahead and submit your=20
registration according to http://tools.ietf.org/html/rfc6838#section-5.2=20
to iana@iana.org or via the form at http://www.iana.org/form/media-types.

(more comments below)

On 2014/03/17 19:01, szilva@changenet.sk wrote:
> Hello,
>
> thank you for your reply.
>
>
> 1. We need to know an IANA-acceptable subtype name for our e-forms
> container in a very short time. It must be written in the Slovak
> legislation and the deadline for the legislation process is in 1 or 2
> weeks from now.
>
> We need to know, what can be the "IANA-approved designation of the
> producer's name".
> After a consultation in one of our working groups we propose the acrony=
m
> "gov.sk" for Slovak national standards for information systems of publi=
c
> administration defined by the Ministry of finance of the Slovak republi=
c
> (in a standardization process in the Committee for standardization of
> information systems of public administration and its working groups).
>
> Is the acronym "gov.sk" acceptable for IANA?
> (As an example, it will be used in the following form:
> application/vnd.gov.sk.some-media-type,
> application/vnd.gov.sk.e-form+xml, etc.)

Looking at examples in the vendor tree, your proposal doesn't look out=20
of line.

> "gov.sk" is the second-level domain name used by the Slovak government
> organizations, such as www.government.gov.sk, www.finance.gov.sk,
> www.nases.gov.sk, etc.
>
> (The contact person for the Ministry of finance of the Slovak republic
> will be Peter Biro - standard ( at ) mfsr.sk )
>
>
> 2. Is the following media type designation acceptable for IANA? :
> "e-form+xml" - application/vnd.gov.sk.e-form+xml
> "e-form+zip" - application/vnd.gov.sk.e-form+zip
>
>
>>> 2. I would like to ask you, what registration tree would you suggest =
for
>>> our national e-forms container. "Vendor tree" or "Personal or Vanity
>>> tree"?

I think vendor tree is definitely better than personal/vanity tree.

>> If it's (or it's going to be) a national standard, then why not
>> Standards Tree? For more details, please see
>> http://tools.ietf.org/html/rfc6838#section-3.1.
>
>
> Do you think IESG can accept the Ministry of finance of the Slovak
> republic as a recognized standards-related organization? If you think
> so, how long can such a decision take and what is needed for such an
> approval?

I'd guess it will take longer than one or two weeks.

> Or you think we should submit our specification to the IESG
> standardization process - i.e. for publication as an RFC?

I don't think that should be necessary.

> We do not have any experience with the IETF/IESG standardization proces=
s
> and I have doubt if it is realistic to try to register our national
> standard in the Standards Tree. Our specifications are currently only i=
n
> the Slovak language and I don't know if or when we will create an
> adequate English version. Our working groups do not have enough time an=
d
> human resources (most of the work is done voluntarily). I'm afraid our
> standardization effort in the Standards Tree can get stuck because of
> these reasons. We need the media type registration in a short time.

Then probably vendor tree is best.

Regards,   Martin.

>
> Thank you for any help.
>
> Stefan Szilva
> Viglasska 7
> Bratislava
> Slovak republic
>
>
>
> Cit=C3=A1t "Martin J. D=C3=BCrst" <duerst@it.aoyama.ac.jp>:
>
>> Hello Stefan,
>>
>> On 2014/03/09 00:08, szilva@changenet.sk wrote:
>>> Dear sirs,
>>>
>>> I am an idependent member of working groups of the Committee for
>>> standardization of information systems of public administration in
>>> Slovak republic, which defined a national e-forms container and is
>>> working also on another standards. The Committee works under the
>>> Ministry of finance of the Slovak republic and its public website is
>>> here: http://informatizacia.sk/standards-for-is-pa/4632s
>>>
>>> The e-forms container will contain all definitions, schemas and
>>> transformations needed for a visual and other presentations of an
>>> e-government e-form, for filling an e-form, validation of filled
>>> data, etc.
>>>
>>> We would like to register a mimetype for this national e-forms
>>> container, but firstly we would like to consult the correct naming.
>>>
>>>
>>> My questions:
>>>
>>> 1. Is there any experience with registration of media types for natio=
nal
>>> IT or e-government standards? Are there any examples of national
>>> standards' subtypes?
>>
>> I don't remember any such case.
>>
>>> 2. I would like to ask you, what registration tree would you suggest =
for
>>> our national e-forms container. "Vendor tree" or "Personal or Vanity
>>> tree"?
>>
>> If it's (or it's going to be) a national standard, then why not
>> Standards Tree? For more details, please see
>> http://tools.ietf.org/html/rfc6838#section-3.1.
>>
>> Regards,   Martin.
>>
>>> 3. What should be the "IANA-approved designation of the producer's na=
me"
>>> in the case of national e-government standard? Are there any written
>>> rules for the names?
>>>
>>>
>>> More explanation:
>>>
>>> The e-forms container will be primarily used by Slovak national
>>> e-government portal for publication of all e-forms specifications, bu=
t
>>> it will be also used by vendors/software producers, who will create a=
nd
>>> distribute commercial or freeware software for general public and
>>> business customers (e.g. economical or accounting software for busine=
ss,
>>> software for filling e-forms, software for e-signing of e-forms, etc)=
.
>>> It could be possibly used by other countries or vendors.
>>>
>>> The container has two equal forms: XML structure or ZIP container.
>>> The technical specification of the e-forms container is published as =
a
>>> legislative document - "Edict About Standards for Information Systems=
 of
>>> Public Administration" and use of this specification is imposed by th=
e
>>> Slovak national legislation. (It is currently available only in Slova=
k
>>> language and the requirements for the e-forms container are defined i=
n
>>> this supplement:
>>> https://lt.justice.gov.sk/Attachment/Priloha_3_e-formulare.pdf?instEI=
D=3D-1&attEID=3D63268&docEID=3D353297&matEID=3D6842&langEID=3D1&tStamp=3D=
20140304134546663
>>>
>>> )
>>>
>>> The e-forms container is based on existing standards: JAR file format=
,
>>> DublinCore, Open Packaging Format, OpenDocument format, EPUB Open
>>> Container Format. The e-forms container also extends these standards =
for
>>> specific e-forms usage.
>>>
>>>
>>> Currently the following nonstandard media types for e-forms container=
s
>>> are used in Slovakia:
>>> application/e-form+zip
>>> application/x-eform-xml
>>>
>>> Firstly we thought, we can register something like this:
>>> application/vnd.e-form+zip
>>> application/vnd.e-form+xml
>>> (maybe "e-form" will be only "eform")
>>>
>>> But if we understand the RFC 6838 correctly, we should create an
>>> abbreviation for the organization which is responsible for the Slovak
>>> e-government IT standards and this abbreviation must be incorporated =
in
>>> the subtype name.
>>>
>>> Maybe something like this ? :
>>> (note, these are only examples that were not approved or consulted by
>>> our Committee)
>>>
>>> application/vnd.gov.sk.e-form+zip
>>> application/vnd.gov.sk.e-form+xml
>>>
>>> or something like this :
>>>
>>> application/vnd.finance.gov.sk.e-form+zip
>>> application/vnd.finance.gov.sk.e-form+xml
>>>
>>> Explanation for the "gov.sk": It is the second-level domain name used=
 by
>>> the Slovak government organizations, such as www.government.gov.sk,
>>> www.finance.gov.sk, www.nases.gov.sk, etc.
>>>
>>>
>>>
>>> As an example I filled the registration template for the XML variant =
of
>>> the container, but this is not an official registration request:
>>>
>>>
>>>
>>>    Type name: application
>>>
>>>    Subtype name: Vendor Tree - vnd.gov.sk.e-form+xml
>>>
>>>    Required parameters:   None.
>>>
>>>    Optional parameters:  "charset"
>>>
>>>          UTF-8 is required for Slovak national e-forms containers. Th=
is
>>> parameter has identical semantics to the charset parameter of the
>>> "application/xml" media type as specified in RFC3023.
>>>
>>>    Encoding considerations:  Identical to those of "application/xml" =
as
>>> described in RFC3023, Section 3.2.
>>>
>>>    Security considerations:  Files may contain script and other activ=
e
>>> content.
>>>
>>>    Interoperability considerations:
>>>
>>>    Published specification:  (only in Slovak language)
>>> https://lt.justice.gov.sk/Attachment/Priloha_3_e-formulare.pdf?instEI=
D=3D-1&attEID=3D63268&docEID=3D353297&matEID=3D6842&langEID=3D1&tStamp=3D=
20140304134546663
>>>
>>>
>>>
>>>    Applications that use this media type:  Slovak e-government portal=
s
>>> and (in the future) software from some other vendors.
>>>
>>>    Fragment identifier considerations:
>>>
>>>    Additional information:
>>>
>>>      Deprecated alias names for this type:
>>>
>>>      Magic number(s):  As specified for "application/xml" in RFC3023,
>>> Section 3.2.
>>>
>>>      File extension(s):  .xml, .eform
>>>
>>>      Macintosh file type code(s):  TEXT
>>>
>>>    Person & email address to contact for further information:  Nation=
al
>>> agency for network and electronic services  -  or  -  Ministry of
>>> Finance of the Slovak republic
>>>
>>>    Intended usage: COMMON
>>>
>>>    (One of COMMON, LIMITED USE, or OBSOLETE.)
>>>
>>>    Restrictions on usage:
>>>
>>>    (Any restrictions on where the media type can be used go here.)
>>>
>>>    Author:
>>>
>>>
>>> ----
>>>
>>>
>>> An incomplete e-forms container structure:
>>> - mimetype - e-form mimetype
>>> - META-INF/manifest.xml - references and paths of all of the content =
in
>>> the container
>>> - meta.xml - e-form identification, version, name, short description =
and
>>> other metadata
>>> - schema.xsd - XML Schema for the data.xml
>>> - data.xml - optional - user data filled in the e-form
>>> - Content/ - presentation schema and transformation schema of the dat=
a
>>> (primarily XSLT file)
>>> - Presentation/ - optional - a presentation containing the data fille=
d
>>> by an user (a result of the XSLT transformation of data.xml)
>>> - Thumbnails/ - e-form thumbnail
>>> - attachments.xml - optional - list of attachments
>>> - Attachments/ - optional - attachments listed in attachments.xml
>>> - settings.xml - optional - application settings
>>>
>>>
>>> ---
>>>
>>>
>>> Thank you for any help
>>>
>>> Stefan Szilva
>>> Viglasska 7
>>> Bratislava
>>> Slovak republic
>>> szilva@changenet.sk
>>>
>>>
>>>
>>> _______________________________________________
>>> media-types mailing list
>>> media-types@ietf.org
>>> https://www.ietf.org/mailman/listinfo/media-types
>>>
>>
>
>
>
> _______________________________________________
> media-types mailing list
> media-types@ietf.org
> https://www.ietf.org/mailman/listinfo/media-types


From nobody Sun Mar 23 09:53:45 2014
Return-Path: <sm@elandsys.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 5C6B51A08E1 for <media-types@ietfa.amsl.com>; Fri, 21 Mar 2014 18:04:34 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 2.001
X-Spam-Level: **
X-Spam-Status: No, score=2.001 tagged_above=-999 required=5 tests=[BAYES_40=-0.001, DATE_IN_PAST_03_06=1.592, DKIM_SIGNED=0.1, MIME_8BIT_HEADER=0.3, T_DKIM_INVALID=0.01] autolearn=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 09vPJEXVqqeG for <media-types@ietfa.amsl.com>; Fri, 21 Mar 2014 18:04:33 -0700 (PDT)
Received: from pechora5.dc.icann.org (pechora5.icann.org [IPv6:2620:0:2830:201::1:71]) by ietfa.amsl.com (Postfix) with ESMTP id E709B1A08C7 for <media-types@ietf.org>; Fri, 21 Mar 2014 18:04:31 -0700 (PDT)
Received: from mx.ipv6.elandsys.com (mx.ipv6.elandsys.com [IPv6:2001:470:f329:1::1]) by pechora5.dc.icann.org (8.13.8/8.13.8) with ESMTP id s2M141rN032196 for <media-types@iana.org>; Sat, 22 Mar 2014 01:04:22 GMT
Received: from SUBMAN.elandsys.com ([197.224.143.85]) (authenticated bits=0) by mx.elandsys.com (8.14.5/8.14.5) with ESMTP id s2M0rTwe028937 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=NO); Fri, 21 Mar 2014 17:53:40 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=opendkim.org; s=mail2010; t=1395449623; bh=d7hW5/kXVkVP5ep+fww6+XQ+/ObxeHzhR9P6e/YS5y4=; h=Date:To:From:Subject:Cc:In-Reply-To:References; b=SZrGoJerjYSGd26UgilJVnXL3FIlGImvak6pJNUcnobl3QiEaaVfu+qbKunM85pUk 7IoNV2EdYyGTgT5Qz40LpcZr6hsw77dPYqU3WcJidThiktcKzvzs3YOZcT+D/5WYFf q9u4V2Yyrz6GI1gI12jznleIAYHT+a35wQLpTtJ0=
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=elandsys.com; s=mail; t=1395449623; i=@elandsys.com; bh=d7hW5/kXVkVP5ep+fww6+XQ+/ObxeHzhR9P6e/YS5y4=; h=Date:To:From:Subject:Cc:In-Reply-To:References; b=gEjfE0XsQ8IkpYgnMcU+byV9GdzW3BpJY+9bf+NMAHXnIBgOOkMRXnU4Y3fmeub83 Uhwe3p8u4J/5Rin4BJONTZiUIhMHfT4Mtu560g1zVrIr4VF7o0ly+LP8+sYTw7eWTP Zmjw4CFHrJF0nnjNB/P7MqDBh7eNt/zSZY20bBOA=
Message-Id: <6.2.5.6.2.20140321141522.0d3b6180@resistor.net>
X-Mailer: QUALCOMM Windows Eudora Version 6.2.5.6
Date: Fri, 21 Mar 2014 14:30:00 -0700
To: szilva@changenet.sk, =?iso-8859-1?Q?=22Martin_J=2E_D=FCrst=22?= <duerst@it.aoyama.ac.jp>
From: S Moonesamy <sm+ietf@elandsys.com>
In-Reply-To: <20140317110118.10645ltjtjjp6c0s@mail.changenet.sk>
References: <20140308160850.57913ia6w1v9df0g@mail.changenet.sk> <5322BCCD.8080000@it.aoyama.ac.jp> <20140317110118.10645ltjtjjp6c0s@mail.changenet.sk>
Mime-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"; format=flowed
Content-Transfer-Encoding: quoted-printable
X-Greylist: Delayed for 00:10:09 by milter-greylist-4.0 (pechora5.dc.icann.org [IPv6:2620:0:2830:201::1:71]); Sat, 22 Mar 2014 01:04:22 +0000 (UTC)
Archived-At: http://mailarchive.ietf.org/arch/msg/media-types/-3PwUf-MmoN9xmYbyD8QmG1GrmI
X-Mailman-Approved-At: Sun, 23 Mar 2014 09:53:43 -0700
Cc: media-types@iana.org
Subject: Re: [media-types] media type registration of the Slovak national standard for e-forms container e-form+xml, e-form+zip
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sat, 22 Mar 2014 01:04:34 -0000

Hi Stefan,
At 03:01 17-03-2014, szilva@changenet.sk wrote:
>Do you think IESG can accept the Ministry of finance of the Slovak
>republic as a recognized standards-related organization? If you think
>so, how long can such a decision take and what is needed for such an
>approval?

Would it be possible to do it through S=DATN?

>Or you think we should submit our specification to the IESG
>standardization process - i.e. for publication as an RFC?
>
>We do not have any experience with the IETF/IESG standardization
>process and I have doubt if it is realistic to try to register our
>national standard in the Standards Tree. Our specifications are
>currently only in the Slovak language and I don't know if or when we
>will create an adequate English version. Our working groups do not
>have enough time and human resources (most of the work is done
>voluntarily). I'm afraid our standardization effort in the Standards
>Tree can get stuck because of these reasons. We need the media type
>registration in a short time.

It would help to have a stable specification.  It does not have to be a RFC.

It is better to do what is easier for you=20
especially if there isn't enough human=20
resources.  Please ask questions if you have any=20
doubt about how the standardization process works.

Regards,
S. Moonesamy=20


From sujoy.gupta@appdirect.com  Mon Mar 24 14:56:24 2014
Return-Path: <sujoy.gupta@appdirect.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id B910E1A02A2 for <media-types@ietfa.amsl.com>; Mon, 24 Mar 2014 14:56:24 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 2.088
X-Spam-Level: **
X-Spam-Status: No, score=2.088 tagged_above=-999 required=5 tests=[BAYES_50=0.8, FM_FORGED_GMAIL=0.622, HTML_MESSAGE=0.001, SPF_SOFTFAIL=0.665] autolearn=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id RZwt0lOd-_f0 for <media-types@ietfa.amsl.com>; Mon, 24 Mar 2014 14:56:23 -0700 (PDT)
Received: from pechora7.dc.icann.org (pechora7.icann.org [IPv6:2620:0:2830:201::1:73]) by ietfa.amsl.com (Postfix) with ESMTP id 99C351A0295 for <media-types@ietf.org>; Mon, 24 Mar 2014 14:56:23 -0700 (PDT)
Received: from mail-oa0-f43.google.com (mail-oa0-f43.google.com [209.85.219.43]) by pechora7.dc.icann.org (8.13.8/8.13.8) with ESMTP id s2OLu2Ur016581 for <ietf-types@iana.org>; Mon, 24 Mar 2014 21:56:22 GMT
Received: by mail-oa0-f43.google.com with SMTP id eb12so6660908oac.30 for <ietf-types@iana.org>; Mon, 24 Mar 2014 14:56:02 -0700 (PDT)
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20130820; h=x-gm-message-state:mime-version:date:message-id:subject:from:to :content-type; bh=UNiD0m9Xp6L74JulJqC6fzLa2W4O1NdA4W+/xrJv5MM=; b=OPuirhNjDcDR+y/FyYdkBnoGcVHMvW8fGWzmDeOXp1TC4b+xnz807gEYrdBKhu6dNT ilZODClMjj9rHeZAOK41yhimss9kbiX5fr1SXGxK7Oq2djV5Qnyj/qVRiJLntPSKbR7i dcVNzzRvtWHDJRkOH5Q0ohRSo7vQL+CuzomhzJurEoYWu0mMKQqbRWU58v5jKCIXWKhG urQkGnAEo/FhyQdjG+I6myfIxy6t+wdGsrXR0idJ6Lvb4CjhuR/SSCKscJokFO36oy45 elb4013SiH0TM9eD8KFcefm1m2lZC/EobyCsuTJW5C4/LI8XI+6SgeIk1v138e9ArVSB 12eA==
X-Gm-Message-State: ALoCoQlpdX0MIFP6VCZOgl7ZXGhkH75jCvcVxMPBTrNP5cn1nlFlRJ42jiWsgxwzE/c6ZgwBdzo5
MIME-Version: 1.0
X-Received: by 10.182.142.229 with SMTP id rz5mr54762990obb.12.1395698162178;  Mon, 24 Mar 2014 14:56:02 -0700 (PDT)
Received: by 10.182.72.66 with HTTP; Mon, 24 Mar 2014 14:56:02 -0700 (PDT)
Date: Mon, 24 Mar 2014 14:56:02 -0700
Message-ID: <CAH4xyXOLeCY1edUTKXA6o2aTEkxKi9_fxEhbH_ec8osv2UAxjg@mail.gmail.com>
From: Sujoy Gupta <sujoy.gupta@appdirect.com>
To: ietf-types@iana.org
Content-Type: multipart/alternative; boundary=001a11c362e62c511604f5614df2
X-Greylist: IP, sender and recipient auto-whitelisted, not delayed by milter-greylist-4.2.3 (pechora7.dc.icann.org [192.0.46.73]); Mon, 24 Mar 2014 21:56:22 +0000 (UTC)
Archived-At: http://mailarchive.ietf.org/arch/msg/media-types/kex1NtEIyjSV-rIJD1SNID64fDc
X-Mailman-Approved-At: Tue, 25 Mar 2014 19:28:56 -0700
Subject: [media-types] Registering our company in the Vendor tree for use in Accepts Header
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 24 Mar 2014 22:00:06 -0000

--001a11c362e62c511604f5614df2
Content-Type: text/plain; charset=ISO-8859-1

Hello,

Pursuant to http://tools.ietf.org/html/rfc4288, I am interested in
registering "appdirect" in the Vendor tree. This is so that we can use
headers such as Content-Type: application/vnd.appdirect.acme.v2+json
without conflict with existing vendors.

Looking forward to questions or comments.

Thanks,
Sujoy Gupta
Principal Engineer, AppDirect Inc.

--001a11c362e62c511604f5614df2
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr">Hello,<div><br></div><div>Pursuant to=A0<a href=3D"http://=
tools.ietf.org/html/rfc4288">http://tools.ietf.org/html/rfc4288</a>, I am i=
nterested in registering &quot;appdirect&quot; in the Vendor tree. This is =
so that we can use headers such as Content-Type: application/vnd.appdirect.=
acme.v2+json without conflict with existing vendors.</div>
<div><br></div><div>Looking forward to questions or comments.</div><div><br=
></div><div>Thanks,</div><div>Sujoy Gupta</div><div>Principal Engineer, App=
Direct Inc.</div></div>

--001a11c362e62c511604f5614df2--


From nobody Tue Mar 25 22:53:54 2014
Return-Path: <duerst@it.aoyama.ac.jp>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id A64881A00C2 for <media-types@ietfa.amsl.com>; Tue, 25 Mar 2014 22:16:22 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 1.1
X-Spam-Level: *
X-Spam-Status: No, score=1.1 tagged_above=-999 required=5 tests=[BAYES_50=0.8,  MIME_8BIT_HEADER=0.3] autolearn=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 2kFXXk6YtgpP for <media-types@ietfa.amsl.com>; Tue, 25 Mar 2014 22:16:21 -0700 (PDT)
Received: from pechora4.lax.icann.org (pechora4.icann.org [IPv6:2620:0:2d0:201::1:74]) by ietfa.amsl.com (Postfix) with ESMTP id 10CFD1A00C0 for <media-types@ietf.org>; Tue, 25 Mar 2014 22:16:20 -0700 (PDT)
Received: from scspool01-14.scbb.aoyama.ac.jp (scspool.scbb.aoyama.ac.jp [133.2.253.9]) by pechora4.lax.icann.org (8.13.8/8.13.8) with ESMTP id s2Q5FwXY010232 for <ietf-types@iana.org>; Wed, 26 Mar 2014 05:16:19 GMT
Received: from scintmta01-14.scbb.aoyama.ac.jp (scintmta.scbb.aoyama.ac.jp [133.2.253.64]) by scspool01-14.scbb.aoyama.ac.jp (Postfix) with ESMTP id AD79732E59A for <ietf-types@iana.org>; Wed, 26 Mar 2014 11:39:48 +0900 (JST)
Received: from scmse02.scbb.aoyama.ac.jp (scmse02.scbb.aoyama.ac.jp [133.2.253.159]) by scintmta01-14.scbb.aoyama.ac.jp (Postfix) with SMTP id 3DBB132E54A; Wed, 26 Mar 2014 11:39:48 +0900 (JST)
Received: from (unknown [133.2.206.134]) by scmse02.scbb.aoyama.ac.jp with smtp id 071e_0838_e5f0aeba_b48f_11e3_9b01_001e6722eec2; Wed, 26 Mar 2014 11:39:47 +0900
Received: from [IPv6:::1] (unknown [133.2.210.1]) by itmail2.it.aoyama.ac.jp (Postfix) with ESMTP id C7099BF544; Wed, 26 Mar 2014 11:39:47 +0900 (JST)
Message-ID: <53323DED.9070400@it.aoyama.ac.jp>
Date: Wed, 26 Mar 2014 11:39:41 +0900
From: =?UTF-8?B?Ik1hcnRpbiBKLiBEw7xyc3Qi?= <duerst@it.aoyama.ac.jp>
Organization: Aoyama Gakuin University
User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.4.0
MIME-Version: 1.0
To: Sujoy Gupta <sujoy.gupta@appdirect.com>, ietf-types@iana.org
References: <CAH4xyXOLeCY1edUTKXA6o2aTEkxKi9_fxEhbH_ec8osv2UAxjg@mail.gmail.com>
In-Reply-To: <CAH4xyXOLeCY1edUTKXA6o2aTEkxKi9_fxEhbH_ec8osv2UAxjg@mail.gmail.com>
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 7bit
X-Greylist: IP, sender and recipient auto-whitelisted, not delayed by milter-greylist-4.0 (pechora4.lax.icann.org [192.0.33.74]); Wed, 26 Mar 2014 05:16:19 +0000 (UTC)
Archived-At: http://mailarchive.ietf.org/arch/msg/media-types/1t7VC6GzfCSIADK0fnexy3s2RDA
X-Mailman-Approved-At: Tue, 25 Mar 2014 22:53:53 -0700
Subject: Re: [media-types] Registering our company in the Vendor tree for use in Accepts Header
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 26 Mar 2014 05:16:22 -0000

On 2014/03/25 06:56, Sujoy Gupta wrote:
> Hello,
>
> Pursuant to http://tools.ietf.org/html/rfc4288, I am interested in
> registering "appdirect" in the Vendor tree. This is so that we can use
> headers such as Content-Type: application/vnd.appdirect.acme.v2+json
> without conflict with existing vendors.

As far as I understand, there are no registrations for vendors, just for 
specific types.

Regards,   Martin.


From nobody Wed Mar 26 07:22:06 2014
Return-Path: <tony@att.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 45C0D1A0095 for <media-types@ietfa.amsl.com>; Wed, 26 Mar 2014 05:28:50 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -0.001
X-Spam-Level: 
X-Spam-Status: No, score=-0.001 tagged_above=-999 required=5 tests=[BAYES_40=-0.001] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id MDUlpgg_VtTM for <media-types@ietfa.amsl.com>; Wed, 26 Mar 2014 05:28:48 -0700 (PDT)
Received: from pechora3.lax.icann.org (pechora3.icann.org [IPv6:2620:0:2d0:201::1:73]) by ietfa.amsl.com (Postfix) with ESMTP id 890C61A0084 for <media-types@ietf.org>; Wed, 26 Mar 2014 05:28:48 -0700 (PDT)
Received: from egssmtp01.att.com (egssmtp01.att.com [144.160.112.12]) by pechora3.lax.icann.org (8.13.8/8.13.8) with ESMTP id s2QCSQO2013295 for <ietf-types@iana.org>; Wed, 26 Mar 2014 12:28:47 GMT
Received: from mailgw1.maillennium.att.com (maillennium.att.com [135.25.114.99]) by egssmtp01.att.com ( egs 8.14.5/8.14.5) with ESMTP id s2QCSQ2f020244 for <ietf-types@iana.org>; Wed, 26 Mar 2014 07:28:26 -0500
Received: from vpn-135-70-103-88.vpn.swst.att.com ([135.70.103.88]) by maillennium.att.com (mailgw1) with ESMTP id <20140326122825gw100j0cc6e>; Wed, 26 Mar 2014 12:28:25 +0000
X-Originating-IP: [135.70.103.88]
Message-ID: <5332C7E9.5070402@att.com>
Date: Wed, 26 Mar 2014 08:28:25 -0400
From: Tony Hansen <tony@att.com>
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:24.0) Gecko/20100101 Thunderbird/24.3.0
MIME-Version: 1.0
To: Sujoy Gupta <sujoy.gupta@appdirect.com>, ietf-types@iana.org
References: <CAH4xyXOLeCY1edUTKXA6o2aTEkxKi9_fxEhbH_ec8osv2UAxjg@mail.gmail.com> <53323DED.9070400@it.aoyama.ac.jp>
In-Reply-To: <53323DED.9070400@it.aoyama.ac.jp>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
X-Greylist: IP, sender and recipient auto-whitelisted, not delayed by milter-greylist-4.0 (pechora3.lax.icann.org [192.0.33.73]); Wed, 26 Mar 2014 12:28:47 +0000 (UTC)
Archived-At: http://mailarchive.ietf.org/arch/msg/media-types/8lMOdBXUSXwEztHN1Twwg5hji8s
X-Mailman-Approved-At: Wed, 26 Mar 2014 07:22:03 -0700
Subject: Re: [media-types] Registering our company in the Vendor tree for use in Accepts Header
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 26 Mar 2014 12:28:50 -0000

On 3/25/14, 10:39 PM, "Martin J. Dürst" wrote:
> On 2014/03/25 06:56, Sujoy Gupta wrote:
>> Hello,
>>
>> Pursuant to http://tools.ietf.org/html/rfc4288, I am interested in
>> registering "appdirect" in the Vendor tree. This is so that we can use
>> headers such as Content-Type: application/vnd.appdirect.acme.v2+json
>> without conflict with existing vendors.
>
> As far as I understand, there are no registrations for vendors, just 
> for specific types.

To put it another way, Sujoy, when you have a specific media type to 
register, such as application/vnd.appdirect.acme.v2+json, THAT is when 
you follow the process from section 3.2 in RFC 4288.

     Tony Hansen

