
From nobody Thu Mar 15 18:29:02 2018
Return-Path: <bradnelson@google.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 8144B127873 for <media-types@ietfa.amsl.com>; Thu, 15 Mar 2018 18:29:00 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.7
X-Spam-Level: 
X-Spam-Status: No, score=-2.7 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_LOW=-0.7, SPF_PASS=-0.001, T_FILL_THIS_FORM_SHORT=0.01, T_RP_MATCHES_RCVD=-0.01] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=google.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id B06_1dRWrivF for <media-types@ietfa.amsl.com>; Thu, 15 Mar 2018 18:28:58 -0700 (PDT)
Received: from mail-it0-x22a.google.com (mail-it0-x22a.google.com [IPv6:2607:f8b0:4001:c0b::22a]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 1F5201201F8 for <media-types@ietf.org>; Thu, 15 Mar 2018 18:28:58 -0700 (PDT)
Received: by mail-it0-x22a.google.com with SMTP id w3-v6so200223itc.4 for <media-types@ietf.org>; Thu, 15 Mar 2018 18:28:58 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=20161025; h=mime-version:from:date:message-id:subject:to; bh=mO9rkKETZsDRM3BEs+vAPaoUNOOhe31sIHpjcam5lNY=; b=cYUoTIpvdiUmEoZ+fxXX6Ofk7a/tBtycUVGEdpg/JiCND4n9n51klGJYGHT2desWcP RsPquEjenqJ2ee+qA7oIFRkVgAC9HwkCY0I5njutp04MMLHxC3dKUqf+BnCXUmCPltQR OXivoShm0368b1gDqh/7o26qjG52b8KR6nEcHCMwpxQpw7NL+DK1d9Megb59iF4eQmiJ yQK7cbuPWVBpHDFtc52wLgmEUxd21XM4sNe1pfNEhWwACDo3wjo/CcReIHYFVnR5pjuP B6ulKBoR+yMQHZs58RnBcpvOXRMtD387dXaTYmily4nNFPQTbiC4+GUv1H/QN37MFBV4 bHbw==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:from:date:message-id:subject:to; bh=mO9rkKETZsDRM3BEs+vAPaoUNOOhe31sIHpjcam5lNY=; b=Lp6GO7E345cyCXPR3NVI04p//mKtO8hv6iuNXwWgS7Az4IScahdNVlefCcNQHvkDl/ 6t+j08Zsp6vaj4d3K0bMg0HxmVAbrqhv4flkj49OAkB5N97sATlrAA30bY6Mik6dOl5w UI8snu4t5b30TMcB0SmuTNnvt1gHZjlGY85GeoWdJyXyZhkrqGMALKkMwpps3eNZ8hge fT0x8oFP9KLM5b0+0Py8CtV9LcU/AimaVkRrvp3HukYDVFYxpueqc6cwrGjPH4crrCcr R9T7vpggTnbigrMCVEj/cbsGQxtlY3/QGmlXi0nIyn550CRS0Nhoj8icXJ9CNJ81tpXh uS/w==
X-Gm-Message-State: AElRT7GSU7OFNu38gZAK1XoYkgDmaIG2M/qcw3KqnZuOr3u/9TYlVduf +Ns5VJXumY7dy7iVwmtRP3SCiRd/MB4K0dAkPVJcxM9+
X-Google-Smtp-Source: AG47ELvv6Hd7edwLf3bFelanR9MfOJJOrkN7b0oAgR8zRq4j3wYKz+tepxff2f1uuNvUHZ1T+wf4ruoOth3wz/YfgZk=
X-Received: by 2002:a24:5b04:: with SMTP id g4-v6mr387583itb.68.1521163736718;  Thu, 15 Mar 2018 18:28:56 -0700 (PDT)
MIME-Version: 1.0
From: Bradley Nelson <bradnelson@google.com>
Date: Fri, 16 Mar 2018 01:28:44 +0000
Message-ID: <CAG=ZA4dFzSJLYNW9jg2A2MEZSnhh5Md+QkVHFJFYt-qoiKoLWg@mail.gmail.com>
To: media-types@ietf.org
Content-Type: multipart/alternative; boundary="0000000000002ce00705677d883c"
Archived-At: <https://mailarchive.ietf.org/arch/msg/media-types/_Rbp86umiuwstvavBsOpm3ZsWpc>
Subject: [media-types] Media Types Registration for application/wasm
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 16 Mar 2018 01:29:00 -0000

--0000000000002ce00705677d883c
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

Hi Media Types,

I'd like to file the follow mime type request:

Your Full Name
Required

*Bradley Nelson*

Your E-mail
Required

*bradnelson@google.com <bradnelson@google.com>*

Please read the following questions carefully and provide complete answers.
Write "N/A" for mandatory answers that are not applicable.

Type Name
Required
What is the media type name?
See RFC 2046 =C2=A73, and RFC 2077.
*application*

Subtype Name
Required
What is the media subtype name?
*wasm*

Review the existing subtype names. See also RFC 2046, and RFC 6838, =C2=A73=
 and
=C2=A74.2. Note: Registrations in the standards tree must be approved by th=
e
IESG or must correspond to a formal publication by a recognized standards
body.

Required Parameters
Required
Describe the required parameters.
*N/A*

See RFC 2046 =C2=A71, and RFC 6838 =C2=A74.3.
Optional Parameters
Required
Describe the optional parameters.

*N/A*

See RFC 2046 =C2=A71, and RFC 6838 =C2=A74.3.
Encoding Considerations
Required
 7-bit text
 8-bit text (this media type may require encoding on transports not capable
of handling 8-bit text)
* binary (this media type may require encoding on transports not capable of
handling binary)*
 framed (transport must provide framing information)

Additional notes (optional):
*N/A*

See RFC 2045 =C2=A76, and RFC 6838 =C2=A74.8.
Security Considerations
Required
Provide a discussion of the security considerations.

*The WebAssembly.compileStreaming and WebAssembly.instantiateStreaming APIs
enforce that the mime type is application/wasm so that we can ensure
non-wasm content isn't used to create modules.*

See RFC 6838 =C2=A74.6
Interoperability Considerations
Required
Provide a discussion of the interoperability considerations.

*The mime type is currently actively used in browsers that have shipped the
streaming APIs (Chrome, Firefox).*

See RFC 6838 =C2=A74.5
Published specification
Required
Provide references to the published specification.


*https://www.w3.org/TR/wasm-web-api-1/
<https://www.w3.org/TR/wasm-web-api-1/>*

See RFC 6838 =C2=A74.10
Application Usage
Required
Describe applications which use this media type.


*Ideally all applications that use WebAssembly (games, rich media, code
ported from languages other than JS, codecs, simulations) will use this
mime type.*

See RFC 6838 =C2=A74.5
Fragment Identifier Considerations
*Disallowed.*

See RFC 6838 =C2=A74.11
Restrictions on Usage
*N/A*

See RFC 6838 =C2=A74.9
Provisional Registrations
Standards tree applications only.

*Wasm has it's first public working draft but no final W3C REC yet.*
*I assume that means we need this?*

See RFC 6838 =C2=A75.2.1
Additional Information
Required
See RFC 6838, =C2=A74.12

Deprecated alias names for this type
*N/A*

 This field is required.
Magic number(s)
*0x6d736100 (i.e., '\0asm')*

This field is required.
File extension(s)

*.wasm*

Macintosh File Type Code(s)
*N/A*

 This field is required.
Object Identifier(s) or OID(s) =E2=80=94 See RFC 1494
*N/A*

This field is required.
Intended Usage
Required
*This mime type would be used when applications include binary WebAssembly
modules for use as part of the application.*

Other Information & Comments

Contact Person
Provide the contact for further information. See RFC 6838 =C2=A75.5.

Contact Name
*Brad Nelson*

Contact Email Address

*bradnelson@google.com <bradnelson@google.com>*

Author/Change Controller (for standards tree registrations, this is
typically the standards body)
*WebAssembly Working Group*

--0000000000002ce00705677d883c
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr">Hi Media Types,<div><br></div><div>I&#39;d like to file th=
e follow mime type request:</div><div><br></div><div><div>Your Full Name<br=
></div><div>Required</div><div><b>Bradley Nelson<br></b></div><div><br></di=
v><div>Your E-mail</div><div>Required</div><div><b><a href=3D"mailto:bradne=
lson@google.com">bradnelson@google.com</a><br></b></div><div><br></div><div=
>Please read the following questions carefully and provide complete answers=
. Write &quot;N/A&quot; for mandatory answers that are not applicable.</div=
><div><br></div><div>Type Name</div><div>Required</div><div>What is the med=
ia type name?</div><div>See RFC 2046 =C2=A73, and RFC 2077.<br></div><div><=
b>application</b></div><div><br></div><div>Subtype Name</div><div>Required<=
/div><div>What is the media subtype name?</div><div><u><b>wasm</b></u></div=
><div><br></div><div>Review the existing subtype names. See also RFC 2046, =
and RFC 6838, =C2=A73 and =C2=A74.2. Note: Registrations in the standards t=
ree must be approved by the IESG or must correspond to a formal publication=
 by a recognized standards body.<br></div><div><br></div><div>Required Para=
meters</div><div>Required</div><div>Describe the required parameters.</div>=
<div><b>N/A</b></div><div><br></div><div>See RFC 2046 =C2=A71, and RFC 6838=
 =C2=A74.3.</div><div>Optional Parameters<br></div><div>Required</div><div>=
Describe the optional parameters.</div><div><b>N/A<br></b></div><div><br></=
div><div>See RFC 2046 =C2=A71, and RFC 6838 =C2=A74.3.</div><div>Encoding C=
onsiderations</div><div>Required</div><div>=C2=A07-bit text</div><div>=C2=
=A08-bit text (this media type may require encoding on transports not capab=
le of handling 8-bit text)</div><div><b>=C2=A0binary (this media type may r=
equire encoding on transports not capable of handling binary)</b></div><div=
>=C2=A0framed (transport must provide framing information)</div><div><br></=
div><div>Additional notes (optional):</div><div><b>N/A</b></div><div><br></=
div><div>See RFC 2045 =C2=A76, and RFC 6838 =C2=A74.8.</div><div>Security C=
onsiderations</div><div>Required</div><div>Provide a discussion of the secu=
rity considerations.</div><div><b>The WebAssembly.compileStreaming and WebA=
ssembly.instantiateStreaming APIs enforce that the mime type is application=
/wasm so that we can ensure non-wasm content isn&#39;t used to create modul=
es.<br></b></div><div><br></div><div>See RFC 6838 =C2=A74.6</div><div>Inter=
operability Considerations</div><div>Required</div><div>Provide a discussio=
n of the interoperability considerations.</div><div><br></div><div><b>The m=
ime type is currently actively used in browsers that have shipped the strea=
ming APIs (Chrome, Firefox).</b></div><div><br></div><div>See RFC 6838 =C2=
=A74.5</div><div>Published specification<br></div><div>Required</div><div>P=
rovide references to the published specification.</div><div><br></div><div>=
<b><a href=3D"https://www.w3.org/TR/wasm-web-api-1/">https://www.w3.org/TR/=
wasm-web-api-1/</a><br></b></div><div><br></div><div>See RFC 6838 =C2=A74.1=
0</div><div>Application Usage<br></div><div>Required</div><div>Describe app=
lications which use this media type.</div><div><br></div><div><b>Ideally al=
l applications that use WebAssembly (games, rich media, code ported from la=
nguages other than JS, codecs, simulations) will use this mime type.<br></b=
></div><div><br></div><div>See RFC 6838 =C2=A74.5</div><div>Fragment Identi=
fier Considerations<br></div><div><b>Disallowed.</b></div><div><br></div><d=
iv>See RFC 6838 =C2=A74.11</div><div>Restrictions on Usage</div><div><b>N/A=
</b><br></div><div><br></div><div>See RFC 6838 =C2=A74.9</div><div>Provisio=
nal Registrations<br></div><div>Standards tree applications only.</div><div=
><b>Wasm has it&#39;s first public working draft but no final W3C REC yet.<=
br></b></div><div><b>I assume that means we need this?</b></div><div><br></=
div><div>See RFC 6838 =C2=A75.2.1</div><div>Additional Information<br></div=
><div>Required</div><div>See RFC 6838, =C2=A74.12</div><div><br></div><div>=
Deprecated alias names for this type</div><div><b>N/A</b></div><div><br></d=
iv><div>=C2=A0This field is required.</div><div>Magic number(s)</div><div><=
b>0x6d736100 (i.e., &#39;\0asm&#39;)</b><br></div><div><b><br></b></div><di=
v>This field is required.</div><div>File extension(s)</div><div><b>.wasm<br=
></b></div><div><br></div><div>Macintosh File Type Code(s)</div><div><b>N/A=
</b></div><div><br></div><div>=C2=A0This field is required.</div><div>Objec=
t Identifier(s) or OID(s) =E2=80=94 See RFC 1494</div><div><b>N/A</b></div>=
<div><br></div><div>This field is required.</div><div>Intended Usage</div><=
div>Required</div><div><b>This mime type would be used when applications in=
clude binary WebAssembly modules for use as part of the application.</b><br=
></div><div><br></div><div>Other Information &amp; Comments</div><div><br><=
/div><div>Contact Person</div><div>Provide the contact for further informat=
ion. See RFC 6838 =C2=A75.5.</div><div><br></div><div>Contact Name</div><di=
v><b>Brad Nelson</b></div><div><br></div><div>Contact Email Address</div><d=
iv><b><a href=3D"mailto:bradnelson@google.com">bradnelson@google.com</a><br=
></b></div><div><br></div><div>Author/Change Controller (for standards tree=
 registrations, this is typically the standards body)</div><div><b>WebAssem=
bly Working Group</b></div></div><div><b><br></b></div></div>

--0000000000002ce00705677d883c--


From nobody Thu Mar 15 18:42:00 2018
Return-Path: <chris@w3.org>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 398FC127873 for <media-types@ietfa.amsl.com>; Thu, 15 Mar 2018 18:41:59 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.21
X-Spam-Level: 
X-Spam-Status: No, score=-4.21 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001, T_RP_MATCHES_RCVD=-0.01] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id TEZ6CjQLx3Qg for <media-types@ietfa.amsl.com>; Thu, 15 Mar 2018 18:41:57 -0700 (PDT)
Received: from raoul.w3.org (raoul.w3.org [128.30.52.128]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 76FA91201F8 for <media-types@ietf.org>; Thu, 15 Mar 2018 18:41:57 -0700 (PDT)
Received: from c-24-91-175-73.hsd1.vt.comcast.net ([24.91.175.73] helo=[10.0.0.122]) by raoul.w3.org with esmtpsa (TLS1.2:ECDHE_RSA_AES_128_GCM_SHA256:128) (Exim 4.84_2) (envelope-from <chris@w3.org>) id 1eweNX-000EWx-DM for media-types@ietf.org; Fri, 16 Mar 2018 01:41:55 +0000
To: media-types@ietf.org
References: <CAG=ZA4dFzSJLYNW9jg2A2MEZSnhh5Md+QkVHFJFYt-qoiKoLWg@mail.gmail.com>
From: Chris Lilley <chris@w3.org>
Message-ID: <999c9e7c-f6c5-e57c-a966-17a37dedc902@w3.org>
Date: Thu, 15 Mar 2018 21:41:51 -0400
User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:59.0) Gecko/20100101 Thunderbird/59.0
MIME-Version: 1.0
In-Reply-To: <CAG=ZA4dFzSJLYNW9jg2A2MEZSnhh5Md+QkVHFJFYt-qoiKoLWg@mail.gmail.com>
Content-Type: multipart/alternative; boundary="------------99D29BFB6D90204C4CD09A82"
Content-Language: en-US
Archived-At: <https://mailarchive.ietf.org/arch/msg/media-types/xDcog5o_9QrR6Eo_UEtMqt-NRQY>
Subject: Re: [media-types] Media Types Registration for application/wasm
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 16 Mar 2018 01:41:59 -0000

This is a multi-part message in MIME format.
--------------99D29BFB6D90204C4CD09A82
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 8bit


On 3/15/2018 9:28 PM, Bradley Nelson wrote:
>
> See RFC 2045 §6, and RFC 6838 §4.8.
> Security Considerations
> Required
> Provide a discussion of the security considerations.
> *The WebAssembly.compileStreaming and WebAssembly.instantiateStreaming 
> APIs enforce that the mime type is application/wasm so that we can 
> ensure non-wasm content isn't used to create modules.
> *

I would suggest adding some text derived from the Web Assembly 
specification:

Code is validated and executes in a memory-safe, sandboxed environment 
preventing data corruption or security breaches. *
*

> See RFC 6838 §4.9
> Provisional Registrations
> Standards tree applications only.
> *Wasm has it's first public working draft but no final W3C REC yet.
> *
> *I assume that means we need this?*
>
Yes, it should be a provisional registration. Fold in any comments about 
the media type before you go to CR, then request the non-provisional 
registration after CR is published. You should not wait for final REC.

-- 
Chris Lilley
@svgeesus
Technical Director @ W3C
W3C Strategy Team, Core Web Design
W3C Architecture & Technology Team, Core Web & Media


--------------99D29BFB6D90204C4CD09A82
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: 8bit

<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    <p><br>
    </p>
    <div class="moz-cite-prefix">On 3/15/2018 9:28 PM, Bradley Nelson
      wrote:<br>
    </div>
    <blockquote type="cite"
cite="mid:CAG=ZA4dFzSJLYNW9jg2A2MEZSnhh5Md+QkVHFJFYt-qoiKoLWg@mail.gmail.com">
      <div dir="ltr"><br>
        <div>
          <div>See RFC 2045 §6, and RFC 6838 §4.8.</div>
          <div>Security Considerations</div>
          <div>Required</div>
          <div>Provide a discussion of the security considerations.</div>
          <div><b>The WebAssembly.compileStreaming and
              WebAssembly.instantiateStreaming APIs enforce that the
              mime type is application/wasm so that we can ensure
              non-wasm content isn't used to create modules.<br>
            </b></div>
        </div>
      </div>
    </blockquote>
    <p>I would suggest adding some text derived from the Web Assembly
      specification:</p>
    <p>Code is validated and executes in a memory-safe, sandboxed
      environment preventing data corruption or security breaches. <b><br>
      </b></p>
    <blockquote type="cite"
cite="mid:CAG=ZA4dFzSJLYNW9jg2A2MEZSnhh5Md+QkVHFJFYt-qoiKoLWg@mail.gmail.com">
      <div dir="ltr">
        <div>See RFC 6838 §4.9
          <div>Provisional Registrations<br>
          </div>
          <div>Standards tree applications only.</div>
          <div><b>Wasm has it's first public working draft but no final
              W3C REC yet.<br>
            </b></div>
          <div><b>I assume that means we need this?</b></div>
          <div><br>
          </div>
        </div>
      </div>
    </blockquote>
    <p>Yes, it should be a provisional registration. Fold in any
      comments about the media type before you go to CR, then request
      the non-provisional registration after CR is published. You should
      not wait for final REC.<br>
    </p>
    <blockquote type="cite"
cite="mid:CAG=ZA4dFzSJLYNW9jg2A2MEZSnhh5Md+QkVHFJFYt-qoiKoLWg@mail.gmail.com"></blockquote>
    <pre class="moz-signature" cols="72">-- 
Chris Lilley
@svgeesus
Technical Director @ W3C
W3C Strategy Team, Core Web Design
W3C Architecture &amp; Technology Team, Core Web &amp; Media</pre>
  </body>
</html>

--------------99D29BFB6D90204C4CD09A82--


From nobody Fri Mar 23 03:54:29 2018
Return-Path: <allison.mankin@gmail.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id E650712D86B for <media-types@ietfa.amsl.com>; Fri, 23 Mar 2018 03:54:27 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -0.998
X-Spam-Level: 
X-Spam-Status: No, score=-0.998 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, FREEMAIL_REPLY=1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=no autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Lkim4JsK4uY0 for <media-types@ietfa.amsl.com>; Fri, 23 Mar 2018 03:54:26 -0700 (PDT)
Received: from mail-pg0-x22b.google.com (mail-pg0-x22b.google.com [IPv6:2607:f8b0:400e:c05::22b]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 5287B1205D3 for <media-types@ietf.org>; Fri, 23 Mar 2018 03:54:26 -0700 (PDT)
Received: by mail-pg0-x22b.google.com with SMTP id y63so1295404pgy.12 for <media-types@ietf.org>; Fri, 23 Mar 2018 03:54:26 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025;  h=mime-version:from:date:message-id:subject:to:cc; bh=6g8pG7rds//5Cw6S231v3TSedyUX01JIVfi4/5h/SsQ=; b=Mb5ZBDO+zFzZ9g43T9SpKws8MKAkUeGPQ43e2CkkGxus112LfprTllohwD1zkK+DkJ sXVrsP0zpI/YBGYec8y6J6lsJHmNvhL/84E59EXSOP7AbndaVU7MJF4cn27qwfuHtKZu jRn5GoYVBbM3w7a2Rzl1Lfyr0QnFnrG0TqHW18H7zHB/ksvWGfkgqAq2p1ADr0/g++U/ mC2tGKD1ITk/ZP+MjPiaEJD6ESRU1jsqzPuWDkf++5TG0vQAWXwkqKKLV90UlF7+9qOr FN7efHX5raXE8oQrpyvRTEyKofI+ySTrFIXW8HXXts5bgcNa4BIYuRyOgykl3b7bSgTn fIwg==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:from:date:message-id:subject:to:cc; bh=6g8pG7rds//5Cw6S231v3TSedyUX01JIVfi4/5h/SsQ=; b=oPQfQJSsW9KfU/iQKExnWLi8ZMeyCWmmQymOK12aBvTgghpdMr50QXV9rAC2c5V46h XUW0FYrsO8JqlurWO5L+TrEQBXxErXkYYO1csEutvy2R6f0T4U9oqM44Gm16C6/RbUcZ pMylZuMXc5cjS4GDaVZW+qJ41o5KsDQG706J8CdwWKt+7XFtmPi9fDN3JRsSpKPZ4ttl W76vYKmeX/kEuzwR0szNwUFFbVE9ViAX4xSWkkk+/Q4QiAgjGC9hBeOgk+pSG/2+f3oy Na13iqZK61ViyyExFL5YRPDB2o3X+eofZbL8IFcFmSHjMsftBkZQ4YRoeF9eqZ/kgYwX NesQ==
X-Gm-Message-State: AElRT7Gd6Nw+WVpfSRDwbqWE+1j4Q9FWHIA/coMU9DGPyqs6OIkkDr73 eviBbKJ2QicoHsXgxIRx4zUCrH06D4vMMTbCcHq0hg==
X-Google-Smtp-Source: AG47ELvKhSTEXCq86Hu/czYlt8w+QFfY3d6iNj322U/OEvBMf5TwqaOPAVVY9HrxVDT1SJU1+aLiGgsTdQNr9PguMGU=
X-Received: by 10.98.98.194 with SMTP id w185mr23708265pfb.206.1521802465753;  Fri, 23 Mar 2018 03:54:25 -0700 (PDT)
MIME-Version: 1.0
Received: by 10.100.132.225 with HTTP; Fri, 23 Mar 2018 03:54:25 -0700 (PDT)
From: Allison Mankin <allison.mankin@gmail.com>
Date: Fri, 23 Mar 2018 10:54:25 +0000
Message-ID: <CAP8yD=tbaWEVbGO2k+kVRrJz9+i1MMMbuMgCzdVVbJgcoUYnBQ@mail.gmail.com>
To: media-types@ietf.org
Cc: Brian Rosen <br@brianrosen.net>, Hannes Tschofenig <Hannes.Tschofenig@gmx.net>
Content-Type: multipart/alternative; boundary="94eb2c0472d263c2040568123f2a"
Archived-At: <https://mailarchive.ietf.org/arch/msg/media-types/Pph9G8Ht-XQN3KHqIf-ivfMKLtM>
Subject: [media-types] =?utf-8?q?=E2=80=8BRequest_from_ECRIT_WG_for_?= =?utf-8?q?=E2=80=8Bregistration_of_MIME_media_type_application/EmergencyC?= =?utf-8?q?allData=2Ecap+xml?=
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 23 Mar 2018 10:54:28 -0000

--94eb2c0472d263c2040568123f2a
Content-Type: text/plain; charset="UTF-8"

   MIME media type name:  application


   MIME subtype name:  cap+xml


   Required parameters:  (none)



   Optional parameters:  charset; Indicates the character encoding of
      enclosed XML.  Default is UTF-8 [RFC3629
<https://tools.ietf.org/html/rfc3629>].


   Encoding considerations:  Uses XML, which can employ 8-bit
      characters, depending on the character encoding used.  See RFC
<https://tools.ietf.org/html/rfc3023>
      3023 <https://tools.ietf.org/html/rfc3023> [RFC3023], Section
3.2 <https://tools.ietf.org/html/rfc3023#section-3.2>.


   Security considerations:  This content type is designed to carry
      payloads of the Common Alerting Protocol (CAP).  RFC XXX [Replace
      by the RFC number of this specification] discusses security
      considerations for this.


   Interoperability considerations:  This content type provides a way to
      convey CAP payloads.



   Published specification:  RFC XXX [Replace by the RFC number of this
      specification].


   Applications which use this media type:  Applications that convey
      alerts and warnings according to the CAP standard.



   Additional information:  OASIS has published the Common Alerting
      Protocol at http://www.oasis-open.org/committees/
<http://www.oasis-open.org/committees/documents>
      documents
<http://www.oasis-open.org/committees/documents>.php&wg_abbrev=emergency


   Person and email address to contact for further information:  Hannes
      Tschofenig, hannes.tschofenig@gmx.net


   Intended usage:  Limited use


   Author/Change controller:  IETF ECRIT working group


   Other information:  This media type is a specialization of
      application/xml RFC 3023 <https://tools.ietf.org/html/rfc3023>
[RFC3023 <https://tools.ietf.org/html/rfc3023>], and many of the
considerations
      described there also apply to application/cap+xml.

--94eb2c0472d263c2040568123f2a
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr"><div class=3D"gmail_quote"><br><div dir=3D"ltr"><div style=
=3D"font-family:arial,helvetica,sans-serif"><pre class=3D"m_211772345635432=
9443gmail-newpage">   MIME media type name:  application


   MIME subtype name:  cap+xml


   Required parameters:  (none)



   Optional parameters:  charset; Indicates the character encoding of
      enclosed XML.  Default is UTF-8 [<a href=3D"https://tools.ietf.org/ht=
ml/rfc3629" title=3D"&quot;UTF-8, a transformation format of ISO 10646&quot=
;" target=3D"_blank">RFC3629</a>].


   Encoding considerations:  Uses XML, which can employ 8-bit
      characters, depending on the character encoding used.  See <a href=3D=
"https://tools.ietf.org/html/rfc3023" target=3D"_blank">RFC</a>
      <a href=3D"https://tools.ietf.org/html/rfc3023" target=3D"_blank">302=
3</a> <a href=3D"https://tools.ietf.org/html/rfc3023#section-3.2" target=3D=
"_blank">[RFC3023], Section=C2=A03.2</a>.


   Security considerations:  This content type is designed to carry
      payloads of the Common Alerting Protocol (CAP).  RFC XXX [Replace
      by the RFC number of this specification] discusses security
      considerations for this.


   Interoperability considerations:  This content type provides a way to
      convey CAP payloads.



   Published specification:  RFC XXX [Replace by the RFC number of this
      specification].


   Applications which use this media type:  Applications that convey
      alerts and warnings according to the CAP standard.

<span class=3D"m_2117723456354329443gmail-grey"></span>


   Additional information:  OASIS has published the Common Alerting
      Protocol at <a href=3D"http://www.oasis-open.org/committees/documents=
" target=3D"_blank">http://www.oasis-open.org/<wbr>committees/</a>
      <a href=3D"http://www.oasis-open.org/committees/documents" target=3D"=
_blank">documents</a>.php&amp;wg_abbrev=3D<wbr>emergency


   Person and email address to contact for further information:  Hannes
      Tschofenig, <a href=3D"mailto:hannes.tschofenig@gmx.net" target=3D"_b=
lank">hannes.tschofenig@gmx.net</a>


   Intended usage:  Limited use


   Author/Change controller:  IETF ECRIT working group


   Other information:  This media type is a specialization of
      application/xml <a href=3D"https://tools.ietf.org/html/rfc3023" targe=
t=3D"_blank">RFC 3023</a> [<a href=3D"https://tools.ietf.org/html/rfc3023" =
title=3D"&quot;XML Media Types&quot;" target=3D"_blank">RFC3023</a>], and m=
any of the considerations
      described there also apply to application/cap+xml.

</pre><br></div></div>
</div><br></div>

--94eb2c0472d263c2040568123f2a--


From nobody Fri Mar 23 07:07:28 2018
Return-Path: <allison.mankin@gmail.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id D440F12D88E for <media-types@ietfa.amsl.com>; Fri, 23 Mar 2018 03:07:47 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -0.332
X-Spam-Level: 
X-Spam-Status: No, score=-0.332 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, FREEMAIL_REPLY=1, HTML_MESSAGE=0.001, SPF_SOFTFAIL=0.665, URIBL_BLOCKED=0.001] autolearn=no autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id eOKmNAR8oaM2 for <media-types@ietfa.amsl.com>; Fri, 23 Mar 2018 03:07:45 -0700 (PDT)
Received: from pechora6.dc.icann.org (pechora6.icann.org [192.0.46.72]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 136B8126CC4 for <media-types@ietf.org>; Fri, 23 Mar 2018 03:07:45 -0700 (PDT)
Received: from mail-pl0-x22f.google.com (mail-pl0-x22f.google.com [IPv6:2607:f8b0:400e:c01::22f]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by pechora6.dc.icann.org (Postfix) with ESMTPS id 08F931E00DF for <ietf-types@iana.org>; Fri, 23 Mar 2018 10:07:44 +0000 (UTC)
Received: by mail-pl0-x22f.google.com with SMTP id n15-v6so7138562plp.12 for <ietf-types@iana.org>; Fri, 23 Mar 2018 03:07:44 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025;  h=mime-version:from:date:message-id:subject:to:cc; bh=w0y/rvIrSXEf0SmsXlXradcqrFbX156hFowTueBI1hU=; b=XC7XUY1EVKpLiv/Wx6LiEOPkj+WeLcJGx9Vr698M7fqCg270i/YPzYCmDqW0UocusE DzUzLQVcBGcIb0SSl/TGLGNJ4eZYz2nLCNmPlJHfHLoHGKShLZWnrr1QalPfqMnQuP6l N6cdMNyi1KyW6+NsOVey9iCopIZMQouwvo/010cgCIbHtxFCuNs6Mnz4EVhl/M3WbCV1 8wGBbQGg2+Qb1jyvIv3WSfv3hyLyQeWTTt6teVXu826FgQUtamRju4IiMwx3/MtWd8ef bjdhzoM+xAa7RuxqPJ9vr6g5Jd3QrzHz8Vz7NC3Vqn8RanaZgWylSNRx2aiNs0WMVplT A5dg==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:from:date:message-id:subject:to:cc; bh=w0y/rvIrSXEf0SmsXlXradcqrFbX156hFowTueBI1hU=; b=EaqbXh4DRbjEOBmt1LqVxAA9dApxhcP9KaqqwYQMm5ER3qlBDNXTh5O+on0K8SYcUv dZaIAR09Gd+LWPU4etmXO8fu6/OMAw2kKZLBJg+MKOKwlk5zrFp2HEmeDx6IN9+VPHU7 D8QbCfLs70u5TJAjgapi1DeEr79BVE/KOkpwPuj1J5GCG0axz+tW4ewh3zsdjQHDgudv D+cDrUUrFwV2QCUKOIt/a9iIongpI8ywZ/HqHJU1vqtqBryWU1maY8MxQHiPKBcJouKN VTDfPM9Exm6tv6/pRWotAeJwi3Bpcxc/j759ODyC4QdGHPBpTAmvriIVjpFhz96tgi57 68zw==
X-Gm-Message-State: AElRT7EmgctscuSDnANY7fVBsek62/IxShOLmz8Dne1cfuczH2X2Xxj3 vaSAPh+lVHUX984sSRLEuAaROlDxYEtDJJFXqchj6Q==
X-Google-Smtp-Source: AG47ELuPIQjWZuMcmBSNOlmeI0G0CWxWB/v++cCufY2CZm0gMTyUccdQ9Nww0pGegsJQ6C/gmoGNdIHLPI2zi5udP+E=
X-Received: by 2002:a17:902:6884:: with SMTP id i4-v6mr29476801plk.259.1521799662649;  Fri, 23 Mar 2018 03:07:42 -0700 (PDT)
MIME-Version: 1.0
Received: by 10.100.132.225 with HTTP; Fri, 23 Mar 2018 03:07:41 -0700 (PDT)
From: Allison Mankin <allison.mankin@gmail.com>
Date: Fri, 23 Mar 2018 10:07:41 +0000
Message-ID: <CAP8yD=t7WOGhqxKmERFiohfS=-RX8VierphQ0h8avx8Mx0bT+A@mail.gmail.com>
To: ietf-types@iana.org
Cc: ajm <allison.mankin@gmail.com>, Brian Rosen <br@brianrosen.net>,  Hannes Tschofenig <Hannes.Tschofenig@gmx.net>
Content-Type: multipart/alternative; boundary="0000000000004fc5c90568119867"
Archived-At: <https://mailarchive.ietf.org/arch/msg/media-types/O_E92PWjzWmPheZfzzliFDIENkE>
X-Mailman-Approved-At: Fri, 23 Mar 2018 07:07:27 -0700
Subject: [media-types] Registration of MIME media type application/EmergencyCallData.cap+xml
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 23 Mar 2018 10:07:48 -0000

--0000000000004fc5c90568119867
Content-Type: text/plain; charset="UTF-8"

   MIME media type name:  application


   MIME subtype name:  cap+xml


   Required parameters:  (none)



   Optional parameters:  charset; Indicates the character encoding of
      enclosed XML.  Default is UTF-8 [RFC3629
<https://tools.ietf.org/html/rfc3629>].


   Encoding considerations:  Uses XML, which can employ 8-bit
      characters, depending on the character encoding used.  See RFC
<https://tools.ietf.org/html/rfc3023>
      3023 <https://tools.ietf.org/html/rfc3023> [RFC3023], Section
3.2 <https://tools.ietf.org/html/rfc3023#section-3.2>.


   Security considerations:  This content type is designed to carry
      payloads of the Common Alerting Protocol (CAP).  RFC XXX [Replace
      by the RFC number of this specification] discusses security
      considerations for this.


   Interoperability considerations:  This content type provides a way to
      convey CAP payloads.



   Published specification:  RFC XXX [Replace by the RFC number of this
      specification].


   Applications which use this media type:  Applications that convey
      alerts and warnings according to the CAP standard.



   Additional information:  OASIS has published the Common Alerting
      Protocol at http://www.oasis-open.org/committees/
<http://www.oasis-open.org/committees/documents>
      documents
<http://www.oasis-open.org/committees/documents>.php&wg_abbrev=emergency


   Person and email address to contact for further information:  Hannes
      Tschofenig, hannes.tschofenig@gmx.net


   Intended usage:  Limited use


   Author/Change controller:  IETF ECRIT working group


   Other information:  This media type is a specialization of
      application/xml RFC 3023 <https://tools.ietf.org/html/rfc3023>
[RFC3023 <https://tools.ietf.org/html/rfc3023>], and many of the
considerations
      described there also apply to application/cap+xml.

--0000000000004fc5c90568119867
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr"><div class=3D"gmail_default" style=3D"font-family:arial,he=
lvetica,sans-serif"><pre class=3D"gmail-newpage">   MIME media type name:  =
application


   MIME subtype name:  cap+xml


   Required parameters:  (none)



   Optional parameters:  charset; Indicates the character encoding of
      enclosed XML.  Default is UTF-8 [<a href=3D"https://tools.ietf.org/ht=
ml/rfc3629" title=3D"&quot;UTF-8, a transformation format of ISO 10646&quot=
;">RFC3629</a>].


   Encoding considerations:  Uses XML, which can employ 8-bit
      characters, depending on the character encoding used.  See <a href=3D=
"https://tools.ietf.org/html/rfc3023">RFC</a>
      <a href=3D"https://tools.ietf.org/html/rfc3023">3023</a> <a href=3D"h=
ttps://tools.ietf.org/html/rfc3023#section-3.2">[RFC3023], Section=C2=A03.2=
</a>.


   Security considerations:  This content type is designed to carry
      payloads of the Common Alerting Protocol (CAP).  RFC XXX [Replace
      by the RFC number of this specification] discusses security
      considerations for this.


   Interoperability considerations:  This content type provides a way to
      convey CAP payloads.



   Published specification:  RFC XXX [Replace by the RFC number of this
      specification].


   Applications which use this media type:  Applications that convey
      alerts and warnings according to the CAP standard.

<span class=3D"gmail-grey"></span>


   Additional information:  OASIS has published the Common Alerting
      Protocol at <a href=3D"http://www.oasis-open.org/committees/documents=
">http://www.oasis-open.org/committees/</a>
      <a href=3D"http://www.oasis-open.org/committees/documents">documents<=
/a>.php&amp;wg_abbrev=3Demergency


   Person and email address to contact for further information:  Hannes
      Tschofenig, <a href=3D"mailto:hannes.tschofenig@gmx.net">hannes.tscho=
fenig@gmx.net</a>


   Intended usage:  Limited use


   Author/Change controller:  IETF ECRIT working group


   Other information:  This media type is a specialization of
      application/xml <a href=3D"https://tools.ietf.org/html/rfc3023">RFC 3=
023</a> [<a href=3D"https://tools.ietf.org/html/rfc3023" title=3D"&quot;XML=
 Media Types&quot;">RFC3023</a>], and many of the considerations
      described there also apply to application/cap+xml.

</pre><br></div></div>

--0000000000004fc5c90568119867--


From nobody Fri Mar 30 10:14:01 2018
Return-Path: <mmitar@gmail.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id C8AFD124F57 for <media-types@ietfa.amsl.com>; Fri, 30 Mar 2018 10:13:59 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2
X-Spam-Level: 
X-Spam-Status: No, score=-2 tagged_above=-999 required=5 tests=[BAYES_00=-1.9,  DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Vr45SFyKqX67 for <media-types@ietfa.amsl.com>; Fri, 30 Mar 2018 10:13:57 -0700 (PDT)
Received: from mail-lf0-x243.google.com (mail-lf0-x243.google.com [IPv6:2a00:1450:4010:c07::243]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 7EE7B126FDC for <media-types@ietf.org>; Fri, 30 Mar 2018 10:13:57 -0700 (PDT)
Received: by mail-lf0-x243.google.com with SMTP id t132-v6so13325464lfe.2 for <media-types@ietf.org>; Fri, 30 Mar 2018 10:13:57 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025;  h=mime-version:from:date:message-id:subject:to; bh=gjphQ5YkV3z76Ow8iM7isHxeKRyJ6vezdGSw4mE+gzw=; b=ZJepXuYSJiWjdIoNxRDtpxBrNHqp4++/GbOZ2Xsj16QBgS8grwCxfsx6Gu7gyCHKGR Yal77dXdx8gqqA8jd8sQ+ikN3siOyob7XTSG91Pjn3wn9uODfbFRNgSyNKsIYPpioQmw GpJQFlK+elDh6DpakoUgkYbSHM4I1Bc+jj95mF9tOZA/gT/kqqPO4/CmZEZxPHfMql+v 6/XsVqxjJaRKqGIge3uzLEB5phDeWEfXemjuZ8sEzIhWogvLCJPO471K9LM9+NZCb1yJ Umjpv8l7UqLL9iUdhPubm/pm+svSzDzcam0v1fI5IY5LWSQNQDWUvegixfhlSCssMvPQ c2HQ==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:from:date:message-id:subject:to; bh=gjphQ5YkV3z76Ow8iM7isHxeKRyJ6vezdGSw4mE+gzw=; b=YXFaJ1kGL2R8jIdJGIepGA+XXebqm0UT8pbX5ataRtRsBM+8v8SIs/2HWOTrTgkcyK wUsaobdk2tm5+HSrVmOq+m07eaA/GBrDHXZyU5aMfrPW6RJfbmj9a62TewLQcX6cUawU i6DC8y/e4WHTb8z5vi/Sre1uCkT0c0KRQ5W9m5IAXHxnhWnsTdO9aH2/mvMC1b6Jc9of rLcRqGGw9jtMd3YHnpkTEECYncqbwoEiRppB44j64JoMYlgY47vVIoY/D9YeUw98rbZi JS+m7XlsxTeJzhog0gWeTbUBNjBxoFWRp6ar7Xco/V4BcfEg6GxkdCPot0LfWfExk+QE ZF2Q==
X-Gm-Message-State: AElRT7GiJLjEKsF3F2Gt2ZWQh5l6ygNqRSIcecuau4kdK4/xnJ2guq2l EnrYvWCv6NLyl8dSlVAbeDsxM2bQP1fRlGscKL9BnA==
X-Google-Smtp-Source: AIpwx48ZYg8NC2lTlpL0GnruTSGlfZAEeGxkQeZQky0HY8YP3YkiaXLD1H+DwxdR+JlGgZzYcwp0f8VHI98+74Jws1k=
X-Received: by 2002:a19:2c85:: with SMTP id s127-v6mr8987161lfs.18.1522430035455;  Fri, 30 Mar 2018 10:13:55 -0700 (PDT)
MIME-Version: 1.0
Received: by 2002:a19:e82f:0:0:0:0:0 with HTTP; Fri, 30 Mar 2018 10:13:54 -0700 (PDT)
From: Mitar <mmitar@gmail.com>
Date: Fri, 30 Mar 2018 10:13:54 -0700
Message-ID: <CAKLmikNBG3Eq22FeTH0BOyenqj8LTmR4wECB9j-D4OZWTnfmgA@mail.gmail.com>
To: media-types@ietf.org
Content-Type: text/plain; charset="UTF-8"
Archived-At: <https://mailarchive.ietf.org/arch/msg/media-types/WzvAz0XIfWXtUqvlm58nFeuLeM8>
Subject: [media-types] Media types for some some common data formats
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 30 Mar 2018 17:14:00 -0000

Hi!

I am new to all this. But in an app we are working on we are trying to
use media types to record the information what a binary blob/file
contains. Our target domain is data analysis so we came up around many
data files we have hard time finding suitable types for.

For example:

Graph Modelling Language files
(https://en.wikipedia.org/wiki/Graph_Modelling_Language)

Python numpy array .npy files

If I understand correctly, the best would be for us to use something
like text/prs.gml and application/prs.npy for these? But because they
are common formats, is there something better we can do?

(We are not affiliated with authors of any of those two formats.)


Mitar

-- 
http://mitar.tnode.com/
https://twitter.com/mitar_m

