
From nobody Tue Jul  3 02:51:47 2018
Return-Path: <duerst@it.aoyama.ac.jp>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id EB99C130F84 for <media-types@ietfa.amsl.com>; Tue,  3 Jul 2018 02:51:45 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -3.545
X-Spam-Level: 
X-Spam-Status: No, score=-3.545 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, RCVD_IN_DNSWL_MED=-2.3, SPF_SOFTFAIL=0.665, T_DKIMWL_WL_MED=-0.01] autolearn=unavailable autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=itaoyama.onmicrosoft.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id AoFiBGEp1C23 for <media-types@ietfa.amsl.com>; Tue,  3 Jul 2018 02:51:45 -0700 (PDT)
Received: from pechora1.lax.icann.org (pechora1.icann.org [IPv6:2620:0:2d0:201::1:71]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 063B7130E36 for <media-types@ietf.org>; Tue,  3 Jul 2018 02:51:45 -0700 (PDT)
Received: from JPN01-OS2-obe.outbound.protection.outlook.com (mail-os2jpn01on0105.outbound.protection.outlook.com [104.47.92.105]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-SHA384 (256/256 bits)) (No client certificate requested) by pechora1.lax.icann.org (Postfix) with ESMTPS id 8A2AD1E0325 for <media-types@iana.org>; Tue,  3 Jul 2018 09:51:44 +0000 (UTC)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=itaoyama.onmicrosoft.com; s=selector1-it-aoyama-ac-jp; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=WXWz0XnTkK1EJXfWMBE95CzsGvIboiINEC596nnq2cI=; b=H2bFMLPEsSOIn0/Bz7qLJxddr9JY+6/5djnk7Ta+pknPzYYBOQkXENq33d+Q9jBIYLAsQK/Q+yimrfmHw5DBpM0KVbWzjwPRjXeePi+NhwumGG4qnEX7NteiWu/SftC8BPlVBckTGxdzG06Ws4oE2z6dAqKKNsS9+LHOG5y5lTo=
Authentication-Results: spf=none (sender IP is ) smtp.mailfrom=duerst@it.aoyama.ac.jp; 
Received: from [133.2.210.64] (133.2.210.64) by TYXPR01MB1552.jpnprd01.prod.outlook.com (2603:1096:403:d::12) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.906.26; Tue, 3 Jul 2018 09:51:22 +0000
To: Ben Schwartz <bemasc=40google.com@dmarc.ietf.org>, media-types@iana.org
Cc: Patrick McManus <mcmanus@ducksong.com>, Paul Hoffman <paul.hoffman@icann.org>, Adam Roach <adam@nostrum.com>, David Lawrence <tale@dd.org>
References: <CAHbrMsCupObmz5Ye7fdKSt3YOpUsPiH3ReV0UV0g3WuOQH0Zqg@mail.gmail.com>
From: =?UTF-8?Q?Martin_J._D=c3=bcrst?= <duerst@it.aoyama.ac.jp>
Organization: Aoyama Gakuin University
Message-ID: <63a538a6-d761-1372-ebd2-1a5d4a85d743@it.aoyama.ac.jp>
Date: Tue, 3 Jul 2018 18:51:19 +0900
User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Thunderbird/52.8.0
MIME-Version: 1.0
In-Reply-To: <CAHbrMsCupObmz5Ye7fdKSt3YOpUsPiH3ReV0UV0g3WuOQH0Zqg@mail.gmail.com>
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Language: en-US
Content-Transfer-Encoding: 7bit
X-Originating-IP: [133.2.210.64]
X-ClientProxiedBy: KAWPR01CA0093.jpnprd01.prod.outlook.com (2603:1096:402:c::29) To TYXPR01MB1552.jpnprd01.prod.outlook.com (2603:1096:403:d::12)
X-MS-PublicTrafficType: Email
X-MS-Office365-Filtering-Correlation-Id: 0a312050-b469-4c81-46d9-08d5e0ca88c6
X-Microsoft-Antispam: UriScan:; BCL:0; PCL:0; RULEID:(7020095)(4652040)(8989117)(5600053)(711020)(4534165)(4627221)(201703031133081)(201702281549075)(8990107)(2017052603328)(7153060)(7193020); SRVR:TYXPR01MB1552; 
X-Microsoft-Exchange-Diagnostics: 1; TYXPR01MB1552; 3:HWoaeY53UoIFxqrQNHj6U0WjEq+3ZUo1LPLdbeqJgBaGW8hULgAJKcX9SjJKbzUk2UGCz/f7+r2vAEYLe+Qns2tmVmm6qFok36j4cu716VBpBfGJFxHsGzpP6jGq5b15udcvwa5CsN+LWQcaxQ2A+3nwmgcQuFXQkDLWyYnsbu7Hjt5DSz4lh1K7uWxo7fdM5lGhZ/lW5otXRP4FCLWXk4nIK6ZYy4xS6MiHLhQcH02mGNuP4iYvygsDwrDpyYrC; 25:58Flh2G9cmj/Uo9V/ejJ/DtNYbov313VF93fM9928A+DzSJVPV12nPG3Z8C0xy5/I7yBVTPK8N/sku+VEECXU0QvulUJSlYHSGwYlkgRyjTA2S9m6YtAOyMiht42aS76wOwPiXlZPBZAwbFokePYZrJSI6uCyzosHCdzKvnD9l49R4kg4HpITidw9/jLUjJPTjRChmgzy/3D4FAIKri6RQCIBgSJEycpsS/ybIYCVxVa1dGNdJtm2ZYskRTvqKC3koZa4NrYLccH2ZzfBkKH+16g9G1OmNMEZHC95nj6DAsBYSlo/GeLhNlbIZaajeuHEGXupH9BoU5wKlcbQtIowQ==; 31:3djCtRru1bqDcx/Zfmsn7h1B1lmwgDp4S7j6MIRZHnGekAycKA0GQTTd6k2MHwhBm8Y2GkcaibybVg0Y2Bwm+EnLijVSik9HLXcTXMAkmYWGohVh1SK/2bfPpmMjRHL0dgW0e3D7+nUdBqomlc0kAVuwMUZfbF/ViRydFPZ588K1mJkPIzA+xx4zUiLsur3MP0w+Tfkoyr4hnXr+nLtmfPBhthNmUb7RBT6bFXicgNc=
X-MS-TrafficTypeDiagnostic: TYXPR01MB1552:
X-Microsoft-Antispam-PRVS: <TYXPR01MB1552D17C9C4F2AD57227E3ABCA420@TYXPR01MB1552.jpnprd01.prod.outlook.com>
X-Exchange-Antispam-Report-Test: UriScan:;
X-MS-Exchange-SenderADCheck: 1
X-Exchange-Antispam-Report-CFA-Test: BCL:0; PCL:0; RULEID:(6040522)(2401047)(8121501046)(5005006)(93006095)(93001095)(10201501046)(3002001)(3231254)(944501410)(52105095)(149027)(150027)(6041310)(201703131423095)(201702281529075)(201702281528075)(20161123555045)(201703061421075)(201703061406153)(20161123560045)(20161123562045)(20161123558120)(20161123564045)(6072148)(201708071742011)(7699016); SRVR:TYXPR01MB1552; BCL:0; PCL:0; RULEID:; SRVR:TYXPR01MB1552; 
X-Microsoft-Exchange-Diagnostics: 1; TYXPR01MB1552; 4:CaFNESCIPQySEzg1NS0Xiy2rboAvmphx7UFDMmYqdRkHMEHNvqaJKM6H5CjuJVvccwqBC7cZcGblh77MdXSZfe8GQ2WsNhNjbo4UrXlIU5o0p9fYbG3xFSQwL1254wtcTBacCxh2YO8go+naVRwJfbShUqhojzQ+UjCg0/iaSgmtpbZn/zKjNnAXLAlVlYGq28Clm7YInK3iSvRpxMnB4fAw2QVVXfQDtYJuDDMRZavlaBuznyrDe6QUhbsPzTzAdSy1T8r8XVJHxjilj6IZRw==
X-Forefront-PRVS: 0722981D2A
X-Forefront-Antispam-Report: SFV:NSPM; SFS:(10019020)(6049001)(136003)(376002)(396003)(346002)(39840400004)(366004)(199004)(189003)(65806001)(446003)(14444005)(478600001)(476003)(2616005)(966005)(68736007)(50466002)(106356001)(229853002)(230700001)(81166006)(7736002)(486006)(74482002)(66066001)(186003)(16526019)(8936002)(956004)(64126003)(5660300001)(15650500001)(3846002)(65956001)(6116002)(2906002)(105586002)(8676002)(6666003)(305945005)(11346002)(65826007)(47776003)(26005)(53936002)(86362001)(31686004)(67846002)(2486003)(81156014)(49976009)(76176011)(52116002)(23676004)(52146003)(36916002)(4326008)(53546011)(6246003)(786003)(316002)(16576012)(25786009)(58126008)(54906003)(97736004)(31696002)(6306002)(6486002)(386003)(3940600001); DIR:OUT; SFP:1102; SCL:1; SRVR:TYXPR01MB1552; H:[133.2.210.64]; FPR:; SPF:None; LANG:en; PTR:InfoNoRecords; A:0; MX:1; 
Received-SPF: None (protection.outlook.com: it.aoyama.ac.jp does not designate permitted sender hosts)
X-Microsoft-Exchange-Diagnostics: =?utf-8?B?MTtUWVhQUjAxTUIxNTUyOzIzOlMxTERmdk9iaXBYVXZnamtLY3pMSEE1ZFVG?= =?utf-8?B?amoyZE1TT3d0OHE5TVg2Smc1NTQyL1NCOHI5VHRzdndNZ2JBV0hXVW1nY3dr?= =?utf-8?B?RnN3aHFubTlCOG53dHBDN3cwU2ZxV2hmOHhxSzcvTnVDOUhldWNhcGZxM3ZY?= =?utf-8?B?VmdDcU41RmFEbVNHZks5eVlIYUw1V2hGa1dVTk1TMVZDdkxaa016VVdLZE84?= =?utf-8?B?dVg5OXhucW1FREM5ZjNCK1NOeXRBTWRUZVM5MExoSHhqNkhJTnRjdi9wMnEx?= =?utf-8?B?UWNQeS9qclNBT05sV1lHanJLbmEzQWNmZVY1VUYzSmRQQXRHV3E0NkVPZGpF?= =?utf-8?B?UzZCSEd0a2hWdis4djRGRXh6SlgvbGhscE04aFdNSjU1NFpDNEtkcWUxQndD?= =?utf-8?B?QVhaMlI4Sy9WcFRGbEQvTWhSN0VJekF2U1VZZEhHalBFS1k0NXBKRTRpNE84?= =?utf-8?B?dThCbllBa0R0K0dId0o3aUtYTFZ0QU9oMXVCOFZNL085MFNiekdWSGpNcGYx?= =?utf-8?B?SXJ0eUYyLzM2UnEydnRuMkNNTmk2WXprcWpHQXVpUy9rRlZzMHNlc3I2ZWtz?= =?utf-8?B?Z1FCRlN0K045TEJoL2tBd0ZTRVZKWGh6c0pVUVFmWTdnOFdWdUd3QmpIdzZ3?= =?utf-8?B?OXROTFU2WTlxVTN4andsNUlDQWloYUVNaVMxSHB1TS95djJyVityT2lCTnhr?= =?utf-8?B?NHAyN2luNUp0OUVuNDJrYk1HMzYzMXFkdnZlNFZQUUM0Vm93Mk5pbERnQkVN?= =?utf-8?B?cXg4RXZ1SVZLY2VoTWZUTHFTamRTMzBpVlU5YjVuWFozcDQ1R2owU3BIRGds?= =?utf-8?B?VmlpRytvZWtFcHBHMVVnbXh5UUlpaGVrOUZ6T05UWXhqV01BTDBBUS9nN2xK?= =?utf-8?B?NFI4M0lCM1lrcEtERmxZRnpOeUNWWGNkT3NhSkkvM3YrUDJ1WXZ6SmNWUEM1?= =?utf-8?B?WkpMQTZwbExyTTNMcnU4RUZMQ2hmcGp0MGxMSEhCNk9UZ2VqanpEWFJDUWNV?= =?utf-8?B?U2YxeWJkNjFRaktCL1k3bkVJenB2amZHTy9lV3NUQ0lZWHMzUHF3Q2krQUoz?= =?utf-8?B?aS8rRURxR01QZU1WNjBXSFVHbVV0RTJOKzdtKzZuTkxmYkJSdWk3d2pmQWI0?= =?utf-8?B?NFoySXBTYVp3bEFhb3dFVHk3YnEyL3c2N25NbFdkWXZJaGNFdUdRVkJzTG5w?= =?utf-8?B?RjJyNXFqYmM4WFA4Uk5mMklHS2tNU0FOdjYzdFg1WjhGTk9pTHZSM3ViRWNr?= =?utf-8?B?bGpJMWdJWGp0RzkwVHd6U2ZsODhRL0s2OWxMQzRyVnR1WUowQmwrTmgzTDF3?= =?utf-8?B?MWNMamRGSzhENmtaYlBxQW5xajRTdkZIVC9HSzl4Mjh2ZWxKd1FNMGNWWEcr?= =?utf-8?B?ajM4NGdVVDVoYWNuNUsxd1E2Z1dNUEZ2TGVsbmhvM1VMRmJNcmNhNmRaSFZz?= =?utf-8?B?NU0wNVVzY3U5dlZGaE9WMktVRzR5SGZiQjlYK0oxWmNMY0JsMnl0RU9jY1Rw?= =?utf-8?B?QURGUUt0bVpTeTFlbm9SNjlsUThHMnBoNHY3Rlp3NldyYXNVaElRc014NlBk?= =?utf-8?B?eWo4VjNNL3RYVnpEVEk1L2k5R2pCSC9pc1NmYTFJT3ZiMlRodU5zWk5xNENT?= =?utf-8?B?cEkzck1PbndYNUpEVHFIRzl6SWhEa2FJeWN3K0xIVS81ZWFabU1JN2ZRUHR0?= =?utf-8?B?L2ZqbkUrMGFuTFhaVGE4cVFXL2dJSkV3Y242Q0VQaEZiclB5RFJTZHV2TWo0?= =?utf-8?B?T1VTMHFPSy9DMDJlVUdOY05NT0d6UWRHUTRKVkN5WnRBVXJzbG45NzBpaFRW?= =?utf-8?B?VDNDRXNJSWVPWDJJYzlsZ29TOHQwWTFKbEZJWWJQWm5oSUhDSGVwTkVPTUhx?= =?utf-8?B?ZGt4VU1URE94eXVxUUpkV2x5WVhRZGo4bCtxU3B5anp2U3dFOUFoZ1JYRUp1?= =?utf-8?B?SmtMbFp3THNjMU5zUk5DZ0g5cFFtRXJsS3Yzd2U0WFQwaWdZOEwxODYwRGx5?= =?utf-8?B?REI2OFpBSzJFaUV3OUlzTVkwa1NsVlFTTnhzRURGUzRlS3VyRFFqNTdQamNp?= =?utf-8?B?MU9NSmpicUtyRUxEMlVvNWowd1RnSjVhRmQ2WVJlNVBBSkcyM0VCbFZReklZ?= =?utf-8?Q?SqxITGV95kN1FCXZ/7QkIjs=3D?=
X-Microsoft-Antispam-Message-Info: 8EEJ/az9YajA6Q9ux9gJQ6CAshDIXMJzL9iBPtujDWfDKN+2WnmsbKECmotisGIF5r2fQQvVUvG7L4MCY8280Waqf2zup0opdiTcYptyT8d5b4QqSY+G02UbLja/ZrqMW2uN+iHoCdZXOU4cglH1s+TSf5Xq+9gqAilpW33H01/d85DAzXxJtu6wBdx1USkKxHgjjHNgbLEj2jVRE3vQeSIsQ7NnVS9+tOPqQkXDiGY7hLjMHXo+e9sXk3MTJIKnsvkcgfKqC8TEExbqqdeuL9N24/aD85wU1yP2wEeSenR8NDf7oJaTjkn6UD1uV1C1uz5KdjQmHDKyaM/Wryi1sDdXJT055sOgvuzoGJ7qgUI=
X-Microsoft-Exchange-Diagnostics: 1; TYXPR01MB1552; 6:jcAGTCINZWQChT20YvB/WBwiLFGag08+/9zBB6UVH4mwIU5DKhD9ZFdQeqNSv/qAENFUruePM9wr0rOV66b8SqynnIZzpuIZ+SmMla5FuJnlGmxbxwTbKmY0z+h4CjSxTXjRA9KS4KNhEZTlh9rYMLOFfG3AHwk7XKsCKbtUN0f385zdbNFhFedG44tthxCi7d78ekUtUXphzcb473YnTCgFn1sRgFegwzWMHKV3jEdzUOT0kxvpAE/FJQabjj4YGMkgBQsnfi8XwSZgE2wZ3TSWqBhe/gDRVwR+PqR1aLUsJ4WYSEGy9CiUzeYm/TZ9AW8amneBaTiNwjc3eMehOQLN3HxnV6l5rtD0PfaLlBnwrldSUENayTrpiXLnbhsawDTXTuvf+eGOtZ6zGvWV2Lwf6MTiMXEOT0Q/0QJUZdJLSk7wKQTBKeO9bcuQPvS8qA/Ud6v5r6caZaPiyPQJ3w==; 5:mnoeQp4/zc8TA9Kfjq2HEFz0avLMDbFFi0GVW9qd+RMMyXANHWdiJIetznR5j+EONWg90+KRS/Z7P67cqDLbhSBMqS6hdmJ2km5bocIFuq43ftXsNIJZCps1crjtp1pnsig5W2xBxqZUcLtb+gywq8/Fds/LhZqp89dHjsjbLSQ=; 24:s2WJQfCbnOobFqUpoZrY9Vs4WJwF2d/gOla+tdHCvQznCy5HfTh8NXIokPwXddtGKE88altnRknv97KUYb1YSGVd/GVAOn/Yb+oDNmEPC94=
SpamDiagnosticOutput: 1:99
SpamDiagnosticMetadata: NSPM
X-Microsoft-Exchange-Diagnostics: 1; TYXPR01MB1552; 7:D6IJ/JMtMS/3s9esulipRQyDEpS8rvWaMOSt9BBVA45mDHI6s6lOjFOTs0yd/8Q6RBRL1XbU5E1cbNxrRr45J1mk++tpYk8UycONJ713tOFrdSrfSkkBwnYsjtRqaWH/zqNVU/Aij6crB1cEedxI2LuKcLVs+EUowBx9IN6uX4iu3dFHkZWczAs05zxBg+b3hLTTYvsrhYa33euq/O7gb5HlAr0S0NMTg9mTDX+mLylezGOF+W5x5/qepeNFCU6S
X-OriginatorOrg: it.aoyama.ac.jp
X-MS-Exchange-CrossTenant-OriginalArrivalTime: 03 Jul 2018 09:51:22.3785 (UTC)
X-MS-Exchange-CrossTenant-Network-Message-Id: 0a312050-b469-4c81-46d9-08d5e0ca88c6
X-MS-Exchange-CrossTenant-FromEntityHeader: Hosted
X-MS-Exchange-CrossTenant-Id: e02030e7-4d45-463e-a968-0290e738c18e
X-Greylist: Sender passed SPF test, not delayed by milter-greylist-4.5.16 (pechora1.lax.icann.org [192.0.33.71]); Tue, 03 Jul 2018 09:51:44 +0000 (UTC)
X-MS-Exchange-Transport-CrossTenantHeadersStamped: TYXPR01MB1552
Archived-At: <https://mailarchive.ietf.org/arch/msg/media-types/soIHzBGXdL7Ihv2G44fNeIRmFGs>
Subject: Re: [media-types] DNS over HTTPS forthcoming Media Type Registration Notice
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.26
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 03 Jul 2018 09:51:46 -0000

Hello Ben,

If at all possible, please submit the registration templates here. That 
greatly increases the chance to get (potentially valuable) comments.

Regards,   Martin.

On 2018/06/28 00:45, Ben Schwartz wrote:
> Hello Media Type Experts,
> 
> In accordance with RFC 6838 Section 5.1, I would like to notify you that
> the forthcoming draft "DNS over HTTPS" will request a new media type,
> "application/dns-message".  See
> https://tools.ietf.org/html/draft-ietf-doh-dns-over-https-11#section-8.1.
> 
> I hope we're following this process correctly.
> 
> --Ben Schwartz, for the DOH Chairs


From nobody Tue Jul  3 07:28:11 2018
Return-Path: <bemasc@google.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id B7DC5130E47 for <media-types@ietfa.amsl.com>; Tue,  3 Jul 2018 07:28:08 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -8.844
X-Spam-Level: 
X-Spam-Status: No, score=-8.844 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, HTML_MESSAGE=0.001, SPF_SOFTFAIL=0.665, T_DKIMWL_WL_MED=-0.01, USER_IN_DEF_DKIM_WL=-7.5] autolearn=no autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=google.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ypGlYw62TXMz for <media-types@ietfa.amsl.com>; Tue,  3 Jul 2018 07:28:07 -0700 (PDT)
Received: from pechora2.lax.icann.org (pechora2.icann.org [IPv6:2620:0:2d0:201::1:72]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 2B9B8130E10 for <media-types@ietf.org>; Tue,  3 Jul 2018 07:28:07 -0700 (PDT)
Received: from mail-it0-x229.google.com (mail-it0-x229.google.com [IPv6:2607:f8b0:4001:c0b::229]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by pechora2.lax.icann.org (Postfix) with ESMTPS id C18411E0300 for <media-types@iana.org>; Tue,  3 Jul 2018 14:28:06 +0000 (UTC)
Received: by mail-it0-x229.google.com with SMTP id p17-v6so3400036itc.2 for <media-types@iana.org>; Tue, 03 Jul 2018 07:28:06 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=20161025; h=mime-version:references:in-reply-to:from:date:message-id:subject:to :cc; bh=XEiBHGhv+4tAPegmTDSoVUVNMDr8RBfFc+gkmDaRE1I=; b=Mk3I5LvbcdH2enCZLcRtbH7CLJcrABl5FnadRx/qdM/FHZCj7iERy5VHVuMolYSCah dMFlNC0mODrivMAcYxH5qCebVw29OtzTQ2E12eWq94Fmy8wHYeizrPOY4qir2QAf84SP cGmJL9lrPHhc1bJAM32/c41c9D55JZK4chyK2TKZp+kXofVIlmyZV4KTkkXNj8FZUXEE AOxvRB6nhtwHLX1iLYaLk8mKSdWLb4Dcvs8K31cmZMjk7Y+OQ/tNpH8LD13SGJYFFlgm UtYXwnlef3AeJ8t3OYShTPFT++SWtaKP888XBANViC1Qy1Cd8b8tBooR9cx+awZ0ecxY nUwg==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:references:in-reply-to:from:date :message-id:subject:to:cc; bh=XEiBHGhv+4tAPegmTDSoVUVNMDr8RBfFc+gkmDaRE1I=; b=cEWWVm28qUosbM/eGExeCC7W2ZIXHEd5KvIrSY2g1Hd87hrV5VdCs81gbFqJtUVfbJ djmNniD4gxTShRpVHK9jxqBo/c+Tev+jasbpSpeuHac8SiMBcOZ9INvPqWPQ/V1o1MAn JG5X8b+r55TRxbKt8tP0U8KfzNjc9h+UoktLOoKGGVZ5vurnnA0mMbNXy0qOC4ClLgvL TcWH3sr8h4XxaPjrTwa+JC64Z4nOX/JwvWt4lVEHmFiusau1wr9Z3aSbchRx3YlhXOjm 3OEgpgHOsruYceFAojSXdTnYtpsKXCZm2k1RDNUl/nYaXWsFftAG/s1Wbtsa/aHhAcHK Y1wQ==
X-Gm-Message-State: APt69E3NLf/d3XaZ9F9JE4+cH+l3Y79pcCo+A/RIUHDRTjBbgQfV+hxN DEyxdy+rdgJ/Jg5bLyXNBMaq7IUXx7aN7TAXClf21g==
X-Google-Smtp-Source: AAOMgpefeqcLwOftHQqUKclzYsgdwAEgLx1Q4+CPqPrAUbbrRAByFyidU8hw+zVkArYM9zeIEkxFyk7bztMoBedJPgY=
X-Received: by 2002:a24:c903:: with SMTP id h3-v6mr13557210itg.87.1530628085424;  Tue, 03 Jul 2018 07:28:05 -0700 (PDT)
MIME-Version: 1.0
References: <CAHbrMsCupObmz5Ye7fdKSt3YOpUsPiH3ReV0UV0g3WuOQH0Zqg@mail.gmail.com> <63a538a6-d761-1372-ebd2-1a5d4a85d743@it.aoyama.ac.jp>
In-Reply-To: <63a538a6-d761-1372-ebd2-1a5d4a85d743@it.aoyama.ac.jp>
From: Ben Schwartz <bemasc@google.com>
Date: Tue, 3 Jul 2018 10:27:54 -0400
Message-ID: <CAHbrMsBMG_+X6s4G3O9ABh-Ehy+xoi-AenhpmRjhmwwaDU-33A@mail.gmail.com>
To: duerst@it.aoyama.ac.jp
Cc: media-types@iana.org, Patrick McManus <mcmanus@ducksong.com>,  Paul Hoffman <paul.hoffman@icann.org>, Adam Roach <adam@nostrum.com>, David Lawrence <tale@dd.org>
Content-Type: multipart/signed; protocol="application/pkcs7-signature"; micalg=sha-256; boundary="0000000000005bbf890570191f5d"
Archived-At: <https://mailarchive.ietf.org/arch/msg/media-types/tAq-kiuwFCRVtJJWjhWjaZzcLzU>
Subject: Re: [media-types] DNS over HTTPS forthcoming Media Type Registration Notice
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.26
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 03 Jul 2018 14:28:09 -0000

--0000000000005bbf890570191f5d
Content-Type: multipart/alternative; boundary="000000000000515b8e0570191f0a"

--000000000000515b8e0570191f0a
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

Here are the contents of Section 8.1, which matches the template form:

   MIME media type name: application

   MIME subtype name: dns-message

   Required parameters: n/a

   Optional parameters: n/a

   Encoding considerations: This is a binary format. The contents are a
   DNS message as defined in RFC 1035. The format used here is for DNS
   over UDP, which is the format defined in the diagrams in RFC 1035.

   Security considerations:  The security considerations for carrying
   this data are the same for carrying DNS without encryption.

   Interoperability considerations:  None.

   Published specification:  This document.

   Applications that use this media type:
     Systems that want to exchange full DNS messages.

   Additional information:

   Magic number(s):  n/a

   File extension(s):  n/a

   Macintosh file type code(s):  n/a

   Person & email address to contact for further information:
      Paul Hoffman, paul.hoffman@icann.org

   Intended usage:  COMMON

   Restrictions on usage:  n/a

   Author:  Paul Hoffman, paul.hoffman@icann.org

   Change controller:  IESG

On Tue, Jul 3, 2018 at 5:51 AM Martin J. D=C3=BCrst <duerst@it.aoyama.ac.jp=
>
wrote:

> Hello Ben,
>
> If at all possible, please submit the registration templates here. That
> greatly increases the chance to get (potentially valuable) comments.
>
> Regards,   Martin.
>
> On 2018/06/28 00:45, Ben Schwartz wrote:
> > Hello Media Type Experts,
> >
> > In accordance with RFC 6838 Section 5.1, I would like to notify you tha=
t
> > the forthcoming draft "DNS over HTTPS" will request a new media type,
> > "application/dns-message".  See
> > https://tools.ietf.org/html/draft-ietf-doh-dns-over-https-11#section-8.=
1
> .
> >
> > I hope we're following this process correctly.
> >
> > --Ben Schwartz, for the DOH Chairs
>
>

--000000000000515b8e0570191f0a
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr">Here are the contents of Section 8.1, which=C2=A0matches t=
he template form:<div><br></div><div><div>=C2=A0 =C2=A0MIME media type name=
: application<br></div><div><br></div><div>=C2=A0 =C2=A0MIME subtype name: =
dns-message</div><div><br></div><div>=C2=A0 =C2=A0Required parameters: n/a<=
/div><div><br></div><div>=C2=A0 =C2=A0Optional parameters: n/a</div><div><b=
r></div><div>=C2=A0 =C2=A0Encoding considerations: This is a binary format.=
 The contents are a</div><div>=C2=A0 =C2=A0DNS message as defined in RFC 10=
35. The format used here is for DNS</div><div>=C2=A0 =C2=A0over UDP, which =
is the format defined in the diagrams in RFC 1035.</div><div><br></div><div=
>=C2=A0 =C2=A0Security considerations:=C2=A0 The security considerations fo=
r carrying</div><div>=C2=A0 =C2=A0this data are the same for carrying DNS w=
ithout encryption.</div><div><br></div><div>=C2=A0 =C2=A0Interoperability c=
onsiderations:=C2=A0 None.</div><div><br></div><div>=C2=A0 =C2=A0Published =
specification:=C2=A0 This document.</div><div><br></div><div>=C2=A0 =C2=A0A=
pplications that use this media type:</div><div>=C2=A0 =C2=A0 =C2=A0Systems=
 that want to exchange full DNS messages.</div><div><br></div><div>=C2=A0 =
=C2=A0Additional information:</div><div><br></div><div>=C2=A0 =C2=A0Magic n=
umber(s):=C2=A0 n/a</div><div><br></div><div>=C2=A0 =C2=A0File extension(s)=
:=C2=A0 n/a</div><div><br></div><div>=C2=A0 =C2=A0Macintosh file type code(=
s):=C2=A0 n/a</div><div><br></div><div>=C2=A0 =C2=A0Person &amp; email addr=
ess to contact for further information:</div><div>=C2=A0 =C2=A0 =C2=A0 Paul=
 Hoffman, <a href=3D"mailto:paul.hoffman@icann.org">paul.hoffman@icann.org<=
/a></div><div><br></div><div>=C2=A0 =C2=A0Intended usage:=C2=A0 COMMON</div=
><div><br></div><div>=C2=A0 =C2=A0Restrictions on usage:=C2=A0 n/a</div><di=
v><br></div><div>=C2=A0 =C2=A0Author:=C2=A0 Paul Hoffman, <a href=3D"mailto=
:paul.hoffman@icann.org">paul.hoffman@icann.org</a></div><div><br></div><di=
v>=C2=A0 =C2=A0Change controller:=C2=A0 IESG</div></div></div><br><div clas=
s=3D"gmail_quote"><div dir=3D"ltr">On Tue, Jul 3, 2018 at 5:51 AM Martin J.=
 D=C3=BCrst &lt;<a href=3D"mailto:duerst@it.aoyama.ac.jp">duerst@it.aoyama.=
ac.jp</a>&gt; wrote:<br></div><blockquote class=3D"gmail_quote" style=3D"ma=
rgin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hello Ben,<br>
<br>
If at all possible, please submit the registration templates here. That <br=
>
greatly increases the chance to get (potentially valuable) comments.<br>
<br>
Regards,=C2=A0 =C2=A0Martin.<br>
<br>
On 2018/06/28 00:45, Ben Schwartz wrote:<br>
&gt; Hello Media Type Experts,<br>
&gt; <br>
&gt; In accordance with RFC 6838 Section 5.1, I would like to notify you th=
at<br>
&gt; the forthcoming draft &quot;DNS over HTTPS&quot; will request a new me=
dia type,<br>
&gt; &quot;application/dns-message&quot;.=C2=A0 See<br>
&gt; <a href=3D"https://tools.ietf.org/html/draft-ietf-doh-dns-over-https-1=
1#section-8.1" rel=3D"noreferrer" target=3D"_blank">https://tools.ietf.org/=
html/draft-ietf-doh-dns-over-https-11#section-8.1</a>.<br>
&gt; <br>
&gt; I hope we&#39;re following this process correctly.<br>
&gt; <br>
&gt; --Ben Schwartz, for the DOH Chairs<br>
<br>
</blockquote></div>

--000000000000515b8e0570191f0a--

--0000000000005bbf890570191f5d
Content-Type: application/pkcs7-signature; name="smime.p7s"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="smime.p7s"
Content-Description: S/MIME Cryptographic Signature
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==
--0000000000005bbf890570191f5d--


From nobody Wed Jul  4 04:39:35 2018
Return-Path: <jwilkes@metabit.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id A5925130ED4 for <media-types@ietfa.amsl.com>; Wed,  4 Jul 2018 04:39:33 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.899
X-Spam-Level: 
X-Spam-Status: No, score=-1.899 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, HTML_MESSAGE=0.001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 9U_199cf5q76 for <media-types@ietfa.amsl.com>; Wed,  4 Jul 2018 04:39:29 -0700 (PDT)
Received: from corwin.metabit.com (corwin.metabit.com [87.234.239.99]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id A17FC130E55 for <media-types@ietf.org>; Wed,  4 Jul 2018 04:39:26 -0700 (PDT)
To: media-types@ietf.org
References: <CAHbrMsCupObmz5Ye7fdKSt3YOpUsPiH3ReV0UV0g3WuOQH0Zqg@mail.gmail.com> <63a538a6-d761-1372-ebd2-1a5d4a85d743@it.aoyama.ac.jp> <CAHbrMsBMG_+X6s4G3O9ABh-Ehy+xoi-AenhpmRjhmwwaDU-33A@mail.gmail.com>
From: Jo Wilkes <jwilkes@metabit.com>
Openpgp: preference=signencrypt
Autocrypt: addr=jwilkes@metabit.com; prefer-encrypt=mutual; keydata= xsFNBFHK368BEADMlhWMZjrN7UBrgoGEGoK21wsv02DNHd030X24AcKpfegN281Ingbw+JZl ZRly5pQlFB8dlPx/PTPqdSPU8XyQJ9sMiZRRlsRvyQGh4hdd6EJrrSF9pO2NgX2xnE5JYVyp xv9X4EFOdUBzcLqFDqB8Vjtm57nzAwkmBQvhxjFcGQEtIFugdqBIlkEo2hK4GAR7S0NwN/JP 63lUuA0HnGUtSBhQVqty7bHLG6dK+3cElklVicB+UwjKu8p3qu5irRUV/FGfIqS+NDlHF9bK hzxecRdT9h7kBUdrTB9000tocbppMObLYQlzH9h0JRveQwR+//8Kn3FkD1UIIUuE5VNcQivP F0Cqzu7hKmVhwpw998qd/+P51Y7wxbLhNBcHXO0RpDNzzaGYy7AnZ0lxyNYinu8bddxiHuBF 0DHrJPe8yzmFj/IkihFf5xJ6+Gmr5QaPR2Fyl3R7kzdp3fNjuv0iPKJVV9gMR6bVtOoP+kDS Sq04yWRyi/03oS48SgJvOmyIfAafcRwYpoZ048YNci96SpQzarjMQ/sVBUYFgJZcWOsIpq4w KoNAyh8fh2deMwzEcUFmSwFkhSD8hmjhqMz/QB+p0zV4/EvWhtGPZBTl90Ux/9Wzumr6uaL1 Y0AIB7HSctumf5iW3QQqRgI+RfnjkmcdvBaE1OIcF/muEovgtQARAQABzVFKLldpbGtlcyAo Sm8gV2lsa2VzICh2b3JtYWxzIGtleUlEIDI5REIxRTFBKSA8andpbGtlc0BnbXgubmV0Pikg PGp3aWxrZXNAZ214Lm5ldD7CwXgEEwECACIFAlHK368CGyMGCwkIBwMCBhUIAgkKCwQWAgMB Ah4BAheAAAoJEJmKQ1ylCCoE0gAP/RrJRhCKoJoath8fUxtOo+hKvcgTPauJcnRka47zDuRY H0tayliXWGTj74EDFT0wITsTbZzxLTRWTezBes+fVq2O2yAmdpjzzVL2O+p+vmS16SvMvqAE wrEYzuMQiU0xwKydJyWqLS0jSIYrijvcZAMnmO6g2jJqF/VQY6Gp5GzBuAL9+OL7XozpuShA SWuEJWHeQ4++zhkFLklwOpMmD0UslwtBN72puvy4V/AveuDmJs7frwh/anrz2N/GjREme1JC uJosQD+HOKEmgbzJ9y+cQCVRQrDaHz5oOvWn4OfexnjB8z//auaGHi54A24o2dAxIf66I+Oh SNzXyz5sgHam7mVBXRab/VXAm0U16YEkQbAdZlDKSRH/vkLh0ZD9rGoUR9/V3bKf+knyVSwN jCCITnMxWmMJ8AgWSqnbM2eKMYiWl1xLAANP9A8WIfUcDy+x1RgkUWYGcg1d5irRF3ikw41G 2tg4H2MyF9t/Y7ZyjrEzIKo7tNnOYuM0k7YEya6+KwASSpmpipff0KUfJFCYYzOOL5WIxQHV gXNJT2VhjlZ4cDjPBr5yCaS5xj3L9lRRJ0LUmWYyEwV9oruKmIrNQKVGW9qHMMAwYzUVL49o G4KuEdoNxK+s+o8cIhioFmFw4REk3EhWE81VM2MW8GRBDCIzwtzMGRdr1lgNQlD0zsFNBFHK 368BEAC01l7Eb2JhtZPMUIsrCPFHOagoizMDMapo4dC0RsknIDh0ibm1mkg8NirOvomko9IP lAdC7jy7spf7IIqEVWGUqm3sMhy+bKhBJ23/pdNqlIPY+XIn5PCojvHCjS4mG+kIfLoI8wc2 JSNaXcRQfie+UffgR4fjO4W3JYwIGEk2XfjdTZlLCe3xcr0ZrU+nlMMCqoSrpuAtirScCCdy 4C0qz/mJwzxxs5mmjZY39pbDV1hrw8h3ztTnEY2tHXD50XkIU574gOoIiHNAIUDG09S+9M6p aXloPgQUB0HsKWOYnrZY/8Tzl+6L9HAt/8Ro84FY4zLqDrpqeQbCJfAX4Iw6Ecm2dfkMownl TEDQXNH0E+ob2XyFKpSRU4Y7qmb10+MUU5MLJaVjSi92mPXhPRnYvUEA9tnJxk8ldJGsJ/vg mjLrqT6qjeayASWiBnxOlM7JAqgg79ZqcOsTbSuDmt2KilzVPoSPeTPiX51JfZ2vxYDRRbVi kk1S8mpyBkvyb/orboWgNmMLJa4RBeCUMo2ZT/YIw0hiHVK/RQj3JuPoY9j1NlGQg8FGm2NF w9DRo0fK1JqE5PDoQlukfbkCLMr+C7DJxs4uBAaK1Q8I6ERbOOEP+WnaxlbzFC502Mi1yhl6 UlBACmSxc/vtn8CJL0Tu/wE4n79ppvcjfKl1RxRtywARAQABwsFfBBgBAgAJBQJRyt+vAhsM AAoJEJmKQ1ylCCoEYccQALl96vccahLt/M3wnNNQ8nRYB3fxq1MzJsuQAZ/sJoFF6ZvJe5ii G8+VEgs1wjMq3U/aFfJokqONRULeHLdPuF6C4CgF96cjRUfDjNAZSIfj6vaW0o/F8FTPYMMj BpD4Wy8dGuEZHI84otzL7CNbk1qXgRnPE2/iq1aGAQUJ9abwYav5mXAkxZ8Ad8MC0YP9MwYG IXFLBhXbW6gneqqbwh2MZltW/ii7xPI5DOSr9js/i1x9jZMtVOhg4dcB9Mjzog2/FUH/AMSH fPZIRCVJ0O8XEOcyKIyt+FTGiPbVl6h1ijeNUx2U0vWdPHHJt4IpNXATeMxLc3U0aOaYaix3 1lP2KeEbeOCMnHFXqxIy9LCbpId08tFTDGsLg5tzeSO3oXRoHgOxhTKAL8zWtVBWtBwuk0Th vwu/1HK5yNspTJ+Sn2NMNWW8N5Mjo2rlva0JcHzn29BeBM0z9l3nKaMIpdxb1pEHEG1v6Rkr B8sbHBDVnZrCHQeLQnybM0w2evM+NUqFvnAOq8HslP05h5TwmmM4Nh1wQxSVsFdFW/kvr/nB EMjakHJoAkc4Jb/cprpsDoGXWzSrvfpMThMSVBjZRKvRTbpSH4S2wZ5HyEbR4xAV6cz9Ru7+ hqW7sclMJk/NmLQG0REH5gygdQ2DoCPk1zXAhKKWZoVbQ5OXFci0fCQt
Message-ID: <e215b873-2fc8-54f7-158c-500dde6f069f@metabit.com>
Date: Wed, 4 Jul 2018 13:39:22 +0200
MIME-Version: 1.0
In-Reply-To: <CAHbrMsBMG_+X6s4G3O9ABh-Ehy+xoi-AenhpmRjhmwwaDU-33A@mail.gmail.com>
Content-Type: multipart/alternative; boundary="------------9E9DEE0C64D58B46F62042F6"
Content-Language: de-DE-1901
Authentication-Results: ORIGINATING; auth=pass smtp.auth=jwilkes@metabit.com smtp.mailfrom=jwilkes@metabit.com
Archived-At: <https://mailarchive.ietf.org/arch/msg/media-types/U7UKzE2RUvv5VQpYxatMwDqpfdc>
Subject: Re: [media-types] DNS over HTTPS forthcoming Media Type Registration Notice
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.26
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 04 Jul 2018 11:39:34 -0000

This is a multi-part message in MIME format.
--------------9E9DEE0C64D58B46F62042F6
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable

Hello Ben,

are there no amendments or additions in regard to size limits (RFC 1035 s=
ection 2.3.4, section 4.2.1)?


Regards,
Jo


Am 2018-07-03 um 16:27 schrieb Ben Schwartz:
> Here are the contents of Section 8.1, which=C2=A0matches the template f=
orm:
>
> =C2=A0 =C2=A0MIME media type name: application
>
> =C2=A0 =C2=A0MIME subtype name: dns-message
>
> =C2=A0 =C2=A0Required parameters: n/a
>
> =C2=A0 =C2=A0Optional parameters: n/a
>
> =C2=A0 =C2=A0Encoding considerations: This is a binary format. The cont=
ents are a
> =C2=A0 =C2=A0DNS message as defined in RFC 1035. The format used here i=
s for DNS
> =C2=A0 =C2=A0over UDP, which is the format defined in the diagrams in R=
FC 1035.
>
> =C2=A0 =C2=A0Security considerations:=C2=A0 The security considerations=
 for carrying
> =C2=A0 =C2=A0this data are the same for carrying DNS without encryption=
=2E
>
> =C2=A0 =C2=A0Interoperability considerations:=C2=A0 None.
>
> =C2=A0 =C2=A0Published specification:=C2=A0 This document.
>
> =C2=A0 =C2=A0Applications that use this media type:
> =C2=A0 =C2=A0 =C2=A0Systems that want to exchange full DNS messages.
>
> =C2=A0 =C2=A0Additional information:
>
> =C2=A0 =C2=A0Magic number(s):=C2=A0 n/a
>
> =C2=A0 =C2=A0File extension(s):=C2=A0 n/a
>
> =C2=A0 =C2=A0Macintosh file type code(s):=C2=A0 n/a
>
> =C2=A0 =C2=A0Person & email address to contact for further information:=

> =C2=A0 =C2=A0 =C2=A0 Paul Hoffman, paul.hoffman@icann.org <mailto:paul.=
hoffman@icann.org>
>
> =C2=A0 =C2=A0Intended usage:=C2=A0 COMMON
>
> =C2=A0 =C2=A0Restrictions on usage:=C2=A0 n/a
>
> =C2=A0 =C2=A0Author:=C2=A0 Paul Hoffman, paul.hoffman@icann.org <mailto=
:paul.hoffman@icann.org>
>
> =C2=A0 =C2=A0Change controller:=C2=A0 IESG
>
> On Tue, Jul 3, 2018 at 5:51 AM Martin J. D=C3=BCrst <duerst@it.aoyama.a=
c.jp <mailto:duerst@it.aoyama.ac.jp>> wrote:
>
>     Hello Ben,
>
>     If at all possible, please submit the registration templates here. =
That
>     greatly increases the chance to get (potentially valuable) comments=
=2E
>
>     Regards,=C2=A0 =C2=A0Martin.
>
>     On 2018/06/28 00:45, Ben Schwartz wrote:
>     > Hello Media Type Experts,
>     >
>     > In accordance with RFC 6838 Section 5.1, I would like to notify y=
ou that
>     > the forthcoming draft "DNS over HTTPS" will request a new media t=
ype,
>     > "application/dns-message".=C2=A0 See
>     > https://tools.ietf.org/html/draft-ietf-doh-dns-over-https-11#sect=
ion-8.1.
>     >
>     > I hope we're following this process correctly.
>     >
>     > --Ben Schwartz, for the DOH Chairs
>
>
>
> _______________________________________________
> media-types mailing list
> media-types@ietf.org
> https://www.ietf.org/mailman/listinfo/media-types


--------------9E9DEE0C64D58B46F62042F6
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: 8bit

<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    <p>Hello Ben,<br>
    </p>
    <p>are there no amendments or additions in regard to size limits
      (RFC 1035 section 2.3.4, section 4.2.1)?<br>
    </p>
    <br>
    Regards,<br>
    Jo<br>
    <br>
    <br>
    <div class="moz-cite-prefix">Am 2018-07-03 um 16:27 schrieb Ben
      Schwartz:<br>
    </div>
    <blockquote type="cite"
cite="mid:CAHbrMsBMG_+X6s4G3O9ABh-Ehy+xoi-AenhpmRjhmwwaDU-33A@mail.gmail.com">
      <div dir="ltr">Here are the contents of Section 8.1, which matches
        the template form:
        <div><br>
        </div>
        <div>
          <div>   MIME media type name: application<br>
          </div>
          <div><br>
          </div>
          <div>   MIME subtype name: dns-message</div>
          <div><br>
          </div>
          <div>   Required parameters: n/a</div>
          <div><br>
          </div>
          <div>   Optional parameters: n/a</div>
          <div><br>
          </div>
          <div>   Encoding considerations: This is a binary format. The
            contents are a</div>
          <div>   DNS message as defined in RFC 1035. The format used
            here is for DNS</div>
          <div>   over UDP, which is the format defined in the diagrams
            in RFC 1035.</div>
          <div><br>
          </div>
          <div>   Security considerations:  The security considerations
            for carrying</div>
          <div>   this data are the same for carrying DNS without
            encryption.</div>
          <div><br>
          </div>
          <div>   Interoperability considerations:  None.</div>
          <div><br>
          </div>
          <div>   Published specification:  This document.</div>
          <div><br>
          </div>
          <div>   Applications that use this media type:</div>
          <div>     Systems that want to exchange full DNS messages.</div>
          <div><br>
          </div>
          <div>   Additional information:</div>
          <div><br>
          </div>
          <div>   Magic number(s):  n/a</div>
          <div><br>
          </div>
          <div>   File extension(s):  n/a</div>
          <div><br>
          </div>
          <div>   Macintosh file type code(s):  n/a</div>
          <div><br>
          </div>
          <div>   Person &amp; email address to contact for further
            information:</div>
          <div>      Paul Hoffman, <a
              href="mailto:paul.hoffman@icann.org"
              moz-do-not-send="true">paul.hoffman@icann.org</a></div>
          <div><br>
          </div>
          <div>   Intended usage:  COMMON</div>
          <div><br>
          </div>
          <div>   Restrictions on usage:  n/a</div>
          <div><br>
          </div>
          <div>   Author:  Paul Hoffman, <a
              href="mailto:paul.hoffman@icann.org"
              moz-do-not-send="true">paul.hoffman@icann.org</a></div>
          <div><br>
          </div>
          <div>   Change controller:  IESG</div>
        </div>
      </div>
      <br>
      <div class="gmail_quote">
        <div dir="ltr">On Tue, Jul 3, 2018 at 5:51 AM Martin J. Dürst
          &lt;<a href="mailto:duerst@it.aoyama.ac.jp"
            moz-do-not-send="true">duerst@it.aoyama.ac.jp</a>&gt; wrote:<br>
        </div>
        <blockquote class="gmail_quote" style="margin:0 0 0
          .8ex;border-left:1px #ccc solid;padding-left:1ex">Hello Ben,<br>
          <br>
          If at all possible, please submit the registration templates
          here. That <br>
          greatly increases the chance to get (potentially valuable)
          comments.<br>
          <br>
          Regards,   Martin.<br>
          <br>
          On 2018/06/28 00:45, Ben Schwartz wrote:<br>
          &gt; Hello Media Type Experts,<br>
          &gt; <br>
          &gt; In accordance with RFC 6838 Section 5.1, I would like to
          notify you that<br>
          &gt; the forthcoming draft "DNS over HTTPS" will request a new
          media type,<br>
          &gt; "application/dns-message".  See<br>
          &gt; <a
href="https://tools.ietf.org/html/draft-ietf-doh-dns-over-https-11#section-8.1"
            rel="noreferrer" target="_blank" moz-do-not-send="true">https://tools.ietf.org/html/draft-ietf-doh-dns-over-https-11#section-8.1</a>.<br>
          &gt; <br>
          &gt; I hope we're following this process correctly.<br>
          &gt; <br>
          &gt; --Ben Schwartz, for the DOH Chairs<br>
          <br>
        </blockquote>
      </div>
      <!--'"--><br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
media-types mailing list
<a class="moz-txt-link-abbreviated" href="mailto:media-types@ietf.org">media-types@ietf.org</a>
<a class="moz-txt-link-freetext" href="https://www.ietf.org/mailman/listinfo/media-types">https://www.ietf.org/mailman/listinfo/media-types</a>
</pre>
    </blockquote>
    <br>
  </body>
</html>

--------------9E9DEE0C64D58B46F62042F6--


From nobody Wed Jul 18 13:51:24 2018
Return-Path: <dev+ietf@seantek.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id D0C91130EA7 for <media-types@ietfa.amsl.com>; Wed, 18 Jul 2018 13:51:21 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.899
X-Spam-Level: 
X-Spam-Status: No, score=-1.899 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, URIBL_BLOCKED=0.001] autolearn=unavailable autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id w5Zcm_aL5yKj for <media-types@ietfa.amsl.com>; Wed, 18 Jul 2018 13:51:19 -0700 (PDT)
Received: from pechora6.dc.icann.org (pechora6.icann.org [IPv6:2620:0:2830:201::1:72]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 70B681271FF for <media-types@ietf.org>; Wed, 18 Jul 2018 13:51:19 -0700 (PDT)
Received: from smtp-out-2.mxes.net (smtp-out-2.mxes.net [67.222.241.118]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by pechora6.dc.icann.org (Postfix) with ESMTPS id C8F281E00FB for <media-types@iana.org>; Wed, 18 Jul 2018 20:51:18 +0000 (UTC)
Received: from Customer-MUA (mua.mxes.net [10.0.0.1]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.mxes.net (Postfix) with ESMTPSA id A69992753F; Wed, 18 Jul 2018 16:50:55 -0400 (EDT)
Content-Type: text/plain; charset=utf-8
Mime-Version: 1.0 (Mac OS X Mail 11.3 \(3445.6.18\))
From: Sean Leonard <dev+ietf@seantek.com>
In-Reply-To: <CAHbrMsBMG_+X6s4G3O9ABh-Ehy+xoi-AenhpmRjhmwwaDU-33A@mail.gmail.com>
Date: Wed, 18 Jul 2018 16:50:54 -0400
Cc: =?utf-8?B?Ik1hcnRpbiBKLiBEw7xyc3Qi?= <duerst@it.aoyama.ac.jp>, Patrick McManus <mcmanus@ducksong.com>, Paul Hoffman <paul.hoffman@icann.org>, Adam Roach <adam@nostrum.com>, media-types@iana.org, David Lawrence <tale@dd.org>
Content-Transfer-Encoding: quoted-printable
Message-Id: <991912F7-5CA4-4466-9FCB-BBA46E2F6F9E@seantek.com>
References: <CAHbrMsCupObmz5Ye7fdKSt3YOpUsPiH3ReV0UV0g3WuOQH0Zqg@mail.gmail.com> <63a538a6-d761-1372-ebd2-1a5d4a85d743@it.aoyama.ac.jp> <CAHbrMsBMG_+X6s4G3O9ABh-Ehy+xoi-AenhpmRjhmwwaDU-33A@mail.gmail.com>
To: Ben Schwartz <bemasc=40google.com@dmarc.ietf.org>
X-Mailer: Apple Mail (2.3445.6.18)
X-Sent-To: <bWVkaWEtdHlwZXNAaWFuYS5vcmc=>
Archived-At: <https://mailarchive.ietf.org/arch/msg/media-types/7lPKP07cSyJ01J1Q2ZSXKTKdSfo>
Subject: Re: [media-types] DNS over HTTPS forthcoming Media Type Registration Notice
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.27
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 18 Jul 2018 20:51:22 -0000

Looks okay to me. Be sure that the published specification is replaced =
with RFC XXXX (this should be obvious, but usually it is denoted as =
[[RFCXXXX]] or [[NOTE to Editor, etc. etc.]]).

Sean

> On Jul 3, 2018, at 10:27 AM, Ben Schwartz =
<bemasc=3D40google.com@dmarc.ietf.org> wrote:
>=20
> Here are the contents of Section 8.1, which matches the template form:
>=20
>    MIME media type name: application
>=20
>    MIME subtype name: dns-message
>=20
>    Required parameters: n/a
>=20
>    Optional parameters: n/a
>=20
>    Encoding considerations: This is a binary format. The contents are =
a
>    DNS message as defined in RFC 1035. The format used here is for DNS
>    over UDP, which is the format defined in the diagrams in RFC 1035.
>=20
>    Security considerations:  The security considerations for carrying
>    this data are the same for carrying DNS without encryption.
>=20
>    Interoperability considerations:  None.
>=20
>    Published specification:  This document.
>=20
>    Applications that use this media type:
>      Systems that want to exchange full DNS messages.
>=20
>    Additional information:
>=20
>    Magic number(s):  n/a
>=20
>    File extension(s):  n/a
>=20
>    Macintosh file type code(s):  n/a
>=20
>    Person & email address to contact for further information:
>       Paul Hoffman, paul.hoffman@icann.org
>=20
>    Intended usage:  COMMON
>=20
>    Restrictions on usage:  n/a
>=20
>    Author:  Paul Hoffman, paul.hoffman@icann.org
>=20
>    Change controller:  IESG
>=20
> On Tue, Jul 3, 2018 at 5:51 AM Martin J. D=C3=BCrst =
<duerst@it.aoyama.ac.jp> wrote:
> Hello Ben,
>=20
> If at all possible, please submit the registration templates here. =
That=20
> greatly increases the chance to get (potentially valuable) comments.
>=20
> Regards,   Martin.
>=20
> On 2018/06/28 00:45, Ben Schwartz wrote:
> > Hello Media Type Experts,
> >=20
> > In accordance with RFC 6838 Section 5.1, I would like to notify you =
that
> > the forthcoming draft "DNS over HTTPS" will request a new media =
type,
> > "application/dns-message".  See
> > =
https://tools.ietf.org/html/draft-ietf-doh-dns-over-https-11#section-8.1.
> >=20
> > I hope we're following this process correctly.
> >=20
> > --Ben Schwartz, for the DOH Chairs
>=20
> _______________________________________________
> media-types mailing list
> media-types@ietf.org
> https://www.ietf.org/mailman/listinfo/media-types


From nobody Sat Jul 28 21:16:03 2018
Return-Path: <poccil14@gmail.com>
X-Original-To: media-types@ietfa.amsl.com
Delivered-To: media-types@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id C479712F18C for <media-types@ietfa.amsl.com>; Sat, 28 Jul 2018 21:16:01 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.749
X-Spam-Level: 
X-Spam-Status: No, score=-1.749 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_ENVFROM_END_DIGIT=0.25, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_PASS=-0.001] autolearn=no autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 5YK6yf1Um7ac for <media-types@ietfa.amsl.com>; Sat, 28 Jul 2018 21:16:00 -0700 (PDT)
Received: from mail-yb0-x22d.google.com (mail-yb0-x22d.google.com [IPv6:2607:f8b0:4002:c09::22d]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id DDDA0127332 for <media-types@ietf.org>; Sat, 28 Jul 2018 21:15:59 -0700 (PDT)
Received: by mail-yb0-x22d.google.com with SMTP id k124-v6so3551655ybk.6 for <media-types@ietf.org>; Sat, 28 Jul 2018 21:15:59 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025;  h=message-id:mime-version:to:from:subject:date:importance; bh=ldmRMkLKiBc4xkX8qA2i6F5VMmWseAjwGEqefp2jJCQ=; b=nUVw/W3vNCq3y1Wf/gVTTvJsZKLqvFb4qRYqbd42QOVEPnTnSOq3ET2Uc/bCDb7mNE srKxJ9kPk8GWs7cWGxTl0j94f44Qs4a73lxIwC4YHqZFSX62DPeDzbUVFYqw2KCunC+1 Xkz3ACAAgxVhlORxuCZg12VgykM1yfw/ywfx/lOdlkOAsVjoFMLtETJDbSM7dxiApxJs k6Tt87ZQLU4oKQQlToHcuiMUYcejTWf8CyMdqOISMiSDsYLp3TCbU6LK+vix/aZx4aVP O+fGhiLGnhA3/rjDYyuG+XzWpo1GQEPfSwRgCelO3gI9rCJbwlZOldQOHyeDPUAZ2Tnr mCPg==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:message-id:mime-version:to:from:subject:date :importance; bh=ldmRMkLKiBc4xkX8qA2i6F5VMmWseAjwGEqefp2jJCQ=; b=OMXwGgQakGRFDEunCP2gGAPx6PGNX2I8A8ySpU7aFypqHAjz+mXKu9nzYyHcreTN5B PRGWUwexMjG2dLu+bQHpmQaoSfow5OyJU0N8buv9NBIP60x76hlwBZMQoqW06nrphVoT xXyMn+w4WFKjcwVbrSfZperUxzR8gLyLujDcqFCFzWjFm7T0VUowPRKHmjQDhf6NhltT 4yLVU+SeZ0ymS9l/DEam9ElSY/aHfv0k0xBTzzq3ScoOk3BYfnVtILIROMlJLng3Fdnq M3QEhCwUT72ILmNeho8WNtyexe7664kgfx4g/u9EQZKClAADJPW0Q1K8SgnGrcpnvUY8 roIA==
X-Gm-Message-State: AOUpUlGT024zAbP4kivFYhRSs9HgPLwsbUIcS9g75e1SPPAqGEY4Niur YHcyqobXDDXZ34edRYB7Ttmk66Gr
X-Google-Smtp-Source: AAOMgpcQ/V+/jlFS8EbN371F8/x5lIsvp+E9nuJjj0FHNkfkUrmC1fmDhWAB9TS0pOWBMJs3GyukPw==
X-Received: by 2002:a25:860a:: with SMTP id y10-v6mr6613638ybk.327.1532837758625;  Sat, 28 Jul 2018 21:15:58 -0700 (PDT)
Received: from ?IPv6:2601:192:4e00:596:22:8b71:4eb9:6006? ([2601:192:4e00:596:22:8b71:4eb9:6006]) by smtp.gmail.com with ESMTPSA id 203-v6sm3564600ywv.34.2018.07.28.21.15.57 for <media-types@ietf.org> (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Sat, 28 Jul 2018 21:15:58 -0700 (PDT)
Message-ID: <5b5d3f7e.1c69fb81.304f4.1280@mx.google.com>
MIME-Version: 1.0
To: "media-types@ietf.org" <media-types@ietf.org>
From: Peter Occil <poccil14@gmail.com>
Date: Sun, 29 Jul 2018 00:15:59 -0400
Importance: normal
X-Priority: 3
Content-Type: multipart/alternative; boundary="_C627CA8E-20A6-4650-96AE-5B19ABF77823_"
Archived-At: <https://mailarchive.ietf.org/arch/msg/media-types/DMDWjQc3EmNZ4uQy8OSZoIpYkdo>
Subject: [media-types] Default charset parameter for text media types
X-BeenThere: media-types@ietf.org
X-Mailman-Version: 2.1.27
Precedence: list
List-Id: "IANA mailing list for reviewing Media Type \(MIME Type, Content Type\) registration requests." <media-types.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/media-types>, <mailto:media-types-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/media-types/>
List-Post: <mailto:media-types@ietf.org>
List-Help: <mailto:media-types-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/media-types>, <mailto:media-types-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sun, 29 Jul 2018 04:16:02 -0000

--_C627CA8E-20A6-4650-96AE-5B19ABF77823_
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain; charset="utf-8"

What is the default charset parameter when that parameter is absent from a =
text media type?  Before RFC 6657, the answer was simple: US-ASCII.  Howeve=
r, things have become more complicated since that RFC was published -- RFC =
6657 says:

   [A]ll new "text/*" registrations [that is, registrations after July 2012=
] MUST clearly specify how the charset is determined[.] However, existing "=
text/*" registrations [before July 2012] that fail to specify how the chars=
et is determined still default to US-ASCII.

This would be easy if all existing and new text media types "specif[ied] ho=
w the charset is determined".  Unfortunately this is not the case.

Although I have managed to categorize all text media types into three categ=
ories: "no default", "US-ASCII default", and "UTF-8 default", deciding whic=
h category a media type falls in is not always trivial, since it depends am=
ong other things on when the media type was registered, whether it treats t=
he charset parameter as required, optional, or not used, and whether the te=
xt is always ASCII or always UTF-8.

What follows are notes that explain how each text media type is assigned on=
e of those three categories (source is my MailLib library's MediaType.cs). =
 They may be helpful in the process of revising some of those media types s=
o that they "clearly specify how the charset is determined", as RFC 6657 re=
quires for media type registrations after July 2012.

      // NOTE: RFC6657 changed the rules for the default charset in text
      // media types, so that there is no default charset for as yet
      // undefined media types. However,
      // media types defined before this RFC (July 2012) are grandfathered
      // from the rule: those
      // media types "that fail to specify how the charset is determined" s=
till
      // have US-ASCII as default. The text media types defined as of
      // Jul. 11, 2018, are listed below:
      //
      // -- No default charset assumed: --
      //
      // RTP payload types; these are usually unsuitable for MIME,
      // and don't permit a charset parameter, so a default charset is
      // irrelevant:
      // -- 1d-interleaved-parityfec, fwdred, red, parityfec, encaprtp,
      // raptorfec, rtp-enc-aescm128, t140, ulpfec, rtx, rtploopback
      //
      // Charset determined out-of-band:
      // -- vnd.motorola.reflex*(5)*(10)
      //
      // Special procedure defined for charset detection:
      // -- ecmascript*(8), javascript*(8), html,
      // rtf*(5)
      //
      // XML formats (no default assumed if charset is absent, according
      // to RFC7303, the revision of the XML media type specification):
      // -- xml, xml-external-parsed-entity,
      // vnd.in3d.3dml*, vnd.iptc.newsml, vnd.iptc.nitf,
      // vnd.ms-mediapackage*(5),
      // vnd.net2phone.commcenter.command, vnd.radisys.msml-basic-layout,
      // vnd.wap.si, vnd.wap.sl, vnd.wap.wml
      //
      // Behavior deliberately undefined (so whether US-ASCII or another
      // charset is treated as default is irrelevant):
      // -- example
      //
      // These media types don't define a charset parameter (after
      // RFC6657):
      // -- grammar-ref-list*(9), vnd.hgl*(6)*(9), vnd.gml*(9)
      //
      // Uses charset parameter, but no default charset specified (after
      // RFC6657):
      // -- markdown*
      //
      // -- US-ASCII assumed: --
      //
      // These media types don't define a charset parameter (before
      // RFC6657):
      // -- dns, mizar, vnd.latex-z,
      // prs.lines.tag, vnd.dmclientscript,
      // vnd.dvb.subtitle, rfc822-headers,
      // vnd.si.uricatalogue*(7), vnd.si.fly*(7)
      //
      // No charset parameter defined, but does specify ASCII only (after
      // RFC6657):
      // -- vnd.ascii-art****, prs.prop.logic*
      //
      // These media types don't define a default charset:
      // -- css, richtext, enriched, tab-separated-values*,
      // vnd.in3d.spot*, vnd.abc, vnd.wap.wmlscript, vnd.curl,
      // vnd.fmi.flexstor, uri-list, directory*
      //
      // US-ASCII default:
      // -- plain, sgml, troff
      //
      // -- UTF-8 assumed: --
      //
      // UTF-8 only:
      // -- vcard, jcr-cnd, cache-manifest
      //
      // Charset parameter defined but is "always ... UTF-8":
      // -- n3, turtle, vnd.debian.copyright, provenance-notation
      //
      // UTF-8 default:
      // -- csv, calendar**, vnd.a***, parameters, prs.fallenstein.rst,
      // vnd.esmertec.theme.descriptor, vnd.trolltech.linguist,
      // vnd.graphviz, vnd.sun.j2me.app-descriptor, strings*(5),
      // csv-schema*(5)
      //
      // * Required parameter.
      // ** No explicit default, but says that "[t]he charset supported
      // by this revision of iCalendar is UTF-8."
      // *(5) No charset parameter defined.
      // *(6) 8-bit encoding.
      // *(7) Says "US-ASCII" is always used, or otherwise says
      // the media type contains ASCII text
      // *(8) RFC4329: If charset unrecognized, check for UTF-8/16/32 BOM i=
f it
      // exists; otherwise use UTF-8. If UTF-8, ignore UTF-8 BOM
      // *(9) After RFC 6657.
      // *(10) Charset determined "in an a priori manner", rather than
      // being stated in the payload.
      // *** Default is UTF-8 "if 8-bit bytes are encountered" (even if
      // none are found, though, a 7-bit ASCII text is still also UTF-8).
      // **** Content containing non-ASCII bytes "should be rejected".

--Peter

--_C627CA8E-20A6-4650-96AE-5B19ABF77823_
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html; charset="utf-8"

<html xmlns:o=3D"urn:schemas-microsoft-com:office:office" xmlns:w=3D"urn:sc=
hemas-microsoft-com:office:word" xmlns:m=3D"http://schemas.microsoft.com/of=
fice/2004/12/omml" xmlns=3D"http://www.w3.org/TR/REC-html40"><head><meta ht=
tp-equiv=3DContent-Type content=3D"text/html; charset=3Dutf-8"><meta name=
=3DGenerator content=3D"Microsoft Word 15 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
	{font-family:"Cambria Math";
	panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
	{font-family:Calibri;
	panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
	{margin:0in;
	margin-bottom:.0001pt;
	font-size:11.0pt;
	font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
	{mso-style-priority:99;
	color:blue;
	text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
	{mso-style-priority:99;
	color:#954F72;
	text-decoration:underline;}
.MsoChpDefault
	{mso-style-type:export-only;}
@page WordSection1
	{size:8.5in 11.0in;
	margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
	{page:WordSection1;}
--></style></head><body lang=3DEN-US link=3Dblue vlink=3D"#954F72"><div cla=
ss=3DWordSection1><p class=3DMsoNormal>What is the default charset paramete=
r when that parameter is absent from a text media type?=C2=A0 Before RFC 66=
57, the answer was simple: US-ASCII.=C2=A0 However, things have become more=
 complicated since that RFC was published -- RFC 6657 says:</p><p class=3DM=
soNormal><o:p>&nbsp;</o:p></p><p class=3DMsoNormal>=C2=A0=C2=A0 [A]ll new &=
quot;text/*&quot; registrations [that is, registrations after July 2012] MU=
ST clearly specify how the charset is determined[.] However, existing &quot=
;text/*&quot; registrations [before July 2012] that fail to specify how the=
 charset is determined still default to US-ASCII.</p><p class=3DMsoNormal><=
o:p>&nbsp;</o:p></p><p class=3DMsoNormal>This would be easy if all existing=
 and new text media types &quot;specif[ied] how the charset is determined&q=
uot;.=C2=A0 Unfortunately this is not the case.</p><p class=3DMsoNormal><o:=
p>&nbsp;</o:p></p><p class=3DMsoNormal>Although I have managed to categoriz=
e all text media types into three categories: &quot;no default&quot;, &quot=
;US-ASCII default&quot;, and &quot;UTF-8 default&quot;, deciding which cate=
gory a media type falls in is not always trivial, since it depends among ot=
her things on when the media type was registered, whether it treats the cha=
rset parameter as required, optional, or not used, and whether the text is =
always ASCII or always UTF-8.</p><p class=3DMsoNormal><o:p>&nbsp;</o:p></p>=
<p class=3DMsoNormal>What follows are notes that explain how each text medi=
a type is assigned one of those three categories (source is my MailLib libr=
ary's MediaType.cs).=C2=A0 They may be helpful in the process of revising s=
ome of those media types so that they &quot;clearly specify how the charset=
 is determined&quot;, as RFC 6657 requires for media type registrations aft=
er July 2012.</p><p class=3DMsoNormal><o:p>&nbsp;</o:p></p><p class=3DMsoNo=
rmal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // NOTE: RFC6657 changed the rules for =
the default charset in text</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0 // media types, so that there is no default charset for as yet</p=
><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // undefined media typ=
es. However,</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // medi=
a types defined before this RFC (July 2012) are grandfathered</p><p class=
=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // from the rule: those</p><p c=
lass=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // media types &quot;that f=
ail to specify how the charset is determined&quot; still</p><p class=3DMsoN=
ormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // have US-ASCII as default. The text =
media types defined as of</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0 // Jul. 11, 2018, are listed below:</p><p class=3DMsoNormal>=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0 // -- No default charset assumed: --</p><p class=3DMsoNormal>=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0 // RTP payload types; these are usually unsuitable for MIME,</=
p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // and don't permit a=
 charset parameter, so a default charset is</p><p class=3DMsoNormal>=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0 // irrelevant:</p><p class=3DMsoNormal>=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0 // -- 1d-interleaved-parityfec, fwdred, red, parityfe=
c, encaprtp,</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // rapt=
orfec, rtp-enc-aescm128, t140, ulpfec, rtx, rtploopback</p><p class=3DMsoNo=
rmal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0 // Charset determined out-of-band:</p><p class=3DMsoNorm=
al>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // -- vnd.motorola.reflex*(5)*(10)</p><p =
class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal=
>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // Special procedure defined for charset de=
tection:</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // -- ecmas=
cript*(8), javascript*(8), html,</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0 // rtf*(5)</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0 //</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // XML format=
s (no default assumed if charset is absent, according</p><p class=3DMsoNorm=
al>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // to RFC7303, the revision of the XML me=
dia type specification):</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0 // -- xml, xml-external-parsed-entity,</p><p class=3DMsoNormal>=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0 // vnd.in3d.3dml*, vnd.iptc.newsml, vnd.iptc.ni=
tf,</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // vnd.ms-mediap=
ackage*(5),</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // vnd.n=
et2phone.commcenter.command, vnd.radisys.msml-basic-layout,</p><p class=3DM=
soNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // vnd.wap.si, vnd.wap.sl, vnd.wap.=
wml</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=
=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // Behavior deliberately undefi=
ned (so whether US-ASCII or another</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 // charset is treated as default is irrelevant):</p><p clas=
s=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // -- example</p><p class=3DMs=
oNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0 // These media types don't define a charset parameter=
 (after</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // RFC6657):=
</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // -- grammar-ref-l=
ist*(9), vnd.hgl*(6)*(9), vnd.gml*(9)</p><p class=3DMsoNormal>=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0 // Uses charset parameter, but no default charset specified (after</p><=
p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // RFC6657):</p><p class=
=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // -- markdown*</p><p class=3DM=
soNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0 // -- US-ASCII assumed: --</p><p class=3DMsoNormal=
>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 // These media types don't define a charset parameter (befo=
re</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // RFC6657):</p><=
p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // -- dns, mizar, vnd.la=
tex-z,</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // prs.lines.=
tag, vnd.dmclientscript,</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0 // vnd.dvb.subtitle, rfc822-headers,</p><p class=3DMsoNormal>=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0 // vnd.si.uricatalogue*(7), vnd.si.fly*(7)</p><p c=
lass=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // No charset parameter defined, but does sp=
ecify ASCII only (after</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0 // RFC6657):</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // =
-- vnd.ascii-art****, prs.prop.logic*</p><p class=3DMsoNormal>=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0 // These media types don't define a default charset:</p><p class=3DMsoN=
ormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // -- css, richtext, enriched, tab-sep=
arated-values*,</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // v=
nd.in3d.spot*, vnd.abc, vnd.wap.wmlscript, vnd.curl,</p><p class=3DMsoNorma=
l>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // vnd.fmi.flexstor, uri-list, directory*<=
/p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMso=
Normal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // US-ASCII default:</p><p class=3DMs=
oNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // -- plain, sgml, troff</p><p class=
=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0 // -- UTF-8 assumed: --</p><p class=3DMsoNormal=
>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 // UTF-8 only:</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0 // -- vcard, jcr-cnd, cache-manifest</p><p class=3DMsoNormal>=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 // Charset parameter defined but is &quot;always ... UTF-8&=
quot;:</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // -- n3, tur=
tle, vnd.debian.copyright, provenance-notation</p><p class=3DMsoNormal>=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0 // UTF-8 default:</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0 // -- csv, calendar**, vnd.a***, parameters, prs.fallenstein.r=
st,</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // vnd.esmertec.=
theme.descriptor, vnd.trolltech.linguist,</p><p class=3DMsoNormal>=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0 // vnd.graphviz, vnd.sun.j2me.app-descriptor, strings=
*(5),</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // csv-schema*=
(5)</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 //</p><p class=
=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // * Required parameter.</p><p =
class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // ** No explicit default,=
 but says that &quot;[t]he charset supported</p><p class=3DMsoNormal>=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0 // by this revision of iCalendar is UTF-8.&quot;</=
p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // *(5) No charset pa=
rameter defined.</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // =
*(6) 8-bit encoding.</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
 // *(7) Says &quot;US-ASCII&quot; is always used, or otherwise says</p><p =
class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // the media type contains=
 ASCII text</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // *(8) =
RFC4329: If charset unrecognized, check for UTF-8/16/32 BOM if it</p><p cla=
ss=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // exists; otherwise use UTF-=
8. If UTF-8, ignore UTF-8 BOM</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0 // *(9) After RFC 6657.</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 // *(10) Charset determined &quot;in an a priori manner&quo=
t;, rather than</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // b=
eing stated in the payload.</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0 // *** Default is UTF-8 &quot;if 8-bit bytes are encountered&quot=
; (even if</p><p class=3DMsoNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // none a=
re found, though, a 7-bit ASCII text is still also UTF-8).</p><p class=3DMs=
oNormal>=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 // **** Content containing non-ASCII=
 bytes &quot;should be rejected&quot;.</p><p class=3DMsoNormal><o:p>&nbsp;<=
/o:p></p><p class=3DMsoNormal>--Peter</p></div></body></html>=

--_C627CA8E-20A6-4650-96AE-5B19ABF77823_--

