
From javi@trajano.us.es  Fri Jan 28 17:10:30 2011
Return-Path: <javi@trajano.us.es>
X-Original-To: megaco@core3.amsl.com
Delivered-To: megaco@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 80A1E3A6998 for <megaco@core3.amsl.com>; Fri, 28 Jan 2011 17:10:30 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.599
X-Spam-Level: 
X-Spam-Status: No, score=-6.599 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 2CGzS91dRass for <megaco@core3.amsl.com>; Fri, 28 Jan 2011 17:10:29 -0800 (PST)
Received: from mail.us.es (mail.us.es [193.147.175.20]) by core3.amsl.com (Postfix) with ESMTP id 18F2A3A69A2 for <megaco@ietf.org>; Fri, 28 Jan 2011 17:10:28 -0800 (PST)
Received: (qmail 26683 invoked from network); 29 Jan 2011 02:13:36 +0100
Received: from unknown (HELO us.es) (192.168.2.12) by us.es with SMTP; 29 Jan 2011 02:13:36 +0100
Received: (qmail 31986 invoked by uid 507); 29 Jan 2011 01:13:35 -0000
Received: from 127.0.0.1 by antivirus2 (envelope-from <javi@trajano.us.es>, uid 501) with qmail-scanner-2.08 (clamdscan: 0.96.5/12583.   Clear:RC:1(127.0.0.1):.  Processed in 0.030516 secs); 29 Jan 2011 01:13:35 -0000
Received: from unknown (HELO antivirus2) (127.0.0.1) by us.es with SMTP; 29 Jan 2011 01:13:35 -0000
Received: from 192.168.1.13 (192.168.1.13) by antivirus2 (F-Secure/fsigk_smtp/403/antivirus2); Sat, 29 Jan 2011 02:13:35 +0100 (CET)
X-Virus-Status: clean(F-Secure/fsigk_smtp/403/antivirus2)
Received: (qmail 4066 invoked from network); 29 Jan 2011 02:13:34 +0100
Received: from trajano.us.es (193.147.162.130) by us.es with AES256-SHA encrypted SMTP; 29 Jan 2011 02:13:34 +0100
Received: from [192.168.1.40] (10.Red-81-33-38.dynamicIP.rima-tde.net [81.33.38.10]) (authenticated bits=0) by trajano.us.es (8.13.8/8.13.8/Debian-3) with ESMTP id p0T1DYAG007713;  Sat, 29 Jan 2011 02:13:34 +0100
Message-ID: <4D4369B7.3020100@trajano.us.es>
Date: Sat, 29 Jan 2011 02:13:27 +0100
From: Javi <javi@trajano.us.es>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7
MIME-Version: 1.0
To: megaco@ietf.org
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
Subject: [Megaco] TDMPW and MeGaCo/SDP
X-BeenThere: megaco@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Media Gateway Control <megaco.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/megaco>, <mailto:megaco-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/megaco>
List-Post: <mailto:megaco@ietf.org>
List-Help: <mailto:megaco-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/megaco>, <mailto:megaco-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sat, 29 Jan 2011 01:10:30 -0000

Assuming the next situation:

ISDN Terminal 1  -   MG1 -  [IP network] -  MG2   -   ISDN Terminal 2

where the MGs (Media Gateway) are controlled by a MGC (Media Gateway 
Controller) via MeGaCo[H.248.1].

[ITU-T Y.2262 / Annex IV] proposses that MGs may transport ISDN 
B-channels over the IP network:

+ By a single RTP session (when monochannels ISDN services)

+ Or by TDMoIP (= UDP TDMPWs), when multichannels ISDN services.


How may MGC indicate to the MG that it uses PWs at the IP termination?

It may be done by MeGaCo, using SDP[RFC4566] at Local/Remote 
descriptors. However, how may be that SDP description of TDMPWs?

Thanks,

Javier Muņoz



From albrecht.schwarz@alcatel-lucent.com  Mon Jan 31 00:00:21 2011
Return-Path: <albrecht.schwarz@alcatel-lucent.com>
X-Original-To: megaco@core3.amsl.com
Delivered-To: megaco@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id DBACF3A6BAF for <megaco@core3.amsl.com>; Mon, 31 Jan 2011 00:00:21 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -5.457
X-Spam-Level: 
X-Spam-Status: No, score=-5.457 tagged_above=-999 required=5 tests=[AWL=0.792,  BAYES_00=-2.599, HELO_EQ_FR=0.35, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 8oWbzbGfo3ei for <megaco@core3.amsl.com>; Mon, 31 Jan 2011 00:00:20 -0800 (PST)
Received: from smail3.alcatel.fr (smail3.alcatel.fr [64.208.49.56]) by core3.amsl.com (Postfix) with ESMTP id 890593A6BAE for <megaco@ietf.org>; Mon, 31 Jan 2011 00:00:19 -0800 (PST)
Received: from FRMRSSXCHHUB03.dc-m.alcatel-lucent.com (FRMRSSXCHHUB03.dc-m.alcatel-lucent.com [135.120.45.63]) by smail3.alcatel.fr (8.14.3/8.14.3/ICT) with ESMTP id p0V83V8v017832 (version=TLSv1/SSLv3 cipher=RC4-MD5 bits=128 verify=NOT); Mon, 31 Jan 2011 09:03:32 +0100
Received: from FRMRSSXCHMBSD2.dc-m.alcatel-lucent.com ([135.120.45.53]) by FRMRSSXCHHUB03.dc-m.alcatel-lucent.com ([135.120.45.63]) with mapi; Mon, 31 Jan 2011 09:03:32 +0100
From: "Schwarz, Albrecht (Albrecht)" <albrecht.schwarz@alcatel-lucent.com>
To: Javi <javi@trajano.us.es>, "megaco@ietf.org" <megaco@ietf.org>
Date: Mon, 31 Jan 2011 09:03:30 +0100
Thread-Topic: [Megaco] TDMPW and MeGaCo/SDP
Thread-Index: Acu/Udl404G/FI0xSsWXBeBemAminwByo+ng
Message-ID: <5F7BCCF5541B7444830A2288ABBEBC961D50018F98@FRMRSSXCHMBSD2.dc-m.alcatel-lucent.com>
References: <4D4369B7.3020100@trajano.us.es>
In-Reply-To: <4D4369B7.3020100@trajano.us.es>
Accept-Language: de-DE, en-US
Content-Language: en-US
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
acceptlanguage: de-DE, en-US
Content-Type: multipart/alternative; boundary="_000_5F7BCCF5541B7444830A2288ABBEBC961D50018F98FRMRSSXCHMBSD_"
MIME-Version: 1.0
X-Scanned-By: MIMEDefang 2.64 on 155.132.188.83
Subject: Re: [Megaco] TDMPW and MeGaCo/SDP
X-BeenThere: megaco@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Media Gateway Control <megaco.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/megaco>, <mailto:megaco-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/megaco>
List-Post: <mailto:megaco@ietf.org>
List-Help: <mailto:megaco-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/megaco>, <mailto:megaco-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 31 Jan 2011 08:00:22 -0000

--_000_5F7BCCF5541B7444830A2288ABBEBC961D50018F98FRMRSSXCHMBSD_
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Note: the referred text relates to an Appendix ( =3D informativ), not to an=
 Annex (=3D normativ). Thus, just examples, not mandatory.

Replies:
there are H.248 profile specifications with support support of monorate emu=
lation, see e.g.

ETSI ES 283 024, Trunking Gateway
5.15.1.4        Clearmode codec
On IMS/NGN Terminations, Clearmode codec is transported according to RFC 40=
40 [15].
When the MGC determines that a 64 kbit/s unrestricted bearer service is req=
uested, the clearmode codec shall be used. A Dynamic Payload type with CLEA=
RMODE as encoding name shall be included in both the local and remote descr=
iptor.
The behaviour of the TMGW shall then conform to RFC 4040 [15]. All voice an=
d signal processing functions such as silence suppression, comfort noise in=
sertion and gain adjustment shall be automatically turned off. The MG shall=
 inherit the same QoS objectives as the ISDN bearer service.

However, there was never any H.248 Profile standardized with multirate supp=
ort, at least to my knowledge.
(I'm aware of vendor specific profile, but that are proprietary solutions.)
-Albrecht

__
Y.2262 PSTN/ISDN emulation and simulation, Appendix IV
Examples of emulation of PSTN and N-ISDN bearer services
(This appendix does not form an integral part of this Recommendation)

Examples for the emulation of PSTN and N-ISDN bearer services are provided:

1) Monorate bearer services (=3D 1 =D7 64-kbit/s digital bearer in PSTN/ISD=
N)
* ITU-T Recommendations I.231.2 and I.231.3 may be emulated by a single RTP
session, with or without RTP control protocol (RTCP), using an RTP profile =
according
to IETF RFC 3551.
* ITU-T Recommendation I.231.1 may be emulated by a single RTP session, wit=
h or
without RTCP, using RTP clearmode according to IETF RFC 4040.

2) Multirate bearer services (=3D N =D7 64-kbit/s digital bearer in PSTN/IS=
DN; N greater than one)
* ITU-T Recommendations I.231.4 to I.231.10 may be emulated by TDMoIP descr=
ibed
in ITU-T Recommendation Y.1453.


> -----Original Message-----
> From: megaco-bounces@ietf.org
> [mailto:megaco-bounces@ietf.org] On Behalf Of Javi
> Sent: Samstag, 29. Januar 2011 02:13
> To: megaco@ietf.org
> Subject: [Megaco] TDMPW and MeGaCo/SDP
>
> Assuming the next situation:
>
> ISDN Terminal 1  -   MG1 -  [IP network] -  MG2   -   ISDN Terminal 2
>
> where the MGs (Media Gateway) are controlled by a MGC (Media Gateway
> Controller) via MeGaCo[H.248.1].
>
> [ITU-T Y.2262 / Annex IV] proposses that MGs may transport
> ISDN B-channels over the IP network:
>
> + By a single RTP session (when monochannels ISDN services)
>
> + Or by TDMoIP (=3D UDP TDMPWs), when multichannels ISDN services.
>
>
> How may MGC indicate to the MG that it uses PWs at the IP termination?
>
> It may be done by MeGaCo, using SDP[RFC4566] at Local/Remote
> descriptors. However, how may be that SDP description of TDMPWs?
>
> Thanks,
>
> Javier Mu=F1oz
>
>
> _______________________________________________
> Megaco mailing list
> Megaco@ietf.org
> https://www.ietf.org/mailman/listinfo/megaco
>

--_000_5F7BCCF5541B7444830A2288ABBEBC961D50018F98FRMRSSXCHMBSD_
Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD><TITLE></TITLE>
<META http-equiv=3DContent-Type content=3D"text/html; charset=3Diso-8859-1"=
>
<META content=3D"MSHTML 6.00.2900.6049" name=3DGENERATOR></HEAD>
<BODY><!-- Converted from text/plain format -->
<P><FONT size=3D2><FONT face=3D"Courier New">Note: the referred text relate=
s to an=20
Appendix ( =3D informativ), not to an Annex (=3D normativ). Thus, just exam=
ples, not=20
mandatory.<BR><BR>Replies:<BR>there are H.248 profile specifications with=20
support support of <EM><STRONG>monorate</STRONG></EM> emulation, see=20
e.g.<BR><BR><STRONG>ETSI ES 283 024, Trunking=20
Gateway<BR></STRONG><EM>5.15.1.4&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;=
=20
Clearmode codec<BR>On IMS/NGN Terminations, Clearmode codec is transported=
=20
according to RFC 4040 [15].<BR>When the MGC determines that a 64 kbit/s=20
unrestricted bearer service is requested, the clearmode codec shall be used=
. A=20
Dynamic Payload type with CLEARMODE as encoding name shall be included in b=
oth=20
the local and remote descriptor.<BR>The behaviour of the TMGW shall then co=
nform=20
to RFC 4040 [15]. All voice and signal processing functions such as silence=
=20
suppression, comfort noise insertion and gain adjustment shall be automatic=
ally=20
turned off. The MG shall inherit the same QoS objectives as the ISDN bearer=
=20
service.<BR></EM></FONT></FONT></P>
<DIV><FONT size=3D2><FONT face=3D"Courier New">However, there was never any=
 H.248=20
Profile standardized with <EM><STRONG>multirate</STRONG></EM> support, at l=
east=20
to my knowledge.</FONT></FONT></DIV>
<DIV><FONT face=3D"Courier New" size=3D2>(I'm aware of vendor specific prof=
ile, but=20
that are proprietary solutions.)</FONT></DIV>
<DIV><FONT face=3D"Courier New" size=3D2>-Albrecht</FONT><FONT size=3D2><FO=
NT=20
face=3D"Courier New"><BR><BR>__<BR><EM><STRONG>Y.2262 PSTN/ISDN emulation a=
nd=20
simulation, Appendix IV<BR>Examples of emulation of PSTN and N-ISDN bearer=
=20
services<BR></STRONG>(This appendix does not form an integral part of this=
=20
Recommendation)<BR><BR>Examples for the emulation of PSTN and N-ISDN bearer=
=20
services are provided:<BR><BR>1) Monorate bearer services (=3D 1 =D7 64-kbi=
t/s=20
digital bearer in PSTN/ISDN)<BR>=95 ITU-T Recommendations I.231.2 and I.231=
.3 may=20
be emulated by a single RTP<BR>session, with or without RTP control protoco=
l=20
(RTCP), using an RTP profile according<BR>to IETF RFC 3551.<BR>=95 ITU-T=20
Recommendation I.231.1 may be emulated by a single RTP session, with=20
or<BR>without RTCP, using RTP clearmode according to IETF RFC 4040.<BR><BR>=
2)=20
Multirate bearer services (=3D N =D7 64-kbit/s digital bearer in PSTN/ISDN;=
 N=20
greater than one)<BR>=95 ITU-T Recommendations I.231.4 to I.231.10 may be e=
mulated=20
by TDMoIP described<BR>in ITU-T Recommendation=20
Y.1453.<BR><BR></EM></FONT><BR>&gt; -----Original Message-----<BR>&gt; From=
:=20
megaco-bounces@ietf.org<BR>&gt; [<A=20
href=3D"mailto:megaco-bounces@ietf.org">mailto:megaco-bounces@ietf.org</A>]=
 On=20
Behalf Of Javi<BR>&gt; Sent: Samstag, 29. Januar 2011 02:13<BR>&gt; To:=20
megaco@ietf.org<BR>&gt; Subject: [Megaco] TDMPW and MeGaCo/SDP<BR>&gt;<BR>&=
gt;=20
Assuming the next situation:<BR>&gt;<BR>&gt; ISDN Terminal 1&nbsp; -&nbsp;&=
nbsp;=20
MG1 -&nbsp; [IP network] -&nbsp; MG2&nbsp;&nbsp; -&nbsp;&nbsp; ISDN Termina=
l=20
2<BR>&gt;<BR>&gt; where the MGs (Media Gateway) are controlled by a MGC (Me=
dia=20
Gateway<BR>&gt; Controller) via MeGaCo[H.248.1].<BR>&gt;<BR>&gt; [ITU-T Y.2=
262 /=20
Annex IV] proposses that MGs may transport<BR>&gt; ISDN B-channels over the=
 IP=20
network:<BR>&gt;<BR>&gt; + By a single RTP session (when monochannels ISDN=
=20
services)<BR>&gt;<BR>&gt; + Or by TDMoIP (=3D UDP TDMPWs), when multichanne=
ls ISDN=20
services.<BR>&gt;<BR>&gt;<BR>&gt; How may MGC indicate to the MG that it us=
es=20
PWs at the IP termination?<BR>&gt;<BR>&gt; It may be done by MeGaCo, using=
=20
SDP[RFC4566] at Local/Remote<BR>&gt; descriptors. However, how may be that =
SDP=20
description of TDMPWs?<BR>&gt;<BR>&gt; Thanks,<BR>&gt;<BR>&gt; Javier=20
Mu=F1oz<BR>&gt;<BR>&gt;<BR>&gt;=20
_______________________________________________<BR>&gt; Megaco mailing=20
list<BR>&gt; Megaco@ietf.org<BR>&gt; <A=20
href=3D"https://www.ietf.org/mailman/listinfo/megaco">https://www.ietf.org/=
mailman/listinfo/megaco</A><BR>&gt;=20
</FONT></DIV></BODY></HTML>

--_000_5F7BCCF5541B7444830A2288ABBEBC961D50018F98FRMRSSXCHMBSD_--

From javi@trajano.us.es  Mon Jan 31 02:44:35 2011
Return-Path: <javi@trajano.us.es>
X-Original-To: megaco@core3.amsl.com
Delivered-To: megaco@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 8EF833A6BE6 for <megaco@core3.amsl.com>; Mon, 31 Jan 2011 02:44:35 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.598
X-Spam-Level: 
X-Spam-Status: No, score=-6.598 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 1hlCT8doMQpY for <megaco@core3.amsl.com>; Mon, 31 Jan 2011 02:44:30 -0800 (PST)
Received: from mail.us.es (mail.us.es [193.147.175.20]) by core3.amsl.com (Postfix) with ESMTP id 59DED3A68FF for <megaco@ietf.org>; Mon, 31 Jan 2011 02:44:28 -0800 (PST)
Received: (qmail 2160 invoked from network); 31 Jan 2011 11:47:41 +0100
Received: from unknown (HELO us.es) (192.168.2.13) by us.es with SMTP; 31 Jan 2011 11:47:41 +0100
Received: (qmail 14340 invoked by uid 507); 31 Jan 2011 10:47:38 -0000
Received: from 127.0.0.1 by antivirus3 (envelope-from <javi@trajano.us.es>, uid 501) with qmail-scanner-2.08 (clamdscan: 0.96.5/12592.   Clear:RC:1(127.0.0.1):.  Processed in 0.060594 secs); 31 Jan 2011 10:47:38 -0000
Received: from unknown (HELO antivirus3) (127.0.0.1) by us.es with SMTP; 31 Jan 2011 10:47:38 -0000
Received: from 192.168.1.13 (192.168.1.13) by antivirus3 (F-Secure/fsigk_smtp/403/antivirus3); Mon, 31 Jan 2011 11:47:38 +0100 (CET)
X-Virus-Status: clean(F-Secure/fsigk_smtp/403/antivirus3)
Received: (qmail 26324 invoked from network); 31 Jan 2011 11:47:38 +0100
Received: from trajano.us.es (193.147.162.130) by us.es with AES256-SHA encrypted SMTP; 31 Jan 2011 11:47:38 +0100
Received: from [192.168.1.40] (154.Red-83-54-5.dynamicIP.rima-tde.net [83.54.5.154]) (authenticated bits=0) by trajano.us.es (8.13.8/8.13.8/Debian-3) with ESMTP id p0VAlaIH028555;  Mon, 31 Jan 2011 11:47:37 +0100
Message-ID: <4D46933D.6000505@trajano.us.es>
Date: Mon, 31 Jan 2011 11:47:25 +0100
From: Javi <javi@trajano.us.es>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7
MIME-Version: 1.0
To: megaco@ietf.org
References: <4D4369B7.3020100@trajano.us.es> <5F7BCCF5541B7444830A2288ABBEBC961D50018F98@FRMRSSXCHMBSD2.dc-m.alcatel-lucent.com>
In-Reply-To: <5F7BCCF5541B7444830A2288ABBEBC961D50018F98@FRMRSSXCHMBSD2.dc-m.alcatel-lucent.com>
Content-Type: multipart/alternative; boundary="------------080200060904030602080800"
Subject: Re: [Megaco] TDMPW and MeGaCo/SDP
X-BeenThere: megaco@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Media Gateway Control <megaco.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/megaco>, <mailto:megaco-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/megaco>
List-Post: <mailto:megaco@ietf.org>
List-Help: <mailto:megaco-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/megaco>, <mailto:megaco-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 31 Jan 2011 10:44:35 -0000

This is a multi-part message in MIME format.
--------------080200060904030602080800
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit

I agree, TDMoIP is an option only.

But, if it is used, MGC would use SDP at Local/Remote MeGaCo 
descriptors. How may be that SDP description for TDMoIP?

> However, there was never any H.248 Profile standardized with 
> /*multirate*/ support, at least to my knowledge.
> (I'm aware of vendor specific profile, but that are proprietary 
> solutions.)
>

I would be interested to know any of that proprietary solutions. May you 
indicate me any?

>
> __
> /*Y.2262 PSTN/ISDN emulation and simulation, Appendix IV
> Examples of emulation of PSTN and N-ISDN bearer services
> *(This appendix does not form an integral part of this Recommendation)
>
> Examples for the emulation of PSTN and N-ISDN bearer services are 
> provided:
>
> 1) Monorate bearer services (= 1 × 64-kbit/s digital bearer in PSTN/ISDN)
> . ITU-T Recommendations I.231.2 and I.231.3 may be emulated by a 
> single RTP
> session, with or without RTP control protocol (RTCP), using an RTP 
> profile according
> to IETF RFC 3551.
> . ITU-T Recommendation I.231.1 may be emulated by a single RTP 
> session, with or
> without RTCP, using RTP clearmode according to IETF RFC 4040.
>
> 2) Multirate bearer services (= N × 64-kbit/s digital bearer in 
> PSTN/ISDN; N greater than one)
> . ITU-T Recommendations I.231.4 to I.231.10 may be emulated by TDMoIP 
> described
> in ITU-T Recommendation Y.1453.
>
> /
> > -----Original Message-----
> > From: megaco-bounces@ietf.org
> > [mailto:megaco-bounces@ietf.org] On Behalf Of Javi
> > Sent: Samstag, 29. Januar 2011 02:13
> > To: megaco@ietf.org
> > Subject: [Megaco] TDMPW and MeGaCo/SDP
> >
> > Assuming the next situation:
> >
> > ISDN Terminal 1  -   MG1 -  [IP network] -  MG2   -   ISDN Terminal 2
> >
> > where the MGs (Media Gateway) are controlled by a MGC (Media Gateway
> > Controller) via MeGaCo[H.248.1].
> >
> > [ITU-T Y.2262 / Annex IV] proposses that MGs may transport
> > ISDN B-channels over the IP network:
> >
> > + By a single RTP session (when monochannels ISDN services)
> >
> > + Or by TDMoIP (= UDP TDMPWs), when multichannels ISDN services.
> >
> >
> > How may MGC indicate to the MG that it uses PWs at the IP termination?
> >
> > It may be done by MeGaCo, using SDP[RFC4566] at Local/Remote
> > descriptors. However, how may be that SDP description of TDMPWs?
> >
> > Thanks,
> >
> > Javier Muņoz
> >
> >
> > _______________________________________________
> > Megaco mailing list
> > Megaco@ietf.org
> > https://www.ietf.org/mailman/listinfo/megaco
> >


--------------080200060904030602080800
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#ffffff" text="#000000">
    I agree, TDMoIP is an option only.<br>
    <br>
    But, if it is used, MGC would use SDP at Local/Remote MeGaCo
    descriptors. How may be that SDP description for TDMoIP?<br>
    <br>
    <blockquote
cite="mid:5F7BCCF5541B7444830A2288ABBEBC961D50018F98@FRMRSSXCHMBSD2.dc-m.alcatel-lucent.com"
      type="cite">
      <div><font size="2"><font face="Courier New">However, there was
            never any H.248 Profile standardized with <em><strong>multirate</strong></em>
            support, at least to my knowledge.</font></font></div>
      <div><font size="2" face="Courier New">(I'm aware of vendor
          specific profile, but that are proprietary solutions.)</font></div>
      <div><font size="2" face="Courier New"></font><font size="2"><font
            face="Courier New"><br>
          </font></font></div>
    </blockquote>
    <br>
    I would be interested to know any of that proprietary solutions. May
    you indicate me any?<br>
    <br>
    <blockquote
cite="mid:5F7BCCF5541B7444830A2288ABBEBC961D50018F98@FRMRSSXCHMBSD2.dc-m.alcatel-lucent.com"
      type="cite">
      <div><font size="2"><font face="Courier New"><br>
            __<br>
            <em><strong>Y.2262 PSTN/ISDN emulation and simulation,
                Appendix IV<br>
                Examples of emulation of PSTN and N-ISDN bearer services<br>
              </strong>(This appendix does not form an integral part of
              this Recommendation)<br>
              <br>
              Examples for the emulation of PSTN and N-ISDN bearer
              services are provided:<br>
              <br>
              1) Monorate bearer services (= 1 &times; 64-kbit/s digital
              bearer in PSTN/ISDN)<br>
              &#8226; ITU-T Recommendations I.231.2 and I.231.3 may be
              emulated by a single RTP<br>
              session, with or without RTP control protocol (RTCP),
              using an RTP profile according<br>
              to IETF RFC 3551.<br>
              &#8226; ITU-T Recommendation I.231.1 may be emulated by a single
              RTP session, with or<br>
              without RTCP, using RTP clearmode according to IETF RFC
              4040.<br>
              <br>
              2) Multirate bearer services (= N &times; 64-kbit/s digital
              bearer in PSTN/ISDN; N greater than one)<br>
              &#8226; ITU-T Recommendations I.231.4 to I.231.10 may be
              emulated by TDMoIP described<br>
              in ITU-T Recommendation Y.1453.<br>
              <br>
            </em></font><br>
          &gt; -----Original Message-----<br>
          &gt; From: <a class="moz-txt-link-abbreviated" href="mailto:megaco-bounces@ietf.org">megaco-bounces@ietf.org</a><br>
          &gt; [<a moz-do-not-send="true"
            href="mailto:megaco-bounces@ietf.org">mailto:megaco-bounces@ietf.org</a>]
          On Behalf Of Javi<br>
          &gt; Sent: Samstag, 29. Januar 2011 02:13<br>
          &gt; To: <a class="moz-txt-link-abbreviated" href="mailto:megaco@ietf.org">megaco@ietf.org</a><br>
          &gt; Subject: [Megaco] TDMPW and MeGaCo/SDP<br>
          &gt;<br>
          &gt; Assuming the next situation:<br>
          &gt;<br>
          &gt; ISDN Terminal 1&nbsp; -&nbsp;&nbsp; MG1 -&nbsp; [IP network] -&nbsp; MG2&nbsp;&nbsp; -&nbsp;&nbsp;
          ISDN Terminal 2<br>
          &gt;<br>
          &gt; where the MGs (Media Gateway) are controlled by a MGC
          (Media Gateway<br>
          &gt; Controller) via MeGaCo[H.248.1].<br>
          &gt;<br>
          &gt; [ITU-T Y.2262 / Annex IV] proposses that MGs may
          transport<br>
          &gt; ISDN B-channels over the IP network:<br>
          &gt;<br>
          &gt; + By a single RTP session (when monochannels ISDN
          services)<br>
          &gt;<br>
          &gt; + Or by TDMoIP (= UDP TDMPWs), when multichannels ISDN
          services.<br>
          &gt;<br>
          &gt;<br>
          &gt; How may MGC indicate to the MG that it uses PWs at the IP
          termination?<br>
          &gt;<br>
          &gt; It may be done by MeGaCo, using SDP[RFC4566] at
          Local/Remote<br>
          &gt; descriptors. However, how may be that SDP description of
          TDMPWs?<br>
          &gt;<br>
          &gt; Thanks,<br>
          &gt;<br>
          &gt; Javier Mu&ntilde;oz<br>
          &gt;<br>
          &gt;<br>
          &gt; _______________________________________________<br>
          &gt; Megaco mailing list<br>
          &gt; <a class="moz-txt-link-abbreviated" href="mailto:Megaco@ietf.org">Megaco@ietf.org</a><br>
          &gt; <a moz-do-not-send="true"
            href="https://www.ietf.org/mailman/listinfo/megaco">https://www.ietf.org/mailman/listinfo/megaco</a><br>
          &gt; </font></div>
    </blockquote>
    <br>
  </body>
</html>

--------------080200060904030602080800--

From albrecht.schwarz@alcatel-lucent.com  Mon Jan 31 07:51:22 2011
Return-Path: <albrecht.schwarz@alcatel-lucent.com>
X-Original-To: megaco@core3.amsl.com
Delivered-To: megaco@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 764FF3A67B6 for <megaco@core3.amsl.com>; Mon, 31 Jan 2011 07:51:22 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -5.57
X-Spam-Level: 
X-Spam-Status: No, score=-5.57 tagged_above=-999 required=5 tests=[AWL=0.678,  BAYES_00=-2.599, HELO_EQ_FR=0.35, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 4ELChvonaN4f for <megaco@core3.amsl.com>; Mon, 31 Jan 2011 07:51:19 -0800 (PST)
Received: from smail2.alcatel.fr (smail2.alcatel.fr [64.208.49.57]) by core3.amsl.com (Postfix) with ESMTP id 2082E3A6BFF for <megaco@ietf.org>; Mon, 31 Jan 2011 07:51:17 -0800 (PST)
Received: from FRMRSSXCHHUB04.dc-m.alcatel-lucent.com (FRMRSSXCHHUB04.dc-m.alcatel-lucent.com [135.120.45.64]) by smail2.alcatel.fr (8.14.3/8.14.3/ICT) with ESMTP id p0VFsTex024648 (version=TLSv1/SSLv3 cipher=RC4-MD5 bits=128 verify=NOT); Mon, 31 Jan 2011 16:54:31 +0100
Received: from FRMRSSXCHMBSD2.dc-m.alcatel-lucent.com ([135.120.45.53]) by FRMRSSXCHHUB04.dc-m.alcatel-lucent.com ([135.120.45.64]) with mapi; Mon, 31 Jan 2011 16:54:30 +0100
From: "Schwarz, Albrecht (Albrecht)" <albrecht.schwarz@alcatel-lucent.com>
To: Javi <javi@trajano.us.es>, "megaco@ietf.org" <megaco@ietf.org>
Date: Mon, 31 Jan 2011 16:54:29 +0100
Thread-Topic: [Megaco] TDMPW and MeGaCo/SDP
Thread-Index: AcvBNFU1rtN4U33vRN6FeEZDBGve4wAKjO3g
Message-ID: <5F7BCCF5541B7444830A2288ABBEBC961D500190D7@FRMRSSXCHMBSD2.dc-m.alcatel-lucent.com>
References: <4D4369B7.3020100@trajano.us.es> <5F7BCCF5541B7444830A2288ABBEBC961D50018F98@FRMRSSXCHMBSD2.dc-m.alcatel-lucent.com> <4D46933D.6000505@trajano.us.es>
In-Reply-To: <4D46933D.6000505@trajano.us.es>
Accept-Language: de-DE, en-US
Content-Language: en-US
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
acceptlanguage: de-DE, en-US
Content-Type: multipart/alternative; boundary="_000_5F7BCCF5541B7444830A2288ABBEBC961D500190D7FRMRSSXCHMBSD_"
MIME-Version: 1.0
X-Scanned-By: MIMEDefang 2.64 on 155.132.188.80
Subject: Re: [Megaco] TDMPW and MeGaCo/SDP
X-BeenThere: megaco@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Media Gateway Control <megaco.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/megaco>, <mailto:megaco-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/megaco>
List-Post: <mailto:megaco@ietf.org>
List-Help: <mailto:megaco-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/megaco>, <mailto:megaco-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 31 Jan 2011 15:51:22 -0000

--_000_5F7BCCF5541B7444830A2288ABBEBC961D500190D7FRMRSSXCHMBSD_
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Just some high-level indications:

Multirate means effectively N-out-of-K (with K =3D 24 or 30 dependent on AN=
SI /ETSI markets; and 1 < N <=3D K).
That's a first requirement.
Secondly, the selection of channels may be random, they must not be in cons=
ecutive order (e.g., think about the permutations for N =3D 5).
Thirdly, there could be a dependency of the choosen CESoIP emulation servic=
e to the H.248 connection model.

Possible solution: H.248 MUX termination ... at the high-level ...


________________________________
From: Javi [mailto:javi@trajano.us.es]
Sent: Montag, 31. Januar 2011 11:47
To: megaco@ietf.org
Subject: Re: [Megaco] TDMPW and MeGaCo/SDP

I agree, TDMoIP is an option only.

But, if it is used, MGC would use SDP at Local/Remote MeGaCo descriptors. H=
ow may be that SDP description for TDMoIP?

However, there was never any H.248 Profile standardized with multirate supp=
ort, at least to my knowledge.
(I'm aware of vendor specific profile, but that are proprietary solutions.)


I would be interested to know any of that proprietary solutions. May you in=
dicate me any?


__
Y.2262 PSTN/ISDN emulation and simulation, Appendix IV
Examples of emulation of PSTN and N-ISDN bearer services
(This appendix does not form an integral part of this Recommendation)

Examples for the emulation of PSTN and N-ISDN bearer services are provided:

1) Monorate bearer services (=3D 1 =D7 64-kbit/s digital bearer in PSTN/ISD=
N)
* ITU-T Recommendations I.231.2 and I.231.3 may be emulated by a single RTP
session, with or without RTP control protocol (RTCP), using an RTP profile =
according
to IETF RFC 3551.
* ITU-T Recommendation I.231.1 may be emulated by a single RTP session, wit=
h or
without RTCP, using RTP clearmode according to IETF RFC 4040.

2) Multirate bearer services (=3D N =D7 64-kbit/s digital bearer in PSTN/IS=
DN; N greater than one)
* ITU-T Recommendations I.231.4 to I.231.10 may be emulated by TDMoIP descr=
ibed
in ITU-T Recommendation Y.1453.


> -----Original Message-----
> From: megaco-bounces@ietf.org<mailto:megaco-bounces@ietf.org>
> [mailto:megaco-bounces@ietf.org] On Behalf Of Javi
> Sent: Samstag, 29. Januar 2011 02:13
> To: megaco@ietf.org<mailto:megaco@ietf.org>
> Subject: [Megaco] TDMPW and MeGaCo/SDP
>
> Assuming the next situation:
>
> ISDN Terminal 1  -   MG1 -  [IP network] -  MG2   -   ISDN Terminal 2
>
> where the MGs (Media Gateway) are controlled by a MGC (Media Gateway
> Controller) via MeGaCo[H.248.1].
>
> [ITU-T Y.2262 / Annex IV] proposses that MGs may transport
> ISDN B-channels over the IP network:
>
> + By a single RTP session (when monochannels ISDN services)
>
> + Or by TDMoIP (=3D UDP TDMPWs), when multichannels ISDN services.
>
>
> How may MGC indicate to the MG that it uses PWs at the IP termination?
>
> It may be done by MeGaCo, using SDP[RFC4566] at Local/Remote
> descriptors. However, how may be that SDP description of TDMPWs?
>
> Thanks,
>
> Javier Mu=F1oz
>
>
> _______________________________________________
> Megaco mailing list
> Megaco@ietf.org<mailto:Megaco@ietf.org>
> https://www.ietf.org/mailman/listinfo/megaco
>


--_000_5F7BCCF5541B7444830A2288ABBEBC961D500190D7FRMRSSXCHMBSD_
Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; charset=3Diso-8859-1"=
>
<META content=3D"MSHTML 6.00.2900.6049" name=3DGENERATOR></HEAD>
<BODY text=3D#000000 bgColor=3D#ffffff>
<DIV dir=3Dltr align=3Dleft><SPAN class=3D856075015-31012011><FONT face=3D"=
Courier New"=20
color=3D#800000 size=3D2><EM>Just some high-level=20
indications:</EM></FONT></SPAN></DIV>
<DIV dir=3Dltr align=3Dleft><SPAN class=3D856075015-31012011><EM><FONT=20
face=3D"Courier New" color=3D#800000 size=3D2></FONT></EM></SPAN>&nbsp;</DI=
V>
<DIV dir=3Dltr align=3Dleft><SPAN class=3D856075015-31012011><EM><FONT=20
face=3D"Courier New" color=3D#800000 size=3D2>Multirate means effectively N=
-out-of-K=20
(with K =3D 24 or 30 dependent on ANSI /ETSI markets; and 1 &lt; N &lt;=3D=
=20
K).</FONT></EM></SPAN></DIV>
<DIV dir=3Dltr align=3Dleft><SPAN class=3D856075015-31012011><EM><FONT=20
face=3D"Courier New" color=3D#800000 size=3D2>That's a first=20
requirement.</FONT></EM></SPAN></DIV>
<DIV dir=3Dltr align=3Dleft><SPAN class=3D856075015-31012011><EM><FONT=20
face=3D"Courier New" color=3D#800000 size=3D2>Secondly, the selection of ch=
annels may=20
be random, they must not be in consecutive order (e.g., think about the=20
permutations for N =3D 5).</FONT></EM></SPAN></DIV>
<DIV dir=3Dltr align=3Dleft><SPAN class=3D856075015-31012011><EM><FONT=20
face=3D"Courier New" color=3D#800000 size=3D2>Thirdly, there could be a dep=
endency of=20
the choosen CESoIP emulation service to the H.248 connection=20
model.</FONT></EM></SPAN></DIV>
<DIV dir=3Dltr align=3Dleft><SPAN class=3D856075015-31012011><EM><FONT=20
face=3D"Courier New" color=3D#800000 size=3D2></FONT></EM></SPAN>&nbsp;</DI=
V>
<DIV dir=3Dltr align=3Dleft><SPAN class=3D856075015-31012011><EM><FONT=20
face=3D"Courier New" color=3D#800000 size=3D2>Possible solution: H.248 MUX =
termination=20
... at the high-level ...</FONT></EM></SPAN></DIV>
<DIV dir=3Dltr align=3Dleft><SPAN class=3D856075015-31012011><EM><FONT=20
face=3D"Courier New" color=3D#800000 size=3D2></FONT></EM></SPAN>&nbsp;</DI=
V><BR>
<BLOCKQUOTE=20
style=3D"PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #800000 2px soli=
d; MARGIN-RIGHT: 0px">
  <DIV class=3DOutlookMessageHeader lang=3Den-us dir=3Dltr align=3Dleft>
  <HR tabIndex=3D-1>
  <FONT face=3DTahoma size=3D2><B>From:</B> Javi [mailto:javi@trajano.us.es=
]=20
  <BR><B>Sent:</B> Montag, 31. Januar 2011 11:47<BR><B>To:</B>=20
  megaco@ietf.org<BR><B>Subject:</B> Re: [Megaco] TDMPW and=20
  MeGaCo/SDP<BR></FONT><BR></DIV>
  <DIV></DIV>I agree, TDMoIP is an option only.<BR><BR>But, if it is used, =
MGC=20
  would use SDP at Local/Remote MeGaCo descriptors. How may be that SDP=20
  description for TDMoIP?<BR><BR>
  <BLOCKQUOTE=20
  cite=3Dmid:5F7BCCF5541B7444830A2288ABBEBC961D50018F98@FRMRSSXCHMBSD2.dc-m=
.alcatel-lucent.com=20
  type=3D"cite">
    <DIV><FONT size=3D2><FONT face=3D"Courier New">However, there was never=
 any=20
    H.248 Profile standardized with <EM><STRONG>multirate</STRONG></EM> sup=
port,=20
    at least to my knowledge.</FONT></FONT></DIV>
    <DIV><FONT face=3D"Courier New" size=3D2>(I'm aware of vendor specific =
profile,=20
    but that are proprietary solutions.)</FONT></DIV>
    <DIV><FONT face=3D"Courier New" size=3D2></FONT><FONT size=3D2><FONT=20
    face=3D"Courier New"><BR></FONT></FONT></DIV></BLOCKQUOTE><BR>I would b=
e=20
  interested to know any of that proprietary solutions. May you indicate me=
=20
  any?<BR><BR>
  <BLOCKQUOTE=20
  cite=3Dmid:5F7BCCF5541B7444830A2288ABBEBC961D50018F98@FRMRSSXCHMBSD2.dc-m=
.alcatel-lucent.com=20
  type=3D"cite">
    <DIV><FONT size=3D2><FONT face=3D"Courier New"><BR>__<BR><EM><STRONG>Y.=
2262=20
    PSTN/ISDN emulation and simulation, Appendix IV<BR>Examples of emulatio=
n of=20
    PSTN and N-ISDN bearer services<BR></STRONG>(This appendix does not for=
m an=20
    integral part of this Recommendation)<BR><BR>Examples for the emulation=
 of=20
    PSTN and N-ISDN bearer services are provided:<BR><BR>1) Monorate bearer=
=20
    services (=3D 1 =D7 64-kbit/s digital bearer in PSTN/ISDN)<BR>=95 ITU-T=
=20
    Recommendations I.231.2 and I.231.3 may be emulated by a single=20
    RTP<BR>session, with or without RTP control protocol (RTCP), using an R=
TP=20
    profile according<BR>to IETF RFC 3551.<BR>=95 ITU-T Recommendation I.23=
1.1 may=20
    be emulated by a single RTP session, with or<BR>without RTCP, using RTP=
=20
    clearmode according to IETF RFC 4040.<BR><BR>2) Multirate bearer servic=
es (=3D=20
    N =D7 64-kbit/s digital bearer in PSTN/ISDN; N greater than one)<BR>=95=
 ITU-T=20
    Recommendations I.231.4 to I.231.10 may be emulated by TDMoIP=20
    described<BR>in ITU-T Recommendation Y.1453.<BR><BR></EM></FONT><BR>&gt=
;=20
    -----Original Message-----<BR>&gt; From: <A class=3Dmoz-txt-link-abbrev=
iated=20
    href=3D"mailto:megaco-bounces@ietf.org">megaco-bounces@ietf.org</A><BR>=
&gt;=20
    [<A href=3D"mailto:megaco-bounces@ietf.org"=20
    moz-do-not-send=3D"true">mailto:megaco-bounces@ietf.org</A>] On Behalf =
Of=20
    Javi<BR>&gt; Sent: Samstag, 29. Januar 2011 02:13<BR>&gt; To: <A=20
    class=3Dmoz-txt-link-abbreviated=20
    href=3D"mailto:megaco@ietf.org">megaco@ietf.org</A><BR>&gt; Subject: [M=
egaco]=20
    TDMPW and MeGaCo/SDP<BR>&gt;<BR>&gt; Assuming the next=20
    situation:<BR>&gt;<BR>&gt; ISDN Terminal 1&nbsp; -&nbsp;&nbsp; MG1 -&nb=
sp;=20
    [IP network] -&nbsp; MG2&nbsp;&nbsp; -&nbsp;&nbsp; ISDN Terminal=20
    2<BR>&gt;<BR>&gt; where the MGs (Media Gateway) are controlled by a MGC=
=20
    (Media Gateway<BR>&gt; Controller) via MeGaCo[H.248.1].<BR>&gt;<BR>&gt;=
=20
    [ITU-T Y.2262 / Annex IV] proposses that MGs may transport<BR>&gt; ISDN=
=20
    B-channels over the IP network:<BR>&gt;<BR>&gt; + By a single RTP sessi=
on=20
    (when monochannels ISDN services)<BR>&gt;<BR>&gt; + Or by TDMoIP (=3D U=
DP=20
    TDMPWs), when multichannels ISDN services.<BR>&gt;<BR>&gt;<BR>&gt; How =
may=20
    MGC indicate to the MG that it uses PWs at the IP=20
    termination?<BR>&gt;<BR>&gt; It may be done by MeGaCo, using SDP[RFC456=
6] at=20
    Local/Remote<BR>&gt; descriptors. However, how may be that SDP descript=
ion=20
    of TDMPWs?<BR>&gt;<BR>&gt; Thanks,<BR>&gt;<BR>&gt; Javier=20
    Mu=F1oz<BR>&gt;<BR>&gt;<BR>&gt;=20
    _______________________________________________<BR>&gt; Megaco mailing=
=20
    list<BR>&gt; <A class=3Dmoz-txt-link-abbreviated=20
    href=3D"mailto:Megaco@ietf.org">Megaco@ietf.org</A><BR>&gt; <A=20
    href=3D"https://www.ietf.org/mailman/listinfo/megaco"=20
    moz-do-not-send=3D"true">https://www.ietf.org/mailman/listinfo/megaco</=
A><BR>&gt;=20
    </FONT></DIV></BLOCKQUOTE><BR></BLOCKQUOTE></BODY></HTML>

--_000_5F7BCCF5541B7444830A2288ABBEBC961D500190D7FRMRSSXCHMBSD_--
