
From rbonica@juniper.net  Tue Jul  3 08:05:36 2012
Return-Path: <rbonica@juniper.net>
X-Original-To: mib-doctors@ietfa.amsl.com
Delivered-To: mib-doctors@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 312D121F8872 for <mib-doctors@ietfa.amsl.com>; Tue,  3 Jul 2012 08:05:36 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -106.575
X-Spam-Level: 
X-Spam-Status: No, score=-106.575 tagged_above=-999 required=5 tests=[AWL=0.024, BAYES_00=-2.599, RCVD_IN_DNSWL_MED=-4, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id NmmsNVFI9xAH for <mib-doctors@ietfa.amsl.com>; Tue,  3 Jul 2012 08:05:34 -0700 (PDT)
Received: from exprod7og104.obsmtp.com (exprod7og104.obsmtp.com [64.18.2.161]) by ietfa.amsl.com (Postfix) with ESMTP id 7691421F8871 for <mib-doctors@ietf.org>; Tue,  3 Jul 2012 08:05:34 -0700 (PDT)
Received: from P-EMHUB01-HQ.jnpr.net ([66.129.224.36]) (using TLSv1) by exprod7ob104.postini.com ([64.18.6.12]) with SMTP ID DSNKT/MKRo9e31Pv/KcPUpoxh/McQNtE6awp@postini.com; Tue, 03 Jul 2012 08:05:42 PDT
Received: from P-CLDFE02-HQ.jnpr.net (172.24.192.60) by P-EMHUB01-HQ.jnpr.net (172.24.192.35) with Microsoft SMTP Server (TLS) id 8.3.213.0; Tue, 3 Jul 2012 08:03:30 -0700
Received: from p-emfe01-wf.jnpr.net (172.28.145.24) by p-cldfe02-hq.jnpr.net (172.24.192.60) with Microsoft SMTP Server (TLS) id 14.1.355.2; Tue, 3 Jul 2012 08:03:29 -0700
Received: from EMBX01-WF.jnpr.net ([fe80::1914:3299:33d9:e43b]) by p-emfe01-wf.jnpr.net ([fe80::d0d1:653d:5b91:a123%11]) with mapi; Tue, 3 Jul 2012 11:03:29 -0400
From: Ronald Bonica <rbonica@juniper.net>
To: "mib-doctors@ietf.org" <mib-doctors@ietf.org>
Date: Tue, 3 Jul 2012 11:03:28 -0400
Thread-Topic: Errata against RFC 1628
Thread-Index: Ac1ZLQCcMizmiq2hT6eIGoZk65nVUg==
Message-ID: <13205C286662DE4387D9AF3AC30EF456D76F688B4B@EMBX01-WF.jnpr.net>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
acceptlanguage: en-US
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
Subject: [MIB-DOCTORS] Errata against RFC 1628
X-BeenThere: mib-doctors@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: MIB Doctors list <mib-doctors.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/mib-doctors>
List-Post: <mailto:mib-doctors@ietf.org>
List-Help: <mailto:mib-doctors-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 03 Jul 2012 15:05:36 -0000

Folks,

Could someone please comment on the errata (below) against RFC 1628? Am I c=
orrect in assuming that the text in the RFC won't compile at all?

--------------------------
Ron Bonica
vcard:       www.bonica.org/ron/ronbonica.vcf


Errata ID: 3275

Status: Reported
Type: Technical

Reported By: J=FCrgen Sellinath
Date Reported: 2012-07-03
Section 4 says:

UPS-MIB DEFINITIONS ::=3D BEGIN

   IMPORTS
       MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE,
       OBJECT-IDENTITY, Counter32, Gauge32, Integer32
           FROM SNMPv2-SMI
       DisplayString, TimeStamp, TimeInterval, TestAndIncr,
         AutonomousType
           FROM SNMPv2-TC
       MODULE-COMPLIANCE, OBJECT-GROUP
           FROM SNMPv2-CONF;


It should say:

UPS-MIB DEFINITIONS ::=3D BEGIN

   IMPORTS
       MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE,
       OBJECT-IDENTITY, Counter32, Gauge32, Integer32
           FROM SNMPv2-SMI
       DisplayString, TimeStamp, TimeInterval, TestAndIncr,
         AutonomousType, TEXTUAL-CONVENTION
           FROM SNMPv2-TC
       MODULE-COMPLIANCE, OBJECT-GROUP
           FROM SNMPv2-CONF;


Notes:

Textual conventions are used within this MIB, but the macro "TEXTUAL-CONVEN=
TION" itself is not imported, as it should (RFC 2578 =A73.2).



From j.schoenwaelder@jacobs-university.de  Tue Jul  3 09:35:25 2012
Return-Path: <j.schoenwaelder@jacobs-university.de>
X-Original-To: mib-doctors@ietfa.amsl.com
Delivered-To: mib-doctors@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id C931A21F86D6 for <mib-doctors@ietfa.amsl.com>; Tue,  3 Jul 2012 09:35:25 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -103.187
X-Spam-Level: 
X-Spam-Status: No, score=-103.187 tagged_above=-999 required=5 tests=[AWL=0.062, BAYES_00=-2.599, HELO_EQ_DE=0.35, RCVD_IN_DNSWL_LOW=-1, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ajkwyq8eyEBR for <mib-doctors@ietfa.amsl.com>; Tue,  3 Jul 2012 09:35:24 -0700 (PDT)
Received: from hermes.jacobs-university.de (hermes.jacobs-university.de [212.201.44.23]) by ietfa.amsl.com (Postfix) with ESMTP id 6A71921F86D3 for <mib-doctors@ietf.org>; Tue,  3 Jul 2012 09:35:24 -0700 (PDT)
Received: from localhost (demetrius3.jacobs-university.de [212.201.44.48]) by hermes.jacobs-university.de (Postfix) with ESMTP id 1651D20A13; Tue,  3 Jul 2012 18:35:32 +0200 (CEST)
X-Virus-Scanned: amavisd-new at jacobs-university.de
Received: from hermes.jacobs-university.de ([212.201.44.23]) by localhost (demetrius3.jacobs-university.de [212.201.44.32]) (amavisd-new, port 10024) with ESMTP id X0FLQxI3lDQ3; Tue,  3 Jul 2012 18:35:31 +0200 (CEST)
Received: from elstar.local (elstar.jacobs.jacobs-university.de [10.50.231.133]) by hermes.jacobs-university.de (Postfix) with ESMTP id A3FDE209D7; Tue,  3 Jul 2012 18:35:31 +0200 (CEST)
Received: by elstar.local (Postfix, from userid 501) id 013C32042AEF; Tue,  3 Jul 2012 18:35:30 +0200 (CEST)
Date: Tue, 3 Jul 2012 18:35:30 +0200
From: Juergen Schoenwaelder <j.schoenwaelder@jacobs-university.de>
To: Ronald Bonica <rbonica@juniper.net>
Message-ID: <20120703163530.GA2439@elstar.local>
Mail-Followup-To: Ronald Bonica <rbonica@juniper.net>, "mib-doctors@ietf.org" <mib-doctors@ietf.org>
References: <13205C286662DE4387D9AF3AC30EF456D76F688B4B@EMBX01-WF.jnpr.net>
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
In-Reply-To: <13205C286662DE4387D9AF3AC30EF456D76F688B4B@EMBX01-WF.jnpr.net>
User-Agent: Mutt/1.5.21 (2010-09-15)
Cc: "mib-doctors@ietf.org" <mib-doctors@ietf.org>
Subject: Re: [MIB-DOCTORS] Errata against RFC 1628
X-BeenThere: mib-doctors@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
Reply-To: Juergen Schoenwaelder <j.schoenwaelder@jacobs-university.de>
List-Id: MIB Doctors list <mib-doctors.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/mib-doctors>
List-Post: <mailto:mib-doctors@ietf.org>
List-Help: <mailto:mib-doctors-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 03 Jul 2012 16:35:26 -0000

On Tue, Jul 03, 2012 at 11:03:28AM -0400, Ronald Bonica wrote:
> Folks,
> 
> Could someone please comment on the errata (below) against RFC 1628? Am I correct in assuming that the text in the RFC won't compile at all?
> 

Yep. There are also invalid range restrictions:

Index: src/libsmi/mibs/ietf/UPS-MIB
===================================================================
--- src/libsmi/mibs/ietf/UPS-MIB	(revision 706)
+++ src/libsmi/mibs/ietf/UPS-MIB	(working copy)
@@ -1013,7 +1013,7 @@
     ::= { upsControl 1 }
 
 upsShutdownAfterDelay OBJECT-TYPE
-    SYNTAX     INTEGER (-1..2147483648)
+    SYNTAX     INTEGER (-1..2147483647)
     UNITS      "seconds"
     MAX-ACCESS read-write
     STATUS     current
@@ -1041,7 +1041,7 @@
     ::= { upsControl 2 }
 
 upsStartupAfterDelay OBJECT-TYPE
-    SYNTAX     INTEGER (-1..2147483648)
+    SYNTAX     INTEGER (-1..2147483647)
     UNITS      "seconds"
     MAX-ACCESS read-write
     STATUS     current

No, I am too lazy to file erratas at the moment...

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

From rbonica@juniper.net  Tue Jul  3 12:28:50 2012
Return-Path: <rbonica@juniper.net>
X-Original-To: mib-doctors@ietfa.amsl.com
Delivered-To: mib-doctors@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 82A3611E8170 for <mib-doctors@ietfa.amsl.com>; Tue,  3 Jul 2012 12:28:50 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -106.576
X-Spam-Level: 
X-Spam-Status: No, score=-106.576 tagged_above=-999 required=5 tests=[AWL=0.024, BAYES_00=-2.599, RCVD_IN_DNSWL_MED=-4, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ZD5bki3CXnV3 for <mib-doctors@ietfa.amsl.com>; Tue,  3 Jul 2012 12:28:49 -0700 (PDT)
Received: from exprod7og106.obsmtp.com (exprod7og106.obsmtp.com [64.18.2.165]) by ietfa.amsl.com (Postfix) with ESMTP id 283D521F85A3 for <mib-doctors@ietf.org>; Tue,  3 Jul 2012 12:28:47 -0700 (PDT)
Received: from P-EMHUB03-HQ.jnpr.net ([66.129.224.36]) (using TLSv1) by exprod7ob106.postini.com ([64.18.6.12]) with SMTP ID DSNKT/NH95x44hhZASjTWNUKixaVxBBNljpn@postini.com; Tue, 03 Jul 2012 12:28:58 PDT
Received: from p-emfe01-wf.jnpr.net (172.28.145.24) by P-EMHUB03-HQ.jnpr.net (172.24.192.37) with Microsoft SMTP Server (TLS) id 8.3.213.0; Tue, 3 Jul 2012 12:27:12 -0700
Received: from EMBX01-WF.jnpr.net ([fe80::1914:3299:33d9:e43b]) by p-emfe01-wf.jnpr.net ([fe80::d0d1:653d:5b91:a123%11]) with mapi; Tue, 3 Jul 2012 15:27:11 -0400
From: Ronald Bonica <rbonica@juniper.net>
To: Juergen Schoenwaelder <j.schoenwaelder@jacobs-university.de>
Date: Tue, 3 Jul 2012 15:27:10 -0400
Thread-Topic: [MIB-DOCTORS] Errata against RFC 1628
Thread-Index: Ac1ZOd9O4NCo3vDISu6X3X1KxtzKJwAF98vg
Message-ID: <13205C286662DE4387D9AF3AC30EF456D76F8A86DD@EMBX01-WF.jnpr.net>
References: <13205C286662DE4387D9AF3AC30EF456D76F688B4B@EMBX01-WF.jnpr.net> <20120703163530.GA2439@elstar.local>
In-Reply-To: <20120703163530.GA2439@elstar.local>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
acceptlanguage: en-US
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
Cc: "mib-doctors@ietf.org" <mib-doctors@ietf.org>
Subject: Re: [MIB-DOCTORS] Errata against RFC 1628
X-BeenThere: mib-doctors@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: MIB Doctors list <mib-doctors.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/mib-doctors>
List-Post: <mailto:mib-doctors@ietf.org>
List-Help: <mailto:mib-doctors-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 03 Jul 2012 19:28:50 -0000

Thanks much. I will verify this errata and another that reports the out-of-=
range value.

                                               Ron

> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:j.schoenwaelder@jacobs-
> university.de]
> Sent: Tuesday, July 03, 2012 12:36 PM
> To: Ronald Bonica
> Cc: mib-doctors@ietf.org
> Subject: Re: [MIB-DOCTORS] Errata against RFC 1628
>=20
> On Tue, Jul 03, 2012 at 11:03:28AM -0400, Ronald Bonica wrote:
> > Folks,
> >
> > Could someone please comment on the errata (below) against RFC 1628?
> Am I correct in assuming that the text in the RFC won't compile at all?
> >
>=20
> Yep. There are also invalid range restrictions:
>=20
> Index: src/libsmi/mibs/ietf/UPS-MIB
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
> --- src/libsmi/mibs/ietf/UPS-MIB	(revision 706)
> +++ src/libsmi/mibs/ietf/UPS-MIB	(working copy)
> @@ -1013,7 +1013,7 @@
>      ::=3D { upsControl 1 }
>=20
>  upsShutdownAfterDelay OBJECT-TYPE
> -    SYNTAX     INTEGER (-1..2147483648)
> +    SYNTAX     INTEGER (-1..2147483647)
>      UNITS      "seconds"
>      MAX-ACCESS read-write
>      STATUS     current
> @@ -1041,7 +1041,7 @@
>      ::=3D { upsControl 2 }
>=20
>  upsStartupAfterDelay OBJECT-TYPE
> -    SYNTAX     INTEGER (-1..2147483648)
> +    SYNTAX     INTEGER (-1..2147483647)
>      UNITS      "seconds"
>      MAX-ACCESS read-write
>      STATUS     current
>=20
> No, I am too lazy to file erratas at the moment...
>=20
> /js
>=20
> --
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

From randy_presuhn@mindspring.com  Tue Jul  3 12:32:12 2012
Return-Path: <randy_presuhn@mindspring.com>
X-Original-To: mib-doctors@ietfa.amsl.com
Delivered-To: mib-doctors@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 0565C11E81D7 for <mib-doctors@ietfa.amsl.com>; Tue,  3 Jul 2012 12:32:12 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -101.07
X-Spam-Level: 
X-Spam-Status: No, score=-101.07 tagged_above=-999 required=5 tests=[AWL=1.530, BAYES_00=-2.599, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Z4SveRZ0rhQx for <mib-doctors@ietfa.amsl.com>; Tue,  3 Jul 2012 12:32:11 -0700 (PDT)
Received: from elasmtp-banded.atl.sa.earthlink.net (elasmtp-banded.atl.sa.earthlink.net [209.86.89.70]) by ietfa.amsl.com (Postfix) with ESMTP id E1BBF11E81BE for <mib-doctors@ietf.org>; Tue,  3 Jul 2012 12:32:10 -0700 (PDT)
DomainKey-Signature: a=rsa-sha1; q=dns; c=nofws; s=dk20050327; d=mindspring.com; b=aWIir80WBm4bcEZCwA0NUjyiAMxtgOjXul7Isw8ar3phEoYR4ue0Geb5QgBIg2Jr; h=Received:Message-ID:From:To:References:Subject:Date:MIME-Version:Content-Type:Content-Transfer-Encoding:X-Priority:X-MSMail-Priority:X-Mailer:X-MimeOLE:X-ELNK-Trace:X-Originating-IP;
Received: from [99.38.144.250] (helo=oemcomputer) by elasmtp-banded.atl.sa.earthlink.net with esmtpa (Exim 4.67) (envelope-from <randy_presuhn@mindspring.com>) id 1Sm8pd-0005nR-B5 for mib-doctors@ietf.org; Tue, 03 Jul 2012 15:32:17 -0400
Message-ID: <004901cd5953$22928e00$6b01a8c0@oemcomputer>
From: "Randy Presuhn" <randy_presuhn@mindspring.com>
To: <mib-doctors@ietf.org>
References: <13205C286662DE4387D9AF3AC30EF456D76F688B4B@EMBX01-WF.jnpr.net>
Date: Tue, 3 Jul 2012 12:36:24 -0700
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: 8bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 6.00.2800.1478
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1478
X-ELNK-Trace: 4488c18417c9426da92b9037bc8bcf44d4c20f6b8d69d888b7f3a87d4e9c50f1e4634f2f00b1e3059405c1c900eb99ad350badd9bab72f9c350badd9bab72f9c
X-Originating-IP: 99.38.144.250
Subject: Re: [MIB-DOCTORS] Errata against RFC 1628
X-BeenThere: mib-doctors@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: MIB Doctors list <mib-doctors.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/mib-doctors>
List-Post: <mailto:mib-doctors@ietf.org>
List-Help: <mailto:mib-doctors-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 03 Jul 2012 19:32:12 -0000

Hi -

Yes, the omission of TEXTUAL-CONVENTION from the IMPORTS is
an error.

I don't know what the current implementation consensus is,
but historically, some MIB compilers did not check to see whether
TEXTUAL-CONVENTION was imported, and some responded to
it with only a warning rather than an error message.

Given RFC 1628's age, it's not particularly surprising that it doesn't
quite align with RFC 2578  :-).

Randy

----- Original Message ----- 
From: "Ronald Bonica" <rbonica@juniper.net>
To: <mib-doctors@ietf.org>
Sent: Tuesday, July 03, 2012 8:03 AM
Subject: [MIB-DOCTORS] Errata against RFC 1628


Folks,

Could someone please comment on the errata (below) against RFC 1628? Am I correct in assuming that the text in the RFC won't compile
at all?

--------------------------
Ron Bonica
vcard:       www.bonica.org/ron/ronbonica.vcf


Errata ID: 3275

Status: Reported
Type: Technical

Reported By: Jürgen Sellinath
Date Reported: 2012-07-03
Section 4 says:

UPS-MIB DEFINITIONS ::= BEGIN

   IMPORTS
       MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE,
       OBJECT-IDENTITY, Counter32, Gauge32, Integer32
           FROM SNMPv2-SMI
       DisplayString, TimeStamp, TimeInterval, TestAndIncr,
         AutonomousType
           FROM SNMPv2-TC
       MODULE-COMPLIANCE, OBJECT-GROUP
           FROM SNMPv2-CONF;


It should say:

UPS-MIB DEFINITIONS ::= BEGIN

   IMPORTS
       MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE,
       OBJECT-IDENTITY, Counter32, Gauge32, Integer32
           FROM SNMPv2-SMI
       DisplayString, TimeStamp, TimeInterval, TestAndIncr,
         AutonomousType, TEXTUAL-CONVENTION
           FROM SNMPv2-TC
       MODULE-COMPLIANCE, OBJECT-GROUP
           FROM SNMPv2-CONF;


Notes:

Textual conventions are used within this MIB, but the macro "TEXTUAL-CONVENTION" itself is not imported, as it should (RFC 2578
§3.2).


_______________________________________________
MIB-DOCTORS mailing list
MIB-DOCTORS@ietf.org
https://www.ietf.org/mailman/listinfo/mib-doctors



From bclaise@cisco.com  Mon Jul  9 02:56:31 2012
Return-Path: <bclaise@cisco.com>
X-Original-To: mib-doctors@ietfa.amsl.com
Delivered-To: mib-doctors@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 9E01521F8699 for <mib-doctors@ietfa.amsl.com>; Mon,  9 Jul 2012 02:56:31 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -10.144
X-Spam-Level: 
X-Spam-Status: No, score=-10.144 tagged_above=-999 required=5 tests=[AWL=0.455, BAYES_00=-2.599, RCVD_IN_DNSWL_HI=-8]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id uQc0NYK0C7ZE for <mib-doctors@ietfa.amsl.com>; Mon,  9 Jul 2012 02:56:30 -0700 (PDT)
Received: from av-tac-bru.cisco.com (weird-brew.cisco.com [144.254.15.118]) by ietfa.amsl.com (Postfix) with ESMTP id 3A90521F8602 for <mib-doctors@ietf.org>; Mon,  9 Jul 2012 02:56:30 -0700 (PDT)
X-TACSUNS: Virus Scanned
Received: from strange-brew.cisco.com (localhost.cisco.com [127.0.0.1]) by av-tac-bru.cisco.com (8.13.8+Sun/8.13.8) with ESMTP id q699lZgo005535; Mon, 9 Jul 2012 11:47:35 +0200 (CEST)
Received: from [10.60.67.85] (ams-bclaise-8914.cisco.com [10.60.67.85]) by strange-brew.cisco.com (8.13.8+Sun/8.13.8) with ESMTP id q699lYCU003539; Mon, 9 Jul 2012 11:47:34 +0200 (CEST)
Message-ID: <4FFAA8B6.3080709@cisco.com>
Date: Mon, 09 Jul 2012 11:47:34 +0200
From: Benoit Claise <bclaise@cisco.com>
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120614 Thunderbird/13.0.1
MIME-Version: 1.0
To: Thomas Nadeau <tnadeau@juniper.net>
References: <CC107788.1CA13%tnadeau@juniper.net>
In-Reply-To: <CC107788.1CA13%tnadeau@juniper.net>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Cc: "MIB Doctors \(E-mail\)" <mib-doctors@ietf.org>, Ron Bonica <rbonica@juniper.net>, "Joel M. Halpern" <jmh@joelhalpern.com>, Terry Manderson <terry.manderson@icann.org>
Subject: Re: [MIB-DOCTORS] I-D Action: draft-ietf-lisp-mib-04.txt
X-BeenThere: mib-doctors@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: MIB Doctors list <mib-doctors.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/mib-doctors>
List-Post: <mailto:mib-doctors@ietf.org>
List-Help: <mailto:mib-doctors-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 09 Jul 2012 09:56:31 -0000

Hi Tom,
>
> On 6/27/12 8:13 AM, "Juergen Schoenwaelder"
> <j.schoenwaelder@jacobs-university.de> wrote:
>
>> On Wed, Jun 27, 2012 at 01:18:46PM +0200, Harrie Hazewinkel wrote:
>>> Hallo,
>>>
>>> I did a very quick scan to see how much work it would and may know next
>>> week
>>> more if I would have the time.
>>>
>>>
>>> What I noticed was the imports.
>>>
>>>
>>> In section 8.1 is only one of the imports mentioned, looks odd although
>>> the other imports
>>> are the standard SNMP framework (SMI, etc..).
>>>
>>>
>>> But the document reference for the import
>>> (IANA-ADDRESS-FAMILY-NUMBERS-MIB) is
>>> placed in the informative references and should go in the normative
>>> references.
>>>
>> I think the most important thing to tell people is that their MIB
>> module(s) must compile and that they should read RFC 4181 and check in
>> particular the appendices. Perhaps we should simply return all MIB
>> modules right away if they do not even compile. The LISP-MIB module
>> has some rather serious syntax errors.
> 	I've suggested a few times that it be done as part of id-nits, or as a
> second pass if a MIB is detected.
That would be nice.
Any practical ideas how to do that?

Regards, Benoit.
>
> 	--Tom
>
>> /js
>>
>> -- 
>> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
>> Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
>> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
>> _______________________________________________
>> MIB-DOCTORS mailing list
>> MIB-DOCTORS@ietf.org
>> https://www.ietf.org/mailman/listinfo/mib-doctors
> _______________________________________________
> MIB-DOCTORS mailing list
> MIB-DOCTORS@ietf.org
> https://www.ietf.org/mailman/listinfo/mib-doctors
>
>



From tnadeau@juniper.net  Mon Jul  9 04:24:44 2012
Return-Path: <tnadeau@juniper.net>
X-Original-To: mib-doctors@ietfa.amsl.com
Delivered-To: mib-doctors@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 9B40821F85DF for <mib-doctors@ietfa.amsl.com>; Mon,  9 Jul 2012 04:24:44 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.018
X-Spam-Level: 
X-Spam-Status: No, score=-6.018 tagged_above=-999 required=5 tests=[AWL=0.581,  BAYES_00=-2.599, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id jCAZQWwxZSGH for <mib-doctors@ietfa.amsl.com>; Mon,  9 Jul 2012 04:24:43 -0700 (PDT)
Received: from exprod7og122.obsmtp.com (exprod7og122.obsmtp.com [64.18.2.22]) by ietfa.amsl.com (Postfix) with ESMTP id 12E5B21F85E3 for <mib-doctors@ietf.org>; Mon,  9 Jul 2012 04:24:18 -0700 (PDT)
Received: from P-EMHUB03-HQ.jnpr.net ([66.129.224.36]) (using TLSv1) by exprod7ob122.postini.com ([64.18.6.12]) with SMTP ID DSNKT/q/ejlA9h5R0OVy5ShbDr7PvHEENHwO@postini.com; Mon, 09 Jul 2012 04:25:08 PDT
Received: from p-emfe01-wf.jnpr.net (172.28.145.24) by P-EMHUB03-HQ.jnpr.net (172.24.192.37) with Microsoft SMTP Server (TLS) id 8.3.213.0; Mon, 9 Jul 2012 04:24:25 -0700
Received: from EMBX01-WF.jnpr.net ([fe80::1914:3299:33d9:e43b]) by p-emfe01-wf.jnpr.net ([fe80::d0d1:653d:5b91:a123%11]) with mapi; Mon, 9 Jul 2012 07:24:24 -0400
From: Thomas Nadeau <tnadeau@juniper.net>
To: Benoit Claise <bclaise@cisco.com>
Date: Mon, 9 Jul 2012 07:24:23 -0400
Thread-Topic: [MIB-DOCTORS] I-D Action: draft-ietf-lisp-mib-04.txt
Thread-Index: Ac1dxWRTNa2cpinuQrqdq2Xv/dkCUA==
Message-ID: <CC201A63.1D413%tnadeau@juniper.net>
In-Reply-To: <4FFAA8B6.3080709@cisco.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
user-agent: Microsoft-MacOutlook/14.2.0.120402
acceptlanguage: en-US
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
Cc: "MIB Doctors \(E-mail\)" <mib-doctors@ietf.org>, Ronald Bonica <rbonica@juniper.net>, "Joel M. Halpern" <jmh@joelhalpern.com>, Terry Manderson <terry.manderson@icann.org>
Subject: Re: [MIB-DOCTORS] I-D Action: draft-ietf-lisp-mib-04.txt
X-BeenThere: mib-doctors@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: MIB Doctors list <mib-doctors.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/mib-doctors>
List-Post: <mailto:mib-doctors@ietf.org>
List-Help: <mailto:mib-doctors-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 09 Jul 2012 11:24:44 -0000

On 7/9/12 3:47 AM, "Benoit Claise" <bclaise@cisco.com> wrote:

>Hi Tom,
>>
>> On 6/27/12 8:13 AM, "Juergen Schoenwaelder"
>> <j.schoenwaelder@jacobs-university.de> wrote:
>>
>>> On Wed, Jun 27, 2012 at 01:18:46PM +0200, Harrie Hazewinkel wrote:
>>>> Hallo,
>>>>
>>>> I did a very quick scan to see how much work it would and may know
>>>>next
>>>> week
>>>> more if I would have the time.
>>>>
>>>>
>>>> What I noticed was the imports.
>>>>
>>>>
>>>> In section 8.1 is only one of the imports mentioned, looks odd
>>>>although
>>>> the other imports
>>>> are the standard SNMP framework (SMI, etc..).
>>>>
>>>>
>>>> But the document reference for the import
>>>> (IANA-ADDRESS-FAMILY-NUMBERS-MIB) is
>>>> placed in the informative references and should go in the normative
>>>> references.
>>>>
>>> I think the most important thing to tell people is that their MIB
>>> module(s) must compile and that they should read RFC 4181 and check in
>>> particular the appendices. Perhaps we should simply return all MIB
>>> modules right away if they do not even compile. The LISP-MIB module
>>> has some rather serious syntax errors.
>> 	I've suggested a few times that it be done as part of id-nits, or as a
>> second pass if a MIB is detected.
>That would be nice.
>Any practical ideas how to do that?

	A simple way to do this is to just add this to idnits.  Add some logic
that detects a MIB module and compiles it, and then issues a warning and/o
sets a flag in the I-D's record that we can use for a variety of things.
Perhaps the web-only version of I-d nits can do this due to licensing
issues, but we should be able to do this when a draft is submitted.  If it
doesn't pass, we could allow it to be submitted, but flip a flag producing
a warning message that alerts us and sets a status setting "compiles Y/N"
in the I-d record.  Chairs submitting drafts for IESG review would be
required to have the set to "Y/Passes".  MIB Doctor reviewers could also
get a heads up as to the status of the document prior to reviewing.

	I don't think the above would be too complex and could be handled during
one of the IETF code sprints.

	--Tom


>
>Regards, Benoit.
>>
>> 	--Tom
>>
>>> /js
>>>
>>> --=20
>>> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
>>> Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
>>> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
>>> _______________________________________________
>>> MIB-DOCTORS mailing list
>>> MIB-DOCTORS@ietf.org
>>> https://www.ietf.org/mailman/listinfo/mib-doctors
>> _______________________________________________
>> MIB-DOCTORS mailing list
>> MIB-DOCTORS@ietf.org
>> https://www.ietf.org/mailman/listinfo/mib-doctors
>>
>>
>
>


From bclaise@cisco.com  Wed Jul 11 03:47:07 2012
Return-Path: <bclaise@cisco.com>
X-Original-To: mib-doctors@ietfa.amsl.com
Delivered-To: mib-doctors@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 7DC8121F867D for <mib-doctors@ietfa.amsl.com>; Wed, 11 Jul 2012 03:47:07 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -10.432
X-Spam-Level: 
X-Spam-Status: No, score=-10.432 tagged_above=-999 required=5 tests=[AWL=0.167, BAYES_00=-2.599, RCVD_IN_DNSWL_HI=-8]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 4bYfoPQYalIr for <mib-doctors@ietfa.amsl.com>; Wed, 11 Jul 2012 03:47:07 -0700 (PDT)
Received: from av-tac-bru.cisco.com (weird-brew.cisco.com [144.254.15.118]) by ietfa.amsl.com (Postfix) with ESMTP id 1E59B21F8634 for <mib-doctors@ietf.org>; Wed, 11 Jul 2012 03:47:05 -0700 (PDT)
X-TACSUNS: Virus Scanned
Received: from strange-brew.cisco.com (localhost.cisco.com [127.0.0.1]) by av-tac-bru.cisco.com (8.13.8+Sun/8.13.8) with ESMTP id q6BAYuuk005214; Wed, 11 Jul 2012 12:34:56 +0200 (CEST)
Received: from [10.60.67.85] (ams-bclaise-8914.cisco.com [10.60.67.85]) by strange-brew.cisco.com (8.13.8+Sun/8.13.8) with ESMTP id q6BAYtRB005525; Wed, 11 Jul 2012 12:34:55 +0200 (CEST)
Message-ID: <4FFD56CF.6000302@cisco.com>
Date: Wed, 11 Jul 2012 12:34:55 +0200
From: Benoit Claise <bclaise@cisco.com>
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120614 Thunderbird/13.0.1
MIME-Version: 1.0
To: Thomas Nadeau <tnadeau@juniper.net>
References: <CC201A63.1D413%tnadeau@juniper.net>
In-Reply-To: <CC201A63.1D413%tnadeau@juniper.net>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Cc: "MIB Doctors \(E-mail\)" <mib-doctors@ietf.org>, Ronald Bonica <rbonica@juniper.net>, "Joel M. Halpern" <jmh@joelhalpern.com>, Terry Manderson <terry.manderson@icann.org>
Subject: Re: [MIB-DOCTORS] I-D Action: draft-ietf-lisp-mib-04.txt
X-BeenThere: mib-doctors@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: MIB Doctors list <mib-doctors.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/mib-doctors>
List-Post: <mailto:mib-doctors@ietf.org>
List-Help: <mailto:mib-doctors-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 11 Jul 2012 10:47:07 -0000

Tom,


>>>> I think the most important thing to tell people is that their MIB
>>>> module(s) must compile and that they should read RFC 4181 and check in
>>>> particular the appendices. Perhaps we should simply return all MIB
>>>> modules right away if they do not even compile. The LISP-MIB module
>>>> has some rather serious syntax errors.
>>> 	I've suggested a few times that it be done as part of id-nits, or as a
>>> second pass if a MIB is detected.
>> That would be nice.
>> Any practical ideas how to do that?
> 	A simple way to do this is to just add this to idnits.  Add some logic
> that detects a MIB module and compiles it, and then issues a warning and/o
> sets a flag in the I-D's record that we can use for a variety of things.
> Perhaps the web-only version of I-d nits can do this due to licensing
> issues, but we should be able to do this when a draft is submitted.  If it
> doesn't pass, we could allow it to be submitted, but flip a flag producing
> a warning message that alerts us and sets a status setting "compiles Y/N"
> in the I-d record.  Chairs submitting drafts for IESG review would be
> required to have the set to "Y/Passes".  MIB Doctor reviewers could also
> get a heads up as to the status of the document prior to reviewing.
>
> 	I don't think the above would be too complex and could be handled during
> one of the IETF code sprints.
>
> 	
Let me follow up and see what can be done.

Regards,  Benoit.

From bclaise@cisco.com  Fri Jul 13 16:47:57 2012
Return-Path: <bclaise@cisco.com>
X-Original-To: mib-doctors@ietfa.amsl.com
Delivered-To: mib-doctors@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id BBE5E11E80EE; Fri, 13 Jul 2012 16:47:57 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -10.439
X-Spam-Level: 
X-Spam-Status: No, score=-10.439 tagged_above=-999 required=5 tests=[AWL=0.159, BAYES_00=-2.599, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_HI=-8]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id pTJBDkjHFkok; Fri, 13 Jul 2012 16:47:56 -0700 (PDT)
Received: from av-tac-bru.cisco.com (weird-brew.cisco.com [144.254.15.118]) by ietfa.amsl.com (Postfix) with ESMTP id ED65B11E80C0; Fri, 13 Jul 2012 16:47:55 -0700 (PDT)
X-TACSUNS: Virus Scanned
Received: from strange-brew.cisco.com (localhost.cisco.com [127.0.0.1]) by av-tac-bru.cisco.com (8.13.8+Sun/8.13.8) with ESMTP id q6DNmWQK024250; Sat, 14 Jul 2012 01:48:32 +0200 (CEST)
Received: from [10.60.67.85] (ams-bclaise-8914.cisco.com [10.60.67.85]) by strange-brew.cisco.com (8.13.8+Sun/8.13.8) with ESMTP id q6DNmTxj020470; Sat, 14 Jul 2012 01:48:29 +0200 (CEST)
Message-ID: <5000B3CD.5000604@cisco.com>
Date: Sat, 14 Jul 2012 01:48:29 +0200
From: Benoit Claise <bclaise@cisco.com>
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120614 Thunderbird/13.0.1
MIME-Version: 1.0
To: aaa-doctors@ietf.org, "MIB Doctors (E-mail)" <mib-doctors@ietf.org>, YANG Doctors <yang-doctors@ietf.org>, "ops-dir@ietf.org" <ops-dir@ietf.org>, IETF DNS Directorate <dns-dir@ietf.org>
References: <20120712224354.13043.7504.idtracker@ietfa.amsl.com>
In-Reply-To: <20120712224354.13043.7504.idtracker@ietfa.amsl.com>
X-Forwarded-Message-Id: <20120712224354.13043.7504.idtracker@ietfa.amsl.com>
Content-Type: multipart/alternative; boundary="------------090602040801030608060707"
Subject: [MIB-DOCTORS] [IESG-AGENDA-DIST] Summarized Agenda for the 2012-07-19 IESG Teleconference
X-BeenThere: mib-doctors@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: MIB Doctors list <mib-doctors.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/mib-doctors>
List-Post: <mailto:mib-doctors@ietf.org>
List-Help: <mailto:mib-doctors-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/mib-doctors>, <mailto:mib-doctors-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 13 Jul 2012 23:47:58 -0000

This is a multi-part message in MIME format.
--------------090602040801030608060707
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Dear all,

Please find below the agenda of the July 19th  IESG telechat.

Please send your questions, comments and concerns before July 18th COB.

Thanks and Regards, Benoit.


-------- Original Message --------
Subject: 	[IESG-AGENDA-DIST] Summarized Agenda for the 2012-07-19 IESG 
Teleconference
Date: 	Thu, 12 Jul 2012 15:43:54 -0700
From: 	IESG Secretary <iesg-secretary@ietf.org>
To: 	iesg-agenda-dist@ietf.org



INTERNET ENGINEERING STEERING GROUP (IESG)
Summarized Agenda for the 2012-07-19 IESG Teleconference

This agenda was generated at 2012-07-12 15:42:12 PDT
Up-to-date web version of this agenda can be found at:
http://datatracker.ietf.org/iesg/agenda/
                                                                                 


2. Protocol Actions
2.1 WG Submissions
2.1.1 New Items

   o draft-sakane-dhc-dhcpv6-kdc-option-17
     Kerberos Options for DHCPv6 (Proposed Standard)
     Note: The Document Shepherd for this document is Jeffrey Hutzelman,
     (jhutz@cmu.edu).
     Token: Stephen Farrell

   o draft-ietf-behave-lsn-requirements-08
     Common requirements for Carrier Grade NATs (CGNs) (Best Current
     Practice)
     Note: Dan Wing (dwing@cisco.com) is the document shepherd.
     Token: Wesley Eddy

   o draft-ietf-6lowpan-btle-08
     Transmission of IPv6 Packets over Bluetooth Low Energy (Proposed
     Standard)
     Note: Carsten Bormann (cabo@tzi.org) is the Document Shepherd.
     Token: Ralph Droms

   o draft-ietf-idr-rfc4893bis-07
     BGP Support for Four-octet AS Number Space (Proposed Standard)
     Note: John Scudder (jgs@juniper.net) is the document shepherd.
     Token: Stewart Bryant

   o draft-ietf-abfab-gss-eap-08
     A GSS-API Mechanism for the Extensible Authentication Protocol
     (Proposed Standard)
     Token: Stephen Farrell

   o draft-ietf-dnsext-dnssec-algo-imp-status-03
     Applicability Statement: DNS Security (DNSSEC) DNSKEY Algorithm
     Implementation Status (Best Current Practice)
     Note: Andrew Sullivan (ajs@anvilwalrusden.com) is the Document
     Shepherd
     Token: Ralph Droms

   o draft-ietf-dnsext-dnssec-registry-update-03
     DNS Security (DNSSEC) DNSKEY Algorithm IANA Registry Updates
     (Proposed Standard)
     Note: Andrew Sullivan (ajs@anvilwalrusden.com) is the Document
     Shepherd
     Token: Ralph Droms

   o draft-ietf-appsawg-received-state-04
     Indicating Email Handling States in Trace Fields (Proposed Standard)
     Token: Barry Leiba

   o draft-ietf-pkix-caa-10
     DNS Certification Authority Authorization (CAA) Resource Record
     (Proposed Standard)
     Note: Steve Kent (kent@bbn.com) is the Document Shepherd.
     Token: Sean Turner

2.1.2 Returning Items

   NONE

2.2 Individual Submissions
2.2.1 New Items

   o draft-sandlund-rfc4996bis-02
     RObust Header Compression (ROHC): A Profile for TCP/IP (ROHC-TCP)
     (Proposed Standard)
     Token: Wesley Eddy

   o draft-camarillo-rai-media-policy-dataset-02
     A User Agent Profile Data Set for Media Policy (Proposed Standard)
     Note: Mary Barnes is the document shepherd
     Token: Robert Sparks

   o draft-farrell-decade-ni-09
     Naming Things with Hashes (Proposed Standard)
     Note: Alexey Melnikov (Alexey.Melnikov@isode.com) is the document
     shepherd.
     Token: Barry Leiba

2.2.2 Returning Items

   NONE

3. Document Actions
3.1 WG Submissions
3.1.1 New Items

   o draft-ietf-karp-threats-reqs-05
     Keying and Authentication for Routing Protocols (KARP) Overview,
     Threats, and Requirements (Informational)
     Note: Brian Weis (bew@cisco.com) is the document shepherd.
     Token: Stewart Bryant

   o draft-ietf-cdni-use-cases-09
     Use Cases for Content Delivery Network Interconnection
     (Informational)
     Note:  Francois Le Faucheur (flefauch@cisco.com) is the Document
     Shepherd.
     Token: Martin Stiemerling

   o draft-ietf-ippm-twamp-value-added-octets-04
     Ericsson TWAMP Value-Added Octets (Informational)
     Note: Henk Uijterwaal (henk@uijterwaal.nl) is the document shepherd.
     Token: Wesley Eddy

   o draft-ietf-oauth-urn-sub-ns-05
     An IETF URN Sub-Namespace for OAuth (Informational)
     Note: Derek Atkins (derek@ihtfp.com) is the document shepherd.
     Token: Stephen Farrell

3.1.2 Returning Items

   NONE

3.2 Individual Submissions Via AD
3.2.1 New Items

   o draft-claise-export-application-info-in-ipfix-09
     Cisco Systems Export of Application Information in IPFIX
     (Informational)
     Note: Individual Submission, AD-sponsored, Nevil Brownlee is the
     document shepherd,
     Token: Ronald Bonica

   o draft-melnikov-smtp-priority-tunneling-03
     Tunneling of SMTP Message Transfer Priorities (Experimental)
     Token: Pete Resnick

   o draft-krishnan-nomcom-tools-01
     Requirements for IETF Nominations Committee tools (Informational)
     Token: Russ Housley

3.2.2 Returning Items

   NONE

3.3 IRTF and Independent Submission Stream Documents
3.3.1 New Items

   NONE

3.3.2 Returning Items

   NONE

3.3.3 For Action

   o draft-mme-trill-fcoe-02
     FCoE over TRILL (Informational)
     Note: ISE submission
     Token: Ralph Droms

4. Working Group Actions
4.1 WG Creation
4.1.1 Proposed for IETF Review

   NONE

4.1.2 Proposed for Approval

   NONE

4.2 WG Rechartering
4.2.1 Under Evaluation for IETF Review

   NONE

4.2.2 Proposed for Approval

   NONE



--------------090602040801030608060707
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<html>
  <head>

    <meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    Dear all,
    <br>
    <br>
    Please find below the agenda of the July 19th&nbsp; IESG telechat.
    <br>
    <br>
    Please send your questions, comments and concerns before July 18th
    COB.
    <br>
    <br>
    Thanks and Regards, Benoit.
    <div class="moz-forward-container"><br>
      <br>
      -------- Original Message --------
      <table class="moz-email-headers-table" border="0" cellpadding="0"
        cellspacing="0">
        <tbody>
          <tr>
            <th align="RIGHT" nowrap="nowrap" valign="BASELINE">Subject:
            </th>
            <td>[IESG-AGENDA-DIST] Summarized Agenda for the 2012-07-19
              IESG Teleconference</td>
          </tr>
          <tr>
            <th align="RIGHT" nowrap="nowrap" valign="BASELINE">Date: </th>
            <td>Thu, 12 Jul 2012 15:43:54 -0700</td>
          </tr>
          <tr>
            <th align="RIGHT" nowrap="nowrap" valign="BASELINE">From: </th>
            <td>IESG Secretary <a class="moz-txt-link-rfc2396E" href="mailto:iesg-secretary@ietf.org">&lt;iesg-secretary@ietf.org&gt;</a></td>
          </tr>
          <tr>
            <th align="RIGHT" nowrap="nowrap" valign="BASELINE">To: </th>
            <td><a class="moz-txt-link-abbreviated" href="mailto:iesg-agenda-dist@ietf.org">iesg-agenda-dist@ietf.org</a></td>
          </tr>
        </tbody>
      </table>
      <br>
      <br>
      <pre>INTERNET ENGINEERING STEERING GROUP (IESG)
Summarized Agenda for the 2012-07-19 IESG Teleconference

This agenda was generated at 2012-07-12 15:42:12 PDT
Up-to-date web version of this agenda can be found at:
<a class="moz-txt-link-freetext" href="http://datatracker.ietf.org/iesg/agenda/">http://datatracker.ietf.org/iesg/agenda/</a>
                                                                                


2. Protocol Actions
2.1 WG Submissions
2.1.1 New Items

  o draft-sakane-dhc-dhcpv6-kdc-option-17
    Kerberos Options for DHCPv6 (Proposed Standard)
    Note: The Document Shepherd for this document is Jeffrey Hutzelman,
    (<a class="moz-txt-link-abbreviated" href="mailto:jhutz@cmu.edu">jhutz@cmu.edu</a>).
    Token: Stephen Farrell

  o draft-ietf-behave-lsn-requirements-08
    Common requirements for Carrier Grade NATs (CGNs) (Best Current
    Practice)
    Note: Dan Wing (<a class="moz-txt-link-abbreviated" href="mailto:dwing@cisco.com">dwing@cisco.com</a>) is the document shepherd.
    Token: Wesley Eddy

  o draft-ietf-6lowpan-btle-08
    Transmission of IPv6 Packets over Bluetooth Low Energy (Proposed
    Standard)
    Note: Carsten Bormann (<a class="moz-txt-link-abbreviated" href="mailto:cabo@tzi.org">cabo@tzi.org</a>) is the Document Shepherd. 
    Token: Ralph Droms

  o draft-ietf-idr-rfc4893bis-07
    BGP Support for Four-octet AS Number Space (Proposed Standard)
    Note: John Scudder (<a class="moz-txt-link-abbreviated" href="mailto:jgs@juniper.net">jgs@juniper.net</a>) is the document shepherd.
    Token: Stewart Bryant

  o draft-ietf-abfab-gss-eap-08
    A GSS-API Mechanism for the Extensible Authentication Protocol
    (Proposed Standard)
    Token: Stephen Farrell

  o draft-ietf-dnsext-dnssec-algo-imp-status-03
    Applicability Statement: DNS Security (DNSSEC) DNSKEY Algorithm
    Implementation Status (Best Current Practice)
    Note: Andrew Sullivan (<a class="moz-txt-link-abbreviated" href="mailto:ajs@anvilwalrusden.com">ajs@anvilwalrusden.com</a>) is the Document
    Shepherd
    Token: Ralph Droms

  o draft-ietf-dnsext-dnssec-registry-update-03
    DNS Security (DNSSEC) DNSKEY Algorithm IANA Registry Updates
    (Proposed Standard)
    Note: Andrew Sullivan (<a class="moz-txt-link-abbreviated" href="mailto:ajs@anvilwalrusden.com">ajs@anvilwalrusden.com</a>) is the Document
    Shepherd
    Token: Ralph Droms

  o draft-ietf-appsawg-received-state-04
    Indicating Email Handling States in Trace Fields (Proposed Standard)
    Token: Barry Leiba

  o draft-ietf-pkix-caa-10
    DNS Certification Authority Authorization (CAA) Resource Record
    (Proposed Standard)
    Note: Steve Kent (<a class="moz-txt-link-abbreviated" href="mailto:kent@bbn.com">kent@bbn.com</a>) is the Document Shepherd.
    Token: Sean Turner

2.1.2 Returning Items

  NONE

2.2 Individual Submissions
2.2.1 New Items

  o draft-sandlund-rfc4996bis-02
    RObust Header Compression (ROHC): A Profile for TCP/IP (ROHC-TCP)
    (Proposed Standard)
    Token: Wesley Eddy

  o draft-camarillo-rai-media-policy-dataset-02
    A User Agent Profile Data Set for Media Policy (Proposed Standard)
    Note: Mary Barnes is the document shepherd
    Token: Robert Sparks

  o draft-farrell-decade-ni-09
    Naming Things with Hashes (Proposed Standard)
    Note: Alexey Melnikov (<a class="moz-txt-link-abbreviated" href="mailto:Alexey.Melnikov@isode.com">Alexey.Melnikov@isode.com</a>) is the document
    shepherd.
    Token: Barry Leiba

2.2.2 Returning Items

  NONE

3. Document Actions
3.1 WG Submissions
3.1.1 New Items

  o draft-ietf-karp-threats-reqs-05
    Keying and Authentication for Routing Protocols (KARP) Overview,
    Threats, and Requirements (Informational)
    Note: Brian Weis (<a class="moz-txt-link-abbreviated" href="mailto:bew@cisco.com">bew@cisco.com</a>) is the document shepherd.
    Token: Stewart Bryant

  o draft-ietf-cdni-use-cases-09
    Use Cases for Content Delivery Network Interconnection
    (Informational)
    Note:  Francois Le Faucheur (<a class="moz-txt-link-abbreviated" href="mailto:flefauch@cisco.com">flefauch@cisco.com</a>) is the Document
    Shepherd.
    Token: Martin Stiemerling

  o draft-ietf-ippm-twamp-value-added-octets-04
    Ericsson TWAMP Value-Added Octets (Informational)
    Note: Henk Uijterwaal (<a class="moz-txt-link-abbreviated" href="mailto:henk@uijterwaal.nl">henk@uijterwaal.nl</a>) is the document shepherd.
    Token: Wesley Eddy

  o draft-ietf-oauth-urn-sub-ns-05
    An IETF URN Sub-Namespace for OAuth (Informational)
    Note: Derek Atkins (<a class="moz-txt-link-abbreviated" href="mailto:derek@ihtfp.com">derek@ihtfp.com</a>) is the document shepherd.
    Token: Stephen Farrell

3.1.2 Returning Items

  NONE

3.2 Individual Submissions Via AD
3.2.1 New Items

  o draft-claise-export-application-info-in-ipfix-09
    Cisco Systems Export of Application Information in IPFIX
    (Informational)
    Note: Individual Submission, AD-sponsored, Nevil Brownlee is the
    document shepherd, 
    Token: Ronald Bonica

  o draft-melnikov-smtp-priority-tunneling-03
    Tunneling of SMTP Message Transfer Priorities (Experimental)
    Token: Pete Resnick

  o draft-krishnan-nomcom-tools-01
    Requirements for IETF Nominations Committee tools (Informational)
    Token: Russ Housley

3.2.2 Returning Items

  NONE

3.3 IRTF and Independent Submission Stream Documents
3.3.1 New Items

  NONE

3.3.2 Returning Items

  NONE

3.3.3 For Action

  o draft-mme-trill-fcoe-02
    FCoE over TRILL (Informational)
    Note: ISE submission
    Token: Ralph Droms

4. Working Group Actions
4.1 WG Creation
4.1.1 Proposed for IETF Review

  NONE

4.1.2 Proposed for Approval

  NONE

4.2 WG Rechartering
4.2.1 Under Evaluation for IETF Review

  NONE

4.2.2 Proposed for Approval

  NONE


</pre>
    </div>
  </body>
</html>

--------------090602040801030608060707--
