Subject: [midcom] Re: I-D ACTION:draft-carpenter-midtax-00.txt

From: Manish Karir <[email-masked]>
Date: Thu, 1 Feb 2001 16:13:24 -0500 (EST)

Brian,

Overall I thought this was quite a good start for the midcom
group, finally we can atleast all try to agree on what 
a middle box is?. and what different types they can be..

However, I thought the section on TCP spoofers was somewhat inaccurate...
section 2.1.5 

I dont think its correct to say that TCP spoofers are mainly propritary,
some implementations are freely available..moreover, it is also 
incorrect to say that they have been charaterized only when they 
introduce interoperability problems with standard TCP.  TCP spoofers
have been studied quite extensively.  Correct implementations interoperate
quite seamlessly with standard TCP.  It is also wrong to say that 
they introduce not only TCP errors, but also changes in TCP adaptive 
behaviour.  Correct implementations do not introduce any TCP errors,
and the changes that the introduce in TCP behavior are intentional 
and desirable. Note: they are only used in cases where the modifications
are desired.

A few references:
Snoop Protocol
http://www.cs.berkeley.edu/~hari/papers/snoop.html
TCP Connection Splitting
http://www.isr.umd.edu/TechReports/CSHCN/1999/CSHCN_TR_99-34/CSHCN_TR_99-34.phtml
http://www.isr.umd.edu/TechReports/CSHCN/1999/CSHCN_TR_99-11/CSHCN_TR_99-11.phtml
http://www.isr.umd.edu/TechReports/CSHCN/1999/CSHCN_MS_99-7/CSHCN_MS_99-7.phtml

manish karir

On Thu, 1 Feb 2001, Bob Braden wrote:

> _____________________________________________________________
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title		: Middle boxes: taxonomy and issues
> 	Author(s)	: B. Carpenter
> 	Filename	: draft-carpenter-midtax-00.txt
> 	Pages		: 15
> 	Date		: 30-Jan-01
> 	
> This document is intended as input to IETF discussion about 'middle
> boxes' - defined as any intermediary box performing functions apart
> from normal, standard functions of an IP router on the data path
> between a source host and destination host.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-carpenter-midtax-00.txt

_______________________________________________
midcom mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/midcom

---

From: Allison Mankin <[email-masked]>
Date: Thu, 01 Feb 2001 17:05:54 -0500

Manish,

Here's the text your mail addresses:

>    Many TCP PEPs are proprietary and
>    have been characterised in the open Internet primarily when they
>    introduce interoperability errors with standard TCP.  As with TLGs,
>    there are circumstances in which a TCP PEP is seen to meet needs not
>    otherwise met.  For example, a TCP PEP may provide re-spacing of ACKs
>    that have been bunched together by a link with bursty service, thus
>    avoiding undesireable data segment bursts.  The PILC (Performance
>    Implications of Link Characteristics) working group has analyzed
>    types of TCP PEPs and their applicability [PILCPEP].

The section does not say that PEPs are "mainly" proprietary, but does
want to draw attention to the impact of proprieatry ones.  Knowledge
of the range of vendors suggests there is a good number of proprietary
ones, and some measurement studies suggest that the proprietary ones
can be noticed/recognized when they break something.   Maybe the wording 
about "errors" could be improved.

On non-proprietary forms of PEPs, the section is meant to imply
that there's detail in the PILCPEC document cited.  SNOOP is
discussed there, for instance.  It seems the wording could
be improved to make sure that the pointer is clear.  PILCPEP has
a fairly long references section, which includes both
publicly documented and available spoofers, and urls for some
products.  There's a plan to update those references before the
document progresses (and also comments on PILCPEP are timely
and welcome).

Allison (speaking for PILCPEP as its AD :)

> Date:    Thu, 01 Feb 2001 16:13:24 EST
> Subject: [midcom] Re: I-D ACTION:draft-carpenter-midtax-00.txt
> From:    Manish Karir <[email-masked]>
> --------
> 
> 
> Brian,
>

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 01 Feb 2001 17:04:28 -0600

Manish,

> > a middle box is?. and what different types they can be..

The draft is not aimed specifically at midcom - it's currently
an orphan - but, hey, if midcom likes it who am I to complain?

   Brian

---

From: "Scott Brim" <[email-masked]>
Date: Fri, 2 Feb 2001 10:24:13 -0500

Brian, it seems that the only reason an HTTP proxy is not an ALG in your
taxonomy is that you don't think ALGs terminate sessions, they only do
field substitution.  I think of ALGs as terminating sessions (anything
that doesn't terminate a session is some kind of relay), and I think of
HTTP proxies as a special case of ALG.

I would add what I call application-level replicators, also known as
application-level multicast "routers".  Example: CU-SeeMe.

Oh, and relays are known in some circles as interworking functions.

See you ... Scott

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 02 Feb 2001 09:54:02 -0600

Hmm. I will need to be more precise in the language since both ways
of looking at this are valid. Thanks.

  Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Program Director, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Board Chairman, Internet Society http://www.isoc.org
Non-IBM email: [email-masked]

---

From: "Scott Brim" <[email-masked]>
Date: Fri, 2 Feb 2001 11:15:49 -0500

> of looking at this are valid. Thanks.

One of the reasons I didn't follow through on a career in plant taxonomy
is because I discovered how arbitrary taxonomy can be.  Anything works;
we'll see what's most useful as we apply it.