Subject: FW: [midcom] SIP MIDCOM flow...

From: "Christopher A. Martin" <[email-masked]>
Date: Fri, 30 Mar 2001 10:33:03 -0600

I thought I should change the name of the SIP proxy to SIP/Ctrl Proxy to
denote that the midcom controller is integrated in this example for this
protocol (and only as an example not as a requirement).

To simplify things a bit, in relation to SIP, I thought that I would add
this call flow to the mix. Middlebox control messages are merely examples.

SIP UA		SIP/Ctrl	Middle	Internal
Client 		Proxy		Box		SIP Client
|			|		    |		   |
|----INVITE------>|		    |		   |
|    		      |-----INVITE--->|		   |
|<---100Trying----|		    |		   |
|    	            |----Initiate-->|	         |
|			|<-Initiated----|		   |
|			|		    |-INVITE-->|
|			|<-----180Ringing----------|
|<--180Ringing----|		    |		   |
|			|<-------200 OK------------|
|<---200 OK ------|	  	    |		   |
|		      |----OPEN Hole->| 	   |
|			|<-OPEN Hole----|		   |
|-------ACK------>|		    |		   |
|		      |-----------ACK------------|
|			|		    |		   |
|<-------------------RTP/RTCP--------------->|
|			|		    |		   |
|-------BYE------>|		    |		   |
|			|----Terminate->|		   |
|		      |<-Terminating--|		   |
|			|		    |----BYE-->|
|			|<----------200 OK---------|
|			|----CloseHole->|		   |
|		      |<---CloseHole--|		   |
|<---200 OK-------|		    |		   |
|			|		    |          |

This flow describes a call from start to finish.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Bob Penfield
> Sent: Friday, March 30, 2001 8:26 AM
> To: [email-masked]; George Michaelson
> Cc: [email-masked]
> Subject: Re: [midcom] SIP MIDCOM flow...
>
>
> see comments below
>
>
> ----- Original Message -----
> From: "George Michaelson" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, March 29, 2001 9:19 PM
> Subject: Re: [midcom] SIP MIDCOM flow...
>
>
> >
> >   Hi,
> >
> >   Can someone help me fill in the missing pieces in the
> following diagram?
> >   I'm trying to understand the flow of communication.
> >
> >
> >                          _________
> >                     --->|   SIP   |<-----\
> >                    /    |  Proxy  |       \
> >                   |     |_________|       |
> >                  1|       |     |       1a|
> >                   |       |     |         |
> >                   |4      |2    |3        |1b
> >      _________    |       |     |         \    ________
> >     | Outside |<--/      _v_____^___       \->|        |
> >     |SIP Phone|     a   |           |    c    | Inside |
> >     |         |>------->| MiddleBox |>------->|  SIP   |
> >     |_________|<-------<|___________|<-------<| Phone  |
> >                     b                    d    |________|
> >
> >   Note that 1/4 is a request/response respectively.
>
> There is a missing request/response (I've added 1a+1b above)
> from the SIP
> Proxy to the Inside SIP Phone. Note that 1+4 and/or 1a+1b may
> go thru the
> MiddleBox for NAT/Firewall, but that rule would have been previously
> estabished.
>
> >
> > I have labelled the other paths {a,b,c,d} to make it plain
> they aren't
> > ordered. Your question lies in the space:
> >
> > "what order do {a,b,c,d} take place"
> >
> These represent the RTP flow for the session and it does not
> really matter
> whether a or d is first. None of them can begin until the
> NAT/forwarding
> rules (forward a to c and d to b) are installed by the 2+3
> transaction from
> the proxy.
>
> > and one presumes there are sequencing differences if c
> predicates 3-4
> > being done etc etc.
> >
> > ie, in a 3-way endpoint dialogue, is there end-to-end-ness for all 3
> parties?
> >
> > (middlebox is being directed in this exchange.
> circumstances where it says
> >  "no" seem to me to under constrains coming from other
> places. Or does it
> have
> >  rigid policy embedded? are there other paths left out for
> simplicity?)
> >
> > -George
> >
> > --
> > George Michaelson         |  DSTC Pty Ltd
> > Email: [email-masked]    |  University of Qld 4072
> > Phone: +61 7 3365 4310    |  Australia
> >   Fax: +61 7 3365 4311    |  http://www.dstc.edu.au
> >
> > _______________________________________________
> > midcom mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/midcom
> >
>
>
> _______________________________________________
> midcom mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/midcom
>

_______________________________________________
midcom mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/midcom

---

From: "Christopher A. Martin" <[email-masked]>
Date: Fri, 30 Mar 2001 10:57:15 -0600

One additional point of clarification, as you can see I am shooting fomr the
hip, the following commands are not related to SIP rather they are used
between middlebox and controller in this "example": Initiate, Initiated,
Terminate, Terminating, OPEN Hole, Close Hole. All other messages are SIP
specific to indicate how they would fit in a call flow together.

> Christopher A. Martin
> Sent: Friday, March 30, 2001 10:33 AM
> To: [email-masked]
> Subject: FW: [midcom] SIP MIDCOM flow...
>
>
> > From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> > Bob Penfield