Subject: RE: [midcom] on "diversion"

From: "Maciocco, Christian" <[email-masked]>
Date: Wed, 28 Mar 2001 12:58:02 -0800

This picture might lead to confusion over what Midcom is doing. At the 
last meeting it was said that Midcom will focus only on NAT/Firewall  
and not application level stuff. I'd remove (2) & (3) from this picture
as this seems closer to what OPES is doing.

Christian

> -----Original Message-----
> From: Eliot Lear [mailto:[email-masked]]
> Sent: Sunday, March 25, 2001 1:04 AM
> To: Randy Turner
> Cc: [email-masked]
> Subject: Re: [midcom] on "diversion"
> 
> 
> To me, diversion means the following (the numbers next to the lines
> indicate the data flow):
> 
>     __________
>    |          |
>    | External |
>    |  Host    |
>    |__________|
>        v
>        |
>        |
>        |1
>        |
>        |
>     ___v______     2        ______________
>    |          |>---------->|              |
>    |  NAT /   |            |  Application |
>    | Firewall |<----------<|  Controller  |
>    |__________|    3       |______________|
>        v
>        |
>        |
>        |4
>        |
>        |
>     ___v______
>    |          |
>    | Internal |
>    |  Host    |
>    |__________|
> 
> 
> 
> Although I indicate flow direction from external to internal, the
> opposite flow direction would also be considered a diversion.
> 
> Note that (3) is optional.  It's quite possible that the
> application controller could conceivably consume the flow in its
> entirety (like in the case of a transparent cache).
> 
> Requiring this sort of capability, and even mentioning it, is
> a rathole.  I'm not arguing that we should go out of our way to
> prevent it, but let's not go out of our way to do that either.
> 
> 
> 
> 
> _______________________________________________
> midcom mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/midcom
> 

_______________________________________________
midcom mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/midcom

---

From: Eliot Lear <[email-masked]>
Date: Wed, 28 Mar 2001 13:37:58 -0800

Well, now.  It sounds like we have consensus.  Let's not do diversion 
and leave that for OPES (if anywhere).