Subject: RE: [midcom] on "diversion"

From: Randy Turner <[email-masked]>
Date: Sat, 24 Mar 2001 21:31:51 -0800

At the plenary meeting of MIDCOM, I don't remember anyone actually
"defining" what diversion meant. I think some folks thought just rewriting
IP addresses meant diversion, while others seem to think that actually
moving a packet to another entity, and then getting back a response, prior
to forwarding (kinda like a remote ALG), was diversion.

Can we agree on what diversion is before we decide if it's necessary.

Thanks!
Randy

-----Original Message-----
From: Eliot Lear
To: [email-masked]
Sent: 3/24/01 4:56 PM
Subject: [midcom] on "diversion"

Do people need to be convinced that diversion is not necessary to
discuss
in ANY midcom work?
--
Eliot Lear
[email-masked]

_______________________________________________
midcom mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/midcom

_______________________________________________
midcom mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/midcom

---

From: Eliot Lear <[email-masked]>
Date: Sun, 25 Mar 2001 01:03:45 -0800

To me, diversion means the following (the numbers next to the lines
indicate the data flow):

    __________
   |          |
   | External |
   |  Host    |
   |__________|
       v
       |
       |
       |1
       |
       |
    ___v______     2        ______________
   |          |>---------->|              |
   |  NAT /   |            |  Application |
   | Firewall |<----------<|  Controller  |
   |__________|    3       |______________|
       v
       |
       |
       |4
       |
       |
    ___v______
   |          |
   | Internal |
   |  Host    |
   |__________|

Although I indicate flow direction from external to internal, the
opposite flow direction would also be considered a diversion.

Note that (3) is optional.  It's quite possible that the
application controller could conceivably consume the flow in its
entirety (like in the case of a transparent cache).

Requiring this sort of capability, and even mentioning it, is
a rathole.  I'm not arguing that we should go out of our way to
prevent it, but let's not go out of our way to do that either.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 27 Mar 2001 12:18:46 -0600

This looks exactly like the OPES call-out model to me, except that 
OPES is restricting the domain of discourse to HTTP and RTP based
apps.

   Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Program Director, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Board Chairman, Internet Society http://www.isoc.org
Non-IBM email: [email-masked]