Subject: [midcom] Some comments on scenario draft

From: "Cedric Aoun" <[email-masked]>
Date: Fri, 11 May 2001 15:43:05 +0100

Christian, 
I have a couple of minor comments on the draft:
-I'm not quite sure that basic NAT (1 address to 1 address mapping) will be
completely forgotten in IPv6, enterprises will still would like to have a
certain independence from their ISP since the used addresses are provided by
the ISP and they don't want to change their addresses when they change their
ISP.

-In big corporations we could have a lot of cases where the signaling flow
will traverse a different Middle box than the bearer path, this is a
realistic scenario.
It won't happen for residential customers and SME (might happen) but for big
corporations having several gateways it will happen.
I know that middle box discovery is out of scope of the workgroup, and that
is the main reason why this scenario is not in your draft but I think it is
worth to
note it. 

I'm sure that other people in the list are interested in this scenario as
well.
Feedback is welcomed
Regards

Cedric Aoun
Nortel Networks
33, quai Paul Doumer
Paris La Defense
92415 Courbevoie Cedex France
Gsm +33 6 85 74 43 04
Fax  +33 1 46215598
[email-masked]

---

From: "Melinda Shore" <[email-masked]>
Date: Fri, 11 May 2001 13:23:33 -0400

> is the main reason why this scenario is not in your draft but I think it is

It may be worth pointing out that while there's a discovery
(or location) component to what you're describing, it's
really a routing problem and it's rather difficult.

Melinda

_______________________________________________
midcom mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/midcom

---

From: Scott Brim <[email-masked]>
Date: Fri, 11 May 2001 15:25:37 -0400

> really a routing problem and it's rather difficult.

Would you expect different middleboxes to have different routes
available to them?  I would think that if you have two middleboxes which
both have the capabilities you're looking for, that the choice would
mainly be one of load balancing.  I have difficulty imagining two
accessible middleboxes which wouldn't have the same routing.

---

From: "Melinda Shore" <[email-masked]>
Date: Fri, 11 May 2001 15:37:31 -0400

> accessible middleboxes which wouldn't have the same routing.

Not that kind of routing - the *other* kind of routing.
In the case of VoIP, where you might have multiple gateways
"owned" by a single call control server and that call
control server is also functioning as a midcom agent, the
call control server would need to know which middlebox to
contact for which gateway.  For large networks this is
potentially pretty hairy.

Melinda