Subject: RE: [midcom] framework document

From: Wanqun Bao <[email-masked]>
Date: Fri, 18 May 2001 13:40:01 -0700

>> I assume, you are refering to figure 1. Are you saying it is visually
>> better to place Policy Server to the side of middlebox. I had it that way
>> originally; and some folks wanted to see end-hosts by the sides.
>> Well, there is only so much space that draft formatting allows.

>Actually, all I was suggesting was starting the line from the side, not
>moving the box.  I didn't count columns to know if ASCII art would allow
>you to do this.  If it does not, you want to make it clear that the policy
>server is not using MIDCOM by drawing a dividing line, going north.  If it
>would help I can send you a suggestion.
>--
>Eliot Lear
>[email-masked]

One way to do this is to add a "Policy Interface" in the middlebox and
let the "Policy Server" to point to it. I made a change in both Fig.1 and
Fig. 2 as below. Note that I removed one of the box for "MIDCOM agent
co-resident on End-hosts" in Fig. 1 because I think one such logical 
entity is enough for this diagram.

Cheers,

Wanqun Bao
[email-masked]

       +---------------+  +---------------+  +-------------+
       | MIDCOM agent  |  | MIDCOM agent  |  | Stand-alone |
       | co-resident on|  | co-resident on|  | MIDCOM agent|
       | Proxy Server  |  | Application GW|  |             |
       +---------------+  +---------------+  +-------------+
                      ^        ^              ^
                      |        |              |           +--------+
                      |        |              |           | Policy |
                      |        |              |         +-| Server |
                      |        |              |        /  +--------+
                      |        |   MIDCOM     |       /
   +-------------+    |        |   Protocol   |      /  
   | MIDCOM agent|    |        |              |     /    
   | co-resident |    |        |              |    /  
   | on End-hosts|<-+ |        |              |   / 
   +-------------+  | |        |              |  |  
                    v v        v              v  v 
              +-------------------------------------------+
              |Middlebox Communication Protocol|Policy    |
              |      (MIDCOM)Interface         |Interface |
              +----------+--------+-----------+-----------+
   Middlebox  |          |        |           |           |
   Functions  | Firewall |  NAT   | DiffServ- | Intrusion |
              |          |        |     QOS   | Detection |
              +----------+--------+-----------+-----------+
   Middlebox  | Firewall ACLs, Session-descriptors,       |
   Managed    | NAT-BINDs, NAT Address-Maps and other     | 
   Resources  | other Middlebox function  attributes      |
              +-------------------------------------------+

     Figure 1: MIDCOM agents interfacing with a middlebox

                             +-----------+
                             | Middlebox |
                             | Policy    |
                             | Server    |~~~~~~~~~~~~|
                             +-----------+             \
                                                        \
                      +---------+                        \        
                      | SIP     |___                      \    
              ________| Proxy   |   \            Middlebox \
             /        +---------+..  |        +-----------------+
            |                     :  | MIDCOM |         |       |
            |  RSTP +----------+  :..|........|MIDCOM   |POLICY |
        SIP |   ____|  RSTP    |.....|........|PROTOCOL |INTER- |
            |  /    |  Proxy   |___  |        |INTERFACE|FACE   |
            | |     +----------+   \  \       |-----------------|
            | |                     \  \------|                 |
            | |                      \--------|                 |
            | |                          -----|    FIREWALL     |-->--
         +-----------+                  /-----|                 |--<--
        +-----------+|   Data streams  //     +-----------------+
       +-----------+||----------->----//           |
       |end-hosts  ||------------<-----            .
       +-----------+   (RTP, RSTP data, etc.)      |  
                                                   .  Outside the
              Within a private domain              |  private domain
                                                   
       Legend: ---- Application data path datagrams
               ____ Application control path datagrams
               .... Middlebox Communication Protocol (MIDCOM)
               ~~~~ MIDCOM Policy Server Interface
                 |
                 .  private domain Boundary
                 |

       Figure 2: In-Path MIDCOM Agents for Middlebox Communication

_______________________________________________
midcom mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/midcom

_______________________________________________
midcom mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/midcom

---

From: Pyda Srisuresh <[email-masked]>
Date: Sat, 19 May 2001 20:19:36 -0700 (PDT)

Having a Policy interface distinct from MIDCOM protocol interface does
make it clearer. 

Thanks, Wanqun. I will use both your figures (and expand figure 3 as 
well accordingly).

cheers,
suresh

> entity is enough for this diagram.

=====

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices
http://auctions.yahoo.com/