Subject: RE: [midcom] Out-of-Path Midcom Agents in framework-02

From: "Maciocco, Christian" <[email-masked]>
Date: Wed, 20 Jun 2001 11:33:00 -0700

OPES non-transparent services which can be local or remote to the device
also support in-path agent (depending upon the services to be provided).
Christian

> -----Original Message-----
> From: Scott Brim [mailto:[email-masked]]
> Sent: Wednesday, June 20, 2001 8:15 AM
> To: Andrew Molitor
> Cc: [email-masked]
> Subject: Re: [midcom] Out-of-Path Midcom Agents in framework-02 
> 
> 
> On 20 Jun 2001 at 00:27 -0500, Andrew Molitor apparently wrote:
> > 	Rather than the loaded terms 'non-transparent' and 
> 'transparent' I
> > propose we use the terms 'In-Path' and 'Out-of-Path' respectively.
> 
> Nice try, but OPES (for example) is working with out-of-path
> non-transparent functions.  Also, the way we use 
> 'transparent' should be
> generally applicable throughout the IETF.  Again I like Randy's
> approach, along with awareness that transparency is a per-layer issue.
> 
> ...Scott
> 
> 
> _______________________________________________
> midcom mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/midcom
> 

_______________________________________________
midcom mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/midcom

---

From: "Zmolek, Andrew (Andrew)" <[email-masked]>
Date: Wed, 20 Jun 2001 16:20:25 -0600

Ultimately, you are correct, Randy. But even a sophisticated user has to
go through the process of implementation even if a 3rd party isn't
involved. And for midcom it's especially hard to argue that the protocol
is user-facing.

--Andy

-----Original Message-----
From: Randy Bush [mailto:[email-masked]]
Sent: Wednesday, June 20, 2001 3:10 PM
To: Zmolek, Andrew (Andrew)
Cc: Keith Moore; [email-masked]
Subject: RE: [midcom] Out-of-Path Midcom Agents in framework-02 

> Agreed. But no standard is worth pursuing if it provides no value to
> potential implementers.

s/implementors/users/

randy