Subject: [midcom] requirements-01 status

From: "Fleischman, Eric W" <[email-masked]>
Date: Wed, 27 Jun 2001 09:57:40 -0700

OK, We've now had a flurry of emails on the requirements draft. Many important points 
have been made. However, what have we learned from this email: what is our status?

I believe that we have consensus that directionality in the Pinhole-descriptor is redundant.

Was there a consensus on Christian Huitema's posting where he said:

>Next comment concerns the figure on page 6. The "Application Control
>Flow" line should be removed. It it a throw back of the "OOP" debate; we
>debated that OOP should maybe be mentioned in the framework with due
>precautions; it certainly does not belong in the requirements.
>Similarly, the paragraph that states that "The Middlebox must support
>the explicit forwarding of application control session information"
>should be removed, as well as the whole of section 7.

I fully agree with Christian's comment here, except for the part about there being a
consensus on OOP, which I feel was never reached. I think that our strong division on
OOP will hinder our making progress and we really need a "Plan B" (i.e., a compromise).
However, if I'm having a "senior moment" and there really was a compromise reached on OOP, 
is Christian's summary of it above accurate? If so, is the WG ready to accept his 
recommendation "as is"?

--Eric

_______________________________________________
midcom mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/midcom

---

From: "Melinda Shore" <[email-masked]>
Date: Wed, 27 Jun 2001 15:05:22 -0400

> consensus on OOP, which I feel was never reached. 

There's strong feeling in both directions, which I'm about 75% certain
will come back and dog us during the review process.  I'm consulting with
a Higher Power or two.

Melinda

---

From: "Bob Penfield" <[email-masked]>
Date: Wed, 27 Jun 2001 16:08:34 -0400

----- Original Message -----
From: "Fleischman, Eric W" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, June 27, 2001 12:57 PM
Subject: [midcom] requirements-01 status

> I believe that we have consensus that directionality in the
Pinhole-descriptor is redundant.

I'm not sure I agree with this. I know we have gone back and forth on
directionality and being able to associate a pinhole-descriptor with an
interface. Could you summarize what you believe is the consensus on any
requirements (or lack there of) for making sure that packets only flow thru
the middlebox in the direction the MIDCOM Agents wants them to.