Subject: RE: Nits (was: RE: [midcom] Comments on Framework 03 draft)

From: [email-masked]
Date: Sat, 28 Jul 2001 21:41:42 +0100

Suresh,

> -----Original Message-----
> From: Pyda Srisuresh [mailto:[email-masked]]
> Sent: 27 July 2001 04:03
> To: [email-masked]; [email-masked]
> Subject: Nits (was: RE: [midcom] Comments on Framework 03 draft)
> 
> 
> 
> --- [email-masked] wrote:
> > > > nits
> > > > ===
> > > > Page 1 and elsewhere. NetMeeting V3.x isn't always a 
> > > peer-peer application
> > > > so it is a bit misleading to cite it. It can be - but 
> not always.
> > > > 
> > > I dont know about specific versions. I dont find this misleading.
> > 
> > Or to be blunt what you have said is factually inaccurate. 
> It is simply an
> > true statement.
> >
> 
> Why is NetMeeting not a peer-to-peer application? Please explain.
> NetMeeting includes audio/video conferencing, chat, file tarnsfer
> and so forth.
> 

Just because NetMeeting includes or can include some traditional peer-peer
applications doesn't mean it is a peer-peer application itself. The text in
question suggested that NetMeeting was a peer-peer application. However in
gatekeeper routed mode, or indeed if it uses a gateway, it clearly isn't a
pure peer-peer application; there is a whole lot of stuff in between the two
end-points. In gatekeeper mode, some of the signalling is communicated via
the gatekeeper and so does not go directly to the called terminal - there is
no guarantee that what NetMeeting sends out is what gets to the far side. In
gateway mode, the call hits a gateway which translates the signalling and
media - so is not peer-to-peer.

Hope this helps.

regards

Richard

> > > > Section 8.6 makes reference to Q.931 which technically 
> > > isn't correct and
> > > > should probably read H.225.0 call signalling.
> > > > 
> > > 
> > > Q.931 is the packet format exchanged over H.323 TCP connection. 
> > > The Intel document that describes H.323 also refers the Q.931
> > > and H.323 connections interchangeably. So, I suggest,
> > > we leave this as is.
> > > 
> > 
> > Sorry - H.323 is an ITU-T specification not an Intel one! H.323 call
> > signalling is defined in H.225.0 which contains a profile 
> of Q.931 (it uses
> > the balanced mode of operation). Therefore the call 
> signalling in H.323 is
> > defined in H.225.0 and not Q.931 - that is a different document and
> > specification all together. I suggest we change it to make 
> it factually
> > acurate.
> > 
> Will do. Thanks.
> 
> > regards
> > 
> > Richard 
> > 
> > _______________________________________________
> > midcom mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/midcom
> 
> 
> =====
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Make international calls for as low as $.04/minute with 
> Yahoo! Messenger
> http://phonecard.yahoo.com/
> 

_______________________________________________
midcom mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/midcom

---

From: Pyda Srisuresh <[email-masked]>
Date: Mon, 30 Jul 2001 18:54:48 -0700 (PDT)

<...  stuff deleted>
> media - so is not peer-to-peer.

Hmm... the semantics I ascribe to peer-to-peer is from the perspective of
end-user and is different from what you seem to imply. Correct me if I 
misunderstood. But, you seem to imply that an application is peer-to-peer
only when there is direct communication between end-hosts with no third 
party intervention. NetMeeting may use Gatekeeper to route calls and to
transit data. So, by your definition, this does not fit the definition
of peer-to-peer.

I dont believe, most people interprest peer-to-peer that way. Certainly,
I dont think Christian implied this when he first suggested including 
this in the text. My understanding of peer-to-peer is simply that either
party can initiate a connection to the other. For example, Telnet and HTTP
browsers would clearly be considered client-server type applications. 
Video conferencing and Phone calls and chat will be considered 
peer-to-peer (unless incoming calls are disabled). This does not necessarily
refer to how a particular application is implemented.

> Richard

Thanks.

regards,
suresh

=====

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

---

From: Bobby Sardana <[email-masked]>
Date: Mon, 30 Jul 2001 23:23:17 -0700

Greetings all:

I do agree with the definition of peer-to-peer that Richard has provided. There
can't be two defintions, one which applies to end-user perception and the other
when end systems are communicating without an intermediate node. If an
intermediate node is involved and performs routing, gatekeeping activities, it
can maintain the state  of each communicating end nodes. The communication of the
end nodes is then via an intermediary and not peer-to-peer. OTOH, if there is no
intermediary involved and the end nodes communicate and maintain the state, the
application is peer-to-peer.

Bobby [0.02c :-] Sardana.
[email-masked]

---

From: Scott Brim <[email-masked]>
Date: Tue, 31 Jul 2001 09:48:10 -0400

Peer-to-peer means intermediaries are not *required*.  Communication at
certain layers may be peer-to-peer while lower layers are not.
Proxy-mediated communication is not peer-to-peer in general, while ALGs
may still allow higher layers to experience peer-to-peer relationships.  

This is a small nit, but it is one of many.  If we want this draft to
survive last call, could we possibly schedule an editing session in the
lobby early in the week?

..Scott

---

From: Pyda Srisuresh <[email-masked]>
Date: Tue, 31 Jul 2001 08:33:30 -0700 (PDT)

> survive last call, could we possibly schedule an editing session in the

Sounds good. Why dont we schedule a meeting, say Tuesday @8:00 PM in the
main lobby. Those of you who can come, please send me a private e-mail.
I will send you an edited copy (with all the corrections that came
about in the past few days of the last call) by the end of the week
and we can go from there. Thanks.

Scott - I am assuming, you will be joining, right. DO let me know, if 
the time I proposed wont work. We can pick a different time. Thanks.

regards,
suresh

=====

---

From: Melinda Shore <[email-masked]>
Date: Tue, 31 Jul 2001 11:42:26 -0400

At 08:33 AM 7/31/01 -0700, Pyda Srisuresh wrote:
>main lobby. 

Please try to keep some flexibility in your choice of time slot -
that falls during the social event, which may be an issue for a
number of people.

Melinda

---

From: Scott Brim <[email-masked]>
Date: Tue, 31 Jul 2001 11:41:36 -0400

> the time I proposed wont work. We can pick a different time. Thanks.

Sounds good.  We can have an alternative social event :-)

---

From: "Bob Penfield" <[email-masked]>
Date: Tue, 31 Jul 2001 11:58:47 -0400

----- Original Message ----- 
From: "Melinda Shore" <[email-masked]>
To: "Pyda Srisuresh" <[email-masked]>; <[email-masked]>
Sent: Tuesday, July 31, 2001 11:42 AM
Subject: Re: Nits (was: RE: [midcom] Comments on Framework 03 draft)

> that falls during the social event, which may be an issue for a

I agree. All work and no play makes Johnny a dull boy.

Can we find a different time.

---

From: Pyda Srisuresh <[email-masked]>
Date: Tue, 31 Jul 2001 09:03:00 -0700 (PDT)

I am there the whole week. Most likely, any time in the evening
will work for me. Any thoughts on alternate time? Thanks.

cheers,
suresh 

=====