Subject: RE: [midcom] policy & duration

From: "Fleischman, Eric W" <[email-masked]>
Date: Wed, 8 Aug 2001 08:15:57 -0700

Michael,

You and I are in harmony on this. I'm sure that we all can agree that there are a large number of other WGs which have relevant insight into elements of the Midcom problem domain, which makes OPES far from unique, and therefore inappropriate as a target for a special WG-to-WG relationship. Take, for example, the many other groups addressing elements of policy including the Policy WG, AAA WG, AFT WG, CDI WG, the IRTF's AAAA WG, and many, many others.

--Eric

> ----------
> From: 	Michael W. Condry[SMTP:[email-masked]]
> Sent: 	Wednesday, August 08, 2001 6:53 AM
> To: 	Fleischman, Eric W; [email-masked]; [email-masked]; 'Melinda Shore'
> Cc: 	[email-masked]
> Subject: 	RE: [midcom] policy & duration
> 
> I agree about the dissimilar problem space.
> However, I still stand by the position that IF there areas of problem overlap,
> such as some policy matters, that ignoring each others requirements
> is a beneficial strategy (or "Dating Relationship").
> 
> At 02:58 AM 8/8/2001, Fleischman, Eric W wrote:
> >I see OPES and midcom addressing very dissimilar problems. I do not view 
> >the problems of enhancing web services (OPES) as directly related to the 
> >problems of opening pinholes through perimeter devices in a manner 
> >consistent with enterprise policies (midcom). I therefore do not think 
> >that OPES has a role in providing feedback to midcom documents that is any 
> >more relevant than the insights coming from other IETF WGs. Thus, even a 
> >"dating relationship" is unnecessary.
> >
> > > ----------
> > > From:         Melinda Shore[SMTP:[email-masked]]
> > > Sent:         Wednesday, August 08, 2001 1:24 AM
> > > To:   [email-masked]; [email-masked]; Michael W. Condry
> > > Cc:   [email-masked]
> > > Subject:      Re: [midcom] policy & duration
> > >
> > > > From: "Michael W. Condry" <[email-masked]>
> > > > To: <[email-masked]>; <[email-masked]>
> > > > Cc: <[email-masked]>
> > > > Sent: Wednesday, August 08, 2001 3:12 AM
> > > > Subject: Re: [midcom] policy & duration
> > >
> > >
> > > > Do you think that alignment between OPES policy and MidCom policy
> > > > concepts should be applied where appropriate?  If so, should the document
> > > > not reflect this?
> > >
> > > I do think that there's value in trying to keep these aligned,
> > > and it would probably be useful to get some feedback on our
> > > documents from OPES.  In the interests of keeping our work
> > > moving forward, it would probably be best to regard midcom
> > > and OPES as dating rather than married.
> > >
> > > Melinda
> > >
> > >
> > >
> > > _______________________________________________
> > > midcom mailing list
> > > [email-masked]
> > > http://www1.ietf.org/mailman/listinfo/midcom
> > >
> 
> Michael W. Condry
> Director,  Network Edge Technology
> 
> 
> 
> 
> _______________________________________________
> midcom mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/midcom
> 

_______________________________________________
midcom mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/midcom

---

From: "Melinda Shore" <[email-masked]>
Date: Wed, 8 Aug 2001 14:34:26 -0400

Once we go into IETF review we can expect to hear from
people involved with a number of different working groups,
and I have little doubt that we'll be hearing from people
involved with policy work in a number of different WGs.
Our relationship with OPES is unique in that while our
architecture is different and our goals are very different,
the details overlap considerably.  However, just because
we're keeping a particular eye on OPES and vice-versa doesn't
preclude any participant calling attention to what we're
up to in any other working group.

Melinda

----- Original Message -----
From: "Fleischman, Eric W" <[email-masked]>
To: <[email-masked]>; <[email-masked]>; "'Melinda Shore'"
<[email-masked]>; "'Michael W. Condry'" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, August 08, 2001 11:15 AM
Subject: RE: [midcom] policy & duration

> Michael,
>
> You and I are in harmony on this. I'm sure that we all can agree that
there are a large number of other WGs which have relevant insight into
elements of the Midcom problem domain, which makes OPES far from unique, and
therefore inappropriate as a target for a special WG-to-WG relationship.
Take, for example, the many other groups addressing elements of policy
including the Policy WG, AAA WG, AFT WG, CDI WG, the IRTF's AAAA WG, and
many, many others.

---

From: Andrew Molitor <[email-masked]>
Date: Wed, 8 Aug 2001 14:15:33 -0500 (CDT)

I have always assumed that the policy server was supposed to
answer questions, asked by the middlebox, of the form 'is <this>
Agent allowed to do <this> operation?'

	I have also, tacitly, assumed that this would in practical
implementations reduce to:

	'This Agent has just connected to me, what sorts of things
	 can he do?'

	with answers drawn from:

	'Nothing'
	'Read Stuff'
	'Read Stuff and Alter State'

	Possibly with a revokation capability or a "ticket lifetime"
or the like as qualifiers. Anything else seems to this implementor as
mere navel staring. In any case, the middlebox certainly doesn't
monkey around talking to the policy server every time an Agent
wants to do something. I don't mind if the architecture and protocol
wind up PERMITTING the middlebox to do this, but you'd have to have
rocks in your head to actually do it that way.

	This has ABSOLUTELY NOTHING to do with the "policy" implemented
by the middlebox in the form of pinholes and NAT binding. I suggest the
phrases 'Agent Policy' and 'Traffic Policy' to distinguish between these
two utterly disjoint notions, in contexts where it may not be clear.

	This whole discussion is starting to have something of an OSI
flavor to it, in which a whole phalanx of mystical widgets will interact
in ways which have complete and complex taxonomies defined but which
enjoy absolutely no concrete semantics, and of course no syntax -- that
being (quite rightly) out of scope.

	Taxonomy.
	Semantics.
	Syntax.

	You need all three to get anything practical done, and all
three should be tied cleanly together. If you omit one, the result is
pointless. If the connections between them are not clear, the
result is incomprehensible. If one is too complex, the result is
unusable.

		Andrew