Subject: RE: [midcom] Trying to bring this to closure ...

From: "Reinaldo Penno" <[email-masked]>
Date: Fri, 17 Aug 2001 08:33:12 -0700

Hello Christopher, 

> -----Original Message-----
> From: Christopher A. Martin [mailto:[email-masked]]
> Sent: Friday, August 17, 2001 8:26 AM
> To: 'Melinda Shore'; [email-masked]
> Subject: RE: [midcom] Trying to bring this to closure ...
> 
> 
> I think that for the filters being requested 5-tuple should 
> be sufficient
> (as it is currently).

Not for me. Being a provider provisioned device 5-tuple won't cut it, so I
need the protocol to be extensible.

> 
> I also believe that the agent would be requesting a filter from the
> middlebox based on application signaling (in the case of SIP and SDP).
> 
> It would not necessarily be carrying a filter rule, rather 
> requesting a
> filter be defined. In the case of SIP/RTP it may also request 
> a precedence
> be applied to the filter if the middlebox is capable of this 
> level of packet
> filtering.
> 
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Melinda Shore
> > Sent: Friday, August 17, 2001 8:11 AM
> > To: [email-masked]
> > Subject: [midcom] Trying to bring this to closure ...
> >
> >
> > We need to try to find some middle ground on this filter
> > rule problem.  Scott proposed that we leave it at the oft-
> > mentioned 5-tuple.  Would it be sufficient to say that the
> > midcom protocol must be able to carry filtering rules,
> > including but not limited to the 5-tuple, from the midcom
> > agent to the middlebox?
> >
> > Melinda
> >
> >
> > _______________________________________________
> > midcom mailing list
> > [email-masked]
> > http://www1.ietf.org/mailman/listinfo/midcom
> >
> 
> 
> _______________________________________________
> midcom mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/midcom
>

---

From: "Christopher A. Martin" <[email-masked]>
Date: Fri, 17 Aug 2001 12:21:03 -0500

RE: [midcom] Trying to bring this to closure ...I would need some
clarification on extensible here...
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Reinaldo Penno
  Sent: Friday, August 17, 2001 10:33 AM
  To: [email-masked]'; 'Melinda Shore'; [email-masked]'
  Subject: RE: [midcom] Trying to bring this to closure ...

  Hello Christopher,

---

From: Melinda Shore <[email-masked]>
Date: Fri, 17 Aug 2001 13:42:54 -0400

At 12:21 PM 8/17/01 -0500, Christopher A. Martin wrote:
>I would need some clarification on extensible here...

Let's not.  I don't think that "extensible" is particularly
ambiguous in this context, and if we're spinning our wheels on
this one it can't possibly bode well for finishing up the rest
of the document.  

Melinda