Subject: RE: [midcom] Trying to bring this to closure ...

From: "Reinaldo Penno" <[email-masked]>
Date: Fri, 17 Aug 2001 08:36:16 -0700

Hello Scott,

I think these statements are too vague and will give room to all kind of
interpretations in the future on what is, for example,  "extensible to allow
the requirements of future applications to be adopted."

We could keep yours, but I would like a specific item on the extensibility
of the filtering rules.

regards,

Reinaldo

> -----Original Message-----
> From: Scott Brim [mailto:[email-masked]]
> Sent: Friday, August 17, 2001 8:26 AM
> To: [email-masked]
> Subject: Re: [midcom] Trying to bring this to closure ...
> 
> 
> On Fri, Aug 17, 2001 at 10:36:18AM -0400, Mark Duffy apparently wrote:
> > At 09:10 AM 8/17/01 -0400, Melinda Shore wrote:
> > >We need to try to find some middle ground on this filter
> > >rule problem.  Scott proposed that we leave it at the oft-
> > >mentioned 5-tuple.  Would it be sufficient to say that the
> > >midcom protocol must be able to carry filtering rules,
> > >including but not limited to the 5-tuple, from the midcom
> > >agent to the middlebox?  
> > >
> > >Melinda
> > 
> > I could be happy with that.
> > Even more so if it went on to say that the criteria 
> filtered on must be
> > readily extensible.
> 
> These aren't going away, and express the requirement better by
> themselves than they would if bundled with the tuple (minimum
> requirement):
> 
>    R2: The syntax and semantics of the Midcom Protocol MUST be
>        extensible to allow the requirements of future 
> applications to be
>        adopted.
> 
>    R41: The MIDCOM Protocol MUST contain version inter-working
>         capabilities to enable subsequent extensions to support
>         different types of Middlebox and future requirements of
>         applications not considered at this stage.
> 
> _______________________________________________
> midcom mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/midcom
>

---

From: "'Scott Brim'" <[email-masked]>
Date: Fri, 17 Aug 2001 12:55:10 -0400

On Fri, Aug 17, 2001 at 08:36:16AM -0700, Reinaldo Penno apparently wrote:
> I would like a specific item on the extensibility
> of the filtering rules.

OK with me.