Subject: RE: [midcom] defining in-path and out-of-path agents

From: "Fernando Cuervo" <[email-masked]>
Date: Fri, 3 Aug 2001 11:30:11 -0400

If you have agent and MB technology that use Midcom then your packaging
scenario is fine. I understood Cedric's comment in a different light:
application intelligence for a particular MB implementation is clearly not
always removable using Midcom given that the scope of midcom is for
functionality that is "in-path". 

Fernando Cuervo

> -----Original Message-----
> From:	Andrew Molitor [SMTP:[email-masked]]
> Sent:	Wednesday, August 01, 2001 3:55 PM
> To:	[email-masked]
> Subject:	RE: [midcom] defining in-path and out-of-path agents
> 
> 
> 
> On Wed, 1 Aug 2001, Melinda Shore wrote:
> 
> > At 03:25 PM 8/1/01 -0400, Fernando Cuervo wrote:
> > 
> > >once you decide that the function of the agent is inside the firewall
> then the thing is neither an in-path nor an out-of-path agent, further, it
> has nothing to do with the protocol. 
> > 
> > It is possible, if unlikely, that someone might want to run a midcom
> protocol between
> > an agent and a firewall on the same box.  
> 
> 	This is the land of networking. If it is possible, the probability
> is nearly 1 that someone somewhere will want to do it.
> 
> 	If you have middlebox technology and agent technology, which
> technologies communicate via MIDCOM, it makes perfect sense to package
> the two together, talking MIDCOM over sockets connected to localhost,
> to implement a lower end solution.
> 
> 	I agree that things become much clearer if you think in
> terms of functions, not boxes. My experience suggests that drawing
> a "box" around any particular set of functions tends to yield a
> more or less well-defined device, which someone will surely desire
> some day.
> 
> 
> 		Andrew
> 
> 
> _______________________________________________
> midcom mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/midcom

---

From: Scott Brim <[email-masked]>
Date: Fri, 3 Aug 2001 15:20:17 -0400

> functionality that is "in-path". 

Fernando, specifically what application intelligence is not removable?