Subject: [midcom] 5-tuple - just checking

From: Melinda Shore <[email-masked]>
Date: Fri, 17 Aug 2001 11:44:06 -0400

I thought I'd better check to make sure that we all agree on
the contents of the 5-tuple: {protocol, destination address,
source address, destination port, source port}.  Is there
anyone who thinks we're talking about something else?

Melinda

_______________________________________________
midcom mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/midcom

---

From: Andrew Molitor <[email-masked]>
Date: Fri, 17 Aug 2001 11:44:17 -0500 (CDT)

> anyone who thinks we're talking about something else?

        I despise pedantry in everyone, but most especially myself.
It therefore pains me deeply to argue this microscopic piece of
terminology.

        I agree entirely except about the words "source" and
"destination." Indeed, these are fine taken literally, but then it
takes TWO 5-tuples to describe a TCP stream.

        The way I usually talk about 5-tuples is to in terms
of two endpoints designated perhaps, so we have:

        IP address A, Port A, IP Address B, Port B, Protocol

	If it turns out everyone else (or even a majority) prefer it
in terms of source and destination, that's fine if we also agree
that a 5-tuple describes a half-duplex data stream.

---

From: "Christopher A. Martin" <[email-masked]>
Date: Fri, 17 Aug 2001 12:20:12 -0500

I agree with your comment fully src_ip src_port dest_ip dest_port protocol.
Also on another note, I would assume precedence and other "extensions" be
taken care of by local policy at the middlebox.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Andrew Molitor
> Sent: Friday, August 17, 2001 11:44 AM
> To: [email-masked]
> Subject: Re: [midcom] 5-tuple - just checking
>
>
>
>