Subject: RE: [midcom] Topology considerations documents

From: "Christian Huitema" <[email-masked]>
Date: Fri, 7 Sep 2001 09:03:33 -0700

We have an inter-realm solution: IPv6.

> -----Original Message-----
> From: Andrew Molitor [mailto:[email-masked]]
> Sent: Friday, September 07, 2001 8:51 AM
> To: [email-masked]
> Subject: Re: [midcom] Topology considerations documents
> 
> 	None of what I am about to say is MIDCOM related, for which I
> apologize in advance.
> 
> 	I think the idea of globally naming Global Realms is a great
> idea. It's also completely out of scope for MIDCOM, and I don't think
> it's at all necessary for MIDCOM, which can treat Realms as not
> much more than a cookie that the Agent and middlebox agree on.
> 
> 	If we stipulate that:
> 
> 	1) IPv4 has scaling problems at a certain point.
> 	2) An approach to dealing with this would be to devise a
> 	   way to interconnect IPv4 networks at a higher layer,
> 	   just as Ethernets are interconnected using IPv4
> 
> 	Then we can rename NATs "Inter-Realm Routers" and achieve
> great happiness.
> 
> 	Given Realms and a global naming scheme for them, together with
> 
> 	a) a discovery/mapping service, probably a little like DNS
> 	   but carting around realm naming and "coarse topology"
> 	   information.
> 	b) a protocol like MIDCOM for setting up end-to-end paths
> 	   by adding net-to-net bindings (i.e. NAT Bindings) to
> 	   Inter-Realm Routers (i.e. middleboxes)
> 
> 	we can back into a sort of disney version of Noel Chiappa's
> nimrod work that has the advantage of being built ON IPv4 instead
> of replacing it, which is wicked cool.
> 
> 	Nimrod-like solutions have much nicer scaling properties than
> IPv4-like solutions like, say, IPv6 (which is arguably no more
> scalable
> than IPv4 -- just BIGGER).
> 
> 	I'm so glad to see that Keith is finally on board the whole
> NAT, err, Inter-Realm Router, thing!
> 
> 		Andrew
> 
> 
> _______________________________________________
> midcom mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/midcom

_______________________________________________
midcom mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/midcom

---

From: Andrew Molitor <[email-masked]>
Date: Fri, 7 Sep 2001 11:12:21 -0500 (CDT)

> We have an inter-realm solution: IPv6.

	While I appreciate your desire to inform, I admit that I actually
was aware of IPv6 already. The Inter-Realm Router is merely an
alternative to it.