Subject: RE: [midcom] More bullets

From: John LaCour <[email-masked]>
Date: Thu, 27 Sep 2001 14:33:21 -0700

> R15: A Midcom agent ought to be able to have a single MIDCOM
>         connection with a middlebox and use the MIDCOM 
> interface on the
>         middlebox to interface with different middlebox 
> functions on the
>         same middlebox interface.
> 
> I'd like to drop the trailing "interface" on this one and propose
> keeping this.

My understanding was the same as Bob Penfield's - that this is
trying to say that you don't need to set up multiple MIDCOM
sessions to request different types of rulesets be installed
(or functions if you prefer).

We also need to change this to reflect a requirement of the
protocol and not the agent.  Also, ought should be changed to
MUST.  I offer a slight variation on Bob Penfield's text:

"The protocol MUST permit a midcom agent to use a 
single midcom session with a middlebox to access different 
middlebox functions."

> R44: The protocol MUST permit the expression of direction to be
>         associated with a pin-hole.  The direction MUST be 
> specified in
>         terms that apply to external view of the Middlebox.  This
>         directionality shall be expressed as 'in', 'out' or 'loopback'
>         (meaning both 'in' and 'out' of the same side of the same
>         Middlebox realm).
> 
> The proposal is to drop this: we've already accepted R82, which gives
> broad leeway in descriptions of filtering rules.

OK

> R74: A Midcom Agent MUST be able to discover what resources are
>         available on a middlebox.
> 
> Proposal: drop.  We've already discussed meaningful error messages.

Agreed.

> R68: The Midcom Protocol MUST allow for preservation of the control
>         messages once the association has been established.
> 
> Proposal: drop.

Ok.

> 
> Once we get these settled we'll tackle semantics.
> 
> Melinda
> 
> 
> _______________________________________________
> midcom mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/midcom
> 

_______________________________________________
midcom mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/midcom

---

From: Scott Brim <[email-masked]>
Date: Thu, 27 Sep 2001 18:17:02 -0400

> sessions to request different types of rulesets be installed

A requirement phrased exactly like that would be acceptable.  

> (or functions if you prefer).

"Function" doesn't imply "ruleset" at all.  The closest you can come is
that "function" refers to something like NAT or firewall.  In both those
cases the mechanism for "accessing" it is by communicating about
rulesets.  That takes you back to your first, very acceptable, phrasing,
up top.  

> MUST.  I offer a slight variation on Bob Penfield's text:

(Protocols have requirements??)

> single midcom session with a middlebox to access different 

See top.