Subject: Re: [midcom] unused states clean-up

From: Melinda Shore <[email-masked]>
Date: Tue, 04 Sep 2001 10:12:52 -0400

At 09:38 AM 9/4/01 +0100, Cedric Aoun wrote:
>A while ago when we discussed and argued on how to clean-up no longer used states on a MB, 
>it was agreed that the requirement is to have a mechanism to cleanup these states. 
>Each protocol may have it's own ways to clean them up, ruleset or bundle related  timers could be a solution 
>but there are other solutions as well. 
>To summarize I think we need to replace R6 and R81, by the real requirement which is: 
>The protocol should have a state clean-up mechanism for no longer used states 

Is R23 insufficient?  It says:

"R23: The Midcom Protocol MUST enable the Middlebox and any associated
        Midcom Agents to establish known and stable state.  This must
        include the case of power failure, or other failure, where the
        protocol must ensure that any resources used by a failed element
        can be released."

Melinda

_______________________________________________
midcom mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/midcom

---

From: "Ram Dantu" <[email-masked]>
Date: Tue, 4 Sep 2001 10:03:24 -0500

Does R23 mean the following:
      MIDCOM protocol to facilitate the exchange of
      each others stable state (Middlebox and Agent)

This helps in cleaning states in either side during failure.

Regards
Ram Dantu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Melinda Shore
Sent: Tuesday, September 04, 2001 9:13 AM
To: Cedric Aoun; Midcom IETF (E-mail)
Subject: Re: [midcom] unused states clean-up

Melinda