Subject: RE: [midcom] pre-midcom work item

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 3 Oct 2001 09:04:25 -0400

> -----Original Message-----
> From: Christopher A. Martin [mailto:[email-masked]]
> Sent: Tuesday, October 02, 2001 2:27 PM
> To: 'Jonathan Rosenberg'; 'Ram Dantu'; 'Abdallah Rayhan'; 'Melinda
> Shore'; [email-masked]
> Subject: RE: [midcom] pre-midcom work item
> 
> 
> I'm jumping in in the middle of this but here goes, my 
> questions are inline

Responses inline.

> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Jonathan Rosenberg
> > Sent: Tuesday, October 02, 2001 10:30 AM
> > To: 'Ram Dantu'; Abdallah Rayhan; Melinda Shore; [email-masked]
> > Subject: RE: [midcom] pre-midcom work item
> >
> >
> >
> >
> > In the stun model, each user has a service provider. The
> > client talks to the
> > stun server of their service provider. Through that
> > communications, they
> > obtain a publically usable IP address for media. That requires no
> > coordination between providers.
> 
> They obtain an IP address, but what about a port number? does 
> the client
> guess what port number that the nat may assign to the 
> transaction? In the
> case of NAPT(PAT) there is a pool of ports being used randomly in most
> cases.

My apologies for being imprecise. Yes, they obtain the port number too. The
server returns an attribute called MAPPED-ADDRESS which includes a port and
IP address. Our assumption was that NAPT was the norm.

> 
> Now in the case of multiple nats this gets even more 
> complicated, unless we
> assumethe outermost nat is the ip address seed.

Exactly. The server is on the public Internet. Since it returns the source
address it saw in the request packet, this will be the source address that
was set by the outermost NAT. This is also a publically routable address.
Packets sent to that address will get properly routed back through that nat,
and any other nats between it and the client.

> 
> >
> > So, consider the case where I am a user of foo.com
> > (sip:[email-masked]).
> > When I start my phone, my phone uses stun, and talks to the
> > foo.com stun
> > server on the public Internet. Using the discovery procedure
> > in the spec, my
> > phone discovers that there is at least one nat between me and
> > the public
> > Internet, and that its full cone.
> 
> What is "full cone"?  These are my only two questions for 
> now, until I read
> the rest of the draft.

Full cone is defined in the document:

Full Cone: A full cone NAT is one where all requests from the
             same internal IP address and port are mapped to the same
             external IP address and port. Furthermore, any external
             host can send a packet to the internal host, by sending a
             packet to the mapped external address.

I have heard that this represents about 35 - 40% of deployed NAT.

Thanks,
Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
midcom mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/midcom

---

From: "Christopher A. Martin" <[email-masked]>
Date: Wed, 03 Oct 2001 16:16:19 -0500

inline

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Wednesday, October 03, 2001 8:04 AM
> To: [email-masked]'; Jonathan Rosenberg; 'Ram Dantu';
> 'Abdallah Rayhan'; 'Melinda Shore'; [email-masked]

Excellent. Does the attribute also facilitate the RTCP port as well?

> I have heard that this represents about 35 - 40% of deployed NAT.

Thanks, And I would concur with that (and add that the number may be
possibly an even larger percentage from my experience)