Subject: RE: [midcom] Another terminology issue

From: "Christian Huitema" <[email-masked]>
Date: Tue, 2 Oct 2001 13:09:56 -0700

I believe that a ruleset contains a filter specification, a set of
actions, and a set of attributes. The stuff that is passed in the
protocol is a subset of the ruleset; some attributes are generated by
the middlebox.

> -----Original Message-----
> From: Melinda Shore [mailto:[email-masked]]
> Sent: Tuesday, October 02, 2001 12:57 PM
> To: Bob Penfield; midcom
> Subject: Re: [midcom] Another terminology issue
> 
> At 03:44 PM 10/2/01 -0400, Bob Penfield wrote:
> >Isn't that what we've been calling a ruleset?
> 
> We need to clarify that, I think.  As things currently stand
> a ruleset could be the aggregation of stuff describing the
> request as carried by the midcom protocol to the middlebox,
> or it could be the instantiation of that aggregation as a
> pinhole on a firewall or a NAT table entry.
> 
> Melinda
> 
> 
> _______________________________________________
> midcom mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/midcom

_______________________________________________
midcom mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/midcom

---

From: "Bob Penfield" <[email-masked]>
Date: Tue, 2 Oct 2001 16:19:05 -0400

----- Original Message -----
From: "Christian Huitema" <[email-masked]>
To: "Melinda Shore" <[email-masked]>; "Bob Penfield"
<[email-masked]>; "midcom" <[email-masked]>
Sent: Tuesday, October 02, 2001 4:09 PM
Subject: RE: [midcom] Another terminology issue

> protocol is a subset of the ruleset; some attributes are generated by

That was my understanding too.

---

From: Mark Duffy <[email-masked]>
Date: Tue, 02 Oct 2001 23:29:35 -0400

It seems to me that there are at least 3 parallel concepts here:
1.  The MB behavior that is desired by an agent
2.  The encoding of that in a message in the midcom protocol
3.  The state installed in the MB to realize the desired behavior.

I suppose it could be argued that 1 and 3 are the same.  In any event, I
think we could get away with using "Ruleset" for all of these and adding
some qualifying words with it in those situations where a distinction is
needed.  (Such as Scott's "the instantiation of the ruleset in the
middlebox").

Looking at the existing definition of "Ruleset" it seems general enough to
fit any of the uses above.

Mark