Subject: RE: [midcom] New requirements bullets

From: "Reinaldo Penno" <[email-masked]>
Date: Mon, 8 Oct 2001 07:17:22 -0700

agreed with all proposals.

> -----Original Message-----
> From: Melinda Shore [mailto:[email-masked]]
> Sent: Monday, October 08, 2001 7:14 AM
> To: midcom
> Subject: [midcom] New requirements bullets
> 
> 
>  R20: As Pin-Holes may be shared across Middlebox functions, it MUST
>         be possible for a Pinhole-Descriptor to be created by one
>         function, and terminated by a different one.
> 
> Proposal: delete.  We're covered by other requirements bullets.
> 
>  R33: The relationship between a Midcom Agent and a given Middlebox
>         may be pre-configured through a manual configuration 
> process or
>         may be established dynamically through a registration process.
>         In either case, depending upon the policy applied to the
>         Middlebox, the Middlebox MUST appropriately authenticate the
>         identity and credentials of the Midcom Agent seeking 
> to make use
>         of its services prior to servicing any other requests from the
>         Midcom Agent.
> 
> Proposal: delete anything to do with provisioning (the first part) and
> change the second part so that 1) the requirement is on the protocol
> and not the middlebox, 2) the requirement is the capability to do
> bidirectional authentication.  The choice to actually do 
> authentication
> is a question of site-local security policy.
> 
>  R65: Individual message authentication MUST be used in addition to
>         host authentication.  Further message confidentiality MAY be
>         administered by employing techniques appropriate to Midcom
>         messages.  Simple Source-address based security is the least
>         form of security and MAY be permitted only to the most trusted
>         hosts.
> 
> Proposal: Again, we can't tell network administrators how to run their
> networks.  The protocol must support message authentication 
> and message
> confidentiality.  That's it.
> 
> Melinda
> 
> 
> _______________________________________________
> midcom mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/midcom
>

---

From: "Sanjoy Sen" <[email-masked]>
Date: Mon, 8 Oct 2001 10:44:31 -0500

Melinda, Comments below. Thanks.

> Sent: Monday, October 08, 2001 9:14 AM
> To: midcom

Agreed.

> is a question of site-local security policy.

I agree that this depends on the local security policies. The requirement is
that
the Midcom protocol must specify the mechanism(s) to do bidirectional
authentication (e.g.,
using an undelying protocol like TLS, IPSec etc.). I don't see a reason why
we need to
build in authentication mechanisms within the protocol itself. 

> confidentiality.  That's it.

Again, for the same reason as above, Midcom must specify the use existing
protocols for doing these.

---

From: Melinda Shore <[email-masked]>
Date: Mon, 08 Oct 2001 11:56:39 -0400

At 10:44 AM 10/8/01 -0500, Sanjoy Sen wrote:
>I agree that this depends on the local security policies. The requirement is that 
>the Midcom protocol must specify the mechanism(s) to do bidirectional authentication (e.g., 
>using an undelying protocol like TLS, IPSec etc.). I don't see a reason why we need to 

Note that I didn't say that.  However, since you bring it up,
it seems to me that for security-sensitive applications it's
preferable that the application have some awareness of its
own security state.  I think that people tend to be awfully
casual in recommending TLS or IPSec - it may be the case that
it would be preferable to use SASL for authentication.

In any event, we aren't specifying mechanism during this iteration
of the working group.  I think it's sufficient to say that the
protocol must support bidirectional authentication and let the
next midcom working group decide how that's to be done.

>Again, for the same reason as above, Midcom must specify the use existing protocols for doing these. 

See above.  Also, if you choose to do application layer authentication
using, say, HMAC-SHA1 you're still using an existing authentication
mechanism.  I'd like to keep the requirement broad until someone does
a proper security analysis.

Melinda

---

From: "Sanjoy Sen" <[email-masked]>
Date: Mon, 8 Oct 2001 16:37:55 -0500

OK. 

> Sent: Monday, October 08, 2001 10:57 AM
> To: Sen, Sanjoy [NGB:B602:EXCH]; midcom
> Subject: RE: [midcom] New requirements bullets
> 
>