Subject: RE: [midcom] pre-midcom work item

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 6 Oct 2001 14:31:17 -0400

> -----Original Message-----
> From: Christopher A. Martin [mailto:[email-masked]]
> Sent: Friday, October 05, 2001 8:55 AM
> To: [email-masked]
> Subject: RE: [midcom] pre-midcom work item
> 
> > Again, this is something commonly done in proprietary protocols,
> > particularly some network games. Seems like a really good
> > idea for VoIP. It
> > needs some additional SDP work in order to function.
> 
> I can see the idea of including the internal address in an 
> external packet
> (in the clear) as being considered as a possible security 
> risk by the IT
> community. This approach should be considered very carefully, 
> since VoIP and
> gaming are two completely different animals. 

If you are concerned about revealing internal IP addresses outside, then
that would be an issue independent if you were using games or VoIP, right?

> When addressing 
> MMoIP as a
> whole one needs to remember that issues of privacy (including internal
> topology) are key concerns with many individuals/organizations.

I don't think its really different for gaming, if you think about it. But in
any case, its irrelevant. If you are using nat to hide internal addresses,
then yes, using the approach of having these two media streams will reveal
your internal address to the outside. One can always get around that problem
by starting with the public address, and if the call terminates on an
another internal user (known through authenticated identities, perhaps),
then you do a re-INVITE to update to the private address.

I do want to emphasize that all of this has nothing to do with stun; we are
discussing an SDP extension which has not yet even been written. Let us
first focus on the main problem at hand.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
midcom mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/midcom

---

From: "Christopher A. Martin" <[email-masked]>
Date: Tue, 09 Oct 2001 13:30:22 -0500

inline

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Saturday, October 06, 2001 1:31 PM
> To: [email-masked]'; [email-masked]

That is correct..was just using those as an example.. the issue of divulging
internal addressing is actually an item that is frowned upon by many
security policies. As such we should consider this. Should I take this to
the SIP mailing list to discuss this since we are talking in terms of a SIP
working item arent we?

> first focus on the main problem at hand.

Sounds good. Just wanted to bring this up now before any writing has begun.