Subject: [midcom] STUN/TURN missing/colliding attribute types

From: "Bob Penfield" <[email-masked]>
Date: Fri, 16 Nov 2001 09:32:57 -0500

The TURN draft says that STUN and TURN can be used together. However, there
is an overlap in the Message Attribute types in the STUN and TURN drafts.
The TURN proposal re-uses type 0x0004 for CHALLENGE. It is SOURCE-ADDRESS in
STUN.

The STUN proposal names 5 attributes, but section 10.2 list only types 1
thru 4. What type is CHANGED-ADDRESS?

Since it is likely that people will want to implement a unified STUN/TURN
server, the attribute types should be unique.

cheers,
(-:bob

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

_______________________________________________
midcom mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/midcom

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 17 Nov 2001 04:21:29 -0500

> -----Original Message-----
> From: Bob Penfield [mailto:[email-masked]]
> Sent: Friday, November 16, 2001 9:33 AM
> To: midcom
> Subject: [midcom] STUN/TURN missing/colliding attribute types
> 
> 

To quote the great Homer Simpson "Doh!". 

Here is the right table:

0x0001: MAPPED-ADDRESS
0x0002: RESPONSE-ADDRESS
0x0003: FLAGS
0x0004: SOURCE-ADDRESS
0x0005: CHANGED-ADDRESS
0x0006: CHALLENGE
0x0007: AUTHENTICATION
0x0008: LIFETIME
0x0009: ALTERNATE-SERVER

Thanks,
Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com