Subject: [midcom] Protocol development

From: Melinda Shore <[email-masked]>
Date: Wed, 13 Mar 2002 09:24:14 -0500

Jonathan has mentioned in the past that he feels that
the actual packetization and protocol used to send
requests around the network is less interesting and
less important than the semantics of those requests.
I agree, and I can foresee us becoming mired in a lengthy
and contentious argument about which base protocol to
use while the substance of the problem gets short shrift.  

In order to 1) avoid that, 2) make progress while
the protocol evaluation is underway, and 3) try to 
maintain focus on the meat of the problem, I'd like
to suggest that we start developing a working document
(i.e. not necessarily for publication) that lays out
the semantics of midcom requests and midcom responses.
Thoughts/opinions/comments/etc. welcome.

Melinda

_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Martin Stiemerling <[email-masked]>
Date: Tue, 19 Mar 2002 14:53:23 +0100

> Thoughts/opinions/comments/etc. welcome.

There have been a lot of calls for doing the real work on the protocol, 
as far as I know. But there haven't been so much technical discussions, 
though there are some drafts for a protocol. These drafts define a 
semantic and a syntax for a protocol. I think there is no need to stuck 
on the syntax, but the work that has been made is a good starting point 
to see where the problems and possibly solutions are.

Martin

-- 
Martin Stiemerling

NEC Europe Ltd. -- Network Laboratories  [email-masked]
IPv4: http://www.ccrle.nec.de  IPv6: http://www.ipv6.ccrle.nec.de