Subject: [midcom] STUN shared secret requests

From: "Panayiotis A. Thermos" <[email-masked]>
Date: Tue, 22 Oct 2002 11:09:01 -0400

Section 8.2 of draft-ietf-midcom-stun-02.txt describes how to handle
shared secret requests over TLS.
Is there a specific port that the STUN server is going to communicate
with the client over TLS?

Based on the draft, the default port for TCP and UDP
connections is 3478. Binding TCP and UDP on one port
is feasible, but how TLS sockets will bind?

Can we bind TCP (clear text), TLS and UDP on one port?

Thanks for your help in advance.

Peter Thermos

_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Martin Stiemerling <[email-masked]>
Date: Tue, 22 Oct 2002 18:28:11 +0200

> Can we bind TCP (clear text), TLS and UDP on one port?

TLS/SSL runs over TCP. So if you use a TCP socket, you open first the 
TCP socket and afterwards run TLS/SSL over/through it, i.e. no need to 
bind TLS to a socket.

Martin

-- 
Martin Stiemerling

NEC Europe Ltd. -- Network Laboratories  [email-masked]
IPv4: http://www.ccrle.nec.de  IPv6: http://www.ipv6.ccrle.nec.de