Subject: [midcom] Assigning media ports with Midcom-unaware NAT/Firewall Traversal

From: "Stukas, Michael T (Mike)" <[email-masked]>
Date: Fri, 18 Oct 2002 13:24:30 -0600

Sanjoy, Patrick and Sean,

I was reading your draft <draft-sen-midcom-fw-nat-01.txt> and had a question to how the RTP ports were being assigned for a given caller.  I was under the impression that when the signaling proxy received an INVITE from a calling client that it would use the control protocol to communicate with the RTP proxy to retreive assigned ports for the caller to send its RTP packets to. Part of the process to identify the correct user with the correct ports was to have the signaling proxy pass to the RTP proxy the NAT address of the calling client.  The RTP proxy would then assign ports for the caller and callee and pass the information back to the signaling proxy to be sent to the caller in a response message.  The problem I see is that if the NAT is a symmetrical NAT then the NATed address that the signaling proxy sees would be different that what the media proxy would see when the client sends the RTP packets to establish a media path.  This assumption is based on the STUN I-D that describes the behavior of a symmetrical NAT.  Could you please clarify this part of the operation within your proposed solution.  Also, can you clarify if there is a difference between NAPT and Symmetric NAT.  I know they both translate address plus port and only accept responses from add|port that a message was already sent to...but the question comes in if Symmetric uses a different mapping if a source sends to a different destination. I have not been able to get a clear resolution on a difference between NAPT and Symmetric.  

I also have not seen much comments on this solution since the conversations with STUN and FANTOM at the end of last year.  Any comments on its current status. Has a proposed name been defined yet?  I am working on my Master's Thesis evaluating different traversal solutions and would any feedback you could provide.

Thanks very much,

~Mike 

Mike Stukas
AVAYA Corporation
System Verification
303.538.4740
[email-masked]

---

From: Melinda Shore <[email-masked]>
Date: Fri, 18 Oct 2002 15:35:16 -0400

> I was reading your draft <draft-sen-midcom-fw-nat-01.txt>
> and had a question to how the RTP ports were being
> assigned for a given caller.

This draft is not a midcom work item and is best discussed
in direct communication with the authors.

Melinda
_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom