Subject: Re: [midcom] COPS discussion

From: "Juergen Quittek" <[email-masked]>
Date: Mon, 28 Oct 2002 21:37:37 +0100

Melinda,

-- Melinda Shore wrote on 28 October 2002 12:32 -0500:

>> There are still discussions to have to come to better understands
>> on this topic.
>> Hence I feel we have NOT reach agreement on the COPS
>> directionality question.
> 
> Can you identify specifically which issues need more
> discussion and then resolution?

The issue is the one Kwok, Tom, Martin, myself, and some more
guys on the mailing list have been discussing recently:

  Is directionality of establishing a midcom connection 
  relevant or irrelevant?

I try to summarize the current point of the discussion:

With COPS-PR, the middlebox establishes the connection with the agent.

- Juergen: This is bad, because we don't want to reconfigure the
           middlebox each time we add, modify, or remove a service 
           that includes a midcom agent.

- Kwok: This is no problem at all, because if we are using COPS-PR
        anyway, we can also use it for telling the middebox to
        which agent to connect next.

Kwok, I might not have stated your position correctly. Please
correct me, If I am wrong. Also I apologize for all other
positions I ignored. Supporters of other positions, please
speak up.

    Juergen

> Thanks,
> 
> Melinda
> _______________________________________________
> midcom mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/midcom

-- 
_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Kwok Ho Chan <[email-masked]>
Date: Mon, 28 Oct 2002 16:31:01 -0500

Juergen, Melinda, all:

I think we have NOT agreed on the functional requirement when
the Directional aspect is further detailed as follows:

>With the above explanation, I have indicated that there are two levels
>of interaction:
>1. Communication Establishment.
>     For COPS, it is initiated by the Middlebox.
>2. MIDCOM Functional Event Flow.
>     For both MIDCOM and COPS, it is from MIDCOM Agent to Middlebox.

And Juergen INCORRECTLY stated Kwok's position.
I have described in details how it would work in our E-Mail discussions
and I believe there are still issues with regard to the importance of each
of the two points above.
-- Kwok --

---

From: Melinda Shore <[email-masked]>
Date: Mon, 28 Oct 2002 17:30:28 -0500

> >     For COPS, it is initiated by the Middlebox.

I think you may be misinterpreting the requirements when you
say, as you did in another message, that the "communication
establishment" directionality requirement is satisfied.
Requirement 2.1.1 in RFC 3304 says "The Midcom protocol must
enable a Midcom agent requiring the services of a middlebox
to establish an authorized association between itself and
the middlebox," which I think is pretty clear that the
association must be initiated by the agent, not the
middlebox.

Melinda