Subject: RE: [midcom] Qn. on draft-ietf-midcom-semantics-00

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 11 Nov 2002 11:34:50 -0500

I'll just add to this that I had this function in my original semantics
document.  I saw that it could be achieved the way Juergen describes it and
accepted that the simplification was appropriate for a base-level semantic
description.

> -----Original Message-----
> From: Juergen Quittek [mailto:[email-masked]] 
> Sent: Monday, November 11, 2002 4:06 PM
> To: [email-masked]; Midcom
> Subject: Re: [midcom] Qn. on draft-ietf-midcom-semantics-00
> 
> 
> Rajith,
> 
> We have not considered a function like this yet. I agree that 
> it can be useful in certain situations. Currently, the 
> semantics document tries to satisfy basic needs derived from 
> the Midcom requirements document.
> 
> It may be the case that the future Midcom protocol will 
> support additional transactions. However, for convenience 
> functions there is always a tradeoff between the number of 
> transactions to be defined and implemented and the number of 
> transactions to be performed for achieving a certain state or 
> for getting certain information.
> 
> With the current semantics, you can get the desired 
> information by (1) using the group list transactions for 
> learning about all groups you may access, then (2) for each 
> group listing all memeber policy rules using the group status 
> transactions, and finally (3) for each rule performing the 
> policy rule status transactions that tells you whether a 
> policy coveres the host you are interested in.
> 
>     Juergen
> 
> 
> -- Rajith wrote on 11 November 2002 14:22 +0530:
> 
> > Hi ,
> >
> > 	When an NE behind NAT sends a packet to external, a 
> session ( with a 
> > port bind ) will be established. I could not find any 
> interface which 
> > would enable the agent query this session details. The 
> interface I am 
> > looking at should give the agent details about the session or all 
> > existing sessions at NAT. The input parameter could be an 
> internal ip 
> > (+ port) or wild carded. An interface which offers details 
> about (an) 
> > already enabled session(s) without an associated policy ID 
> is what I 
> > am looking for.
> >
> > 	Is this outside the scope of MIDCOM ?
> >
> >
> > With Best Regards
> >
> > Rajith
> >
> > _______________________________________________
> > midcom mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/midcom
> 
> 
> _______________________________________________
> midcom mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/midcom
> 
_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Juergen Quittek <[email-masked]>
Date: Mon, 11 Nov 2002 17:57:31 +0100

I think we should add this transaction to the list of
semantics issues to be discussed in Atlanta.

It is not a big issue to add this rather simple transaction
to the current list of transactions and we can declare it
as optional.  However, it should be considered carefully,
whether or not simplifying the the corresponding use-case is
really worth the effort of extending the protocol definition
and of all future protocol implementations.

    Juergen