Subject: RE: [midcom] Winnowing down the list

From: "Louis-Nicolas Hamer" <[email-masked]>
Date: Mon, 11 Nov 2002 14:27:48 -0500

Melinda, all,

Why do you say people are dubious about COPS?
Unfortunately, it appears the persons who have spoken out against COPS don't
intend to re-use any of the proposed protocols. So I think it is fair to say
they are dubious to all the proposed protocols.

The only reason invoked against COPS was the directionality requirement.
Kwok explained in great lengths how this was not a big deal - it can be
fixed quite easily. So I object to your proposal to remove COPS.

As I have indicated before, I think COPS, SNMP and MEGACO are very good fits
for MIDCOM.
I would suggest that the best way forward would be to see what the WG
decides on the approach to take to
"pinpoint" the best protocol to use - I believe you have
that point on the agenda for the Atlanta meeting, right?

l-n

> -----Original Message-----
> From: Melinda Shore [mailto:[email-masked]] 
> Sent: Friday, November 08, 2002 4:51 PM
> To: [email-masked]
> Subject: [midcom] Winnowing down the list
> 
> 
> I'd like to continue to try to narrow the list of midcom 
> candidates.  From the discussion so far it looks like a lot 
> of people are dubious about COPS, so here's the question:
> 
> Is there any objection to removing COPS from the list of 
> candidate midcom protocols?  If you object, please give a reason.
> 
> Melinda
> _______________________________________________
> midcom mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/midcom
>

---

From: Melinda Shore <[email-masked]>
Date: Mon, 11 Nov 2002 14:45:40 -0500

> Unfortunately, it appears the persons who have spoken out
> against COPS don't intend to re-use any of the proposed
> protocols. So I think it is fair to say they are dubious
> to all the proposed protocols.

The reason that the question about COPS was posed is that
there has been more anti-COPS sentiment expressed than
anti-anything else.  

> fixed quite easily. So I object to your proposal to remove COPS.

Fair enough, although I will mention that I thought Kwok's
proposed workaround to be quite awkward.

> I would suggest that the best way forward would be to see
> what the WG decides on the approach to take to "pinpoint"
> the best protocol to use - I believe you have that point
> on the agenda for the Atlanta meeting, right?

Briefly.  Note that the IETF does its work on mailing lists
and that meetings are for discussions that would benefit
from face-to-face interactions.  Any decisions to be made 
will be made here, on the mailing list.

Melinda

---

From: Martin Stiemerling <[email-masked]>
Date: Tue, 12 Nov 2002 11:02:38 +0100

> Melinda, all,
[....]

> fixed quite easily. So I object to your proposal to remove COPS.

Hmm, there is another reason against COPS:
The COPS PEP is not able to receive configuration data from multiple PDP 
for the *same* resource, e.g. the middlebox can not receive policy rule 
configuration requests from different agents for the same packet filter 
at the same time.

Martin

> 
> As I have indicated before, I think COPS, SNMP and MEGACO are very good 
> fits for MIDCOM.