Subject: FW: [midcom] SNMPv3 as MIDCOM protocol: Opinions?

From: "Harrington, David" <[email-masked]>
Date: Mon, 9 Dec 2002 16:46:49 -0500

Another performance report on SNMPv3. This is in msgs/sec.

dbh

-----Original Message-----
From: Wes Hardaker [mailto:[email-masked]]
Sent: Monday, December 09, 2002 1:48 PM
To: Randy Presuhn
Cc: [email-masked]
Subject: Re: [midcom] SNMPv3 as MIDCOM protocol: Opinions?

>>>>> On Fri, 6 Dec 2002 17:30:51 -0800 (PST), Randy Presuhn <[email-masked]> said:

Randy> My recollection from several years ago was that for
Randy> single-varbbind requests in a noAuth/noPriv configuration, we
Randy> were geting about 100 per second on ancient hardware using
Randy> SMUX, and proportionately less (due to greater overhead) with
Randy> AgentX.

Just for kicks, I ran 10000 requests of various kinds against the
Net-SNMP stack (which is not a well optimized stack compared to
the commercial vendors) and timed the results.  This was on a 233 PIII
laptop which was not idle by any means, so take the numbers with a
grain of salt.  MD5 and DES were used for auth and priv.

sysContact.0 in the Master agent:

                       GET    GETNEXT    SET
  AuthPriv            1277    1176       493
  AuthNoPriv          1462    1475       514
  SNMPv1/2c           3769    3467       675

sysContact.0 in a subagent:

                       GET    GETNEXT    SET
  AuthPriv             772     596       304
  AuthNoPriv           860     661       355
  SNMPv1/2c           1461    1018       420

-- 
Wes Hardaker
Network Associates Laboratories
_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: "Bob Penfield" <[email-masked]>
Date: Tue, 10 Dec 2002 13:29:59 -0500

Are those numbers transactions per second? 

cheers,
(-:bob

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

----- Original Message ----- 
From: "Harrington, David" <[email-masked]>