Subject: RE: [midcom] Where we stand/SNMPv3

From: "Cedric Aoun" <[email-masked]>
Date: Fri, 13 Dec 2002 14:46:49 +0100

"As things currently stand the two concerns raised regarding
using SNMPv3 as the midcom protocol are 1) lack of interface
to a keying infrastructure, and 2) questions about
transaction rate.  The first is clearly addressable and the
second, I think, remains an open question.  We don't have a
show-stopper. "

There is something else that people may want to understand is why
the IETF is moving towards XML and leaving SNMP?Is this another protocol
clone war?
or there are real technical arguments for that?
I'm trying to find an answer to this and appreciate any feedback from the
list.

Our problem is that the evaluated protocols meet the job, every protocol has
its own way 
of doing the job. The main differences that we can list are relevant to
performance (they have more or less the same amount of overhead) this what
makes people really about especially that MIDCOM has real time applications.

The first thing that comes to mind when looking at SNMP is its lack of in
built transactional capability, it is up to the data objects carried by SNMP
to achieve this transactional behavior (by looking at some reference number
defined in the object format).
How do people feel about that?
Then we need to look at the atomicity issues that were addressed (by
Juerguen and others) on the mailing list but didn't see any responses.

Until we have cleared our minds on SNMP performance everybody will still
have doubts and no real consensus will be reached, we should go and work on
the MIB and then decide.

We need to consider as well the applicability of the WG's delivery, will the
low end Middlebox CPE vendors use it? SNMPv3
and the other evaluated protocols are more complex than all the protocols
they are already running.
I expect that they will go and use upnp (a lot of them already do that even
with the known security flaws that were announced). Perhaps 2 protocols
should be used in the internet depending on the market fit (please note that
I'm not implying that we bring upnp to IETF and improve it).
   
Cedric

---

From: Melinda Shore <[email-masked]>
Date: Fri, 13 Dec 2002 09:08:26 -0500

> the IETF is moving towards XML and leaving SNMP?Is this another protocol

There is no organized move within the IETF towards XML -
some individual working groups are using XML-encoding for
their protocols, but there's no conspiracy here.  Possibly
the most memorable quote from IETF 54 was Jeff Schilling's
comment in the saag meeting that "XML is this decade's
ASN.1."  

> Our problem is that the evaluated protocols meet the job,
> every protocol has its own way of doing the job. The main
> differences that we can list are relevant to performance
> (they have more or less the same amount of overhead) this
> what makes people really about especially that MIDCOM has
> real time applications.

We don't even know if there really are meaningful
differences between the protocols when it comes to
performance, so I'm not sure that there's progress to be
made here.  I haven't seen calls to eliminate protocols that
use TCP or SCTP for transport on the basis of performance/
scalability.

The discussion about protocol selection is over.  The
question now is whether or not to go ahead with an SNMP-
based midcom protocol.

Melinda
_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom