Subject: RE: [midcom] RE: SNMPv3 as MIDCOM protocol: Opinions?

From: "Moisand, Jerome" <[email-masked]>
Date: Thu, 5 Dec 2002 13:21:51 -0500

I was hesitating to make a similar statement, fearing of being disruptive,
but I do share the very exact same feeling.

Also, Melinda, may I suggest that inquiries be posted to all relevant IETF
WGs (e.g. aaa/diameter, rap/cops, ipsp)?

Cheers,
Jerome

-----Original Message-----
From: Harrington, David [mailto:[email-masked]]
Sent: Thursday, December 05, 2002 12:59 PM
To: Martin Stiemerling; [email-masked]
Cc: [email-masked]
Subject: [midcom] RE: SNMPv3 as MIDCOM protocol: Opinions?

Hi,

Message #2: as an evaluator of SNMPv3 based on the MIDCOM requirements.

In performing the evaluation, SNMPv3 scored very well, but I'd like to
comment on the evaluation process.

It is my feeling that the MIDCOM requirements need work. 

There are many requirements that are ambiguous, and there are many
requirements that have been written to favor a specific type of solution
(not a particular candidate, but a particular approach, which favors some
protocol designs). I don't believe this was done to influence the results, I
think the persons writing the requirements had a solution in mind, and
phrased the questions according to their view of the problems.

I'm not sayingg this becasue I feel that SNMPv3 could have done better with
a different set of requirements; SNMPv3 may have done better or it may have
done worse with a different set of requirements. As it is, I do not feel
that the appropriateness of SNMPv3 or any of the other protocols to the
problem was really addressed in the evaluation. 

I suspect that is why Martin has sent this question to the SNMPv3 mailing
list. I suspect that Martin believes SNMPv3 may or may not be an appropriate
choice, but that the evaluation doesn't provide enough information, or the
right information, to make this determination.

I recommend the MIDCOM WG rethink their requirements document. It may be
necessary to rethink portions of the architecture as well.

dbh

> -----Original Message-----
> From: Martin Stiemerling [mailto:[email-masked]]
> Sent: Thursday, December 05, 2002 9:24 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: SNMPv3 as MIDCOM protocol: Opinions?
> 
> 
> [please keep me in the recipient list, since I'm not subscribed to 
> snmvp3 list]
> 
> Hi,
> 
> as you may have heard: the MIDCOM WG is currently doing a protocol 
> evaluation which protocol to use as the MIDCOM protocol. SNMPv3 is 
> amongst these candidates (diameter, cops(-pr), megaco).
> Would you strongly recommend to use SNMPv3 as the MIDCOM protocol 
> without having a bad feeling? Actually there are only a few 
> pro and cons 
> discussed so far.
> 
> Thanks in advance
> Martin
> 
> 
_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom
_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Melinda Shore <[email-masked]>
Date: Thu, 05 Dec 2002 13:39:24 -0500

> but I do share the very exact same feeling.

The decision to revise the documents needs to be based on
the identification of *specific* problems with them rather
than a general sense that something is not quite right.

Melinda

---

From: Bob Natale <[email-masked]>
Date: Fri, 06 Dec 2002 18:11:56 -0500

At 12/5/2002:01:39 PM, Melinda Shore wrote:

Hi Melinda,

>than a general sense that something is not quite right.

Yeah, in general I agree with your position...but I've got
a very general doubt about the specific problem (as I see
it) of IETF protocol-efforts like AAA (which I followed
for a while) and Midcom (which I have not followed much
since its very early days) ending up by asking the question
"Now, what protocol should be this protocol?" and especially
when one of the (evidently) conceivable answers to that
question is thought to be "SNMP".

SNMP[v3] is the Internet standard management protocol (or
words to that effect).  Other IETF protocols should be
designed with manageability by SNMPv3 in mind, including
current era carrier-grade MIB support.

That is, if SNMPv3 is to be *the* protocol for protocol X,
then what is the added value of protocol X?

If protocol X is not SNMPv3 (which is always true except
for one value of X) but cannot be managed by SNMPv3, then
the IETF process is flawed in some way (and needs to be
fixed).

So, maybe all I am saying here is that I am really clueless.
If so, I will look forward to being clued in.

Thanks,

BobN

---

From: Melinda Shore <[email-masked]>
Date: Fri, 06 Dec 2002 19:37:11 -0500

> current era carrier-grade MIB support.

Those were among the arguments that Christian presented in
the Atlanta meeting when he asked that we skip the lengthy
decision process and choose SNMPv3 now.  When we took it to
the mailing list there were sufficient objections that we
couldn't do it.  That's a decision that can be revisited at
any time and I'd be happy to do so.

In the post to which you're responding I'm asking people to
get specific about architectural issues.  The midcom
requirements and framework documents have been finished for
quite some time.  They went through a lengthy development
process, went through WG last call, went through IESG
review, went through IETF last call, went through the RFC
editor's process, and were published as RFCs.  There's been
plenty of opportunity for input before now.  It could very
well be the case that either or both contain some fatal flaw
and need revision, but if that's the case the arguments for
doing so have to be substantive and specific - "That's not
the way I see it" won't cut it, and that's about the level
of objection that we're getting.  

I should also point out that if the argument is that the
current framework is unsuitable for one of the protocols,
it's probably actually the case that the protocol isn't
suitable for the framework.

Melinda