Subject: RE: [midcom] SNMPv3 as MIDCOM protocol: Opinions?

From: "Harrington, David" <[email-masked]>
Date: Tue, 10 Dec 2002 15:40:04 -0500

Hi Cedric,
 
I agree that the numbers don't say much without knowing what you're measuring and what you're comparing to.
 
Are there specific requirements about the number of transactions per minute that must be met to qualify? I didn't see any in the requirements documents. Eric raised the issue the other day, saying that the requireent was for a number of transactions per minute. Even if it took multiple request/reply pairs to perform a transaction, at ~500 SET messages per second I don't see that SNMPv3 would have a problem.
 
I fear that this is an unnecessary rathole. There are no identified minimum requirements. There are no comparative numbers for the other protocols available. The numbers by themselves are meaningless, except to show that SNMPv3 throughput has not been found to be a problem in other environments.
 
dbh
 
 -----Original Message-----
From: Cedric Aoun [mailto:[email-masked]]
Sent: Tuesday, December 10, 2002 2:40 PM
To: Harrington, David; Bob Penfield; [email-masked]
Subject: RE: [midcom] SNMPv3 as MIDCOM protocol: Opinions?

In order to comment on these performance figures we need to understand if in order to install a policy rule we need 
more than a pair of messages (set and set response), I don't know if we got closure on the command aggregation or not without any proprietary hacks (sorry got lost in all the threads).

The figures could be more representative if we could use the NAT MIB and see how the figures are affected. 

Is it possible to get the figures on the MIDCOM agent side (SNMP manager)? 

The next step is to see how to match this to real application sessions per sec that people expect this protocol to deliver on their boxes. 

We might get some agreement on the expected performance by saying that 6 or 8 pairs of MIDCOM messages (a pair is made of a request and reply) are required (between policy rule installation and policy rule deletion), in an average hold time of 1 min (let's say this is the worst case) this takes us to 16 MIDCOM messages (SNMP messages? ref to my note above) per mins for every application session (VoIP session, RTSP etc ...). 

After that, everyone can see if SNMPv3 meets their performance expectation (obviously without doing any implementation hacks, we're talking of a standard SNMPv3 stack).

Thanks 
Cedric 

-----Original Message----- 
From: Harrington, David [ mailto:[email-masked]] 
Sent: 10 December 2002 20:04 
To: Bob Penfield; [email-masked] 
Subject: RE: [midcom] SNMPv3 as MIDCOM protocol: Opinions? 

Wes posted yesterday stating that it was messages per second. 

dbh 

> -----Original Message----- 
> From: Bob Penfield [ mailto:[email-masked]] 
> Sent: Tuesday, December 10, 2002 1:30 PM 
> To: Harrington, David; [email-masked] 
> Subject: Re: [midcom] SNMPv3 as MIDCOM protocol: Opinions? 
> 
> 
> Are those numbers transactions per second? 
> 
> cheers, 
> (-:bob 
> 
> Robert F. Penfield 
> Chief Software Architect 
> Acme Packet, Inc. 
> 130 New Boston Street 
> Woburn, MA 01801 
> [email-masked] 
> 
> ----- Original Message ----- 
> From: "Harrington, David" <[email-masked]> 
> > -----Original Message----- 
> > From: Wes Hardaker [ mailto:[email-masked]] 
> > 
> > Just for kicks, I ran 10000 requests of various kinds against the 
> > Net-SNMP stack (which is not a well optimized stack compared to 
> > the commercial vendors) and timed the results.  This was on 
> a 233 PIII 
> > laptop which was not idle by any means, so take the numbers with a 
> > grain of salt.  MD5 and DES were used for auth and priv. 
> > 
> > sysContact.0 in the Master agent: 
> > 
> >                        GET    GETNEXT    SET 
> >   AuthPriv            1277    1176       493 
> >   AuthNoPriv          1462    1475       514 
> >   SNMPv1/2c           3769    3467       675 
> > 
> > sysContact.0 in a subagent: 
> > 
> >                        GET    GETNEXT    SET 
> >   AuthPriv             772     596       304 
> >   AuthNoPriv           860     661       355 
> >   SNMPv1/2c           1461    1018       420 
> > 
> > 
> > -- 
> > Wes Hardaker 
> > Network Associates Laboratories 
> > _______________________________________________ 
> > midcom mailing list 
> > [email-masked] 
> > https://www1.ietf.org/mailman/listinfo/midcom 
> > 
> 
> 
_______________________________________________ 
midcom mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/midcom

---

From: "Bob Penfield" <[email-masked]>
Date: Tue, 10 Dec 2002 17:58:11 -0500

Assume a VOIP application using a middlebox handling a 1-Gigabit link. If
you filled that link with G729-codec (8kbs/20ms samples) VOIP calls, you'd
have 41,600 calls (using a bandwidth calculator I found on the web). If you
assume a 3-minute call length, a continuously full 1-gigabit link would have
a call rate of about 230 calls per second. At minimum, each call requires 2
transactions (open pinhole & close pinhole). That's 460 transactions per
second. If it is a NAT box, and we might need to add a "reserve binding
transaction", that's 690 transactions per second. If you had two 1-gigabit
links, that's 1380 transactions per second.

Hope that helps.

cheers,
(-:bob

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

----- Original Message -----
From: "Harrington, David" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, December 10, 2002 3:40 PM
Subject: RE: [midcom] SNMPv3 as MIDCOM protocol: Opinions?

Hi Cedric,

I agree that the numbers don't say much without knowing what you're
measuring and what you're comparing to.

Are there specific requirements about the number of transactions per minute
that must be met to qualify? I didn't see any in the requirements documents.
Eric raised the issue the other day, saying that the requireent was for a
number of transactions per minute. Even if it took multiple request/reply
pairs to perform a transaction, at ~500 SET messages per second I don't see
that SNMPv3 would have a problem.

I fear that this is an unnecessary rathole. There are no identified minimum
requirements. There are no comparative numbers for the other protocols
available. The numbers by themselves are meaningless, except to show that
SNMPv3 throughput has not been found to be a problem in other environments.

dbh

 -----Original Message-----
From: Cedric Aoun [mailto:[email-masked]]
Sent: Tuesday, December 10, 2002 2:40 PM
To: Harrington, David; Bob Penfield; [email-masked]
Subject: RE: [midcom] SNMPv3 as MIDCOM protocol: Opinions?

In order to comment on these performance figures we need to understand if in
order to install a policy rule we need
more than a pair of messages (set and set response), I don't know if we got
closure on the command aggregation or not without any proprietary hacks
(sorry got lost in all the threads).

The figures could be more representative if we could use the NAT MIB and see
how the figures are affected.

The next step is to see how to match this to real application sessions per
sec that people expect this protocol to deliver on their boxes.

We might get some agreement on the expected performance by saying that 6 or
8 pairs of MIDCOM messages (a pair is made of a request and reply) are
required (between policy rule installation and policy rule deletion), in an
average hold time of 1 min (let's say this is the worst case) this takes us
to 16 MIDCOM messages (SNMP messages? ref to my note above) per mins for
every application session (VoIP session, RTSP etc ...).

After that, everyone can see if SNMPv3 meets their performance expectation
(obviously without doing any implementation hacks, we're talking of a
standard SNMPv3 stack).

Thanks
Cedric

-----Original Message-----
From: Harrington, David [ mailto:[email-masked]]
Sent: 10 December 2002 20:04
To: Bob Penfield; [email-masked]
Subject: RE: [midcom] SNMPv3 as MIDCOM protocol: Opinions?

dbh