Subject: RE: [midcom] RE: SNMPv3 as MIDCOM protocol: Opinions?

From: "Moisand, Jerome" <[email-masked]>
Date: Thu, 5 Dec 2002 13:52:16 -0500

Sure, Melinda, you're absolutely right. 

Well, to start with, please look again to my recent e-mail about the three
types of policy management architecture I listed. Correct me if I'm wrong,
but only one of them appears to be envisioned in the existing midcom
requirements/proposed-architecture. 

The two other ones (with a stateful policy server, trigerred by either a
signaling mechanism ala RSVP/NSIS, or by an application layer interaction)
do not seem to be addressed, or seem to be excluded by some requirements
which I find somewhat debatable, specifically:

<<The Midcom protocol must allow a middlebox to communicate with more
   than one Midcom agent simultaneously.>>

I see this as a fairly major issue, I don't believe we should restrict
ourselves, and exclude policy management architectures which have been
promoted by IETF in the context of the "rap" effort for several years. And
just to clear up the water, I'm certainly not excluding either other
architectures which, I believe, have NOT been envisioned by the "rap" group.

Tx
Jerome

-----Original Message-----
From: Melinda Shore [mailto:[email-masked]]
Sent: Thursday, December 05, 2002 1:39 PM
To: Moisand, Jerome
Cc: 'Harrington, David'; Martin Stiemerling; [email-masked];
[email-masked]
Subject: Re: [midcom] RE: SNMPv3 as MIDCOM protocol: Opinions? 

> I was hesitating to make a similar statement, fearing of being disruptive,
> but I do share the very exact same feeling.

The decision to revise the documents needs to be based on
the identification of *specific* problems with them rather
than a general sense that something is not quite right.

Melinda
_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Melinda Shore <[email-masked]>
Date: Thu, 05 Dec 2002 14:00:03 -0500

> requirements/proposed-architecture. 

Policy management is orthogonal to the midcom protocol.  We
assume that there's a policy component but we're not
specifying it.  What's envisioned is that there is one, but
the questions of where it's located, what policy decisions
are negotiated, and specifically what it will look like are
completely outside the scope of the current set of
deliverables.

> promoted by IETF in the context of the "rap" effort for several years. 

I doubt very much that you'd have luck finding *one*
participant who thinks it sufficient to have a middlebox
that's only capable of communicating with one agent.  In the
context of VoIP applications, as well as many others, it is
absolutely mandatory that more than one agent be able to
send requests to a middlebox.

Melinda