Subject: [midcom] H.248 for midcom? Not.

From: "Eric Burger" <[email-masked]>
Date: Fri, 6 Dec 2002 10:47:55 -0500

Reviewing the MIDCOM protocol evaluation document, I had some questions about the H.248 (megaco) analysis.

Requirement 2.1.3, "Middlebox can relate to multiple Agents", refers to the ability for a set of agents to manipulate (in H.248 parlance) the same end-point.  It is true, as described in the document, that one can partition a media gateway into multiple virtual media gateways (VMG).  By design, H.248 restricts a one-to-one association between a VMG and an agent.  In addition, AFAIK the standard H.248 model has no possibility for VMG's to have the same end-points.  This is an architectural feature of H.248.  Even if you "extended" H.248 to allow the same ephemeral end-point to be addressed by two VMG's, it would, by definition, have different names.  Thus, I do not understand how H.248 could possibly meet this requirement.

In fact, the response to Requirement 2.1.4 highlights this issue.  H.248 is deterministic in the face of multiple requests because it cannot have them.

Requirement 2.1.12:
The biggest leap of faith is the proposal of a MIDCOM Ruleset Package.  If we stuck with the H.248 master-slave model, I would expect rule processing to occur at the MGC (agent).  I can't envision how to implement a rule set end-point entity.  It seems to be rather foreign to the whole H.248 framework.
_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Martin Stiemerling <[email-masked]>
Date: Mon, 09 Dec 2002 10:17:25 +0100

Eric,

thanks for the clarification! This helped a lot.

Martin

-- 
************************************************
NEW ADDRESS EFFECTIVE DECEMBER 23RD
Kurfuersten-Anlage 34, 69115 Heidelberg, Germany
phone, fax and email remain unchanged
************************************************

Martin Stiemerling

NEC Europe Ltd. -- Network Laboratories  [email-masked]
IPv4: http://www.ccrle.nec.de  IPv6: http://www.ipv6.ccrle.nec.de