Subject: [midcom] RE: SNMPv3 as MIDCOM protocol: Opinions?

From: "Harrington, David" <[email-masked]>
Date: Thu, 5 Dec 2002 12:58:46 -0500

Hi,

Message #2: as an evaluator of SNMPv3 based on the MIDCOM requirements.

In performing the evaluation, SNMPv3 scored very well, but I'd like to comment on the evaluation process.

It is my feeling that the MIDCOM requirements need work. 

There are many requirements that are ambiguous, and there are many requirements that have been written to favor a specific type of solution (not a particular candidate, but a particular approach, which favors some protocol designs). I don't believe this was done to influence the results, I think the persons writing the requirements had a solution in mind, and phrased the questions according to their view of the problems.

I'm not sayingg this becasue I feel that SNMPv3 could have done better with a different set of requirements; SNMPv3 may have done better or it may have done worse with a different set of requirements. As it is, I do not feel that the appropriateness of SNMPv3 or any of the other protocols to the problem was really addressed in the evaluation. 

I suspect that is why Martin has sent this question to the SNMPv3 mailing list. I suspect that Martin believes SNMPv3 may or may not be an appropriate choice, but that the evaluation doesn't provide enough information, or the right information, to make this determination.

I recommend the MIDCOM WG rethink their requirements document. It may be necessary to rethink portions of the architecture as well.

dbh

> -----Original Message-----
> From: Martin Stiemerling [mailto:[email-masked]]
> Sent: Thursday, December 05, 2002 9:24 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: SNMPv3 as MIDCOM protocol: Opinions?
> 
> 
> [please keep me in the recipient list, since I'm not subscribed to 
> snmvp3 list]
> 
> Hi,
> 
> as you may have heard: the MIDCOM WG is currently doing a protocol 
> evaluation which protocol to use as the MIDCOM protocol. SNMPv3 is 
> amongst these candidates (diameter, cops(-pr), megaco).
> Would you strongly recommend to use SNMPv3 as the MIDCOM protocol 
> without having a bad feeling? Actually there are only a few 
> pro and cons 
> discussed so far.
> 
> Thanks in advance
> Martin
> 
> 
_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Martin Stiemerling <[email-masked]>
Date: Mon, 09 Dec 2002 10:08:37 +0100

Hi,

after starting the discussion, I'm a little behind with reading all 
messages.

> It is my feeling that the MIDCOM requirements need work. 

Unfortunately we're already done with the requirements. The need for 
having a MIDCOM protocol is big and I see no time left for delaying the 
MIDCOM protocol.

> There are many requirements that are ambiguous, and there are many requirements that have been written to favor a specific type of solution (not a particular candidate, but a particular approach, w…

Yep.

> I suspect that is why Martin has sent this question to the SNMPv3 mailing list. I suspect that Martin believes SNMPv3 may or may not be an appropriate choice, but that the evaluation doesn't provid…

The evaluation says only that mechanism x of protocol z fits to the 
midcom in a particular point. The keyword is 'particular'. It doesn't 
say anything about the whole protocol fits to midcom.
This is indeed the reason for my request to the snmp list and I happy to 
see a lot of responses.

Thanks!

> I recommend the MIDCOM WG rethink their requirements document. It may be necessary to rethink portions of the architecture as well.

As said, these two things are done, we have to be ready with the 
protocol soon and the requirements and framework are alright for our 
problem space.

Martin

-- 
************************************************
NEW ADDRESS EFFECTIVE DECEMBER 23RD
Kurfuersten-Anlage 34, 69115 Heidelberg, Germany
phone, fax and email remain unchanged
************************************************

Martin Stiemerling

NEC Europe Ltd. -- Network Laboratories  [email-masked]
IPv4: http://www.ccrle.nec.de  IPv6: http://www.ipv6.ccrle.nec.de