Subject: Fwd: [midcom] I-D ACTION:draft-ietf-midcom-mib-01.txt

From: Melinda Shore <[email-masked]>
Date: Wed, 12 May 2004 14:20:57 -0400

This is our final deliverable - the end is in sight.  Please give the
draft a careful read and post comments to the mailing list.  WG review 
is,
perhaps, the most important stage in moving documents towards 
publication,
and this is the time to catch and fix any problems that may lurk in the
draft.

Thanks,

Melinda

Begin forwarded message:

> From: [email-masked]
> Date: Wed May 12, 2004  9:41:12 AM US/Eastern
> To: [email-masked]
> Cc: [email-masked]
> Subject: [midcom] I-D ACTION:draft-ietf-midcom-mib-01.txt
>
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> This draft is a work item of the Middlebox Communication Working Group 
> of the IETF.
>
> 	Title		: Definitions of Managed Objects for Middlebox
> 			  Communication
> 	Author(s)	: J. Quittek, et al.
> 	Filename	: draft-ietf-midcom-mib-01.txt
> 	Pages		: 82
> 	Date		: 2004-5-11
> 	
> This memo defines a portion of the Management Information Base (MIB)
>    for use with network management protocols in the Internet community.
>    In particular, it describes a set of managed objects that allow
>    configuring middleboxes, such as firewalls and network address
>    translators, in order to enable communication across these devices.
>    The definitions of managed objects in this documents follow closely
>    the MIDCOM semantics defined in RFC XXXX.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-midcom-mib-01.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of 
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
>
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-midcom-mib-01.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-midcom-mib-01.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> Content-Type: text/plain
> Content-ID:	<[email-masked]>

_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: "Medhavi Bhatia" <[email-masked]>
Date: Wed, 12 May 2004 22:18:00 -0400

I have not completely gone through the mib yet, but going through the
semantics documents and the requirements, I did not see anything which
points to how the midcom agent can direct the middlebox to use symmetric
ip/port (ie., the address from which the middle box sends traffic towards an
endpoint A is the same as the address where traffic is being received from
A).  None of the signaling protocols (SIP etc) require this, but it would be
interesting to see if there is any option provided for this.

-Medhavi.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Melinda
> Shore
> Sent: Wednesday, May 12, 2004 2:21 PM
> To: [email-masked]
> Subject: Fwd: [midcom] I-D ACTION:draft-ietf-midcom-mib-01.txt
>

---

From: "Christopher A. Martin" <[email-masked]>
Date: Wed, 12 May 2004 21:39:16 -0500

Hi Melinda, everyone,
Its been awhile. You know I notice that we now have the mib draft and
was wondering, is it out of scope to look into a way to manage via SNMP
via a middle-box using midcom to provide the mechanism for nat traversal
for snmp?

Just a thought...SNMP has always been the sore spot when it comes to
managing devices behind a nat. Before snmp v3 I would never have asked
rfor such functionality, but now...

Any comments from anyone on this would be appreciated.

  _____  

Christopher A. Martin
P.O. Box 1264
Cedar Hill, Texas 75104
  _____  

	DOMAINS.SIP1.COM 	
Select your option below by clicking on the icon.
RegisterForwardDomainAlert MonitoringWeb HostingSite BuilderEmailTraffic
Blazer & Quick SizzleSSLInternet UtilitiesCopyright 	

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Melinda Shore
Sent: Wednesday, May 12, 2004 1:21 PM
To: [email-masked]
Subject: Fwd: [midcom] I-D ACTION:draft-ietf-midcom-mib-01.txt

Thanks,

Melinda

> the message. You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce
> http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>

---

From: Martin Stiemerling <[email-masked]>
Date: Thu, 13 May 2004 21:16:31 +0200

Hi,

There is now parameter/option to tell the middlebox how it should allocated 
IP addresses/port numbers. This is up to the actual implementation of the 
box and/or the MIDCOM stack.

  Martin

--On Mittwoch, 12. Mai 2004 22:18 Uhr -0400 Medhavi Bhatia 
<[email-masked]> wrote:

| 7bit
| MIME-Version: 1.0
| Content-Type: text/plain; charset="us-ascii"
| Content-Transfer-Encoding: 7bit
| 7bit
|
| I have not completely gone through the mib yet, but going through the
| semantics documents and the requirements, I did not see anything which
| points to how the midcom agent can direct the middlebox to use symmetric
| ip/port (ie., the address from which the middle box sends traffic towards
| an endpoint A is the same as the address where traffic is being received
| from A).  None of the signaling protocols (SIP etc) require this, but it
| would be interesting to see if there is any option provided for this.
|
| -Medhavi.
|
|> -----Original Message-----
|> From: [email-masked] [mailto:[email-masked]] On Behalf Of
| Melinda
|> Shore
|> Sent: Wednesday, May 12, 2004 2:21 PM
|> To: [email-masked]
|> Subject: Fwd: [midcom] I-D ACTION:draft-ietf-midcom-mib-01.txt
|>
|> This is our final deliverable - the end is in sight.  Please give the
|> draft a careful read and post comments to the mailing list.  WG review
|> is,
|> perhaps, the most important stage in moving documents towards
|> publication,
|> and this is the time to catch and fix any problems that may lurk in the
|> draft.
|>
|> Thanks,
|>
|> Melinda
|>
|>
|> Begin forwarded message:
|>
|> > From: [email-masked]
|> > Date: Wed May 12, 2004  9:41:12 AM US/Eastern
|> > To: [email-masked]
|> > Cc: [email-masked]
|> > Subject: [midcom] I-D ACTION:draft-ietf-midcom-mib-01.txt
|> >
|> > A New Internet-Draft is available from the on-line Internet-Drafts
|> > directories.
|> > This draft is a work item of the Middlebox Communication Working Group
|> > of the IETF.
|> >
|> > 	Title		: Definitions of Managed Objects for Middlebox
|> > 			  Communication
|> > 	Author(s)	: J. Quittek, et al.
|> > 	Filename	: draft-ietf-midcom-mib-01.txt
|> > 	Pages		: 82
|> > 	Date		: 2004-5-11
|> >
|> > This memo defines a portion of the Management Information Base (MIB)
|> >    for use with network management protocols in the Internet community.
|> >    In particular, it describes a set of managed objects that allow
|> >    configuring middleboxes, such as firewalls and network address
|> >    translators, in order to enable communication across these devices.
|> >    The definitions of managed objects in this documents follow closely
|> >    the MIDCOM semantics defined in RFC XXXX.
|> >
|> > A URL for this Internet-Draft is:
|> > http://www.ietf.org/internet-drafts/draft-ietf-midcom-mib-01.txt
|> >
|> > To remove yourself from the I-D Announcement list, send a message to
|> > [email-masked] with the word unsubscribe in the body of
|> > the message.
|> > You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
|> > to change your subscription settings.
|> >
|> >
|> > Internet-Drafts are also available by anonymous FTP. Login with the
|> > username
|> > "anonymous" and a password of your e-mail address. After logging in,
|> > type "cd internet-drafts" and then
|> > 	"get draft-ietf-midcom-mib-01.txt".
|> >
|> > A list of Internet-Drafts directories can be found in
|> > http://www.ietf.org/shadow.html
|> > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
|> >
|> >
|> > Internet-Drafts can also be obtained by e-mail.
|> >
|> > Send a message to:
|> > 	[email-masked].
|> > In the body type:
|> > 	"FILE /internet-drafts/draft-ietf-midcom-mib-01.txt".
|> >
|> > NOTE:	The mail server at ietf.org can return the document in
|> > 	MIME-encoded form by using the "mpack" utility.  To use this
|> > 	feature, insert the command "ENCODING mime" before the "FILE"
|> > 	command.  To decode the response(s), you will need "munpack" or
|> > 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
|> > 	exhibit different behavior, especially when dealing with
|> > 	"multipart" MIME messages (i.e. documents which have been split
|> > 	up into multiple messages), so check your local documentation on
|> > 	how to manipulate these messages.
|> >
|> >
|> > Below is the data which will enable a MIME compliant mail reader
|> > implementation to automatically retrieve the ASCII version of the
|> > Internet-Draft.
|> > Content-Type: text/plain
|> > Content-ID:	<[email-masked]>
|>
|>
|> _______________________________________________
|> midcom mailing list
|> [email-masked]
|> https://www1.ietf.org/mailman/listinfo/midcom
|
|
| _______________________________________________
| midcom mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/midcom

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 14 May 2004 22:24:58 +0200

> rfor such functionality, but now...

See RFC 2962 for a discussion why the proper way to handle NATs is
the usage of SNMPv3 proxies. Note: I am not saying it is easy - just
that it is possible. ;-)

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany

---

From: "Christopher A. Martin" <[email-masked]>
Date: Fri, 14 May 2004 16:39:44 -0500

I agree, just haven't seen many implementations of SNMP proxies. Is
anyone aware of any generally available SNMPv3 proxies?

  _____  

Christopher A. Martin
P.O. Box 1264
Cedar Hill, Texas 75104
  _____  

	DOMAINS.SIP1.COM 	

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Juergen Schoenwaelder
Sent: Friday, May 14, 2004 3:25 PM
To: Christopher A. Martin
Cc: 'Melinda Shore'; [email-masked]
Subject: Re: [midcom] I-D ACTION:draft-ietf-midcom-mib-01.txt

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen,
Germany