Subject: RE: [midcom] RE: Last Call: 'Definitions of Managed Objects for Middlebox Communication' to Proposed Standard (draft-ietf-midcom-mib)

From: Pyda Srisuresh <[email-masked]>
Date: Mon, 28 Aug 2006 09:28:20 -0700 (PDT)

Hi Dan,

Thanks. Please see my responses inline.

regards,
suresh

--- "Romascanu, Dan (Dan)" <[email-masked]> wrote:

> Hi Suresh,
> 
> (I took out the ietf and iesg lists from the distribution)
> 
> Thank you for the answers. I am happy with many of them, I am waiting
> for clarification from you co-authors on a couple of issues, and have
> two more comments on your answers:
> 
[suresh] Sounds good. Thanks.

>  
>  
> 
> > -----Original Message-----
> > From: Pyda Srisuresh [mailto:[email-masked]] 
> >> 
> > > 8 . There is no DEFVAL for midcomRuleFlowDirection
> > > 
> > [suresh] Right, that was intentional.
> > 
> 
> In the absence of a DEFVAL what is supposed to return an agent on a read
> operation before the object was first time written?
> 
[suresh] I see what you mean. I think, it should be OK to set the DEFVAL to
outbound(2).

> > > 10. What notification needs to be sent when 
> > midcomConfigIfEnabled is 
> > > set to false? Neither the DESCRIPTION of the object nor the 
> > one of the 
> > > notifications do provide any clue.
> > > 
> > [suresh] The DESCRIPTION for midcomConfigIfEnabled does say 
> > the following.
> > 
> >    Setting
> >    this object to false(2) immediately stops middlebox
> >    support at the indexed IP interface.  This implies that
> >    all policy rules that use NAT or firewall resources at
> >    the indexed IP interface are terminated immediately.
> >    In this case, The MIDCOM agent MUST send notifications
> >    to all MIDCOM clients that have access to one of the
> >    terminated rules.
> > 
> 
> I saw this text, but my question was what notifications are being sent?
> 
[suresh] midcomUnsolicitedRuleEvent notifications are sent for each of the
rules that refer the ifindex. We will add this to the DESCRIPTION text. Thanks.

> Regards,
> Dan

regards,
suresh

_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 30 Aug 2006 11:22:21 +0200

Hi,

If I interpret the last call comments correctly there is need for an 
updated version of the draft before progressing to IESG evaluation.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

---

From: Pyda Srisuresh <[email-masked]>
Date: Wed, 30 Aug 2006 05:33:09 -0700 (PDT)

Right. We will have an updated version of the draft shortly. Thank you.

regards,
suresh