Subject: [middisc] Wan Optimization standardization problem statement/analysis?

From: Greg Daley <[email-masked]>
Date: Tue, 26 Feb 2013 00:34:55 +0000

Dear Middisc list, 

Thanks for your work on the Middlebox Negotiation Option draft.

I understand that this list and the draft are not focussed upon standardization of intercompatibility between Middleboxes, but I see it as a positive first step.

Working within the System Integration space, we are seeing significant impact upon customers due to incompatibilities between WAN optimization systems, particularly. 
Our company resells platforms from two Wanopt vendors, and several of our long term customers have deployments from further vendors.

We are seeing increased operational expenses for customers from managing incompatible systems, and difficulties in managing mergers of networks with different heritages.

Has anyone undertaken a review within the IETF of the general problem and scope of standardized WAN optimization?

Are there any organizations other than under IETF guise where this work is being done?

I understand that there are several legal issues associated with the work, and that some of this is before the courts.  

Please let me know if you are interested in furthering this work, and if you would be except for current legal circumstances.

Sincerely,

Greg Daley

---

From: Anantha Ramaiah <[email-masked]>
Date: Mon, 25 Feb 2013 23:12:00 -0800

Greg,

I no longer work with the same company when I initially participated during
writing this draft and hence these are just my personal opinions. Comments
inline :-

On Mon, Feb 25, 2013 at 4:34 PM, Greg Daley <[email-masked]> wrote:

> I understand that this list and the draft are not focussed upon
> standardization of intercompatibility between Middleboxes, but I see it as
> a positive first step.
>

Yes, I think so too.

>
>
> Working within the System Integration space, we are seeing significant
> impact upon customers due to incompatibilities between WAN optimization
> systems, particularly.
> Our company resells platforms from two Wanopt vendors, and several of our
> long term customers have deployments from further vendors.
>
> We are seeing increased operational expenses for customers from managing
> incompatible systems, and difficulties in managing mergers of networks with
> different heritages.

Doesn't  come as a surprise esp., since the solutions are incompatible.

> scope of standardized WAN optimization?

Not that I am aware of.

> Are there any organizations other than under IETF guise where this work is

I don't think so.

>
>
> I understand that there are several legal issues associated with the work,
> and that some of this is before the courts.
>

Well, you probably hit the nail on the head.  I guess, even though there
are technical benefits of standardizing the protocol, lets take the case in
point : auto-discovery.  Firstly the legal issues needs to be sorted out
and enough interest needs to be there to standardize this aspect, then
running code needs to be updated, or at least the companies should be
willing to accept this fact an have this factored in their development
plans.

>
> Please let me know if you are interested in furthering this work, and if
> you would be except for current legal circumstances.
>

Well, I may be able to provide some review/comments if there happens to be
some consensus among the leading vendors to undertake this project, but in
any case cannot take any active role here since this work item is of no
direct benefit to my current employer.

thanks,
-Anantha

>
> Sincerely,
>
> Greg Daley
>
>
>
>
>
>
>
> _______________________________________________
> middisc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/middisc
>

---

From: "Mahdavi, Jamshid" <[email-masked]>
Date: Tue, 26 Feb 2013 15:52:37 +0000

I'd definitely be in favor of seeing standard solutions, as they would be better for customers for exactly the reasons you describe.  I'm happy to see your suggestion!

If I might be so bold as to offer an opinion about how such an effort might fit into the IETF framework, there are typically two distinct parts to a WAN Op solution:

1.  A tunneling protocol in which to carry optimized traffic between symmetric WAN Op devices.  This portion also requires application level routing component, which can be explicitly set up, or done implicitly via a discovery technique such as we have covered in this draft.  

In the original version of this draft, we did include an explicitly reserved portion of the ID space for standard protocols, and another for vendor-specific discovery protocols.  At the time there did not seem to be an appetite for a standardized solution, so that does not appear in the current draft.

We didn't actually suggest any standard solution, just allowed some space for it.  And, is still easily done within the current draft by having the IETF claim an ID when such a standardization effort took place.

The tunneling protocol includes a lot more than just discovery -- it may encompass many of the same elements as TCP itself and may also encompass encryption -- and all of that would also need to be standardized.  When Andrew and I came down to Anaheim two years ago to start this, I attended the "mptcp" working group and remember being struck that there were a lot of similarities between that work and the types of tunneling protocols needed for WAN Op.  I haven't tracked how it has proceeded since then, though.

I'd see all of the above elements as fitting within TSV area.

2.  A compression / optimization protocol, or a series of them, which may be application specific.  For most of the vendors this is probably where there is a lot of "secret sauce" and it would be hard to see practically how one might move forward with standardization.  However, there are a number of published protocols which could form the basis for such a standard and provide some basic cross-vendor interoperability -- perhaps not with the full benefits of a single-vendor solution, but still valuable.

I'd see such work as needing to proceed within the APP area.

All told, I think this would be a heavy lift to get done, but valuable if it could be.  I don't know of any other organization that would make more sense for this than IETF.  However, one challenge with the IETF is that there is a certain reluctance to standardize (or "bless" if you will) some of the things we need to do as middleboxes to make these type of solutions possible.

I think that more pull from customers, and people like you who can speak on behalf of customers, would help work like this to gain traction.

--J

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Greg Daley
Sent: Monday, February 25, 2013 4:35 PM
To: [email-masked]'
Subject: [middisc] Wan Optimization standardization problem statement/analysis?

Dear Middisc list, 

Sincerely,

Greg Daley

---

From: "Knutsen, Andrew" <[email-masked]>
Date: Tue, 26 Feb 2013 17:57:44 +0000

Well put...  I'll just reiterate that the more people who support this sort of technology within the IETF, the closer it will come to representing the needs of the users (and thus staying relevant).  While I do have respect for the purist end-to-end model, we've found that it can be taken too far.

Andrew

________________________________________
From: [email-masked] [[email-masked]] on behalf of Mahdavi, Jamshid
Sent: Tuesday, February 26, 2013 7:52 AM
To: Greg Daley; [email-masked]'
Subject: Re: [middisc] Wan Optimization standardization problem statement/analysis?

--J

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Greg Daley
Sent: Monday, February 25, 2013 4:35 PM
To: [email-masked]'
Subject: [middisc] Wan Optimization standardization problem statement/analysis?

Dear Middisc list,

Sincerely,

Greg Daley

---

From: Greg Daley <[email-masked]>
Date: Tue, 26 Feb 2013 23:05:37 +0000

Hi, 

Thanks for your responses.

I agree that there is a lot of deployed technology, which vendors have been deploying to gain optimizations.

I'm thinking that cataloguing existing deployed approaches could be one part of the a Problem Statement.  
Given the variety of approaches applied in even one vendors solution (Tunnels, TCP optimization, Compression/Dedup, Application specific optimizations), it may still be that any future solution doesn't bite off all of these at once.

I agree that there will be a lot of interaction between TSV and APP.  For latter versions of the problem statement, we may need to work in specific concerns from these areas.   My focus is currently getting a discussion level document out in the near future. 

With respect to the end-to-end model, we can explicitly address differences in the deployments from transparent/pure environments to middlebox arbitrated ones.  

I'd guess it's explicit goal of the WAN accelerators to present identical application data though, and present behaviour compatible with existing edge device TCP/IP stacks. 

Personally, I will not be at IETF, but will start working on a draft for when the submissions open up again.

I'm interested in input if people have hallway conversations during the meeting.

Sincerely, 

Greg

-----Original Message-----
From: Knutsen, Andrew [mailto:[email-masked]] 
Sent: Wednesday, 27 February 2013 4:58 AM
To: Mahdavi, Jamshid; Greg Daley; [email-masked]'
Subject: RE: [middisc] Wan Optimization standardization problem statement/analysis?

Andrew

--J

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Greg Daley
Sent: Monday, February 25, 2013 4:35 PM
To: [email-masked]'
Subject: [middisc] Wan Optimization standardization problem statement/analysis?

Dear Middisc list,

Sincerely,

Greg Daley