Subject: [Mobike] 67 - certain vs. possible changed address info

From: Jari Arkko <[email-masked]>
Date: Sun, 23 Oct 2005 15:06:08 +0300

>
>
>>   o  An INFORMATIONAL request containing ADDITIONAL_IP4/6_ADDRESS
>>      notifications is received.  This means the peer's addresses may
>>      have changed.
>>  
>>
>I think we have two cases: the list (and source) either
>contains the addresses that we currently know of and
>use, or they don't. In the former case addresses may
>have changed, but in the latter case they surely have.
>For instance, if the peer sends us a message saying
>that its now in address B instead of A, we really need
>to take that into account, rather than continuing to
>use A.
>
>Suggestion: explain this in the bullet item, or split the
>item in two.
>

Here's some suggested text:

   o  An INFORMATIONAL request containing ADDITIONAL_IP4/6_ADDRESS
      notifications is received.  This means the peer's addresses may
      have changed.

=>

   o  An INFORMATIONAL request containing ADDITIONAL_IP4/6_ADDRESS
       or NO_ADDITIONAL_ADDRESSES notifications is received.  This means
       the peer's addresses may have changed. This is particularly important
       if the currently used address for peer is no longer in the announced
       set of addresses.

--Jari

_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: <[email-masked]>
Date: Mon, 24 Oct 2005 15:25:16 +0300

Jari Arkko wrote:

>       if the currently used address for peer is no longer in 
>       the announced set of addresses.

Looks good, I rephrased it slightly to this:

   o  An INFORMATIONAL request containing ADDITIONAL_IP4/6_ADDRESS or
      NO_ADDITIONAL_ADDRESS notifications is received.  This means the
      peer's addresses may have changed.  This is particularly important
      if the announced set of address no longer contains the currently
      used address.

BR,
Pasi