Subject: [Mobike] Issue 50: More editorial comments from Maureen (was: Comments on draft-ietf-mobike-protocol-03.txt)

From: <[email-masked]>
Date: Mon, 24 Oct 2005 13:42:51 +0300

Maureen Stillman wrote:
> These comments are all editorial.
> 
> 4.7 Changes in NAT Mappings
> 
>    In MOBIKE, these messages can also be used to detect if NAT
mappings
>    have changed (for example, if the keepalive internal is 
>    too long, or the NAT box is rebooted).  
> 
> I think you meant to say keepalive interval not keepalive internal.

Yes, that's right...

> 5. Payload formats
> 
> 5.1 MOBIKE_SUPPORTED Notify Payload
> 
> I think these headers and text should more closely match what is in
> IKEv2.  Also these messages should be split between what is an error,
> 5.5 and 5.8, and what is a status message all the rest.  This is also
> how the split is done in IKEv2.  See the template and text 
> below which I
> stole from IKEv2.  
> 
> Here is the new suggested text:

<snip>

Hmm.. the Notify payload itself is defined in the IKEv2 spec, and IMHO
we don't need to copy its definition here.  Copying it might even be
confusing, since it could give the impression we're defining a new
payload.

But I'll add some text to the beginning of section 5 to clarify
this (including the error/status types distinction).

Best regards,
Pasi
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Jari Arkko <[email-masked]>
Date: Mon, 24 Oct 2005 13:45:30 +0300

>the Notify payload itself is defined in the IKEv2 spec, and IMHO
Yes.

--Jari