Subject: Re: [Mobike] 51 - spi collisions

From: <[email-masked]>
Date: Mon, 24 Oct 2005 14:05:06 +0300

The basic idea in the text seems to be right, but IMHO we need
much longer explanation than that (at least if we want people
who didn't read the mailing list discussion to understand what
the note says).

I can try to write something (but not today)...

BR,
Pasi

> -----Original Message-----
> From: ext Jari Arkko [mailto:[email-masked]] 
> Sent: 24 October, 2005 13:43
> To: Tuomas Aura; Tero Kivinen; Eronen Pasi 
> (Nokia-NRC/Helsinki); Parthasarathy Mohan (Nokia-NET/MtView)
> Cc: MOBIKE Mailing List
> Subject: 51 - spi collisions
> 
> 
> It seems that we now have the same understanding of
> this issue. I asked Tero to write some text for an
> implementation note. Here goes:
> 
> Add to the end of Section 4.4 an indented implementation
> note as follows:
> 
>     Implementation note: In MOBIKE (and also in IKEv2) it is possible
>     to have cases where the SPI, protocol and destination address
>     may not be uniquely distinguish SA to be used for outgoing
>     traffic. In those cases implementations need to have a direct
>     pointer from the matched traffic selectors of the outgoing traffic
>     to the outbound SA to be used. That is, it is not enough 
>     to store SPI, protocol, and destination address to the SPD-S, 
>     but some kind of unique identifier is also needed. 
> 
> --Jari
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Jari Arkko <[email-masked]>
Date: Mon, 24 Oct 2005 14:15:34 +0300

>I can try to write something (but not today)...

Would this text + a pointer to design draft be sufficient?

--Jari

---

From: Tero Kivinen <[email-masked]>
Date: Mon, 24 Oct 2005 14:37:05 +0300

> who didn't read the mailing list discussion to understand what

As this is only implementation hint and the same problem is already in
the IKEv2 (i.e. the issue is not created by MOBIKE, it just might make
it more common), I do not think we need too much text about that. 
-- 
[email-masked]
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: "Mohan Parthasarathy" <[email-masked]>
Date: Mon, 24 Oct 2005 22:33:17 -0700

> Would this text + a pointer to design draft be sufficient?
The text is too simple to help the readers understand the issue. At least
providing an example (like the one given in Thomas mail) as a background
before the suggested text might help read it better. 

-mohan