Subject: Re: [Modern] modern meeting discussion

From: Richard Shockey <[email-masked]>
Date: Sun, 16 Jul 2017 11:30:37 -0700

Well this idea has the benefit of being actually practical and deployable vs the useless idea of individual number allocation.  Useless in the sense that no carrier I know of is going to rip out their existing OSS/BSS systems to accommodate the original idea.

The idea of white/black lists for the Do Not Originate application has merit as does the idea of listing numbers that have been disconnected and recently reassigned.  MODERN would have to compete, potentially, other methods that the NANPA and other numbering authorities could consider.

The problem right now is that the spoofing industry has moved on into the fully allocated range of the national numbering plans in order to increase answer rates.   A problem only STIR/SHAKEN can ultimately address. There is adequate data from the current crop of data analytics firms to support that thesis. 

In any event this idea does have merit and worth investigation. 

 

— 

Richard Shockey

Shockey Consulting LLC

Chairman of the Board SIP Forum

www.shockey.us

www.sipforum.org

richard<at>shockey.us

Skype-Linkedin-Facebook –Twitter  rshockey101

PSTN +1 703-593-2683

From: Modern <[email-masked]> on behalf of "Peterson, Jon" <[email-masked]>
Date: Sunday, July 16, 2017 at 5:20 AM
To: "[email-masked]" <[email-masked]>
Subject: [Modern] modern meeting discussion

For the MODERN meeting this time, Chris Wendt and I put our heads together to try to come up with a more concrete use case that would have some immediate applicability to the industry. Lately there has been some talk in North America recently about ways to share data structures that will let carriers know if a number is invalid or unallocated, so that abusive calls from numbers that simply shouldn't be able to originate at all can be blocked or otherwise given special treatment. 

Taking that as the sort of thing we hope MODERN could address, we put together this TeRI data structure for expressing that numbers are valid and allocated  - this is a "whitelist" sort of approach to the problem, as it seemed easier to us to share a list of numbers that are valid than it is to come up with all the different ways that someone might try to structure an invalid number. This is intended primarily for use with number ranges, though for some existing use cases (like freephone), assignment of individual numbers is what matters, and that is probably true of some of our future use cases here (like DRiP) as well.

https://tools.ietf.org/html/draft-peterson-modern-teri-valid-00

To get this into shape, I also did a bit more work fleshing out parts of TeRI, which has also been revised for the meeting, and I'll talk a bit about that as well on Friday.

Jon Peterson

Neustar, Inc.

_______________________________________________ Modern mailing list [email-masked] https://www.ietf.org/mailman/listinfo/modern

---

From: "Richard Hill" <[email-masked]>
Date: Mon, 17 Jul 2017 16:23:13 +0200

We get a lot of spoofed calls in Switzerland also. They are illegal, but the call centers are located outside of Switzerland, so there isn’t much that the Swiss authorities can do about it.

If the call center is willing to break the law (and is able to get away with it because they are offshore), how would the proposed TERI scheme help?  Are there variations of TERI that would help?

Thanks and best,

Richard

From: Modern [mailto:[email-masked]] On Behalf Of Richard Shockey
Sent: Sunday, July 16, 2017 20:31
To: Peterson, Jon; [email-masked]
Subject: Re: [Modern] modern meeting discussion

 

— 

Richard Shockey

Shockey Consulting LLC

www.shockey.us

www.sipforum.org

richard<at>shockey.us

PSTN +1 703-593-2683

 

Jon Peterson

Neustar, Inc.