Subject: [Modern] Comments on draft-wendt-modern-drip-02

From: "McGarry, Tom" <[email-masked]>
Date: Sun, 22 Oct 2017 17:03:11 +0000

A few comments on the draft:

  *   5.4, 1st bullet - says "if the node ID has NEVER been seen, store the values, and propagate the key–value data”.  Shouldn’t the node not be trusted, and values NOT stored and data NOT propagated?

  *   5.4, 2nd bullet, 1st subbullet – says if the counter field is greater, then the data must be propagated and new value must be stored.  Shouldn't this happen only if the new value is +1 of the existing value?  If it’s >+1 shouldn’t it assume that it’s missed updates and it needs to synch?

  *     Nits – 5.3, in many of the “Descriptions” of the "Field Names” the last sentence says “forward”, when I believe it should say “forwards”.

Tom

---

From: "McGarry, Tom" <[email-masked]>
Date: Sun, 22 Oct 2017 19:10:01 +0000

Tom

---

From: "McGarry, Tom" <[email-masked]>
Date: Mon, 30 Oct 2017 15:31:53 +0000

*     Nits – 5.3, in many of the “Descriptions” of the "Field Names” the last sentence says “forward”, when it should say “forwards”.

Tom