Subject: [Mops] Benjamin Kaduk's Block on charter-ietf-mops-00-00: (with BLOCK and COMMENT)

From: Benjamin Kaduk via Datatracker <[email-masked]>
Date: Tue, 08 Oct 2019 23:16:43 -0700

Benjamin Kaduk has entered the following ballot position for
charter-ietf-mops-00-00: Block

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-mops/

----------------------------------------------------------------------
BLOCK:
----------------------------------------------------------------------

Probably  a "discuss discuss^Wblock", but:

   1/ Solicit regular updates from other media technology developing
   consortia/standards bodies working with IETF-developed protocols.

How does this fit within the existing IETF/IAB liaison frameworks?

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

   Internet, inter-domain and single domain networking. In this case, media is
   considered to include the transport of video, audio, objects and any
   combination thereof, possibly non-sequentially. The scope is media and media

What are "objects"?

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Wed, 9 Oct 2019 15:54:34 +0000

On 10/9/19, 8:05 AM, "Mops on behalf of Benjamin Kaduk via Datatracker" <[email-masked] on behalf of [email-masked]> wrote:

    
    The document, along with other ballot positions, can be found here:
    https://urldefense.com/v3/__https://datatracker.ietf.org/doc/charter-ietf-mops/__;!c3kmrbLBmhXtig!5md9nfz0b4NOc0W5ahvAAFjgFGxCHYS_hIJQ1u2IYgUvinFlGRDrzHirAD5sQW4H$ 

    

    
We consulted with Ted Hardie and came up with the following clarification and added it the updated MOPS Charter.

"MOPS will work with existing liaison managers where the IETF has them, and informal connections with other organizations otherwise.”

    
    
    What are "objects"?

Objects in AV are the next evolution of how AV elements are represented and used by players to create custom experiences to accommodate viewers.

Today video and audio that is streamed across the Internet digitally encoded analog data that gets encoded via a codec which creates a decodable representation of it. It's sent to the player device which decodes it back into analog audio or frames.  In this, what you encode in is what you decode out.  The output is whatever was captured and encoded in the analog capture (microphone, camera) plus whatever editing was done before the encoding was done.   

The next evolution that's going on is to encode objects that are more than a basic codec encoding of the analog data.    They allow processing and working with the actual AV data on the playout device. They also allow multiple independent objects to be played by the player to create a composition experience directly on the player, instead of just what was in the encoded stream of today.      This can be used in audio to allow playback to be customized and crafted for the equipment and environment of the listener, and even to adapt the content to listener if for instance the listener has some hearing impairment.   Likewise, video objects can be used to deliver video elements which the player can selectively use, combine, interact with to create a custom experience tailored to the viewer, the environment, and the equipment.

Here’s a link that talks about it in the audio context.   https://www.dalet.com/news/object-audio-whats-all-noise-about

-glenn
    -- 
    Mops mailing list
    [email-masked]
    https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/mops__;!c3kmrbLBmhXtig!5md9nfz0b4NOc0W5ahvAAFjgFGxCHYS_hIJQ1u2IYgUvinFlGRDrzHirAJBqBKbj$