Subject: [Mops] FW: Multicast for the Web (and WebTransport in particular)

From: "Holland, Jake" <[email-masked]>
Date: Thu, 29 Jul 2021 17:59:25 +0000

Hi Mops,

Ali just mentioned that the mops group also might be
interested in Web multicast, since video is such an important
use case for it.

It's very late notice, sorry, but anyone who can make it is
invited to attend the Web Multicast bar bof starting in 2
minutes.

Best regards,
Jake

On 07-22, 10:44 AM, "Holland, Jake" <[email-masked]> wrote:

Hi WebTransport,

I'd like to let you know about a new W3C Community group
dedicated to incubating Multicast support for web traffic:
https://www.w3.org/community/multicast/
https://w3c.github.io/multicast-cg/multicast-cg-charter.html

For the first phase, we're working toward an integration with
WebTransport, as the charter describes in more detail.

I've set up a bar bof side meeting at 11am Pacific Time on
Thursday July 29th to discuss further.  Details are attached,
the meeting link is at the bottom, and it's registered here:
https://trac.ietf.org/trac/ietf/meeting/wiki/111sidemeetings

(I'd ask for a slot in webtrans, but hilariously, it's at the
same time as mboned, where some other parts of this work are
under way.)

A little more background:

Akamai is wrapping up some trials and discussions with several
ISPs and content owners evaluating the feasibility of standards-
based multicast delivery for our popular production traffic on a
3-5 year timeline.  The trials were checking whether our
prototypes and specs look like they'll be feasible to deploy
after productizing them, and whether the achievable traffic
offload would make investment worthwhile.

The moderately positive results of these trials (as well as some
interest generated during a W3C Interest group presentation) led
to the creation of the new community group as part of our next
steps.

We'll be relying on progress on some of the IETF docs to clarify
and address the networking requirements for web traffic as it
relates to multicast IP delivery.

The first one to consider from the webtrans point of view is
probably our recently-posted security considerations draft:
https://datatracker.ietf.org/doc/html/draft-krose-multicast-security

The aim is for this doc ultimately to perform a similar function
to what RFC 8826 did for WebRTC.

There are other relevant docs that taken together we think can fill
the security needs we know about so far, with a little refinement:
https://datatracker.ietf.org/doc/html/draft-ietf-mboned-ambi
https://datatracker.ietf.org/doc/html/draft-pardue-quic-http-mcast

I understand this to be outside webtransport's current charter,
but we'd like to develop this work between now and IETF 112, and in
November to bring a coherent and well-supported proposal for next
steps either to a venue like secdispatch or to a BoF for an
appropriate new group, depending on the advice we get along the way.

One option that might be worth considering would be rechartering
webtransport to allow for a scope that includes this work.

But even if that turns out not to be the right thing, we expect
that members of webtransport will have crucial expertise and opinions,
and we would value your feedback and request some level of liaison as
we try to move this forward.

I hope to see some of you next Thursday.

Best regards,
Jake

[1] Webex meeting for Thursday at 11am Pacific (1 hour before the
first sessions of the day):
https://akamai.webex.com/akamai/j.php?MTID=mbe0822775e2ba553d4669b441833ec38

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 29 Jul 2021 14:36:16 -0500

Hi, Jake,

> invited to attend the Web Multicast bar bof starting in 2

This was a very interesting side meeting.

Could I ask where you expect discussion to happen, and where the notes
would be posted?

Best,

Spencer

> --
> Mops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mops
>

---

From: "Holland, Jake" <[email-masked]>
Date: Thu, 29 Jul 2021 21:59:46 +0000

Hi Spencer,

From: Spencer Dawkins at IETF <[email-masked]>
> Date: Thu,2021-07-29 at 12:36 PM
>

Thanks!

> Could I ask where you expect discussion to happen, and
> where the notes would be posted?

I was thinking I'd send a follow-up message to mops and
webtransport with a summary and links to notes and the video
once it's posted (there may be a slight delay).

If we establish an IETF mailing list or venue, I guess I’ll
probably also send one more follow-up message to mops,
webtransport, mboned, and possibly ietf to invite interested
parties to join, unless I get different guidance.

If you want to comment on the IETF drafts or stay in an IETF
context for this, there are several relevant drafts that have
been adopted in mboned, where comment would be very welcome:
https://www.ietf.org/mailman/listinfo/mboned
https://datatracker.ietf.org/doc/draft-ietf-mboned-dorms/
https://datatracker.ietf.org/doc/draft-ietf-mboned-cbacc/
https://datatracker.ietf.org/doc/draft-ietf-mboned-ambi/
https://datatracker.ietf.org/doc/draft-ietf-mboned-mnat/

(NB: I'll also be presenting on these in the mboned meeting
tomorrow.)

If you want to get involved in the overall project including
the web-specific aspect of it or to discuss other topics that
might be tangential to mboned, I'd also encourage joining the
W3C list:
https://lists.w3.org/Archives/Public/public-multicast/

If you're able to participate in W3C, that group is meeting monthly
on first Wednesdays, with the next scheduled meeting on August
4th at 7:30am Pacific time (2:30pm UTC).  The details are here: https://lists.w3.org/Archives/Public/public-multicast/2021Jul/0004.html

Best regards,
Jake

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 30 Jul 2021 08:40:39 -0500

Hi, Jake,

On Thu, Jul 29, 2021 at 4:59 PM Holland, Jake <[email-masked]> wrote:

> 4th at 7:30am Pacific time (2:30pm UTC).  The details are here:
> https://lists.w3.org/Archives/Public/public-multicast/2021Jul/0004.html
>
> Best regards,
> Jake
>

This is all very helpful! Thanks for the quick response.

Do you think a mailing list would be useful for coordinating things among
various venues? If so, please let me know - I know how to request that.

It sounds like you may not need a dedicated venue before IETF 112, but if
you decide that you do, please let me know - I'd love to help with that too.

Best,

Spencer

---

From: Kyle Rose <[email-masked]>
Date: Fri, 30 Jul 2021 09:58:15 -0400

Given the existence of the new W3C multicast community group, one important
consideration at this early stage of work is to make sure we develop a
consistent, coherent vision. I would be in favor of a single mailing list
until/unless we get to a point where responsibility can be assigned to
groups working independently.

Kyle

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 30 Jul 2021 09:10:00 -0500

Hi, Kyle,

On Fri, Jul 30, 2021 at 8:58 AM Kyle Rose <[email-masked]> wrote:

> Given the existence of the new W3C multicast community group, one
> important consideration at this early stage of work is to make sure we
> develop a consistent, coherent vision. I would be in favor of a single
> mailing list until/unless we get to a point where responsibility can be
> assigned to groups working independently.
>

Makes sense to me, even if it's only used for coordination, and all of
the technical work goes somewhere else.

Do you and/or Jake have thoughts about whether that needs to be a new
mailing list, or whether something that already exists is fit for purpose?

Best,

Spencer

---

From: "Holland, Jake" <[email-masked]>
Date: Fri, 30 Jul 2021 14:52:37 +0000

Hi Spencer,

mops is pretty clearly the wrong discussion venue :) (moved to bcc, so reply if you’d like to be on the thread...)

Thus far mboned has been my idea of the closest match, but I think draft-krose-multicast-security gets a little hard to argue it’s in scope.

And really, I think AMBI and to a lesser extent DORMS is in the same boat.  Although we got some early advice it could be done in mboned with just some review from the security area due to not using any novel crypto and the general approach being a well-established authentication strategy, it does touch on some security questions that are kind of a stretch for mboned, especially when we try to consider it in a web security requirements.  And even more so if we want to bring back ALTA at some point (https://datatracker.ietf.org/doc/draft-krose-mboned-alta/).

Previously there has been a much heavier routing area overlap than security area overlap in mboned, and you’d have to look back to msec (and maybe some rmt) to have a closer match in membership.  And a lot of the people who might be interested in discussing multicast’s security implications in a web security context might reasonably be much less interested in some of the other mboned docs, and vice versa...

I thought the best approach would probably be “reopen msec”.  Last time we took that to secdispatch (with alta, maybe at 106 or so?) they said to come back with more people, so that’s what I was trying to do for November, if webtransport didn’t want us.

Best,
Jake

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri,2021-07-30 at 7:10 AM
To: Kyle Rose <[email-masked]>
Cc: "Holland, Jake" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Mops] FW: Multicast for the Web (and WebTransport in particular)

Hi, Kyle,

On Fri, Jul 30, 2021 at 8:58 AM Kyle Rose <[email-masked]<mailto:[email-masked]>> wrote:
Given the existence of the new W3C multicast community group, one important consideration at this early stage of work is to make sure we develop a consistent, coherent vision. I would be in favor of a single mailing list until/unless we get to a point where responsibility can be assigned to groups working independently.

Makes sense to me, even if it's only used for coordination, and all of the technical work goes somewhere else.

Do you and/or Jake have thoughts about whether that needs to be a new mailing list, or whether something that already exists is fit for purpose?

Best,

Spencer

Kyle

On Fri, Jul 30, 2021 at 9:41 AM Spencer Dawkins at IETF <[email-masked]<mailto:[email-masked]>> wrote:
Hi, Jake,

On Thu, Jul 29, 2021 at 4:59 PM Holland, Jake <[email-masked]<mailto:[email-masked]>> wrote:
Hi Spencer,

From: Spencer Dawkins at IETF <[email-masked]<mailto:[email-masked]>>

Thanks!

If you want to comment on the IETF drafts or stay in an IETF
context for this, there are several relevant drafts that have
been adopted in mboned, where comment would be very welcome:
https://www.ietf.org/mailman/listinfo/mboned<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/mboned__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xv7u3NBM$>
https://datatracker.ietf.org/doc/draft-ietf-mboned-dorms/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-mboned-dorms/__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xgA4v7bE$>
https://datatracker.ietf.org/doc/draft-ietf-mboned-cbacc/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-mboned-cbacc/__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2x_D09FJ4$>
https://datatracker.ietf.org/doc/draft-ietf-mboned-ambi/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-mboned-ambi/__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xcQ6xheg$>
https://datatracker.ietf.org/doc/draft-ietf-mboned-mnat/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-mboned-mnat/__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xiOdIYdA$>

If you want to get involved in the overall project including
the web-specific aspect of it or to discuss other topics that
might be tangential to mboned, I'd also encourage joining the
W3C list:
https://lists.w3.org/Archives/Public/public-multicast/<https://urldefense.com/v3/__https:/lists.w3.org/Archives/Public/public-multicast/__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xsNtErYE$>

If you're able to participate in W3C, that group is meeting monthly
on first Wednesdays, with the next scheduled meeting on August
4th at 7:30am Pacific time (2:30pm UTC).  The details are here: https://lists.w3.org/Archives/Public/public-multicast/2021Jul/0004.html<https://urldefense.com/v3/__https:/lists.w3.org/Archives/Public/public-multicast/2021Jul/0004.html__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xUZBGgWo$>

Best regards,
Jake

Do you think a mailing list would be useful for coordinating things among various venues? If so, please let me know - I know how to request that.

It sounds like you may not need a dedicated venue before IETF 112, but if you decide that you do, please let me know - I'd love to help with that too.

Best,

Spencer
--
Mops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mops<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/mops__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xeTNudAk$>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 30 Jul 2021 11:14:55 -0500

Hi, Jake,

On Fri, Jul 30, 2021 at 9:52 AM Holland, Jake <[email-masked]> wrote:

> Hi Spencer,
>
>
>
> mops is pretty clearly the wrong discussion venue :) (moved to bcc, so
> reply if you’d like to be on the thread...)
>

Good idea (and I wish I'd thought of trimming the cc: list earlier - or at
least intentionally removing WISH and AVTCORE!)

Because I agree that MOPS is not the right home (and Kyle and Leslie can
override me on that), I added them back as bcc:, just because I'm drawing
conclusions about your answer. No need to annoy them further.

 Thus far mboned has been my idea of the closest match, but I think
> draft-krose-multicast-security gets a little hard to argue it’s in scope.
>
>
>
> And really, I think AMBI and to a lesser extent DORMS is in the same
> boat.  Although we got some early advice it could be done in mboned with
> just some review from the security area due to not using any novel crypto
> and the general approach being a well-established authentication strategy,
> it does touch on some security questions that are kind of a stretch for
> mboned, especially when we try to consider it in a web security
> requirements.  And even more so if we want to bring back ALTA at some point
> (https://datatracker.ietf.org/doc/draft-krose-mboned-alta/).
>
>
>
> Previously there has been a much heavier routing area overlap than
> security area overlap in mboned, and you’d have to look back to msec (and
> maybe some rmt) to have a closer match in membership.  And a lot of the
> people who might be interested in discussing multicast’s security
> implications in a web security context might reasonably be much less
> interested in some of the other mboned docs, and vice versa...
>
>
>
> I thought the best approach would probably be “reopen msec”.  Last time we
> took that to secdispatch (with alta, maybe at 106 or so?) they said to come
> back with more people, so that’s what I was trying to do for November, if
> webtransport didn’t want us.
>

The more we chat about homes for discussion (and especially coordination),
the more I'm thinking that requesting a new mailing list, where interested
people can work to coordinate at least two or three moving pieces that span
multiple areas, is the right thing to do - not for any solutions work, but
just to make sure that you (and the rest of us) can make sure that we
haven't forgotten or overlooked anything that's necessary for success.

I THINK you're talking about work that is of interest in SEC and ART (and
W3C), and relying on expertise from RTG, OPS, and maybe even INT and TSV,
so it should be pretty easy to find an AD to approve a request for a non-WG
IETF mailing list. 😜

If that sounds like a plan to you, the procedure for that request is at
https://www.ietf.org/how/lists/nonwglist-guidelines/ (and you'll need to
pick "an appropriate AD", so talking to your pick first is usually a good
thing). You can also bikeshed on the name of the mailing list privately
with your AD.

If you want to look at an example, the most recent non-WG mailing list is
https://www.ietf.org/mailman/listinfo/e2ee, I believe. The usual things
that trip requesters up (in my experience) was not providing both a
summary, and a bit more detailed description, and not providing at least
one proposed administrator.

Finally - I'm not sure what I've actually said to you about this, but I'm
glad you're doing this work, and even more glad that you're bringing it to
the IETF. Obviously, it matters to the Internet.

Best,

Spencer

 Best,
>
> Jake
>
>
>
> *From: *Spencer Dawkins at IETF <[email-masked]>
> *Date: *Fri,2021-07-30 at 7:10 AM
> *To: *Kyle Rose <[email-masked]>
> *Cc: *"Holland, Jake" <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *Re: [Mops] FW: Multicast for the Web (and WebTransport in
> particular)
>
>
>
> Hi, Kyle,
>
>
>
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/mboned__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xv7u3NBM$>
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-mboned-dorms/__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xgA4v7bE$>
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-mboned-cbacc/__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2x_D09FJ4$>
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-mboned-ambi/__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xcQ6xheg$>
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-mboned-mnat/__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xiOdIYdA$>
>
> <https://urldefense.com/v3/__https:/lists.w3.org/Archives/Public/public-multicast/__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xsNtErYE$>
>
> <https://urldefense.com/v3/__https:/lists.w3.org/Archives/Public/public-multicast/2021Jul/0004.html__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xUZBGgWo$>
>
> Best regards,
> Jake
>
>
>
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/mops__;!!GjvTz_vk!CssogoPpbhVP1G6MyVypmxoKx6Ub2f44l_L9KXdVt4a9KyZvYUL3Uh2xeTNudAk$>
>
>