Subject: [MSEC] draft-ietf-msec-mikey-ecc-01.txt

From: "Fries, Steffen" <[email-masked]>
Date: Thu, 2 Nov 2006 16:18:51 +0100

Hi Eugene,
 
I was just reading again over the mikey-ecc update. On question to the
ECDSA addition. In the comments I sent to the former version of the
draft, there was also ECGDSA included. The advantage of ECGDSA over
ECDSA is that it does not require inverting the ephemeral key and thus
may be interesting for devices with less computational power. Because of
this we should maybe include it as well. What do you think? 
 
Regards
    Steffen

________________________________

	From: Eugene Chin [mailto:[email-masked]] 
	Sent: Saturday, October 21, 2006 3:14 PM
	To: [email-masked]
	Subject: Re: [MSEC] WGLC on
draft-ietf-msec-mikey-applicability-02,ending Oct 6, 2006 AOE

	Section 3.3 - typo: server -> serve
	"Nevertheless, the established Diffie-Hellman-Secret may server
as a pre-shared key..."
	
	Section 4.1 -
	I've submitted an update to ietf-msec-mikey-ecc.  Where I think
it was previously confusing, the draft now clearly identifies the 4
additional methods (1 added based on Steffen's comments): 
	- extending MIKEY-DHSIGN to use ECDSA
	- extending MIKEY-DHSIGN to use ECDH
	- MIKEY-ECIES
	- MIKEY-ECMQV (renamed from MIKEY-MQV)
	
	The rename to MIKEY-ECMQV also affects section 4.1.2.
	
	Thanks,
	Eugene. 

_______________________________________________
MSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/msec

---

From: "Fries, Steffen" <[email-masked]>
Date: Thu, 2 Nov 2006 16:18:51 +0100

Hi Eugene,

Regards
    Steffen

	
	Section 4.1 -

	Thanks,
	Eugene.

---

From: "Eugene Chin" <[email-masked]>
Date: Fri, 3 Nov 2006 07:21:06 -0500

Hi Steffen,

In the comments I sent to the former version of the draft, there was
> also ECGDSA included.

Oops, I appear to have missed this point from your previous comments.  To be
honest, I am not familiar with ECGDSA, and will get back to you.

Thanks,
Eugene.

---

From: "Eugene Chin" <[email-masked]>
Date: Fri, 3 Nov 2006 07:21:06 -0500

Hi Steffen,

Thanks,
Eugene.

---

From: "Fries, Steffen" <[email-masked]>
Date: Fri, 3 Nov 2006 13:22:04 +0100

HI Eugene,
 
if you need further information on ECGDSA, just let me know.
 
Ciao
    Steffen

	From: Eugene Chin [mailto:[email-masked]] 
	Sent: Friday, November 03, 2006 1:21 PM
	To: Fries, Steffen
	Cc: [email-masked]
	Subject: Re: draft-ietf-msec-mikey-ecc-01.txt

	Hi Steffen,

		In the comments I sent to the former version of the
draft, there was also ECGDSA included.

	Oops, I appear to have missed this point from your previous
comments.  To be honest, I am not familiar with ECGDSA, and will get
back to you. 
	
	Thanks,
	Eugene.

---

From: "Fries, Steffen" <[email-masked]>
Date: Fri, 3 Nov 2006 13:22:04 +0100

HI Eugene,

Ciao
    Steffen

	Hi Steffen,

	
	Thanks,
	Eugene.