Subject: draft-ietf-msgtrk-mtqp-04.txt and draft-ietf-msgtrk-model-04.txt

From: Tony Hansen <[email-masked]>
Date: Wed, 21 Nov 2001 17:53:32 -0500

Sorry for my hiatus. I've sent in updates to the mtqp and model
documents. They can be found here in the meantime:

http://www.geocities.com/tonylhansen/draft-ietf-msgtrk-mtqp-04.txt
http://www.geocities.com/tonylhansen/draft-ietf-msgtrk-model-04.txt

	Tony Hansen
	[email-masked]

---

From: Gregory Neil Shapiro <[email-masked]>
Date: Wed, 21 Nov 2001 17:55:51 -0800

tony> http://www.geocities.com/tonylhansen/draft-ietf-msgtrk-mtqp-04.txt

Here are my comments:

1. Replace 'A record' with 'address record':

-record pointing at the server host, and if not, will have an A record.
+record pointing at the server host, and if not, will have an address record.

2. Spelling errors:

-Which option is picked is an adminstrative decision and is not further
+Which option is picked is an administrative decision and is not further

-     Example #8 Message Delayed and a DotStuffed Header:
+     Example #8 Message Delayed and a Dot-Stuffed Header:

-     If TLS is not suported, then a response code of "/unsupported"
+     If TLS is not supported, then a response code of "/unsupported"

-reponse code of "/unavailable" SHOULD be used.  If a TLS session is
+response code of "/unavailable" SHOULD be used.  If a TLS session is

3. The firewall examples showing relaying to another host and then that
   host's responses seem to show the wrong Remote-MTA hostname but I could
   be wrong.  Somebody should double chek my work:

@@ -519,7 +519,7 @@
      S: Final-Recipient: rfc822; [email-masked]
      S: Action: relayed
      S: Status: 2.1.9
-     S: Remote-MTA: dns; example2.com
+     S: Remote-MTA: dns; smtp.example3.com
      S: Last-Attempt-Date: Mon,  1 Jan 2001 19:15:03 -0500
      S:
      S: --%%%%
@@ -553,7 +553,7 @@
      S: Final-Recipient: rfc822; [email-masked]
      S: Action: relayed
      S: Status: 2.1.9
-     S: Remote-MTA: dns; example2.com
+     S: Remote-MTA: dns; smtp.example3.com
      S: Last-Attempt-Date: Mon,  1 Jan 2001 19:15:03 -0500
      S:
 
4. The MTQP option registration for STARTTLS is improperly formatted:

      One MTQP option is defined in this document:
-     option identifier: STARTTLS option parameters: none added commands:
-     STARTTLS standard commands affected: none specification reference:
-     RFC TBD discussion: see RFC TBD
+     option identifier: STARTTLS
+     option parameters: none
+     added commands: STARTTLS
+     standard commands affected: none
+     specification reference: RFC TBD
+     discussion: see RFC TBD

---

From: Gregory Neil Shapiro <[email-masked]>
Date: Wed, 21 Nov 2001 17:59:55 -0800

tony> http://www.geocities.com/tonylhansen/draft-ietf-msgtrk-model-04.txt

And here are some spelling corrections for the model document:

-               Status Notificatons (DSNs).  (Intermediate MTA's may also
+               Status Notifications (DSNs).  (Intermediate MTA's may also

-assist in its implmentation may be prepared, copied, published and dis-
+assist in its implementation may be prepared, copied, published and dis-

-references to the Internet Society or other Internet organisations,
+references to the Internet Society or other Internet organizations,

---

From: Tony Hansen <[email-masked]>
Date: Wed, 21 Nov 2001 23:23:07 -0500

always some nits. :-) thanks Greg!

more below.

	Tony

> +record pointing at the server host, and if not, will have an address record.

thought I had gotten all of those. rats.

> ...

I think you're right.
 
> +     discussion: see RFC TBD

left off the ".nf/.fi" pair, for those of you who speak *roff.