Subject: Re: [multimob] WG: New Version Notification for draft-von-hugo-multimob-future-work-00

From: "Thomas C. Schmidt" <[email-masked]>
Date: Sat, 24 Oct 2009 23:41:05 +0200

Hi Dirk,

sorry for being late with replying to your draft proposal.

 From a general perspective, it might be good to think about future work 
in Multimob, but personally I believe that we should concentrate on 
keeping the tight schedule for solutions in the Hiroshima meeting. Once 
we have delivered (excellently & in time) the required contributions, we 
might take the time for a new charter discussion - it will probably be 
2010 then.

In detail, let me first play back on this "pleothera" (plethora ?) thing 
;) :

If you work your way through the PS down to the end, you'll find a 
pretty clear road map 
(http://tools.ietf.org/html/draft-irtf-mobopts-mmcastv6-ps-09#page-25):

--------------------------- snip ---------------------------------------
It is recommended that future steps towards extending mobility
services to multicast proceed to first solve the following problems:

      1. Ensure seamless multicast reception during handovers,
         meeting the requirements of mobile IPv6 nodes and networks.
         Thereby address the problems of home subscription without
         n-tunnels, as well as native multicast reception in those
         visited networks, which offer a group communication service.

      2. Integrate multicast listener support into unicast mobility
         management schemes and architectural entities to define a
         consistent mobility service architecture, providing equal
         supporting for unicast and multicast communication.

      3. Provide basic multicast source mobility by designing
         address duality management at end nodes.

--------------------------- snap ---------------------------------------

Still, I'm fairly convinced of that path to go. In shorthand

   1. Complete the MLD optimization issues

   2. Follow the line of unicast mobility protocols

      a.) Minimal multicast in PMIP (we are doing now)
      b.) Optimize PMIP-Multicast
      c.) Extend FMIP/PFMIP, DSMIP, HMIP, Multihoming ...
      d.) Look at NEMO

   3. Design basic source mobility

So this widely agrees with your thoughts, right?

On the contrary, I would tend to disagree about MANET-type of work in 
Multimob. MANET routing works quite differently and multicast/broadcast 
is a fundamental issue there. Leaving this work to the MANET group 
appears much more appropriate to me.

Thanks for thinking ahead!

Cheers,

Thomas

> -----Ursprüngliche Nachricht-----
> Von: IETF I-D Submission Tool [mailto:[email-masked]] 
> Gesendet: Montag, 19. Oktober 2009 13:36
> An: von Hugo, Dirk
> Cc: von Hugo, Dirk
> Betreff: New Version Notification for draft-von-hugo-multimob-future-work-00 
> 
> 
> A new version of I-D, draft-von-hugo-multimob-future-work-00.txt has been successfuly submitted by Dirk von Hugo and posted to the IETF repository.
> 
> Filename:	 draft-von-hugo-multimob-future-work
> Revision:	 00
> Title:		 Evaluation of further issues on Multicast Mobility: Potential future work for WG MultiMob
> Creation_date:	 2009-10-19
> WG ID:		 Independent Submission
> Number_of_pages: 8
> 
> Abstract:
> This document discusses potential future extensions on the current 
> work plan of recently approved WG MultiMob (Multicast Mobility).  
> MultiMob charter explicitly states that scope of work will be limited
> to mobility protocols Proxy Mobile IPv6, and multicast group 
> management in terms of IGMPv3/MLDv2 protocols.  Furthermore only
> listener mobility will be dealt with and any modification to these
> existing protocols and to multicast routing protocols are out of
> scope.
>                                                                                   
> 
> 
> The IETF Secretariat.
> 
> 

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                   Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany °
° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452 °
° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409 °

---

From: <[email-masked]>
Date: Mon, 26 Oct 2009 11:41:36 +0100

Dear Thomas,
No problem - we all are pretty busy these days. Therefore thanks a lot for the comments - I of course fully agree that we have to concentrate on current charter issues first, so as you mentioned the list should only prepare in time for future actions. 
Comparing the single issue with MLD with multiple 'xMIP' issues it surely makes sense to complete that first.
Perhaps I should elaborate the idea of 'MANET-type' mobile multicast a little bit more: Main focus should not deal with the mobile and temporary character of ad hoc networks but with multiple hops and multiple paths of (more or less stable) meshed networks, which is not primary interest of MANET.
I'll try to come up with more detailed consideration later on ...
Thanks again - see you in Hiroshima!

Best regards

Viele Grüße,
Dirk

-----Ursprüngliche Nachricht-----
Von: Thomas C. Schmidt [mailto:[email-masked]] 
Gesendet: Samstag, 24. Oktober 2009 23:41
An: von Hugo, Dirk
Cc: jouni korhonen; [email-masked]
Betreff: Re: WG: New Version Notification for draft-von-hugo-multimob-future-work-00

Hi Dirk,

--------------------------- snap ---------------------------------------

Cheers,

Thomas

--