Subject: [multimob] [Fwd: New Version Notification for draft-schmidt-multimob-pmipv6-mcast-deployment-04]

From: "Thomas C. Schmidt" <[email-masked]>
Date: Mon, 08 Feb 2010 22:02:03 +0100

Hi,

we have submitted a revised version of the PMIPv6 deployment draft.
This version includes all contributions from the extensive and fruitful 
discussions since the last update in December.

 From the Change Log

    The following changes have been made from
    draft-schmidt-multimob-pmipv6-mcast-deployment-03.

    1.  Detailed outline of multicast reconfiguration steps on handovers
        added in protocol overview (section 3).

    2.  Clarified the details of proxy operations at the MAG along with
        the expected features of IGMP/MLD Proxy implementations (section
        4.2).

    3.  Clarified querying in dual-stack scenarios (section 4.4).

    4.  Subsection added on the special case, where multicast is
        available throughout the access network (section 4.5).

    5.  Appendix on IGMP/MLD behaviour added with test reports on current
        Proxy implementations.

We now believe the approach has been thoroughly discussed and the 
document is mature enough to be considered as a WG item.

Best wishes,

Thomas

-------- Original Message --------
Subject: New Version Notification for 
draft-schmidt-multimob-pmipv6-mcast-deployment-04
Date: Mon,  8 Feb 2010 12:53:11 -0800 (PST)
From: IETF I-D Submission Tool <[email-masked]>
To: [email-masked]
CC: 
[email-masked],[email-masked],[email-masked]

A new version of I-D, 
draft-schmidt-multimob-pmipv6-mcast-deployment-04.txt has been 
successfuly submitted by Thomas Schmidt and posted to the IETF repository.

Filename:	 draft-schmidt-multimob-pmipv6-mcast-deployment
Revision:	 04
Title:		 A Minimal Deployment Option for Multicast Listeners in PMIPv6 
Domains
Creation_date:	 2010-02-08
WG ID:		 Independent Submission
Number_of_pages: 19

Abstract:
This document describes deployment options for activating multicast
listener functions in Proxy Mobile IPv6 domains without modifying
mobility and multicast protocol standards.  Similar to Home Agents in
Mobile IPv6, PMIPv6 Local Mobility Anchors serve as multicast
subscription anchor points, while Mobile Access Gateways provide MLD
proxy functions.  In this scenario, Mobile Nodes remain agnostic of
multicast mobility operations.

The IETF Secretariat.

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                   Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany °
° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452 °
° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409 °

---

From: "Lu, Guang" <[email-masked]>
Date: Wed, 17 Feb 2010 16:47:15 -0500

Hi Thomas, 

We reviewed your draft (draft-schmidt-multimob-pmipv6-mcast-deployment-04). It is in good shape. Please see below some comments we have. 

(a) Appendix C. Comparative Evaluation of Different Approaches

In the tables, you provided comparison of "# of redundant streams at MAG" and "# of sim. Streams at LMA / LMA-M". Showing the streams at each LMA is good but not enough though since it only shows the load of one node. IMHO it is also essential to provide total number of simultaneous streams network wise to show the whole picture. Note that this point was raised before in the mailing list (http://www.ietf.org/mail-archive/web/multimob/current/msg00741.html). 

Please see below the extended tables with a new column showing "# of sim. Streams in network for all LMAs". This information can clearly answer some questions raised by the group regarding the traffic profile in various scenarios.

Setting 1:  1,000,000 MNs are subscribed to distinct multicast groups

The combined Unicast/Multicast LMA scheme has 4 LMAs, each with 250,000 streams. So in the network, both solutions have the same number of simultaneous streams. 
 
+=============+===========+================+===================
|             |           |                |                  |
|   PMIP      | # of      | # of sim.      |# of sim. streams |
| Multicast   | redundant | streams at     |in network        |
| scheme      | streams   | each LMA/LMA-M |for all LMAs      |
|             | at MAG    | LMA/LMA-M      |                  |       
+=============+===========+================+==================|
| Combined    |           |                |                  |
| Unicast/    |     0     |   250,000      |    1,000,000     |
| Mcast LMA   |           |                |                  |
+-------------+-----------+----------------+------------------+
| Dedicated   |     0     |   1,000,000    |    1,000,000     |
| Mcast LMA   |           |                |                  |
+-------------+-----------+----------------+------------------+

Setting 2:  1,000,000 MNs are subscribed to the same multicast group 

Due to the traffic replication at MAG, the combined unicast/multicast LMA scheme produces a total of 800 streams between all LMAs and MAGs. The dedicated LMA configuration requires 200 streams, less than the combined solution. This scenario clearly shows the advantage of saving bandwidth with the dedicated multicast LMA when MNs using different LMAs join the same group. 
 
+=============+===========+================+===================
|             |           |                |                  |
|   PMIP      | # of      | # of sim.      |# of sim. streams |
| Multicast   | redundant | streams at     |in network        |
| scheme      | streams   | each LMA/LMA-M |for all LMAs      |
|             | at MAG    | LMA/LMA-M      |                  |       
+=============+===========+================+==================|
| Combined    |           |                |                  |
| Unicast/    |     4     |      50        |       800        |
| Mcast LMA   |           |                |                  |
+-------------+-----------+----------------+------------------+
| Dedicated   |     0     |      200       |       200        |
| Mcast LMA   |           |                |                  |
+-------------+-----------+----------------+------------------+

(b) Figure 2
The Figure seems to mix IGMP and MLD terms (and is not consistent with the text in section 3).  To be consistent, the IGMP term "Join" should be replaced by the MLD term "Report" in the Figure.  

(c) Section 4.5 (Multicast Availability throughout the Access Network) Do you think an air interface protocol like 3GPP MBMS qualifies as a access network multicast support? If so, it would be good to expand this section to include the air interface support of multicast.

(d) Section 7 (Security Considerations)
There are some additional security considerations for dual mode (IPv4/IPv6) raised in [I-D.ietf-netlmm-pmip6-ipv4-support].  Should this be acknowledged in this section?

(e) Appendix B (State of IGMP/MLD Proxy Implementations):
It was good that Cisco edge router was tested.  Do you intend to test the Juniper Networks E-series platform as well as it seems to have good multicast support (http://www.juniper.net/solutions/literature/white_papers/200188.pdf) ?

Best regards,
Guang

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Thomas C. Schmidt
> Sent: Monday, February 08, 2010 4:02 PM
> To: [email-masked]
> Subject: [multimob] [Fwd: New Version Notification fordraft-schmidt-
> multimob-pmipv6-mcast-deployment-04]
> 
> Hi,
> 
> _______________________________________________
> multimob mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multimob

---

From: "Thomas C. Schmidt" <[email-masked]>
Date: Thu, 25 Feb 2010 14:20:52 +0100

Hi Guang,

many thanks for your comments - sorry for missing your mail at first.

Please see answers inline (marked with "Thomas >>>>"):

> The combined Unicast/Multicast LMA scheme has 4 LMAs, each with 250,000 streams. So in the network, both solutions have the same number of simultaneous streams. 

Thomas >>>> Yes, that sounds correct, in fact it's just multiplying it 
out. Looking at the table more closely, there are arithmetic mistakes 
anyway. It should be:

  | Unicast/    |     3     |      200       |       800        |

Thomas >>>> We can add this, even though it's just two sides of the same 
coin ...

> The Figure seems to mix IGMP and MLD terms (and is not consistent with the text in section 3).  To be consistent, the IGMP term "Join" should be replaced by the MLD term "Report" in the Figure.  

Thomas >>>> Yes ... rather it's IGMPv2 language, which bears the beauty 
of simplicity and brevity. IGMPv2 JOIN corresponds to a specific 
IGMPv3/MLDv2 REPORT message (exclude no sources for group G). We should 
re-think presentation, but keep it intuitive.

> (c) Section 4.5 (Multicast Availability throughout the Access Network) Do you think an air interface protocol like 3GPP MBMS qualifies as a access network multicast support? If so, it would be good…

Thomas >>>> I don't get your point here. IMHO, 3GPP/MBMS is a 
particularly striking example of multicast unavailability at the network 
layer ... however, this section is just a pointer to future work on 
optimization. I suppose, this should rest as a pointer and future 
documents (like your work ?) should elaborate on it/ work out optimizing 
set ups, e.g., for 3GPP or emerging architectures.
> There are some additional security considerations for dual mode (IPv4/IPv6) raised in [I-D.ietf-netlmm-pmip6-ipv4-support].  Should this be acknowledged in this section?

Thomas >>>> Thanks for the pointer: The security section should be 
carefully revised anyway, I believe. We don't want to repeat the issues 
of PMIP or MLD, but should re-consider what arises from the combination 
chosen in the draft.

> It was good that Cisco edge router was tested.  Do you intend to test the Juniper Networks E-series platform as well as it seems to have good multicast support (http://www.juniper.net/solutions/lit…

Thomas >>>> We would love to, but we don't have one in our lab. May be 
someone who has easy access to Juniper test equipment volunteers to do 
this?

Cheers,

Thomas

--