Subject: [multimob] About draft-ietf-multimob-pmipv6-base-solution

From: shery sheryar <[email-masked]>
Date: Fri, 30 Jul 2010 12:27:00 +0500

Hi all,

 Can you please guide me, for using MLD messages over IPSec tunnel. I mean
if MAG and Mobile Node (MN) have established IPSec over the tunnel through
some non-trusted access network.

Thanks

Sheheryar

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 30 Jul 2010 02:12:30 -0700 (PDT)

Hi Sherry,

>
>From: shery sheryar <[email-masked]>
>To: "[email-masked]" <[email-masked]>
>Sent: Fri, July 30, 2010 2:27:00 AM
>Subject: [multimob] About draft-ietf-multimob-pmipv6-base-solution
>
>
>Hi all,
> 
> Can you please guide me, for using MLD messages over IPSec tunnel. I mean if 
>MAG and Mobile Node (MN) have established IPSec over the tunnel through some 
>non-trusted access network.
>

I think this is 3GPP kind of deployment.
MLD messages should be sent back and forth over the IPSec tunnel as payload. I 
don't see any problems.
It could also be a way of securing MLD messages.

To shed more light, I found this draft:
http://tools.ietf.org/html/draft-tschofenig-v6ops-secure-tunnels-03

which talks about SPD are used for protecting link-local  traffic.

Regards,

Behcet