Subject: Re: [multrans] Comments on Dual Stack case

From: KELLIL Mounir <[email-masked]>
Date: Mon, 2 May 2011 17:09:32 +0200

Hi Tina,

I think the problem you are addressing is interesting. It reminds me a work we've done in our team a few months ago (an old draft: http://tools.ietf.org/html/draft-kellil-sam-mtocp-01). We addressed the multicasting problem in a heterogeneous IP network (heterogeneity in terms of multicast support and IP protocol version). We proposed an overlay paradigm to be applied at the transport layer. Overlay nodes are in charge of forwarding traffic, but also translating IPv4 packets into IPv6 packets and vice versa. Maybe this work (and probably others from IRTF's SAMRG group) could be quoted as a "state-of-the-art". Just a suggestion...

Regards

Mounir KELLIL

CEA LIST
web : http://www-list.cea.fr
 
> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la
> part de Tina Tsou
> Envoyé : samedi 30 avril 2011 00:58
> À : [email-masked]
> Cc : 'MBONED WG'; [email-masked]
> Objet : [multrans] Comments on Dual Stack case
> 
> Hi all,
> Just bring some comments on the dual stack case for the new problem
> statement I-D based on
> https://datatracker.ietf.org/doc/draft-jaclee-behave-v4v6-mcast-ps/.
> And I
> also suggest the new problem statement I-D being
> draft-jaclee-multrans-v4v6-mcast-ps, since it is not ONLY behave any
> more.
> 
> I cc [email-masked] and [email-masked] looking for multicast expertise
> to
> help on input to this new problem statement.
> 
> Comments on Dual Stack case are below, inspired by talk with Stig.
> 1. Even in the native dual stack case, you want to save bandwidth, not
> put
> two copy of bandwidth under one source.
> 
> 2. For P2MP case, the receivers are part of IPv4, part of IPv6, this is
> problem.
> 
> 3. For video conference, you have 30 people, 15 are v4, 15 are v6, and
> any
> of them can send their videos (everyone has a webcam and microphone).
> 
> 
> We keep our promises with one another - no matter what!
> 
> Best Regards,
> Tina TSOU
> http://tinatsou.weebly.com/contact.html
> 
> 
> 
> _______________________________________________
> multrans mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multrans

---

From: Tina Tsou <[email-masked]>
Date: Mon, 02 May 2011 11:28:54 -0700

Bonjour Mounir,
Thank you. I read draft-kellil-sam-mtocp-01, it is useful to multrans. Do
you consider dual stack network and/or dual stack source?
How is the status of IRTF's SAMRG group? Is it time to move some of the
research result into IETF now?

We keep our promises with one another – no matter what!

Best Regards,
Tina TSOU

-----Original Message-----
From: KELLIL Mounir [mailto:[email-masked]] 
Sent: Monday, May 02, 2011 8:10 AM
To: Tina Tsou
Cc: MBONED WG; [email-masked]; [email-masked]
Subject: RE: [multrans] Comments on Dual Stack case

Hi Tina,

I think the problem you are addressing is interesting. It reminds me a work
we've done in our team a few months ago (an old draft:
http://tools.ietf.org/html/draft-kellil-sam-mtocp-01). We addressed the
multicasting problem in a heterogeneous IP network (heterogeneity in terms
of multicast support and IP protocol version). We proposed an overlay
paradigm to be applied at the transport layer. Overlay nodes are in charge
of forwarding traffic, but also translating IPv4 packets into IPv6 packets
and vice versa. Maybe this work (and probably others from IRTF's SAMRG
group) could be quoted as a "state-of-the-art". Just a suggestion...

Regards

Mounir KELLIL

CEA LIST

---

From: KELLIL Mounir <[email-masked]>
Date: Tue, 3 May 2011 10:11:37 +0200

Bonjour Tina,

We consider a dual-stack network only. The source could be IPv4 only or IPv6 only, not necessarily both. Regarding SAMRG, they normally intend to push the work (not ours) further to IETF. But, honestly, I am not aware of their current status. 

BTW, I will be happy to follow the discussions on multirans 

Best regards

Mounir

Mounir KELLIL
CEA LIST
e-mail : [email-masked]
web : http://www-list.cea.fr
 
> De : Tina Tsou [mailto:[email-masked]]
> Envoyé : lundi 2 mai 2011 20:29
> À : KELLIL Mounir
> Cc : 'MBONED WG'; [email-masked]; [email-masked]
> Objet : RE: [multrans] Comments on Dual Stack case
> 
> Bonjour Mounir,

---

From: Tina Tsou <[email-masked]>
Date: Tue, 03 May 2011 17:21:51 -0700

Bonjour Mounir,
If you consider a dual-stack network only, that's what we are looking for.

Would you review
https://datatracker.ietf.org/doc/draft-jaclee-behave-v4v6-mcast-ps/, and
send out your comments or proposed text to reflect the issues of a dual
stack network, which is not covered by the current version?

Merci.

Yiu Lee is editing the XML file.

Best Regards,
Tina TSOU

-----Original Message-----
From: KELLIL Mounir [mailto:[email-masked]] 
Sent: Tuesday, May 03, 2011 1:12 AM
To: Tina Tsou
Cc: MBONED WG; [email-masked]; [email-masked]
Subject: RE: [multrans] Comments on Dual Stack case

Bonjour Tina,

We consider a dual-stack network only. The source could be IPv4 only or IPv6
only, not necessarily both. Regarding SAMRG, they normally intend to push
the work (not ours) further to IETF. But, honestly, I am not aware of their
current status. 

Best regards

Mounir

Mounir KELLIL
CEA LIST

---

From: KELLIL Mounir <[email-masked]>
Date: Wed, 4 May 2011 09:56:06 +0200

Bonjour Tina,

Sure I will be happy to review the document

Regards

Mounir KELLIL
CEA LIST
 
> Envoyé : mercredi 4 mai 2011 02:22
> À : KELLIL Mounir
> > Thank you. I read draft-kellil-sam-mtocp-01, it is useful to
> multrans.
> > Do
> > I think the problem you are addressing is interesting. It reminds me
> a
> > work
> > > De : [email-masked] [mailto:[email-masked]]
> De
> > la
> > > part de Tina Tsou
> > > 2. For P2MP case, the receivers are part of IPv4, part of IPv6,
> this
> > is
> > > problem.
> > >

---

From: Tina Tsou <[email-masked]>
Date: Tue, 24 May 2011 15:17:40 -0700

Bonjour Mounir,
Would you send out your comments these two days?
Christian is working on the Problem Statement I-D and plans to post the I-D
at the end of this week.

Best Regards,
Tina TSOU

-----Original Message-----
From: KELLIL Mounir [mailto:[email-masked]] 
Sent: Wednesday, May 04, 2011 12:56 AM
To: Tina Tsou
Cc: MBONED WG; [email-masked]; [email-masked]
Subject: RE: [multrans] Comments on Dual Stack case

Bonjour Tina,

Regards

Mounir KELLIL
CEA LIST

---

From: KELLIL Mounir <[email-masked]>
Date: Wed, 25 May 2011 15:52:28 +0200

Bonjour Tina,

OK no problem, I will do my best

Best regards

Mounir

Mounir KELLIL
CEA LIST
 
> Envoyé : mercredi 25 mai 2011 00:18
> À : KELLIL Mounir
> > We consider a dual-stack network only. The source could be IPv4 only
> or
> > IPv6
> > > multicasting problem in a heterogeneous IP network (heterogeneity
> in
> > > terms
> > > > 1. Even in the native dual stack case, you want to save
> bandwidth,
> > > not
> > > > put
> > > > 3. For video conference, you have 30 people, 15 are v4, 15 are
> v6,
> > > and
> > > > any