Subject: [multrans] Fw: Draft Multrans BoF request

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 14 Sep 2011 13:11:46 -0500

Me again, speaking as an individual again ...

The goal in the draft BOF request is to form a working group. The most recent proposed charter I've seen on the mailing list is this one, from before the (excellent) BOF at IETF 81 (if I'm reading Tina's note correctly, this version was created before the informal meeting at IETF 80).

Is a more recent version available?

Thanks,

Spencer, speaking as an individual

----- Original Message ----- 
From: Tina Tsou 
To: 'Jari Arkko' 
Cc: [email-masked] 
Sent: Tuesday, June 14, 2011 2:03 AM
Subject: Re: [multrans] Draft Multrans BoF request

Jari,

About the proposed charter, here is a copy from the presentation in IPv4-IPv6 multicast meetings in Prague in March.

The task of this Working Group is to devise the means whereby existing

multicast distribution mechanisms can work when signalling and content have

to traverse one or more boundaries where IP version changes.

The Working Group will consider three cases:

-- provider distributed multicast (including IPTV);

-- multicast networks connected directly to a multicast backbone network;

-- multicast networks separated from the backbone network by unicast

.

The Working Group's first task is to create a Problem Statement. This

documents will specify the requirements that must be satisfied by multicast

transition solutions for the three cases listed above. It will describe the

scenarios that need to be considered and the challenges posed by those

scenarios in thos e three em Statement will specify

the new functional capabilities required to enable the solution of the

multicast transition problem in the different scenarios.

The Working Group will follow up with one or more framework documents

analyzing the potential multicast transition solutions for specific

scenarios or groups of scenarios. The circumstances under which the

different solution approaches are applicable will be described, taking

account of the unicast transition mechanisms that may be deployed in a

given network . The fr lude a view of the evolution

path for multicast transition over time, possibly though not necessarily as

a function of the associated unicast transition path. The final outcome of

framework drafts should be recommendations for preferred solution

approaches.

Finally, the Working Group will produce a small set of solution drafts for

the cases considered to be of the highest priority before re-chartering or

disbandment. Specifically, the Working Group will provide one or two

solutions for the provider distrib uted mul icast

source and receiver are IPv4 and there is an intervening IPv6 network. The

solution(s) must be compatible with the unicast translation (NAT64) and

tunneling (DS Lite, Gateway-Initiated DS lite) transition mechanisms. The

solution(s) must discuss the considerations specifically relevant to these

three unicast transition mechanisms to the extent this di scussion 

covered by the framework document. The Working Group will also provide a

solution for the case of multicast networks connected directly to a

multicast backbone network.

Relations: Behave, Softwires, PIM, Mboned, V6ops

Deliverables:

Problem Statement (Informational) Framework for the provider distributed multicast case (Informational)

Framework for the case of multicast networks connected directly to a

multicast backbone network (Informational)

Solutions (2-3) (Proposed Standard) 

We keep our promises with one another - no matter what!

Best Regards,

Tina TSOU

http://tinatsou.weebly.com/contact.html

From: Jari Arkko [mailto:[email-masked]] 
Sent: Monday, June 13, 2011 11:09 AM
To: Tina Tsou
Cc: Lee, Yiu; 'Tom Taylor'; [email-masked]; [email-masked]
Subject: Re: [multrans] Draft Multrans BoF request

Tina, others,

I'm trying to construct a wiki entry for this BOF so that the IESG and IAB have all the information available to them to make decisions on what BOFs to approve on Thursday. What other drafts than the ps I should list? Is there a pointer to a mailing list post or some web site for the proposed charter? Also, for my background: are there providers who are asking for multicast transition solutions? I.e., not just deploying multicast separately for the two IP versions?

Here's what we have so far:

MULTRANS - Multicast Transition 

Description
Jari

--------------------------------------------------------------------------------

_______________________________________________
multrans mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/multrans

---

From: Tina TSOU <[email-masked]>
Date: Thu, 15 Sep 2011 07:27:16 +0000

Hi Spencer et al,
Thank you for your question.
I'm taking the next step based on feedback received at the IETF 81 BoF. Here is the revised proposed charter.
----------------
The task of the MULTRANS Working Group is to devise the means whereby existing multicast
mechanisms can operate successfully when signalling and content have to traverse one or more IPv4/IPv6 boundaries.

Goals

1. The Working Group's first task is to develop a problem statement that identifies the scope of the problem of multicast operation during the transition from IPv4 to IPv6. The problem
statement will identify:
     -- requirements that must be satisfied by the mechanisms
        for multicast transition;
     -- use cases that must be considered, ranked by priority; it targets IPTV ("the use case of greatest interest to the IETF 81 BoF participants"), with possible rechartering for other use cases later.
     -- design considerations that should be taken into account in subsequent work.

2. The Multrans Working Group will develop Standards Track documents specifying protocol
interworking for the new combinations of protocols (for example, between PIM (IPv4) and PIM (IPv6)) required for multicast transition from IPv4 to IPv6.

3. The Multrans Working Group will specify the means whereby multicast addresses may be
translated between IPv4 and IPv6, in both stateful and stateless fashion, in direct analogy to
RFC 6052 for unicast addresses.

4. The Multrans Working Group will specify extensions to DHCPv4 and DHCPv6 required to configure hosts during the transitional period.

5. The Multrans Working Group will specify the operational and management capabilities required to support multicast transition. In particular, this work may involve the specification of MIBs.

If the working group identifies any requirements for extensions to the multicast protocols themselves, the requirements would be sent to the working groups responsible for those protocols for consideration. Or have documents in multrans that extend multicast protocols, ask the corresponding working group for review.

Milestones

May 2012  WG adopts
- problem statement draft
- interworking drafts
- DHCP new options drafts
- MIB draft

Sep 2012 Submit to IESG
- problem statement draft
- interworking drafts
- DHCP new options drafts
- MIB draft
------------------

Best Regards,
Tina TSOU

From: [email-masked] [mailto:[email-masked]] On Behalf Of Spencer Dawkins
Sent: Wednesday, September 14, 2011 11:12 AM
To: [email-masked]
Subject: [multrans] Fw: Draft Multrans BoF request

Thanks,

----- Original Message -----
From: Tina Tsou<mailto:[email-masked]>
To: 'Jari Arkko'<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Sent: Tuesday, June 14, 2011 2:03 AM
Subject: Re: [multrans] Draft Multrans BoF request

Jari,

Deliverables:

Best Regards,
Tina TSOU

MULTRANS - Multicast Transition
Description
Jari
________________________________
_______________________________________________
multrans mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/multrans