From owner-nat@livingston.com  Thu Oct 12 11:48:41 2000
Received: from bast.livingston.com (bast.livingston.com [149.198.247.2])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id LAA00481
	for <nat-archive@odin.ietf.org>; Thu, 12 Oct 2000 11:48:40 -0400 (EDT)
Received: from server.livingston.com (server.livingston.com [149.198.1.70])
	by bast.livingston.com (8.11.0/8.11.0) with ESMTP id e9CFjg229806;
	Thu, 12 Oct 2000 08:45:42 -0700 (PDT)
Received: (from majordom@localhost)
	by server.livingston.com (8.9.3/8.9.3/1.0) id IAA13965
	for nat-outgoing; Thu, 12 Oct 2000 08:33:58 -0700 (PDT)
X-Authentication-Warning: server.livingston.com: majordom set sender to owner-nat@livingston.com using -f
Message-Id: <200010111854.LAA22828@boreas.isi.edu>
To: IETF-Announce: ;
Subject: (NAT) RFC 2962 SNMP Payload Address Translation
Cc: rfc-ed@isi.edu, nat@livingston.com
Mime-Version: 1.0
Content-Type: Multipart/Mixed; Boundary=NextPart
Date: Wed, 11 Oct 2000 11:54:27 -0700
From: RFC Editor <rfc-ed@isi.edu>
Sender: owner-nat@livingston.com
Precedence: bulk
Reply-To: RFC Editor <rfc-ed@isi.edu>


--NextPart


A new Request for Comments is now available in online RFC libraries.


        RFC 2962

        Title:	    An SNMP Application Level Gateway for Payload
                    Address Translation
        Author(s):  D. Raz, J. Schoenwaelder, B. Sugla
        Status:     Informational
	Date:       October 2000
        Mailbox:    raz@lucent.com, schoenw@ibr.cs.tu-bs.de,
                    sugla@ispsoft.com 
        Pages:      20
        Characters: 46803
        Updates/Obsoletes/SeeAlso:    none

        I-D Tag:    draft-ietf-nat-snmp-alg-05.txt

        URL:        ftp://ftp.isi.edu/in-notes/rfc2962.txt


This document describes the ALG (Application Level Gateway) for the
SNMP (Simple Network Management Protocol) by which IP (Internet
Protocol) addresses in the payload of SNMP packets are statically
mapped from one group to another.  The SNMP ALG is a specific case of
an Application Level Gateway as described in RFC 2663.
 
An SNMP ALG allows network management stations to manage multiple
networks that use conflicting IP addresses.  This can be important in
environments where there is a need to use SNMP with NAT (Network
Address Translator) in order to manage several potentially overlapping
addressing realms.
 
This document includes a detailed description of the requirements
and limitations for an implementation of an SNMP Application Level
Gateway.  It also discusses other approaches to exchange SNMP packets
across conflicting addressing realms.

This document is a product of the Network Address Translators Working
Group of the IETF.

This memo provides information for the Internet community.  It does
not specify an Internet standard of any kind.  Distribution of this
memo is unlimited.

This announcement is sent to the IETF list and the RFC-DIST list.
Requests to be added to or deleted from the IETF distribution list
should be sent to IETF-REQUEST@IETF.ORG.  Requests to be
added to or deleted from the RFC-DIST distribution list should
be sent to RFC-DIST-REQUEST@RFC-EDITOR.ORG.

Details on obtaining RFCs via FTP or EMAIL may be obtained by sending
an EMAIL message to rfc-info@RFC-EDITOR.ORG with the message body 
help: ways_to_get_rfcs.  For example:

        To: rfc-info@RFC-EDITOR.ORG
        Subject: getting rfcs

        help: ways_to_get_rfcs

Requests for special distribution should be addressed to either the
author of the RFC in question, or to RFC-Manager@RFC-EDITOR.ORG.  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.echo 
Submissions for Requests for Comments should be sent to
RFC-EDITOR@RFC-EDITOR.ORG.  Please consult RFC 2223, Instructions to RFC
Authors, for further information.


Joyce K. Reynolds and Sandy Ginoza
USC/Information Sciences Institute

...

Below is the data which will enable a MIME compliant Mail Reader 
implementation to automatically retrieve the ASCII version
of the RFCs.

--NextPart
Content-Type: Multipart/Alternative; Boundary="OtherAccess"

--OtherAccess
Content-Type:  Message/External-body;
        access-type="mail-server";
        server="RFC-INFO@RFC-EDITOR.ORG"

Content-Type: text/plain
Content-ID: <001011115118.RFC@RFC-EDITOR.ORG>

RETRIEVE: rfc
DOC-ID: rfc2962

--OtherAccess
Content-Type:   Message/External-body;
        name="rfc2962.txt";
        site="ftp.isi.edu";
        access-type="anon-ftp";
        directory="in-notes"

Content-Type: text/plain
Content-ID: <001011115118.RFC@RFC-EDITOR.ORG>

--OtherAccess--
--NextPart--
-
To unsubscribe, email 'majordomo@livingston.com' with
'unsubscribe nat' in the body of the message.


From owner-nat@linux2.advmed.com  Thu Oct 26 05:39:05 2000
Received: from linux2.advmed.com (root@[207.235.58.7])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id FAA28963
	for <nat-archive@odin.ietf.org>; Thu, 26 Oct 2000 05:39:04 -0400 (EDT)
Received: (from majordomo@localhost)
	by linux2.advmed.com (8.11.1/8.11.1) id e9Q967Y19587
	for nat-outgoing; Thu, 26 Oct 2000 04:06:07 -0500
X-Authentication-Warning: linux2.advmed.com: majordomo set sender to owner-nat@portmasters.com using -f
Message-ID: <CD4DE0181670D211AC5400A0C94BD1B8D80FFC@dksmsx30.idk.intel.com>
From: "Egevang, Kjeld" <kjeld.egevang@intel.com>
To: "'Darren Reed'" <darrenr@reed.wattle.id.au>, paul@francis.com
Cc: nat@livingston.com
Subject: RE: (NAT) headaches with NAT and patents.
Date: Thu, 26 Oct 2000 02:26:20 -0700
MIME-Version: 1.0
X-Mailer: Internet Mail Service (5.5.2650.21)
Content-Type: text/plain;
	charset="iso-8859-1"
Sender: owner-nat@portmasters.com
Precedence: bulk
Reply-To: "Egevang, Kjeld" <kjeld.egevang@intel.com>

Hi there.

Perhaps you could be interested in a paper by Van Jacobson about NAT, dated
January 1992!

You can find it at http://kbe.freeyellow.com/nat_van_jacobson.ps

Cheers,

Kjeld.

-----Original Message-----
From: Darren Reed [mailto:darrenr@reed.wattle.id.au]
Sent: 21. september 2000 20:58
To: paul@francis.com
Cc: nat@livingston.com
Subject: Re: (NAT) headaches with NAT and patents.


In some email I received from Paul Francis, sie wrote:
[Charset iso-8859-1 unsupported, filtering to ASCII...]
> 
> > In recent days, someone has made me aware of a patent by Cisco on NAT,
> > #5793763.  Someone pointed me to a NATwg web page which referenced IBM
> > and mentioned they had a patent which was filed before Cisco's.  On top
> > of this, I've had someone contact me and mention that they did a NAT
> > implementation in a time frame which would pre-date the filing dates
> > of both patents.  Is this something which is worth following up with
> 
> What are the filing dates?  (for that matter, do you have a pointer to the
> patent?)

The IBM patent is December 1994 - the URL for this group is
http://www.ietf.org/ietf/IPR/NAT-VRRP-IBM

The Cisco patent was filed November 1995 - number 5793763.

> I gave the first public talk of NAT at the Vancouver IETF (summer 1990),
and
> published it in sigcomm CCR around '91-'92.  That publication talked about
> various things including dns tricks, but unfortunately I don't think it
> included port translation.

Do you have pointers to these papers, online, as URLs ?

Darren
-
To unsubscribe, email 'majordomo@livingston.com' with
'unsubscribe nat' in the body of the message.

-
To unsubscribe, email 'majordomo@portmasters.com' with
'unsubscribe nat' in the body of the message.


From owner-nat@linux2.advmed.com  Sat Oct 28 21:56:02 2000
Received: from linux2.advmed.com (root@[207.235.58.7])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id VAA06452
	for <nat-archive@odin.ietf.org>; Sat, 28 Oct 2000 21:56:01 -0400 (EDT)
Received: (from majordomo@localhost)
	by linux2.advmed.com (8.11.1/8.11.1) id e9T18cd24646
	for nat-outgoing; Sat, 28 Oct 2000 20:08:38 -0500
X-Authentication-Warning: linux2.advmed.com: majordomo set sender to owner-nat@portmasters.com using -f
Date: Sat, 28 Oct 2000 20:08:35 -0500 (CDT)
From: Jake Messinger <jake@portmasters.com>
X-Sender: jake@linux2.advmed.com
To: nat@portmasters.com
Subject: (NAT) test
Message-ID: <Pine.LNX.4.20.0010282008280.24203-100000@linux2.advmed.com>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII
Sender: owner-nat@portmasters.com
Precedence: bulk
Reply-To: Jake Messinger <jake@portmasters.com>

test

-- 
~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~
Jake Messinger, VP.	ph:713-772-6690		Visit:	portmasters.com
AMS, Inc.		fx:713-774-3498 		advmed.com
8300 Bissonnet  #400	jake@jakes.org			disc.cba.uh.edu
Houston, Texas  77074	http://jakes.org		ICQ# 4403734  		

Adjunct Professor	University of Houston, CBA	jake@uh.edu
~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~

		INVENTOR OF the _.,-*~''~*-,._ SQUIGGLES (c) 1978

-
To unsubscribe, email 'majordomo@portmasters.com' with
'unsubscribe nat' in the body of the message.


From owner-nat@linux2.advmed.com  Sat Oct 28 22:28:30 2000
Received: from linux2.advmed.com (root@[207.235.58.7])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id VAA06453
	for <nat-archive@odin.ietf.org>; Sat, 28 Oct 2000 21:56:01 -0400 (EDT)
Received: (from majordomo@localhost)
	by linux2.advmed.com (8.11.1/8.11.1) id e9T1AfT24711
	for nat-outgoing; Sat, 28 Oct 2000 20:10:41 -0500
X-Authentication-Warning: linux2.advmed.com: majordomo set sender to owner-nat@portmasters.com using -f
Date: Sat, 28 Oct 2000 20:10:39 -0500 (CDT)
From: Jake Messinger <jake@portmasters.com>
X-Sender: jake@linux2.advmed.com
To: nat@portmasters.com
Subject: (NAT) test
Message-ID: <Pine.LNX.4.20.0010282010360.24704-100000@linux2.advmed.com>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII
Sender: owner-nat@portmasters.com
Precedence: bulk
Reply-To: Jake Messinger <jake@portmasters.com>

test

-- 
~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~
Jake Messinger, VP.	ph:713-772-6690		Visit:	portmasters.com
AMS, Inc.		fx:713-774-3498 		advmed.com
8300 Bissonnet  #400	jake@jakes.org			disc.cba.uh.edu
Houston, Texas  77074	http://jakes.org		ICQ# 4403734  		

Adjunct Professor	University of Houston, CBA	jake@uh.edu
~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~

		INVENTOR OF the _.,-*~''~*-,._ SQUIGGLES (c) 1978

-
To unsubscribe, email 'majordomo@portmasters.com' with
'unsubscribe nat' in the body of the message.


