
From sethomso@cisco.com  Fri May  8 13:54:46 2009
Return-Path: <sethomso@cisco.com>
X-Original-To: nea@core3.amsl.com
Delivered-To: nea@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 41B943A6AE9 for <nea@core3.amsl.com>; Fri,  8 May 2009 13:54:46 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.599
X-Spam-Level: 
X-Spam-Status: No, score=-6.599 tagged_above=-999 required=5 tests=[AWL=0.000,  BAYES_00=-2.599, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id fTSl30LwxwDi for <nea@core3.amsl.com>; Fri,  8 May 2009 13:54:44 -0700 (PDT)
Received: from sj-iport-1.cisco.com (sj-iport-1.cisco.com [171.71.176.70]) by core3.amsl.com (Postfix) with ESMTP id 7E2523A6B36 for <nea@ietf.org>; Fri,  8 May 2009 13:54:44 -0700 (PDT)
X-IronPort-AV: E=Sophos;i="4.40,319,1238976000"; d="scan'208";a="183037677"
Received: from sj-dkim-1.cisco.com ([171.71.179.21]) by sj-iport-1.cisco.com with ESMTP; 08 May 2009 20:56:13 +0000
Received: from sj-core-1.cisco.com (sj-core-1.cisco.com [171.71.177.237]) by sj-dkim-1.cisco.com (8.12.11/8.12.11) with ESMTP id n48KuD5S022389 for <nea@ietf.org>; Fri, 8 May 2009 13:56:13 -0700
Received: from xbh-rtp-211.amer.cisco.com (xbh-rtp-211.cisco.com [64.102.31.102]) by sj-core-1.cisco.com (8.13.8/8.13.8) with ESMTP id n48KuD71029186 for <nea@ietf.org>; Fri, 8 May 2009 20:56:13 GMT
Received: from xmb-rtp-205.amer.cisco.com ([64.102.31.59]) by xbh-rtp-211.amer.cisco.com with Microsoft SMTPSVC(6.0.3790.1830);  Fri, 8 May 2009 16:56:13 -0400
X-MimeOLE: Produced By Microsoft Exchange V6.5
Content-class: urn:content-classes:message
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
Date: Fri, 8 May 2009 16:56:12 -0400
Message-ID: <E699396B05B527429E4D9B8533679C4906FB3A9F@xmb-rtp-205.amer.cisco.com>
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
Thread-Topic: Submitting PA-TNC and PB-TNC I-Ds to IESG
Thread-Index: AcnQH2tmQcqHVX0dRO69667Jz2TK8g==
From: "Susan Thomson (sethomso)" <sethomso@cisco.com>
To: <nea@ietf.org>
X-OriginalArrivalTime: 08 May 2009 20:56:13.0189 (UTC) FILETIME=[6C096B50:01C9D01F]
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; l=14294; t=1241816173; x=1242680173; c=relaxed/simple; s=sjdkim1004; h=Content-Type:From:Subject:Content-Transfer-Encoding:MIME-Version; d=cisco.com; i=sethomso@cisco.com; z=From:=20=22Susan=20Thomson=20(sethomso)=22=20<sethomso@cis co.com> |Subject:=20Submitting=20PA-TNC=20and=20PB-TNC=20I-Ds=20to= 20IESG |Sender:=20; bh=L1ufJa9lJy2XStsJrrZFw11f8J+9buYFlPE5Z6uy8aA=; b=qzvl76y4QDf+rQ3o2aAJrlFIX/rOv/5ZnUTNXIC7hevOGLUthnwB4AuC3a QNlVUEgRPwR3Ontv735s5VAnDfBlq8ATnnAQhholc05Z3TdpPg1tiSTDP1aQ AW+wHQQgRtjOKqoTS9kNJ+9badIoZsY/GSWbQ4p4t93Xn1ef3xU9U=;
Authentication-Results: sj-dkim-1; header.From=sethomso@cisco.com; dkim=pass ( sig from cisco.com/sjdkim1004 verified; ); 
Subject: [Nea] Submitting PA-TNC and PB-TNC I-Ds to IESG
X-BeenThere: nea@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Network Endpoint Assessment discussion list <nea.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/nea>, <mailto:nea-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/nea>
List-Post: <mailto:nea@ietf.org>
List-Help: <mailto:nea-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/nea>, <mailto:nea-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 08 May 2009 20:54:46 -0000

Now that we have completed WG Last Call and have consensus on the
documents:

draft-ietf-nea-pa-tnc-04.txt
draft-ietf-nea-pb-tnc-04.txt,=20

the next step is to submit the documents to the IESG.=20

Per RFC 4858, I am the document shepherd for both drafts. The next step
is AD evaluation and IETF Last Call. I will be working with our AD, Tim
Polk, to facilitate this process. Attached are the document write-ups
required by this process. I will keep the WG apprised of progress. The
document status can also be seen in
https://datatracker.ietf.org/idtracker/

Thanks
Susan

-----------------
Doc shepherd write-up for: draft-ietf-nea-pb-tnc-04.txt


 (1.a) Who is the Document Shepherd for this document? Has the=20
       Document Shepherd personally reviewed this version of the=20
       document and, in particular, does he or she believe this=20
       version is ready for forwarding to the IESG for publication?=20

Susan Thomson (sethomso@cisco.com) is document shepherd.
I have reviewed this document and believe this version is ready for
forwarding to the IESG.

(1.b) Has the document had adequate review both from key WG members=20
      and from key non-WG members? Does the Document Shepherd have=20
      any concerns about the depth or breadth of the reviews that=20
      have been performed?=20

The document has had adequate review.

(1.c) Does the Document Shepherd have concerns that the document=20
      needs more review from a particular or broader perspective,=20
      e.g., security, operational complexity, someone familiar with=20
      AAA, internationalization or XML?=20

No concerns.

(1.d) Does the Document Shepherd have any specific concerns or=20
      issues with this document that the Responsible Area Director=20
      and/or the IESG should be aware of? For example, perhaps he=20
      or she is uncomfortable with certain parts of the document, or=20
      has concerns whether there really is a need for it. In any=20
      event, if the WG has discussed those issues and has indicated=20
      that it still wishes to advance the document, detail those=20
      concerns here. Has an IPR disclosure related to this document=20
      been filed? If so, please include a reference to the=20
      disclosure and summarize the WG discussion and conclusion on=20
      this issue.=20

No concerns or IPR disclosures related to this document. Please see WG
Summary below for additional information.


(1.e) How solid is the WG consensus behind this document? Does it=20
      represent the strong concurrence of a few individuals, with=20
      others being silent, or does the WG as a whole understand and=20
      agree with it?=20

WG consensus is solid for this document. Please see WG Summary below=20
for additional information.

(1.f) Has anyone threatened an appeal or otherwise indicated extreme=20
      discontent? If so, please summarise the areas of conflict in=20
      separate email messages to the Responsible Area Director. (It=20
      should be in a separate email because this questionnaire is=20
      entered into the ID Tracker.)=20

No.

(1.g) Has the Document Shepherd personally verified that the=20
      document satisfies all ID nits? (See=20
      http://www.ietf.org/ID-Checklist.html and=20
      http://tools.ietf.org/tools/idnits/). Boilerplate checks are=20
      not enough; this check needs to be thorough. Has the document=20
      met all formal review criteria it needs to, such as the MIB=20
      Doctor, media type and URI type reviews?

Yes.=20

(1.h) Has the document split its references into normative and=20
      informative? Are there normative references to documents that=20
      are not ready for advancement or are otherwise in an unclear=20
      state? If such normative references exist, what is the=20
      strategy for their completion? Are there normative references=20
      that are downward references, as described in [RFC3967]? If=20
      so, list these downward references to support the Area=20
      Director in the Last Call procedure for them [RFC3967].=20

The document has split its references into normative and=20
informative. There are no downward references or references to=20
documents that are in an unclear state.

(1.i) Has the Document Shepherd verified that the document IANA=20
      consideration section exists and is consistent with the body=20
      of the document? If the document specifies protocol=20
      extensions, are reservations requested in appropriate IANA=20
      registries? Are the IANA registries clearly identified? If=20
      the document creates a new registry, does it define the=20
      proposed initial contents of the registry and an allocation=20
      procedure for future registrations? Does it suggest a=20
      reasonable name for the new registry? See [RFC5226]. If the=20
      document describes an Expert Review process has Shepherd=20
      conferred with the Responsible Area Director so that the IESG=20
      can appoint the needed Expert during the IESG Evaluation?=20

Yes.

(1.j) Has the Document Shepherd verified that sections of the=20
      document that are written in a formal language, such as XML=20
      code, BNF rules, MIB definitions, etc., validate correctly in=20
      an automated checker?=20

No formal language is used.

(1.k) The IESG approval announcement includes a Document=20
      Announcement Write-Up. Please provide such a Document=20
      Announcement Write-Up? Recent examples can be found in the
      "Action" announcements for approved documents. The approval=20
      announcement contains the following sections:=20

Technical Summary=20

This document defines the PB-TNC protocol. PB-TNC is a Posture=20
Broker protocol that aggregates posture attributes between one or=20
more Posture Collectors on a NEA client and one or more Posture=20
Validators on a NEA server. PB-TNC is equivalent to the=20
Trusted Computing Group's IF-TNCCS 2.0 protocol. It addresses the PB=20
protocol requirements defined in the NEA requirements specification.

Working Group Summary=20

The WG solicited proposals for the PB protocol based on the=20
NEA reference model and requirements specified in RFC 5209. The TCG=20
submitted a specification to the NEA WG in response to the call for=20
proposals. There was broad support in the WG to adopt the submission as=20
a WG document. Subsequent WG updates to the document have not been=20
contentious.

The protocol document specifies a base protocol and is extensible.=20
The WG has discussed the potential for certain optimizations and=20
extensions to the above specifications (e.g. assertion attributes). The=20
proposed extensions did not share the same level of consensus as the=20
base document and also represented significant additional work. The WG=20
decided to defer potential extensions to supplemental documents in the=20
interests of making progress on the base documents.

Document Quality =20

Several vendors have indicated their intention in public or private to=20
implement the specification.

Personnel

Susan Thomson is the document shepherd. Tim Polk is the responsible=20
Area Director. The IANA Expert(s) for the registries in this document=20
<ARE TO BE ADDED BY THE AD>.

------------------
Doc shepherd write-up for: draft-ietf-nea-pa-tnc-04.txt


 (1.a) Who is the Document Shepherd for this document? Has the=20
       Document Shepherd personally reviewed this version of the=20
       document and, in particular, does he or she believe this=20
       version is ready for forwarding to the IESG for publication?=20

Susan Thomson (sethomso@cisco.com) is document shepherd.
I have reviewed this document and believe this version is ready for=20
forwarding to the IESG.

(1.b) Has the document had adequate review both from key WG members=20
      and from key non-WG members? Does the Document Shepherd have=20
      any concerns about the depth or breadth of the reviews that=20
      have been performed?=20

The document has had adequate review.

(1.c) Does the Document Shepherd have concerns that the document=20
      needs more review from a particular or broader perspective,=20
      e.g., security, operational complexity, someone familiar with=20
      AAA, internationalization or XML?=20

No concerns.

(1.d) Does the Document Shepherd have any specific concerns or=20
      issues with this document that the Responsible Area Director=20
      and/or the IESG should be aware of? For example, perhaps he=20
      or she is uncomfortable with certain parts of the document, or=20
      has concerns whether there really is a need for it. In any=20
      event, if the WG has discussed those issues and has indicated=20
      that it still wishes to advance the document, detail those=20
      concerns here. Has an IPR disclosure related to this document=20
      been filed? If so, please include a reference to the=20
      disclosure and summarize the WG discussion and conclusion on=20
      this issue.=20

No concerns or IPR disclosures related to this document. Please see WG=20
Summary below for additional information.


(1.e) How solid is the WG consensus behind this document? Does it=20
      represent the strong concurrence of a few individuals, with=20
      others being silent, or does the WG as a whole understand and=20
      agree with it?=20

WG consensus is solid for this document. Please see WG Summary below=20
for additional information.


(1.f) Has anyone threatened an appeal or otherwise indicated extreme=20
      discontent? If so, please summarise the areas of conflict in=20
      separate email messages to the Responsible Area Director. (It=20
      should be in a separate email because this questionnaire is=20
      entered into the ID Tracker.)=20

No.

(1.g) Has the Document Shepherd personally verified that the=20
      document satisfies all ID nits? (See=20
      http://www.ietf.org/ID-Checklist.html and=20
      http://tools.ietf.org/tools/idnits/). Boilerplate checks are=20
      not enough; this check needs to be thorough. Has the document=20
      met all formal review criteria it needs to, such as the MIB=20
      Doctor, media type and URI type reviews?

Yes.=20

(1.h) Has the document split its references into normative and=20
      informative? Are there normative references to documents that=20
      are not ready for advancement or are otherwise in an unclear=20
      state? If such normative references exist, what is the=20
      strategy for their completion? Are there normative references=20
      that are downward references, as described in [RFC3967]? If=20
      so, list these downward references to support the Area=20
      Director in the Last Call procedure for them [RFC3967].=20

The document has split its references into normative and=20
informative. There are no downward references or references to=20
documents that are in an unclear state.

(1.i) Has the Document Shepherd verified that the document IANA=20
      consideration section exists and is consistent with the body=20
      of the document? If the document specifies protocol=20
      extensions, are reservations requested in appropriate IANA=20
      registries? Are the IANA registries clearly identified? If=20
      the document creates a new registry, does it define the=20
      proposed initial contents of the registry and an allocation=20
      procedure for future registrations? Does it suggest a=20
      reasonable name for the new registry? See [RFC5226]. If the=20
      document describes an Expert Review process has Shepherd=20
      conferred with the Responsible Area Director so that the IESG=20
      can appoint the needed Expert during the IESG Evaluation?=20

Yes.

(1.j) Has the Document Shepherd verified that sections of the=20
      document that are written in a formal language, such as XML=20
      code, BNF rules, MIB definitions, etc., validate correctly in=20
      an automated checker?=20

No formal language is used.

(1.k) The IESG approval announcement includes a Document=20
      Announcement Write-Up. Please provide such a Document=20
      Announcement Write-Up? Recent examples can be found in the
      "Action" announcements for approved documents. The approval=20
      announcement contains the following sections:=20

Technical Summary=20

This document defines the PA-TNC protocol. PA-TNC is a Posture=20
Attribute protocol that carries posture attributes between a=20
Posture Collector on a NEA client and a Posture Validator on a NEA=20
server. The PA-TNC protocol is designed to run over the PB-TNC=20
protocol. PA-TNC is equivalent to the Trusted Computing=20
Group's IF-M 1.0 protocol. It addresses the PA protocol requirements=20
defined in the NEA requirements specification.

Working Group Summary=20

The WG solicited proposals for the PA protocol based on the=20
NEA reference model and requirements specified in RFC 5209. The TCG=20
submitted a specification to the NEA WG in response to the call for=20
proposals. There was broad support in the WG to adopt the submission as=20
a WG document. Subsequent WG updates to the document have not been=20
contentious.

The protocol document specifies a base protocol and is extensible.=20
The WG has discussed the potential for certain optimizations and=20
extensions to the above specifications (e.g. additional standard=20
posture attributes). The proposed extensions did not share the same=20
level of consensus as the base document and represented significant=20
additional work. The WG decided to defer potential extensions to=20
supplemental documents in the interests of making progress on the base=20
documents.

Document Quality =20

Several vendors have indicated their intention in public or private to=20
implement the specification.

Personnel

Susan Thomson is the document shepherd. Tim Polk is the responsible=20
Area Director. The IANA Expert(s) for the registries in this document=20
<ARE TO BE ADDED BY THE AD>.
