Subject: RE: [nemo] Multiple Egress vs multihoming

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 29 Apr 2003 08:09:44 +0100

Cool!

It reminds me of your draft on network registration. Good ideas and a
lot of work ahead :)

Question: if we use your other draft, could the MR just have several IP
addresses on its mobile network, and use that as ID? Does not seem to me
we are short of these!

To be honest, I believe that if we have to include multihoming in the
picture for basic, you approach seems to be the most straightforward,
leading to the simplest solution. At the expense of the support of home
network, which pains me some, but I could accept it considering the
rewards.

If we do that, we are back to the case with several routes to a same
network. 

Also, the various MR addresses may be owned by the same MR or by
different MRs. So what?

If you associate a distance to the advertisement, the HA can use that to
select the best CareOf. 

As I said, it's yet an other (simple) routing protocol, and we need to
understand how these routes are injected to the routing table of the HA,
and then redistributed to the others (you need a metric that can be
configured on the HA for instance). I would not use the Routing protocol
of the AS of the HAs to do that, because I'd contain it inside a HA
multicast group, even if that group spans outside of the AS (JetSet).

You may recognize my initial comments on your other draft here :)

Anyway, I believe that this protocol between HA is really a key for both
your drafts to turn into a solution.

Pascal
> -----Original Message-----
> From: Ryuji Wakikawa [mailto:[email-masked]] 
> Sent: mardi 29 avril 2003 00:49
> To: [email-masked]
> Cc: Pascal Thubert (pthubert); [email-masked]
> Subject: Re: [nemo] Multiple Egress vs multihoming
> 
> 
> 
> Hi Pascal, and thanks watari.
> 
> Let me summarize the draft briefly. 
> We propose how to register multiple CoAs with single HoA.
> It is very simple, we assign new ID number to each interfaces 
> on MN. MN always registers bindings with the ID.
> 
> For example,
>  - IF1 has CoA1 and ID1.
>  - IF2 has CoA2 and ID2.
> 
>  single HoA
>   +- MN-+
>   |     | 
>  IF1   IF2
> 
> MN sends BUx with HoA, CoAx and IDx.  HA will have multiple 
> bindings of MN which are association of HoA and either CoA1 
> or CoA2. Then, HA searches BC with ID and HoA. Managements of 
> each binding are done with correspondent ID respectively.
> 
> This ID is not only used for multiple binding managements but 
> also it could be used to associate some policies to a 
> binding. For example, if MN want to receive TCP packets by 
> IF1, it could send a policy
> (TCP->ID1) somehow (by MIP or by applications) to HA. Before 
> HA can search BC with ID and HoA, it can decide which binding 
> is used for outgoing packets by the policy.
> 
> Policy parts are not discussed in the draft, yet.
> 
> regards,
> ryuji
> 
> At Mon, 28 Apr 2003 17:37:04 +0900 (JST),
> Masafumi Watari wrote:
> > 
> > Hello,
> > 
> > You can find the draft in the URL below.
> > 
> > 
> http://www.ietf.org/internet-drafts/draft->
wakikawa-mobileip-multipleco
> > a-00.txt
> > 
> > regards,
> > watari
> > 
> > On Mon, 28 Apr 2003 07:53:04 +0100,
> > "Pascal Thubert (pthubert)" <[email-masked]> wrote:
> > 
> > > Hi Ryuji:
> > > 
> > > I was not aware of your draft, nor could I find it in th 
> eitf site 
> > > or on google. Is that something you just submitted?
> > > 
> > > Pascal
> > > 
> > > > -----Original Message-----
> > > > From: Ryuji Wakikawa [mailto:[email-masked]]
> > > > Sent: samedi 26 avril 2003 03:03
> > > > To: Hesham Soliman (EAB)
> > > > Cc: Pascal Thubert (pthubert); Chan-Wah Ng; IETF NEMO
> > > > Subject: Re: [nemo] Multiple Egress vs multihoming
> > > > 
> > > > 
> > > > Hi Hesham
> > > > 
> > > > > => I'm interested to know how multiple care-ofs could work in 
> > > > > MIP. We did that for FMIP some time ago but it was based on 
> > > > > bi-casting for a short period (1 second). I will 
> comment on the 
> > > > > rest of the email separately.
> > > > 
> > > > There are some researches for multiple CoA on MIP.
> > > > draft-montavont-mobileip-mmi-00.txt and 
> > > > draft-wakikawa-multiplecoa-00.txt
> > > > 
> > > > regards,
> > > > ryuji
> > > > 
> > > 
> > > 
>

---

From: Ryuji Wakikawa<[email-masked]>
Date: Wed, 30 Apr 2003 07:10:13 +0900

Hi Pascal

At Tue, 29 Apr 2003 08:09:44 +0100,
> Cool!

Thanks!

> addresses on its mobile network, and use that as ID? Does not seem to me

Yes, it can. BUT we need some changes due to 1 byte ID field.
Easy solution for this is that MR calculates ID from MR-A.
However, as you noted, it is possible to use MR-A as ID.

If MR has two egress interfaces, then MR assigns two MR-A for each
egress interfaces and uses MR-A as ID of egress interface.  Since MR-A
is stored in BU and also in binding cache, "ID field" in
draft-multiplecoa is no longer needed for MR.  It indicates no
extensions is needed to the current draft-wakikawa-nemo-basic.

> network, which pains me some, but I could accept it considering the

Our approach does not have "returning home", but I want to emphasize
that our solution still have the optimization in terms of
no-tunneling at home network.

I try to summarize the differences between TJ/PSBU and mine when MR
returns to home domain. 

If I miss something or misunderstand here, please correct me.

TJ/PSBU
     Advantages
	1. No tunneling 
	2. No binding management except for de-registration
	3. Dynamic Routing (i.e. neighbour routers at home network learn a route of MR)
     Weak points
	1. De-registration procedure is high cost and complicated.
	2. Need to co-operate with IGP routing protocol to tell MR's route to neighbour routers.

WAKIKAWA
     Advantages
	1. No tunneling
	2. No de-registration procedure 
	3. Not requirement to run IGP routing protocol at any time.
     Weak points
	1. Binding Management even at home network
	2. Static Routing (all packets are routed via HA)

For better revision of my draft, I want to know whether management of
binding instead of de-registration operations is real problem or not
at home network. I want to know what a kind of advantages should a
NEMO solution support?

> Also, the various MR addresses may be owned by the same MR or by

MR can own several MR addresses. IPv6 allows to assign various
addresses to a same node/interface.

> If you associate a distance to the advertisement, the HA can use that to

Yes.

> your drafts to turn into a solution.

Yes, I see your point of your earlier mail with better understanding now.

I will consider all possible cases such as Tarzan, JetSet, Shinkansen,
and doubleBed. I will update draft-wakikawa-basic-nemo before next IETF. 

# BTW, Shinkansen is name of express train in Japan. I don't know how
# many people recognize what is Shinkansen :-p

regards,
ryuji