Subject: RE: [nemo] Multiple Egress vs multihoming

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 24 Apr 2003 13:15:45 +0100

Hi Hesham and Chan-Wah

OK, it's time to start the taxonomy :)

In the context of multihoming, When we talk about 'mobile networks', I'd
rather consider mobile prefixes, because it's what the MRs carry with
them. A MR may actually use the services of a fixed access point though
it's a bit weird to me. It may happen that over the wireless, two
prefixes, carried by 2 different routers, share the same media for a
period of time, and then, possibly split. I understand that this is the
case you're talking about? While my case was when 2 MRs own the same
prefix and move together like in a train case. Talking prefixes allows
to make that distinction.

Also, when we talk about multiple egress, we may rather consider
multiple access routers. Whether the ARs are on a same egress link or on
different interfaces is IMHO to be supported implicitely (R13.2). What's
impacting the protocol is rather if you want to build more than one
CareOf. And if you let the HA(s) know about that, which would be an
extension to MIPv6.

So I would build my taxonomy on single vs multiple registered CareOf per
prefix:
x : same (x=0) vs multiple (x=1) Home Agents for different CareOfs of
same prefix

In one hand and single vs multiple Mobile Router per ingress:
y : same (y=0) vs different (y=1) Prefixes for different MRs of same
link

In the other hand. Note that this discussion does not presume on whether
Ryiji's elegant solution is finally taken or not.

Which gives us 4 multihoming problems sets, MH(x=0), MH(x=1), MH(y=0)
and MH(y=1), x and y being orthogonal (as far as I can see).

Names for the 4 cases could be taken from specific instances. Examples: 

Tarzan: One MR building and registering (to same HA) several CareOf in
order to maintain connectivity while moving is a MH(x=0)
JetSet: one MR that registers its prefix to Paris and New York at the
same time in order to optimize routing is a MH(x=1)
Shinkansen: A train with one prefix, one care of per MR and 2 MRs, which
is a MH(y=0).
doubleBed: 2 MRs happening to share the same wireless media for their
mobile prefix (Erik's problem) is a MH(y=1)

Note that IMHO:

- one MR with 2 ISPs, one prefix and one HA per ISP, is a collapsed form
of doubleBed. The MR really runs 2 instances of Nemo, and whatever
policies we may apply to doubleBed will hopefully run there too.
- "R13.1: The solution MUST support mobile networks with multiple MRs"
is a catch all for Shinkansen and doubleBed
- "R13.2: The solution MUST support MR with multiple interfaces" goes
without a saying since we're talking about routers
- "R13.3: The solution must support MR with multiple global addresses on
an egress interface" concerns us only as a catch all for Tarzan and
JetSet. Any IPv6 node may build multiple global addresses. Long as we do
not register several CareOfs at the same time, it's not a Nemo issue,
it's a standard feature.

Comments anyone?

Pascal

> -----Original Message-----
> From: Hesham Soliman (EAB) [mailto:[email-masked]] 
> Sent: jeudi 24 avril 2003 11:03
> To: Pascal Thubert (pthubert); Chan-Wah Ng
> Cc: IETF NEMO
> Subject: RE: [nemo] Multiple Egress vs multihoming
> 
> 
> 
>   > > I beg to differ.  Requirement 13.1 does not equate to 
>   > > "Multiple MRs with different HAs advertising same prefix".  
>   > > Why in the first place would two MR choose to advertise the 
>   > > same network prefix if they does not belong to the same 
>   > > administration domain?
>   > 
>   > It's one way of being multihomed. You have a mobile network 
>   > in a train.
>   > One prefix. But you want redundancy (load sharing?) 
> 
> 
> => I was confused by the previous mail and thought 
> that you must have made this assumption to get the previous 
> conclusion. Multihomed mobile networks do not need to use 
> multihoming for redundancy. They mightbe multihomed because 
> they just happened to have two MRs, period. So the initial 
> aim should be to make this configuration work (i.e. how to 
> route outbound traffic through the right MR). I fully agree 
> that multihoming for redundancy should be done 
> later and not part of basic nemo. 
> 
> Hesham
> 
>

---

From: Chan-Wah Ng <[email-masked]>
Date: 25 Apr 2003 12:48:08 +0800

> not register several CareOfs at the same time, it's not a Nemo issue,

Hi, Pascal, and fellow NEMO WG members,

I think it is a bit of a jump on the gun to relate your classifications
to requirements.  I have a slow mind, so let us back track abit, and
first agree on the the taxonomy.  As I see it, we are talking about
multi-egress mobile network (multi-homing may raise too much
confusion).  Thus the way I would build the taxonomy is to start from
multi-egress. 

It can be either 1 MR with multiple egress interface, or multiple MRs.
For each cases, we can have the distintcions as Pascal suggested of
single-vs-multiple HA, and single-vs-multiple mobile network prefix.  It
turns out that on top of Pascal's (x,y), I have (w,x,y), where {w=0: 1
MR with multiple egress interface, w=1: 2 or more MRs }.

With, that, I have the following taxanomy tree:

[Multi-egress NEMO]
 |
 +->[Multi-Interface]: Single MR with multiple egress interface
 |   |
 |   +->[Single HA]: all HoA-CoA bindings sent to same HA
 |   |   |
 |   |   +->(A)[Single Prefix]: MR advertises a single prefix
 |   |   |
 |   |   +->(B)[Multiple Prefix]: MR advertises multiple prefices
 |   |
 |   +->[Multiple HA]: HoA-CoA bindings to different HAs
 |       |
 |       +->(C)[Single Prefix]: MR advertises a single prefix
 |       |
 |       +->(D)[Multiple Prefix]: MR advertises multple prefices
 |
 +->[Multi-MR]: Multiple MR
     |
     +->[Single HA]: all HoA-CoA bindings sent to same HA
     |   |
     |   +->(E)[Single Prefix]: both MRs advertise same prefix
     |   |
     |   +->(F)[Multiple Prefix]: MRs advertise different prefices
     |
     +->[Multiple HA]: MRs send HoA-CoA bindings to different HAs
         |
         +->(G)[Single Prefix]: both MRs advertise same prefix
         |
         +->(H)[Multiple Prefix]: MRs advertise different prefices

Let's for the moment ignore whether or not all the 8 different
leaf-nodes (A-H) are pratical, or functionally different.  But first
off, do everybody agree that teh above taxanomy tree covers all
scenarios that we face in NEMO?

After we get that clear, perhaps we can start evaluating each case. (and
maybe giving them names like Tarzan or Shinkansen, ;)

/rgds
/cwng
-- 
Chan-Wah Ng <[email-masked]>
Panasonic Singapore Laboratories

---

From: Julien Charbon <[email-masked]>
Date: Fri, 25 Apr 2003 19:45:55 +0900

Thierry, il semblerait que nal.motlabs.com ne soit plus joignable pour
le moment alors mon mail pour [email-masked] n'est pas pres
d'arriver. Mais tu as la primeur avant ma prochaine tentative.

------------------------------
  Hi all, hi Pascal,

 I'm working [1] on using Nemo in Multi-Homing cases so I read this
thread with interest. So I allows itself to make some comments.

On Thu, 24 Apr 2003 13:15:45 +0100

> OK, it's time to start the taxonomy :)

  Great ! it is a part of one of my goals.

> mobile prefix (Erik's problem) is a MH(y=1)

  I prefer graphical and so if I understand well :

  o Tarzan: [Single HA for CoAs of a same Prefix]

   Example with one "Multi-egress-interfaced" MR.

                    _____
    _           _  |     |
   |_|-|  _  |-|_|-|     |-|        _
    _  |-|_|=|     |_____| |  _  |-|_|
   |_|-|     |             |-|_|-|
                                 |

   MNNs   MR   AR  Internet  AR    HA

   Remarks :

     - "Multi-egress-interfaced" MR: A MR which has more than one Egress
        Interface. [I didn't find this in the Terminology-Draft].
     - [=] Symbol <=> Two Interfaces.

   In this example :

    - MR have multiple egress interfaces, and registered all its CoAs
      to the same HA with a same prefix.

  Useful for: Keep L2 Connectivity to the Internet while moving by
              switching between interfaces. [Like Tarzan]

  o JetSet: [Multiple HAs for CoAs of a same Prefix]

   Example with one "Multi-egress-interfaced" MR.

                             AR    HA1

                              _  |
                           |-|_|-|  _
                    _____  |     |-|_|
    _           _  |     |-|
   |_|-|  _  |-|_|-|     |
    _  |-|_|=|     |_____|-|        _
   |_|-|     |             |  _  |-|_|
                           |-|_|-|
                                 |

   MNNs  MR    AR  Internet  AR     HA2

   In this example :

    - Mr have multiple egress interfaces, and registered its CoAs
      to differents HAs.

  Useful for: Kind of Routing Optimization make by the MR. [Prefer
              send packet to the nearest HA]. [It's an hypothesis,
              I'm not sure of that].

  o Shinkansen: [Single prefix announced by Egress Router(s)]

   Example with two Egress Routers.

            P
           --->
         MR2
          _  |
    _  |-|_|-|  _____
   |_|-|     |-|     |
    _  |       |     |-|        _
   |_|-|  _  |-|_____| |  _  |-|_|
       |-|_|-|         |-|_|-|
             |               |
   MNNs  MR1   Internet  AR    HA
            P
           --->

  Useful for: Router Redundancy.

  o DoubleBed: [Multiple prefix announced by Egress Router(s)]

   Example with two Egress Routers.

            P2
           --->
         MR2
          _  |
    _  |-|_|-|  _____
   |_|-|     |-|     |
    _  |       |     |-|        _
   |_|-|  _  |-|_____| |  _  |-|_|
       |-|_|-|         |-|_|-|
             |               |
   MNNs  MR1   Internet  AR    HA
            P1
           --->

  Useful for: ISP Redundancy or Keep connectivity through differents
              kind of technology provide by differents ISPs.

> policies we may apply to doubleBed will hopefully run there too.

  Your example:

            ISP 1        AR    HA2
         P1               _  |
        -->  |         |-|_|-|  _
   _  |    __|  _____  |     |-|_|
  |_|-|  _/  |-|     |-|
   _  |-|_|    |     |
  |_|-|   \__|-|_____|-|        _
      |      |         |  _  |-|_|
        -->  |         |-|_|-|
         P2                  |
            ISP2
                         AR    HA1
  MNNs   MR    Internet

  Well,... IMHO I think it's preferable to say :

  It's a

  + Multiple-Interfaced MR [Multiple Interfaces]
  + Single HA              [Just one HA for CoAs for a same prefix]
  + Multiple Prefix        [Announced by Egress Routers]

  case.

  So I think our classification need one level more. [See at the end
of this mail].

> is a catch all for Shinkansen and doubleBed

  Not only for Shinkansen and DoubleBed because, you can have this
case:

          P
         --->
          _         _____
    _  |-|_|-|  _  |     |
   |_|-|     |-|_|-|     |-|        _
    _  |     |     |_____| |  _  |-|_|
   |_|-|  _  |             |-|_|-|
       |-|_|-|                   |

         --->
          P

   MNNs   MR   AR  Internet  AR    HA

  Which is a Tarzan case. [Single HA for CoAs of a same Prefix]

> without a saying since we're talking about routers

  In fact, the requirement should say :

  - "R13.2: The solution MUST support MR with multiple interfaces",
            especially the multi-egress-interfaced MR.

  But it is a tiny detail.

> JetSet.

  Can you be more clear with the notion of "catch-all" ?

  I am explained:

  There is many classes of Multi-Homing:

    o Multi-Address:
      The more interesting case is then an interface
      have more than one IPv6 global address.
    o Multi-Interface: More than one Interface.
    o Multi-Site: More than one "Border Router".

  So for the Tarzan you can have:

   - One multi-addressed MR.

               AR2 [P2]
    _           _   _____
   |_|-|  _  |-|_|-|     |
    _  |-|_|-|  _  |     |-|        _
   |_|-|     |-|_|-|_____| |  _  |-|_|
                           |-|_|-|
                                 |
               AR1 [P1]

   MNNs   MR        Internet  AR    HA

   - One "Multi-egress-interfaced" MR.
                    _____
    _           _  |     |
   |_|-|  _  |-|_|-|     |-|        _
    _  |-|_|=|     |_____| |  _  |-|_|
   |_|-|     |             |-|_|-|
                                 |

   MNNs   MR   AR  Internet  AR    HA

  - Two MR in multi-site case.

          P
         --->
          _         _____
    _  |-|_|-|  _  |     |
   |_|-|     |-|_|-|     |-|        _
    _  |     |     |_____| |  _  |-|_|
   |_|-|  _  |             |-|_|-|
       |-|_|-|                   |

         --->
          P

   MNNs   MR   AR  Internet  AR    HA

   In all this examples the HA will have two CoAs for the same prefix
in one HA. According with your definition they are Tarzan cases.

> Any IPv6 node may build multiple global addresses. Long as we do not
> register several CareOfs at the same time, it's not a Nemo issue,
> it's a standard feature.

  I just add a remark :

    - Example with one MR multi-addressed.

               AR2 [P2]
    _           _   _____
   |_|-|  _  |-|_|-|     |
    _  |-|_|-|  _  |     |-|        _
   |_|-|     |-|_|-|_____| |  _  |-|_|
                           |-|_|-|
                                 |
               AR1 [P1]

   MNNs   MR        Internet  AR    HA
 
  P1/P2: Differents IPv6 /64 Prefix.

  And of course Ingress Filtering is made on AR1 and AR2.

  So the MR may have this two IPv6 global address :

   P2:EUI-64-MR and P1:EUI-64-MR

  If the bi-directional tunnel between the MR and the HA pass through
AR2 and if AR2 is destroyed by Tarzan anger [the real one] and so its
reachability to the Internet lost, how the NEMO mechanism should deal
with this case ?
  So I think Multi-Addressed Multi-Homing is an important case in
NEMO, not just a standard fearture. [But maybe I'm wrong]. Also maybe
it will be resolve by the same mechanism in NEMO, so I put it with the
Multi-Interfaced case.

> Comments anyone?

  I think you have found the good discrimants to classify the
Multi-Homing in NEMO. So I have just read the Chan Wah Ng's mail [2],
and just by taking again his classification and ours :

 And I obtain (w, x, y) :

  with

  w: 0: A Mobile Router have more than one Global IPv6 Address.
        OR a Mobile Router have more than one Interface.
     1: There is more then one Egress Mobile Router.

  x: 0: There is single HA for CoAs of a same Prefix.
     1: There is muliple HA for CoAs of a same Prefix.

  y: 0: A single Prefix is announced by Egress Router(s).
     1: Muliple Prefix are announced by Egress Router(s).

  Excuse for this long mail, it's difficult to be sharp and short.

                                           -- Julien

[1] http://www.sfc.wide.ad.jp/~julien/ [Work in big progress]
[2] http://www.nal.motlabs.com/pipermail/nemo/2003-April/000563.html

---

From: Julien Charbon <[email-masked]>
Date: Fri, 25 Apr 2003 19:21:24 +0900

Hi all, hi Pascal,

                    _____
    _           _  |     |
   |_|-|  _  |-|_|-|     |-|        _

   Remarks :

   In this example :

                             AR    HA1

                              _  |
                           |-|_|-|  _
                    _____  |     |-|_|
    _           _  |     |-|
   |_|-|  _  |-|_|-|     |
    _  |-|_|=|     |_____|-|        _
   |_|-|     |             |  _  |-|_|
                           |-|_|-|
                                 |

   In this example :

            P
           --->
         MR2
          _  |
    _  |-|_|-|  _____
   |_|-|     |-|     |
    _  |       |     |-|        _

            P2
           --->
         MR2
          _  |
    _  |-|_|-|  _____
   |_|-|     |-|     |
    _  |       |     |-|        _

  Your example:

            ISP 1        AR    HA2
         P1               _  |
        -->  |         |-|_|-|  _
   _  |    __|  _____  |     |-|_|
  |_|-|  _/  |-|     |-|
   _  |-|_|    |     |
  |_|-|   \__|-|_____|-|        _
      |      |         |  _  |-|_|
        -->  |         |-|_|-|
         P2                  |
            ISP2
                         AR    HA1
  MNNs   MR    Internet

  It's a

  case.

          P
         --->
          _         _____
    _  |-|_|-|  _  |     |
   |_|-|     |-|_|-|     |-|        _
    _  |     |     |_____| |  _  |-|_|
   |_|-|  _  |             |-|_|-|
       |-|_|-|                   |

         --->
          P

  But it is a tiny detail.

  I am explained:

    o Multi-Address:

               AR2 [P2]
    _           _   _____
   |_|-|  _  |-|_|-|     |
    _  |-|_|-|  _  |     |-|        _

   MNNs   MR        Internet  AR    HA

          P
         --->
          _         _____
    _  |-|_|-|  _  |     |
   |_|-|     |-|_|-|     |-|        _
    _  |     |     |_____| |  _  |-|_|
   |_|-|  _  |             |-|_|-|
       |-|_|-|                   |

         --->
          P

  I just add a remark :

               AR2 [P2]
    _           _   _____
   |_|-|  _  |-|_|-|     |
    _  |-|_|-|  _  |     |-|        _

   MNNs   MR        Internet  AR    HA

 And I obtain (w, x, y) :

  with

                                           -- Julien