Subject: RE: [nemo] Multiple Egress vs multihoming

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Thu, 24 Apr 2003 17:08:19 +0200

> In the context of multihoming, When we talk about 'mobile 
  > networks', I'd
  > rather consider mobile prefixes, because it's what the MRs 
  > carry with
  > them. A MR may actually use the services of a fixed access 
  > point though
  > it's a bit weird to me. It may happen that over the wireless, two
  > prefixes, carried by 2 different routers, share the same media for a
  > period of time, and then, possibly split. 

=> Yes, they may or may not split.

I understand that 
  > this is the
  > case you're talking about? While my case was when 2 MRs own the same
  > prefix and move together like in a train case. Talking 
  > prefixes allows
  > to make that distinction.

=> I thought multihoming refers to the number
of interfaces rather than prefixes. So I'm assuming
that when you say 2 prefixes you mean either 2 MRs
or one MR with 2 interfaces. Having cleared that, 
your case actually seems more difficult to achieve ;)
Are you assuming that the "home" prefix is shared
between the 2 MRs? If so how does the HA distinguish
between the 2 MRs? Is one SA used to setup the tunnel or 2?

  > 
  > Also, when we talk about multiple egress, we may rather consider
  > multiple access routers. Whether the ARs are on a same 
  > egress link or on
  > different interfaces is IMHO to be supported implicitely 
  > (R13.2). What's
  > impacting the protocol is rather if you want to build more than one
  > CareOf. And if you let the HA(s) know about that, which would be an
  > extension to MIPv6.
  > 
  > So I would build my taxonomy on single vs multiple 
  > registered CareOf per
  > prefix:
  > x : same (x=0) vs multiple (x=1) Home Agents for different 
  > CareOfs of
  > same prefix

=> I'm interested to know how multiple care-ofs could
work in MIP. We did that for FMIP some time ago but 
it was based on bi-casting for a short period (1 second).
I will comment on the rest of the email separately.

Hesham

---

From: Ryuji Wakikawa <[email-masked]>
Date: Sat, 26 Apr 2003 10:02:56 +0900

Hi Hesham

> I will comment on the rest of the email separately.

There are some researches for multiple CoA on MIP.
draft-montavont-mobileip-mmi-00.txt and 
draft-wakikawa-multiplecoa-00.txt

regards,
ryuji