Subject: RE: [nemo] Multiple Egress vs multihoming

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 28 Apr 2003 07:53:04 +0100

Hi Ryuji:

I was not aware of your draft, nor could I find it in th eitf site or on
google. Is that something you just submitted? 

Pascal

> -----Original Message-----
> From: Ryuji Wakikawa [mailto:[email-masked]] 
> Sent: samedi 26 avril 2003 03:03
> To: Hesham Soliman (EAB)
> Cc: Pascal Thubert (pthubert); Chan-Wah Ng; IETF NEMO
> Subject: Re: [nemo] Multiple Egress vs multihoming
> 
> 
> Hi Hesham
> 
> > => I'm interested to know how multiple care-ofs could
> > work in MIP. We did that for FMIP some time ago but
> > it was based on bi-casting for a short period (1 second).
> > I will comment on the rest of the email separately.
> 
> There are some researches for multiple CoA on MIP. 
> draft-montavont-mobileip-mmi-00.txt and 
> draft-wakikawa-multiplecoa-00.txt
> 
> regards,
> ryuji
>

---

From: Masafumi Watari <[email-masked]>
Date: Mon, 28 Apr 2003 17:37:04 +0900 (JST)

Hello,

You can find the draft in the URL below.

http://www.ietf.org/internet-drafts/draft-wakikawa-mobileip-multiplecoa-00.txt

regards,
watari

On Mon, 28 Apr 2003 07:53:04 +0100,

---

From: Ryuji Wakikawa<[email-masked]>
Date: Tue, 29 Apr 2003 07:48:59 +0900

Hi Pascal, and thanks watari.

Let me summarize the draft briefly. 
We propose how to register multiple CoAs with single HoA.
It is very simple, we assign new ID number to each interfaces
on MN. MN always registers bindings with the ID.

For example,
 - IF1 has CoA1 and ID1.
 - IF2 has CoA2 and ID2.

 single HoA
  +- MN-+
  |     | 
 IF1   IF2

MN sends BUx with HoA, CoAx and IDx.  HA will have multiple bindings
of MN which are association of HoA and either CoA1 or CoA2. Then, HA
searches BC with ID and HoA. Managements of each binding are done with
correspondent ID respectively.

This ID is not only used for multiple binding managements but also it
could be used to associate some policies to a binding. For example, if
MN want to receive TCP packets by IF1, it could send a policy
(TCP->ID1) somehow (by MIP or by applications) to HA. Before HA can
search BC with ID and HoA, it can decide which binding is used for
outgoing packets by the policy.

Policy parts are not discussed in the draft, yet.

regards,
ryuji

At Mon, 28 Apr 2003 17:37:04 +0900 (JST),