Subject: RE: abstract=true

From: "Rob Enns" <[email-masked]>
Date: Mon, 12 Jul 2004 11:04:28 -0700

Hi, 

The abstract="true" attribute indicates that the type is
an abstract type and can't be instantiated directly. It's
a standard XSD attribute and it's been in the NETCONF XSD
since the -00 draft. What are changes in the schema
that you're concerned about? The only changes made in -03
were to update the schema to match changes in the protocol
itself (modulo bugs of course :-)). 

One bug I've found in the -03 XSD is that the error-info
element's type should be "xs:anyType" rather than "xs:any".

Rob

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Lewis Denizen
> Sent: Monday, July 12, 2004 12:30 AM
> To: Netconf
> Subject: abstract=true
> 
> Hi all,
> 
> Looking through the new Netconf XML Schema, I saw a lot of 
> reference to 
> the abstract="true" attribute for elements.  Is this a W3C approved 
> attribute, or is it more of a "customized" attribute?  I 
> didn't see W3C 
> mentioning about an abstract attribute...  Also, a lot of 
> standards-conforming libraries seem to have trouble understanding the 
> "abstract" attribute.  Any reason why the model changed from Draft2? 
> Thanks in advance!
> 
> Lewis
> 
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Steve Berl <[email-masked]>
Date: Mon, 12 Jul 2004 18:24:14 -0700

I've just had my first look at the XSD and I don't see the "operation" attributes and their allowed values anywhere. Am I missing something?

-steve

---

From: Lewis Denizen <[email-masked]>
Date: Tue, 13 Jul 2004 15:30:19 +0900

Hi,

Sorry for being buggy - just one last question...  The line that starts 
with:
	<xs:element ref="data" minOccurs="0"/>
which is embedded within "rpc-replyType" (roughly around line 70 when 
pretty-printed) doesn't reference to an element inside the Netconf 
schema.  Was this "data" element created to allow future expansion on 
RPC replies?  Or, is this just a small mistake in the XML schema? 
Thanks again :)

Lewis

Rob Enns wrote:
> No problems, I had to look it up myself to be sure! :-)
> FWIW I've been using XMLSpy under windows to double check
> correctness of the XSD.
> 
> Rob
> 
> On Tue, Jul 13, 2004 at 10:46:59AM +0900, Lewis Denizen wrote:
> 
>>Hi,
>>
>>Oops sorry, I guess I missed that in the previous drafts.  It does seem 
>>to be there...  I'm probably going to have to switch parsers/validators 
>>to see which work best.  Thanks for correcting me :)
>>
>>Lewis
>>
>>Rob Enns wrote:
>>
>>>Hi, 
>>>

---

From: Lewis Denizen <[email-masked]>
Date: Tue, 13 Jul 2004 17:26:30 +0900

Sorry, I should've read the document more carefully...  I'm guessing now 
that "data" refers to the return reply from a <get>.  This brings up 
another question, though - should the schema for NETCONF state be used 
in place of "data?"  The schema for NETCONF state doesn't seem to fit 
the NETCONF schema model too well.  According to the examples, it seems 
like the NETCONF schema would want to fit something like:
   <xs:complexType name="rpc-replyType">
     <xs:choice>
       <xs:element name="ok" minOccurs="0"/>
       <xs:element name="rpc-error" type="rpc-errorType" minOccurs="0"/>
       <xs:element ref="config" minOccurs="0"/>
       <xs:element name="data" type="xs:anyType" minOccurs="0"/>
     </xs:choice>
     <xs:attribute name="message-id" type="xs:string" use="required"/>
   </xs:complexType>
NETCONF state schema looks like it describes some parts of the reply for 
a <get> request, but I'm not too sure if this is something that should 
be sent back everytime a <get> request is answered (the <netconf-state> 
element).  Is the NETCONF state schema something "to be completed" in 
the future, or is it something that should be implemented as part of a 
NETCONF message?

Lewis

Lewis Denizen wrote:

> RPC replies?  Or, is this just a small mistake in the XML schema? Thanks 
> again :)
> 
> Lewis
> 
> 
> Rob Enns wrote:
> 
>>> Oops sorry, I guess I missed that in the previous drafts.  It does 
>>> seem to be there...  I'm probably going to have to switch 
>>> parsers/validators to see which work best.  Thanks for correcting me :)
>>>
>>> Lewis
>>>
>>> Rob Enns wrote:
>>>
>>>> Hi,
>>>>> reference to the abstract="true" attribute for elements.  Is this a 
>>>>> W3C approved attribute, or is it more of a "customized" attribute?  
>>>>> I didn't see W3C mentioning about an abstract attribute...  Also, a 
>>>>> lot of standards-conforming libraries seem to have trouble 
>>>>> understanding the "abstract" attribute.  Any reason why the model 
>>>>> changed from Draft2? Thanks in advance!
>>>>>
>>>>> Lewis
>>>>>
>>>>>
>>>>>
>>>>> --